fedora-server
LOGS
18:00:21 <pboy> #startmeeting fedora-server
18:00:22 <zodbot> Meeting started Wed Mar  1 18:00:21 2023 UTC.
18:00:22 <zodbot> This meeting is logged and archived in a public location.
18:00:22 <zodbot> The chair is pboy. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
18:00:22 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:22 <zodbot> The meeting name has been set to 'fedora-server'
18:00:30 <pboy> #topic Welcome / roll call
18:00:38 <mowest> .hello2
18:00:38 <pboy> Welcome to our Server WG IRC meeting today!
18:00:38 <zodbot> mowest: mowest 'Steve Daley' <mowest@vivaldi.net>
18:00:50 <jdubby> .hello2
18:00:50 <pboy> lease, everybody who is lurking, say either .hello2 or .hello <fasname>
18:00:50 <zodbot> jdubby: Sorry, but user 'jdubby' does not exist
18:00:59 <pboy> I’ll post the agenda in 2 minutes.
18:01:07 <eseyman> hello, folks!
18:01:08 <jdubby> .hello jwhimpel
18:01:09 <zodbot> jdubby: jwhimpel 'John Himpel' <john@jlhimpel.net>
18:01:16 <eseyman> .hello2
18:01:19 <zodbot> eseyman: eseyman 'Emmanuel Seyman' <emmanuel@seyman.fr>
18:02:09 <pboy> Welcome everybody
18:02:21 <pboy> We already meet our quorum
18:02:25 * nirik is lurking, but busy with other stuff too.
18:02:27 <pboy> Therefore:
18:02:35 <pboy> #topic Agenda
18:02:43 <pboy> #info  Follow up actions
18:02:51 <pboy> #info  Fedora Website revamp – Fedora Server Edition pages
18:02:58 <pboy> #info  Using Ansible to install and configure Wildfly
18:03:05 <pboy> #info  F38: Shorter Shutdown Timer
18:03:34 <pboy> #info Open floor
18:03:49 <cooltshirtguy> .hello2
18:03:50 <pboy> SORRY, wrong order! Bad copy & paste!
18:03:52 <zodbot> cooltshirtguy: cooltshirtguy 'Jason Beard' <jas_beard@hotmail.com>
18:04:13 <pboy> Shorter shutdown timer first, Website last !!
18:04:29 <pboy> Anything to add?
18:04:47 <pboy> OK
18:04:50 <eseyman> no, that works for me
18:05:04 <pboy> #topic 1. Follow up actions
18:05:13 <pboy> Both open actions, nirik and me, are part of the agenda items.
18:05:20 <pboy> So we sskip theme here.
18:05:26 <pboy> Anything else to announce here?
18:06:01 <pboy> #topic 2. F38 - Shorter Shutdown Timer
18:06:09 <pboy> #link issue #96: https://pagure.io/fedora-server/issue/96
18:06:17 <pboy> #link Mailing list discussion: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/N6TW6EBPG5Q6D6SEV4FFGQH3E6HUTVE2/
18:06:39 <pboy> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/O35T2YYLSXC6YAV5LRYBPZENW3AX4GEP/
18:06:47 <pboy> see specifically Colin Wolters (CoreOS) post on the former
18:07:00 <pboy> Lets spend about 20 min at max. here so we will have time for the  following agenda items
18:07:06 <pboy> the floor is open
18:07:32 <x3mboy> Hi guys
18:07:43 <x3mboy> I'm back
18:07:51 <pboy> +1 and Welcome
18:07:53 <x3mboy> If I can help with something, please let me know
18:08:15 <pboy> We'll find something, for sure
18:08:19 <pboy> :-)
18:08:27 <x3mboy> I will be doing my server installation
18:08:49 <jdubby> I think nirik researched most of our core services and they seem configured for no limit on shutdown time.
18:08:50 <pboy> One question was, what are our core services.
18:09:09 <pboy> I picked up those whoich are listed in our technical specification
18:09:22 <pboy> And regarding alternative progs:
18:09:25 <jdubby> But it might be nice to document on our web page (or somewhere) how to make changes to the .service file if someone has an issue.
18:09:25 <x3mboy> I started with an i3 installation that become into server, now I want to reinstall as server, let's see how is the process, to give better input to the team
18:09:28 <nirik> yeah, I tried to look at the ones listed... but yeah, there's some question about what should be 'core' here.
18:10:17 <pboy> Basically, our core services are listed in the technical specification.
18:10:40 <pboy> We kind of "guarantee" that these will work.
18:10:58 <pboy> Ans they are protential release blockers.
18:11:11 <pboy> So we should not have too much of those
18:11:46 <pboy> jdubby Yes
18:11:51 <nirik> yeah, the more there are, the more testing needed...
18:12:10 <nirik> and if there's choices, the more we have to explain what one people might want to use.
18:12:23 <eseyman> agreed
18:12:32 <pboy> I'll sum up all the findings in the ticket, so will get an overview
18:13:12 <pboy> And as Adam said, we will have to specify, if the service is able to get roughly interrupted, e.g. for Cockpit it is OK
18:13:30 <nirik> +1
18:15:42 <pboy> OK, I'll prepare the summary and we can discuss that next meeting. Any objection?
18:16:13 <eseyman> works for me
18:16:20 <pboy> #action pboy will create a summary of our discussion about service specific timeouts.
18:16:33 <pboy> Another question is, what about interdependencies between services. That is the argument of Collin Walters (CoreOS)
18:16:42 <pboy> CoreOS decided to use the overwrite option and to keep the pld default.
18:17:14 <pboy> Maybe, we discuss that on mailing list and make a final decision next meeting?
18:18:55 <x3mboy> +1
18:19:09 <pboy> OK
18:19:44 <pboy> #action pboy will open a mailing list discussion about interdependencies between services and the consequences.
18:20:10 <pboy> I think we are done with this topic?
18:20:28 <eseyman> yes (just in time, too)
18:20:38 <pboy> Yeah
18:20:49 <pboy> #topic 3. Using Ansible to install and configure Wildfly
18:20:59 <pboy> That's our Ansible pilot project!!
18:21:07 <pboy> #link https://pagure.io/fedora-server/issue/60
18:21:13 <pboy> We had some discussion here:
18:21:22 <pboy> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/2022/12/
18:21:29 <pboy> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/HEHEXBYFVD6E6SG33SOGJBREAEBJHGLE/
18:21:38 <pboy> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/HEHEXBYFVD6E6SG33SOGJBREAEBJHGLE/?sort=thread
18:21:49 <jdubby> My current issue is various blogs/how-to want you to add xml snippets to standalone.xml.  But they don't tell you where in the file to add the snippet.
18:22:53 <pboy> I've to admit, I'm a bit lost after all these unfortunate postponed discussion.
18:22:59 <jdubby> The snippets they want you to add don't seem to be found in any of the schema parts distributed with wildfly.
18:23:48 <jdubby> I tried to "ansibleize" the blog found at https://developer.jboss.org/people/fjuma/blog/2018/08/31/obtaining-certificates-from-lets-encrypt-using-the-wildfly-cli#jive_content_id_Obtaining_a_certificate_from_Lets_Encrypt
18:24:15 <pboy> Seems we have to find a Wildfly expert, or an aAnsible expert?
18:24:27 <jdubby> But I am having issues with getting wildfly to use tls between the browser and wildfly.
18:24:46 <eseyman> this looks like a wildfly issue more than it is an ansible one
18:24:58 <jdubby> It clearly is a wildfly issue.
18:26:32 <pboy> So we have 2 unresolved issues:
18:26:56 <pboy> a) TLS between apache and Wildfly web app
18:27:17 <pboy> b) Tiansiblefy Wildfly
18:27:20 <pboy> right?
18:28:16 <jdubby> Correct.  I have a great deal of the ansiblification done.  Without tls, I can get wildfly to execute.
18:28:34 <pboy> very good!
18:28:48 <pboy> jdubby Do we have a publicly accessible installation anythere ?
18:28:52 <eseyman> jdubby: this is yours, right? https://gitlab.com/jwhimpel/wildfly-ansible
18:29:28 <jdubby> Yes,  I still need to update the "inventory" files in the repo.  I'll get that done today or tomorrow.
18:29:29 <pboy> s/anythere/anywhere
18:30:07 <jdubby> I think if we could identify a wildfly configuration expert, this issue could be quickly solved.
18:30:08 <eseyman> jdubby, please ping the mailing list once the repo is current. I'll clone then and take a look
18:30:44 <jdubby> Will do.
18:30:50 <eseyman> thank you
18:31:47 <pboy> jdubby I tried to install it on one of my (public) servers. Do already you have a public server anywhere?
18:32:03 <pboy> with Wildfly installed
18:32:50 <jdubby> No.  It's only installed in my home behind a nat firewall.
18:33:44 <pboy> OK. Would it be helpfull to have a public server where anybody of us can login (with admin privs) so we can share alle the details? I can provide one.
18:34:22 <jdubby> Let me know how to access and I will work on getting an instance up and running.
18:34:52 <pboy> jdubby OK, I'll do it tomorrow (Thursday) and provide you with the login data.
18:35:15 <jdubby> I have been using nginx but  I think it should not be too hard to convert to httpd.
18:35:45 <pboy> We can configure that server freely. It's just for our Wildfly project.
18:36:34 <pboy> As an Resume:
18:36:58 <pboy> a) eseyman will look at the updated repo
18:37:32 <pboy> b) pboy will provide a public server where we can work in a cooperative work on all the details
18:37:56 <pboy> That's so far.
18:38:02 <pboy> Anything else?
18:38:10 <jdubby> c)  jdubby will update his repo
18:38:23 <pboy> +1
18:38:45 <pboy> #action jdubby will update his repo
18:38:55 <pboy> #action eseyman will look at the updated repo
18:39:07 <pboy> #action pboy will provide a public server where we can work in a cooperative work on all the details
18:39:57 <pboy> Are we done with this topic so far?
18:40:38 <pboy> OK
18:40:41 <jdubby> I'm done for now
18:40:45 <eseyman> same here
18:40:49 <pboy> #topic 4. Fedora Website revamp – Fedora Server Edition pages
18:41:03 <pboy> #link Issue #66: https://pagure.io/fedora-server/issue/66
18:41:16 <pboy> #link Mailing List: https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/7QJHY6E422W6SGLMETH5VFOUY6IKJA3P/
18:41:46 <pboy> It look as if we have a status that can go online?
18:41:53 <mowest> I summarized the current status and issues in the email I sent to the server list this morning. The only thing that I will add is that Emma is hoping to have the last of the graphic assets done by tomorrow, and then the team wants to take a break from our landing page and move onto other website revamp issues.
18:41:56 <pboy> mowest the floor is yours
18:42:39 <pboy> Is there time to discuss that in 14 days?
18:42:57 <pboy> Or is there a deadline?
18:43:37 <eseyman> mowest: so this is near-final? https://fedora.gitlab.io/websites-apps/fedora-websites/fedora-websites-3.0/server
18:43:55 <mowest> I think the team would like to call our current landing page done for now and ready for the F38 rollout. We will have opportunities to make changes after the rollout I believe.
18:44:13 <mowest> Yes, what is there is considered by the team to be near final.
18:44:23 <eseyman> I like it
18:44:40 <pboy> me too
18:44:57 <jdubby> +1
18:45:16 <mowest> Good I'm glad everyone is okay with the 1.0 version of the revamp.
18:46:00 <mowest> I have requested new graphic assets for the last three "features" that is what Emma is working on today and tomorrow.
18:46:36 <pboy> mowest Is there a chance for a better Logo the the current?
18:46:50 <pboy> s/the/then
18:47:20 <mowest> @pboy, I don't know if we can get a better logo at this stage. I know you aren't crazy about the orange. :-)
18:47:54 <pboy> OK. let's hope, and maybe you can nag a bit?
18:48:19 <pboy> Anything else here?
18:48:27 <mowest> Do you have any suggestions to give them some direction.
18:48:45 <pboy> not really at the moment
18:48:54 <mowest> I don't have anything else at this time, I'm thankful for all of the work the website team has put into our page.
18:49:13 <eseyman> yes, huge congrats to the website team
18:49:17 <pboy> maybe a small version of the header graphic (stacked servers)?
18:49:37 <pboy> mowest +1
18:49:40 <mowest> In what color @pboy?
18:50:25 <pboy> mowest I don't know, not orange :-). I think a designer knows best (even if it is orange)
18:50:42 <mowest> Ok :-)
18:50:48 <mowest> I'm done.
18:50:59 <pboy> Something else?
18:51:13 <pboy> Otherwise I'll switch
18:51:15 <mowest> You can move to the next topic.
18:51:55 <pboy> #topic  5. Open Floor
18:52:27 <pboy> I visited Fosdem this year. It was very interesting.
18:52:41 <pboy> There will be a Fedora Magazine article.
18:52:50 * luna was also there helping out in the Fedora booth :) (looking forward to the article)
18:53:10 <pboy> Next year we should have a speech about Fedora Server
18:53:28 <pboy> luna +1 to your work We have met, haven't we?
18:53:47 <luna> pboy: yeah i think so you where the one asking for the getting starting guide stuff right?
18:54:15 <pboy> Yes, it was me. :-)
18:54:20 <luna> then we did :)
18:54:28 <pboy> good!
18:54:42 <eseyman> pboy: I would have reconsidered not going if I had known you would be there
18:55:21 <pboy> As I said, we should aim to have a talk about Fedora server next year, maybe about our Ansible project.
18:56:02 <pboy> eseyman thank you. I must admit, it was quite spontaneous
18:56:39 <pboy> I had some concerns about Covit and the Deutsche Bundesbahn (train company)
18:57:36 <pboy> I think there is a meeting in August in Europe (Spain?)
18:57:49 <pboy> x3mboy as an ambassador, do you know details?
18:57:49 <eseyman> we'll need to plan ahead of FOSDEM 2024 a meeting
18:58:02 <pboy> eseyman +1
18:59:57 <pboy> Obviously, we don't know about this summer at the moment.
19:00:09 <pboy> OK,. time is up
19:00:15 <pboy> anything else?
19:00:29 <eseyman> I'm good
19:00:36 <jdubby> Thanks to everyone who participated today.  Good Meeting!
19:00:54 <pboy> OK, Thanks to everybody for comming
19:01:02 <pboy> See you in 14 days!
19:01:16 <pboy> #endmeeting