council
LOGS
15:02:19 <jwf> #startmeeting Fedora Council meeting - 2022 November 9th
15:02:19 <zodbot> Meeting started Wed Nov  9 15:02:19 2022 UTC.
15:02:19 <zodbot> This meeting is logged and archived in a public location.
15:02:19 <zodbot> The chair is jwf. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
15:02:19 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:19 <zodbot> The meeting name has been set to 'fedora_council_meeting_-_2022_november_9th'
15:02:29 <jwf> #meetingname council
15:02:29 <zodbot> The meeting name has been set to 'council'
15:02:42 <jwf> #topic Welcomes & hellos
15:02:47 <mattdm> hello :)
15:02:47 <dcantrell> .hello2
15:02:48 <zodbot> dcantrell: Something blew up, please try again
15:02:48 <jwf> Take 2 🙂
15:02:51 <zodbot> dcantrell: An error has occurred and has been logged. Please contact this bot's administrator for more information.
15:03:01 <jwf> #chair mattdm dcantrell
15:03:01 <zodbot> Current chairs: dcantrell jwf mattdm
15:03:10 <jwf> .hello jflory7
15:03:11 <zodbot> jwf: Something blew up, please try again
15:03:14 <zodbot> jwf: An error has occurred and has been logged. Please contact this bot's administrator for more information.
15:03:23 <mattdm> zodbot is very explody today
15:03:24 <dcantrell> zodbot is happy
15:03:25 <mattdm> .fire zodbot
15:03:25 <jwf> Seems like Zodbot is having a hard time today.
15:03:27 <zodbot> adamw fires zodbot
15:04:15 <jwf> A good morning from here in the East Coast
15:04:24 <jwf> I'm chairing today, but it might be some figuring it out as I go along :)
15:04:27 <mattdm> so, maybe just the three of us today?
15:04:35 <dcantrell> perhaps
15:04:37 <mattdm> I think it should be low-stress chairing, at least
15:05:09 <mattdm> agenda items?
15:05:54 <jwf> I see three tickets in the queue today. Before jumping into tickets, I thought we could share any interesting news and updates from around the Project for 5 minutes.
15:06:10 <jwf> #topic News, announcements, & other cool things happening in Fedora
15:06:36 <jwf> My big one is the F37 release party, which was a record-breaker 🙂
15:06:36 <mattdm> Hopefully We Will Have A Release Soon?
15:06:53 <dcantrell> jwf: very nice, when was the release party?
15:07:07 <mattdm> Yes, the release party was awesome! Lots of energy and fun -- which is really nice to see at not just a sustained but growing level
15:07:27 <jwf> #info The Fedora Linux 37 Release Party ran last Friday and Saturday, with 1200+ registrants and a 63% turnout rate. This topped Nest in registration numbers but not in turnout rate. We had 21 speakers share news and updates from across engineering and mindshare.
15:07:48 <jwf> #info Fedora Linux 37 will have a go/no-go meeting on Thursday to determine whether we proceed with the 15 November release date.
15:08:06 <mattdm> To save me doing math... what were the turnout numbers?
15:08:29 <jwf> It was something like 750-800?
15:08:38 <jwf> So still a very solid showing
15:08:49 <jwf> Our release parties have really grown up a lot in the last two years.
15:09:26 <jwf> dcantrell: Anything interesting or exciting in FESCo/engineering side? Or has it mostly been centered around the release?
15:09:38 <mattdm> Last one had a turnout rate of 80+%, iirc. I wonder what the difference is in more registrations but similar turnout.
15:10:08 <dcantrell> jwf: not much right now, we've had to cancel a number of recent meetings.  right now it's slow as we close in in F37.  the flood gates are holding back the forthcoming change proposals for F38
15:10:57 <jwf> mattdm: I would also be curious. It is also worth noting that while the turnout rate was lower than Nest, we are still pulling above average in engagement with our virtual events compared to many other communities. Which is nice to see—and also testament to Marie's approach the past couple of years
15:10:59 * jwf nods
15:11:33 <jwf> #info The engineering side is slowing down a bit while F37 edges closer. There are many forthcoming change proposals planned for F38, so it will be good to keep things moving once F37 is out!
15:11:50 <jwf> I think that is a nice range of updates. Anything else before switching over to our tickets?
15:12:09 <mattdm> After the release, Fedora elections.
15:12:25 <mattdm> Worth thinking about people to shoulder-tap
15:12:40 <mattdm> And we also should consider if we need to move this meeting time to accomodate more people
15:12:52 <mattdm> because attendance is, um, low.
15:13:02 <jwf> #info The next election cycle will begin not long after the F37 release. This includes elected seats on the Fedora Council, FESCo, and Mindshare.
15:13:04 <dcantrell> yes, it's now occurring at a very bad time for me
15:13:33 <jwf> Yeah. We can definitely explore a new meeting time as we transition into the new year and bring on any new folks
15:13:40 <mattdm> We should probably wait until post-election to shift. David thanks for being here despite that.
15:13:47 <dcantrell> np
15:13:55 <jwf> ^ +1
15:14:01 <dcantrell> the big problem for me is that I am moving to a new work team and all of my meetings will be in the AM Boston time
15:15:16 <dcantrell> but, I should be able to schedule around that
15:15:16 <jwf> #agreed Exploring a new meeting date/time could be helpful to optimize for engagement.
15:15:16 <mattdm> The other thing is: I have blocked out some time on my calendar to work on Fedora strategy posts to Discussion that I have long promised.
15:15:16 <mattdm> I keep letting interrupt-driven things leave no room for it.
15:15:16 <mattdm> (Eisenhower matrix important/urgent etc. etc.)
15:15:42 <mattdm> This is an announcement in that I am declaring that these should, for real, start showing up soon :)
15:16:12 <jwf> Cool. I'll definitely engage with those posts—they are increasingly of interest to me too 🙂
15:16:26 <jwf> #info Matthew's strategy posts are forthcoming.
15:16:31 <mattdm> Please help promote when they come out
15:16:37 <jwf> #action mattdm Strategy posts on Fedora Discussion.
15:16:40 <jwf> 😉
15:16:49 <jwf> Any other updates or news to highlight?
15:16:57 <jwf> Going once…
15:17:07 <jwf> Going twice…
15:17:18 <jwf> Going thrice…
15:17:28 * jwf gavels
15:17:39 <jwf> #topic Ticket review
15:17:40 <jwf> #link https://pagure.io/Fedora-Council/tickets/issues?priority=2
15:17:59 <jwf> Hmm -- two of these, I'm not sure about needing discussion
15:18:06 <jwf> But we can check in on them and either close or action
15:18:24 <jwf> #topic Issue #418: Approve URL changes in FPCA
15:18:30 <jwf> #link https://pagure.io/Fedora-Council/tickets/issue/418
15:18:54 <jwf> Not sure this warrants a deep review, but it is triaged for our meeting today.
15:19:10 <jwf> Are we okay for Legal to merge this?
15:19:23 <dcantrell> yeah, I just added my +1
15:19:27 <jwf> That is, to give that authorization right now
15:19:38 <jwf> Cool, thanks dcantrell
15:20:03 <jwf> The ticket is a week old, but not sure we need more time for this to bake or if we can give Legal the thumbs-up
15:20:39 <mattdm> this is backed.
15:20:40 <mattdm> baked
15:20:46 <mattdm> I have one trivial formatting suggestion and ben needs to mark it non-draft.
15:21:00 <mattdm> I'll mark the ticket closed
15:21:15 * jwf nods
15:21:16 <dcantrell> is anything ever not a draft?  :)
15:21:24 <jwf> Then we'll move this one on
15:21:41 <jwf> #agreed No further action needed. We will give Legal the thumbs-up on this ticket.
15:22:06 <jwf> #action mattdm Follow up in the MR with Legal, close Council ticket as complete.
15:22:17 <jwf> #topic Issue #416: Register gitlab.com/fedora/council sub-group and create commarch repo
15:22:23 <jwf> #link https://pagure.io/Fedora-Council/tickets/issue/416
15:22:36 <jwf> So, I think this one is more waiting on me
15:22:50 <mattdm> is or is it done?
15:22:51 <jwf> The proposed actions are done, but there is a pending question about our other workflows and docs
15:23:04 <jwf> Not sure if that should go into a new ticket, or if we should pile it onto this one
15:23:39 <mattdm> New ticket, if a ticket at all
15:23:39 <jwf> I am starting to use my own GitLab repo to track things:
15:23:40 <jwf> #link https://gitlab.com/fedora/council/community-architecture/-/issues
15:23:54 <jwf> OK. I do think it is worth a ticket to track how we will migrate.
15:24:35 <jwf> I have a desire to break our docs into multiple repositories, or use a single module to group all of the docs that exist as pagure.io council-docs today
15:24:46 <jwf> But that would be better for a ticket
15:24:48 <jwf> Or Discussion
15:24:48 <mattdm> I'm not a huge fan of non-actionable tickets that are placeholders for project work.
15:25:09 <mattdm> Discussion thread, though, yes.
15:25:33 <mattdm> I don't think there is a Fedora Project level decision to be made -- it's an organizational one for this group as a team
15:26:04 <mattdm> Which is why I had the docs have separate repo and tracker than the main one.
15:26:10 <dcantrell> my only suggestion here is that the group made on gitlab should have some clear ownership so we don't get stuck in a situation where no current member is an admin
15:26:16 <mattdm> Ben isn't here to defend the idea of all tickets in one place :)
15:26:29 <dcantrell> I also agree with mattdm that tickets that are placeholders for project work are not good
15:26:57 <jwf> I can appreciate that while also appreciating actionable outcomes to longer form goals and work produced by the Council. I would like somewhere to lodge this, so we can have that discussion.
15:27:15 <jwf> If it isn't Council tickets, then somewhere else we will work on it
15:27:24 <dcantrell> yeah, I think we need a second place
15:27:48 <dcantrell> like we should be able to run through tickets and make a decision and close the ticket.  that decision may be assigning project work to someone, but then that lives elsewhere
15:28:00 <mattdm> +1 dcantrell
15:28:01 <dcantrell> I don't have a good answer for where that sort of stuff should live
15:28:22 <mattdm> Possibly a gitlab kanban board.
15:28:24 <dcantrell> but basically we're wanting a shared scratchpad of sorts for whoever is lead on projects
15:28:28 <dcantrell> yeah, that works
15:28:40 <dcantrell> I mean, there are a million solutions for this and we can go as complicated as we want
15:29:05 <jwf> In the interim… I will open a ticket to review our ticketing situation 🙂
15:29:13 <mattdm> LOL okay.
15:29:16 <dcantrell> ha
15:29:18 <dcantrell> fair
15:30:00 <dcantrell> let's try to keep that discussion relatively short and just pick one and run with it.  if it's terrible, we can move to something else.  but I think it's more important to have something and start using it than to weigh hypotheticals without ever using something
15:30:04 <jwf> #action jwf Close out #416 as complete, open two new tickets for planning our docs/workflow migration and a better way of using tickets for long-form work
15:30:17 <jwf> +1 dcantrell
15:30:31 <jwf> #topic Issue #415: Thank you, Marie!
15:30:36 <jwf> #link https://pagure.io/Fedora-Council/tickets/issue/415
15:30:46 <jwf> This was triaged for today, but… is it complete?
15:30:51 <mattdm> Yay! Thank you Marie!
15:31:03 <dcantrell> Thank you Marie!
15:31:09 <jwf> Yes. And a big kudos for sure 😀
15:31:38 <mattdm> This looks like a work ticket for Ben. So let's leave it open for him
15:31:58 <jwf> Cool. Then I'll switch it off the meeting agenda.
15:32:28 <mattdm> What's next? :)
15:32:29 <jwf> I think there are a couple pieces remaining, like with the docs
15:32:35 <jwf> But nothing needing a meeting discussion I think
15:32:49 <jwf> That's all the tickets queued for the meeting. We can switch to open floor if no objection
15:32:57 <mattdm> I notice https://pagure.io/Fedora-Council/tickets/issue/400 is still open. Unless either of you object, I'm going to close that...
15:33:09 <mattdm> with a link to current activity in the badges team.
15:33:09 <jwf> And I have one thing to lodge, which I wanted to open a ticket for, but haven't finished it yet
15:33:16 <dcantrell> mattdm: close it
15:33:39 <jwf> #topic Open floor
15:33:46 <jwf> #link https://pagure.io/Fedora-Council/tickets/issue/400
15:34:11 <dcantrell> well yesterday was a big day for me and my family
15:34:16 <dcantrell> we hit PowerBall
15:34:26 <dcantrell> we matched a white ball and the power ball, so I won $4
15:34:49 <mattdm> Amazing.
15:35:05 <jwf> Hah. I was about to wonder if Ben's lottery factor spin on the bus factor was about to manifest 😀
15:35:16 <mattdm> The item I have is: we had, a while ago, roughly agreed that we would have a Council in person F2F soon-ish.
15:35:29 <dcantrell> we did discuss that
15:35:35 <mattdm> I think at the time we were talking about November or December. That is clearly not going to happen.
15:35:42 <dcantrell> no, there's no way
15:35:45 <jwf> mattdm: re, #400. I am indifferent since I haven't read the Discussion thread yet. But I have nothing to add in there either right now.
15:35:50 <dcantrell> I have a trip this weekend, then Thanksgiving, then we have xmas
15:36:09 <mattdm> I wonder if we should consider:
15:36:09 <mattdm> A. Fosdem in February
15:36:09 <mattdm> B. DevConf.cz in June
15:36:09 <mattdm> C. Some time in between
15:36:35 <mattdm> This should probably be a Discussion thread but I wanted to start somewhere :0
15:36:48 <mattdm> s/0/)/
15:36:49 <dcantrell> I am not planning on attending DevConf.cz
15:37:01 <jwf> FWIW, I will be in Europe from January to March-ish, including time at FOSDEM
15:37:11 <dcantrell> other times are dependent on whatever my work schedule is and travel availability
15:37:11 <mattdm> Might you, if we had a co-located Council meeting?
15:37:33 <dcantrell> no, DevConf.cz is in June and that's in the middle of boating season.  not leaving
15:37:51 <mattdm> fair :)
15:38:01 <mattdm> We could always do it ON YOUR BOAT
15:38:11 <dcantrell> we have a very short boating season here and it costs one powerball jackpot to keep the thing going, so I have to maximize water time
15:38:15 <dcantrell> we can do it on my boat
15:38:38 <jwf> 😆
15:38:38 <dcantrell> I mean, we can all take the boat to the cape or north shore somewhere and have a meeting on land with chairs and wifi and stuff and then head back
15:38:55 <mattdm> The general problem with doing things in Boston is that even with two or more of us in the area, it's expensive to house people.
15:39:47 <jwf> My preference would be to time a F2F around FOSDEM time
15:39:57 <jwf> I would also prefer not to wait so long if we can help it
15:40:05 <dcantrell> I think that's reasonable
15:40:07 <dcantrell> sooner is better
15:40:10 <jwf> June feels very far from November :)
15:40:30 <dcantrell> FOSDEM is not a bad option
15:40:58 <mattdm> Ok. Justin, can I ask you to start a Discussion thread on this? I would but this is a perfect example of why I never get the other writing done. :)
15:41:48 <jwf> Yeah. I can do this.
15:42:00 <mattdm> Thank you!
15:42:16 <jwf> #action jwf Open a Discussion thread about a Council face-to-face meeting in early 2023, possibly timed to around FOSDEM
15:42:42 <jwf> This would be a good transition to my open floor topic…
15:43:27 <jwf> I have a ticket mostly drafted, but didn't get it posted yesterday because… water mainline burst… but I wanted to call it out here
15:43:55 <jwf> It is budget season, and we are mapping out how much to ask for with regards to events and travel
15:43:56 <mattdm> wait one second
15:43:58 <mattdm> was looking something up
15:44:06 * jwf waits
15:44:09 <mattdm> GNOME advisory board meeting is penciled in for February 3
15:44:21 <mattdm> So let's not conflict with that please
15:44:23 <mattdm> that's all
15:44:40 <jwf> Yeah, CentOS Connect is also right before FOSDEM and ideally I'd like to go to that too
15:44:49 <jwf> #info Avoid 3 February for said face-to-face
15:45:05 <jwf> Right, so—Fedora events and travel
15:45:23 <jwf> I wanted to have a conversation about our strategy and approach to resuming some in-person hackfests next year
15:45:40 <jwf> The ask I have to the Council in this work will be two-fold:
15:45:58 <jwf> 1. Create a process for how contributors can request funding and support for organizing team hackfests
15:46:11 <jwf> 2. Set a target metric for the number of hackfests we'd like to see next year
15:46:35 <jwf> My thinking as of now was that 2-3 in-person and/or up to 6 virtual ones would be ideal
15:46:49 <jwf> Although I admit I have a hard time visualizing what a virtual hackfest would be, if not just… online meetings.
15:46:55 <dcantrell> is this all separate from Flock?
15:47:11 <jwf> Right, it is separate.
15:47:13 <SumantroMukherje> dcantrell: I have the same question
15:47:21 <mattdm> Oh hi Sumantro Mukherjee !
15:47:31 * jwf waves to Sumantro Mukherjee
15:47:41 <SumantroMukherje> hey! mattdm! and justin!
15:47:47 <dcantrell> from my own experience, in person hackfests are the most useful.  there's something about changing your surroundings and isolating yourself with a group with a specific set of tasks.  that's not to say virtual hackfests are not useful or couldn't be useful, I just can't visualize how it would work
15:47:49 <mattdm> Back in the Before Times, we funded several separate-from-flock team hackfests a year, and I feel like that was generally money well spent.
15:48:09 <mattdm> dcantrell -- same feeling
15:48:17 <jwf> I had a leaning suspicion that the idea of resuming some in-person hackfests wouldn't be too controversial, for said reasons
15:48:18 <mattdm> We generally budgeted $10k or so for each.
15:48:36 <dcantrell> how many people did those events include?
15:49:04 <mattdm> https://budget.fedoraproject.org/budget/fy19/fads.html
15:49:16 <jwf> Going into 2023, we will have new challenges. Including both fiscal and logistics. But I think it is better to try these out again and learn what exactly is different now.
15:49:17 <mattdm> A dozen-ish?
15:49:41 <jwf> The important underlined note here is that I am working on a budget estimate, and I need to have some numbers to pencil in if we want to try these out next year.
15:49:51 <mattdm> lots more in 2018! https://budget.fedoraproject.org/budget/fy18/fads.html
15:49:54 <jwf> This report would be, ideally, submitted by the end of this month.
15:49:56 <dcantrell> well I'm all for putting together a process for how to request and fund an event and then setting some sort of target
15:50:13 <jwf> Thus, the real tricky question I have to the Council is how many and how much, and then we can start mapping out the process going into the new year
15:50:34 <jwf> Ideally I'd like a process before a number, but…
15:50:47 <mattdm> I don't have a sense of team demand.
15:50:55 <dcantrell> jwf: yes, I was just adding +1 to your 1 points above
15:50:58 <jwf> Me either.
15:51:05 <mattdm> I'd like to know how many teams would want to do an in-person hackfest this year if they could.
15:51:13 <mattdm> Like, if it's two groups or twenty.
15:51:13 <jwf> Ack dcantrell :)
15:51:14 <dcantrell> I think if we put together a process and advertise it, some groups may step forward
15:51:45 <jwf> +1. Maybe with the caveat that this is… a "beta" process, post-2020 :P
15:51:48 <SumantroMukherje> I am +1 to dcantrell and Justin W. Flory (he/him)
15:51:55 <mattdm> This is the existing process: https://fedoraproject.org/wiki/How_to_organize_a_FAD
15:52:13 <jwf> Uncategorized wiki pages are my favorite :D
15:52:17 <dcantrell> jwf: if you start a draft document with what our process could look like, I'll help by adding and commenting
15:52:33 <mattdm> (I am, by the way, _very_ in favor of using "Hackfest" instead of jargony-and-not-even-usually-correct "FAD")
15:52:40 * jwf nods
15:52:43 <dcantrell> sure, copy that to a document I can edit with JavaScript WordPerfect and then let's go
15:52:52 <mattdm> jwf: Oh, but it is in Category:FAD!
15:52:52 <jwf> TBH, we haven't called them FADs in practice for quite some time
15:52:54 <dcantrell> FAD sounds too much like FUD
15:53:09 <jwf> dcantrell: Is HackMD OK, or do you have a preference? I guess Etherpad could work
15:53:09 <mattdm> yes that too. and that was probably on purpose from FUDCon
15:53:14 <jwf> Although, this is implementation details :)
15:53:17 <jwf> I see the seed is planted
15:53:17 <dcantrell> jwf: either is fine
15:53:22 <jwf> Which is what I wanted from Open Floor
15:53:30 <mattdm> We should burn these wiki pages as part of the process of replacing them
15:53:40 <SumantroMukherje> mattdm: +!
15:53:40 <jwf> I will have the ticket to boot, and I would appreciate your inputs to the Discussion thread once I post it
15:53:50 <dcantrell> jwf: (I haven't used HackMD but have used Etherpad, but I am capable of learning)
15:54:00 <jwf> Hopefully today, if I can survive meetings and the busted waterline in peace :D
15:54:03 <SumantroMukherje> jwf: ack
15:54:21 <jwf> #agreed JWF will open said ticket about resuming hackfests in 2023
15:54:38 <dcantrell> I am  working today and tomorrow but then am on PTO starting Friday and through Monday, just fyi.  if there are delayed responses from me
15:54:54 <jwf> #action council Start thinking about updates to the hackfest/FAD process, and how many hackfests to target (with funding) in 2023
15:55:26 <jwf> Oh, the draft for the policy will take some time to get going. But I will be coming back for a number so I can at least put in the request to the 2023 budget.
15:55:45 <jwf> I'd like to push for that by end of month ideally, otherwise you will have to trust my own intuition :D
15:55:54 <jwf> Anyways!
15:55:58 <jwf> That's all the open floor I had.
15:56:04 <dcantrell> all sounds good
15:56:05 <jwf> Anyone else want to add in our last four minutes?
15:56:26 <jwf> Open floor, going once…
15:56:51 <SumantroMukherje> all good!
15:56:51 <jwf> Going twice…
15:56:52 <jwf> Going thrice…
15:56:54 <jwf> Adjourned!
15:57:11 <jwf> Thanks folks for being here, whether it is 11am or 21:30 :D
15:57:17 <jwf> Have a good rest of your week.
15:57:17 <mattdm> thanks justin!
15:57:18 <jwf> #endmeeting