f37-final-go_no_go-meeting
MINUTES

#fedora-meeting: F37 Final Go/No-Go meeting

Meeting started by bcotton at 17:01:16 UTC (full logs).

Meeting summary

  1. Roll Call (bcotton, 17:01:21)
  2. Purpose of this meeting (bcotton, 17:06:05)
    1. Purpose of this meeting is to check whether or not F37 is ready for shipment, according to the release criteria. (bcotton, 17:06:05)
    2. This is determined in a few ways: (bcotton, 17:06:05)
    3. 1. No remaining blocker bugs (bcotton, 17:06:12)
    4. 2. Release candidate compose is available (bcotton, 17:06:12)
    5. 3. Test matrices for Final are fully completed (bcotton, 17:06:12)

  3. Current status - blockers (bcotton, 17:06:19)
    1. https://qa.fedoraproject.org/blockerbugs/milestone/37/final/buglist (bcotton, 17:06:19)
    2. 1 Proposed Blockers (bcotton, 17:06:33)
    3. 2 Accepted Blockers (bcotton, 17:06:33)

  4. (2137661) upcoming critical openssl vulnerability (bcotton, 17:06:45)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2137661 (bcotton, 17:06:45)
    2. https://pagure.io/fedora-qa/blocker-review/issue/987 (bcotton, 17:06:45)
    3. Proposed Blocker, openssl, NEW (bcotton, 17:06:52)
    4. Ticket vote: FinalBlocker (+11,0,-3) (+bytehackr, +mattdm, +bcotton, +ngompa, +geraldosimiao, +chrismurphy, +nixuser, +copperi, +sumantrom, +frantisekz, +augenauf, -sgallagh, -catanzaro, -gui1ty) (bcotton, 17:06:52)
    5. Criterion: The release must contain no known security bugs of 'important' or higher impact according to the Red Hat severity classification scale which cannot be satisfactorily resolved by a package update (e.g. issues during installation). (bcotton, 17:08:52)
    6. https://fedoraproject.org/wiki/Fedora_37_Final_Release_Criteria#Security_bugs (bcotton, 17:08:57)
    7. https://pagure.io/fedora-qa/blocker-review/issue/987#comment-822932 (adamw, 17:12:24)
    8. AGREED: 2137661 - AcceptedBlocker(Final) - Given the limited public information, we are unable to definitively determine whether this violates"The release must contain no known security bugs of 'important' or higher impact according to the Red Hat severity classification scale which cannot be satisfactorily resolved by a package update". We therefore are blocking out of an abundance of caution. (bcotton, 17:29:21)

  5. (2135772) Editing the recurring event freezes Calendar. (bcotton, 17:30:06)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2135772 (bcotton, 17:30:06)
    2. https://pagure.io/fedora-qa/blocker-review/issue/977 (bcotton, 17:30:06)
    3. Accepted Blocker, gnome-calendar, NEW (bcotton, 17:30:06)
    4. Upstream says "I'm pretty positive nothing about recurrent events has ever worked properly. There's a lot more that needs to be done to make it work reliably, and I'm considering how to do that, but yeah, it's just stupidly broken." (bcotton, 17:31:44)

  6. (2137600) Plasma on Wayland hangs at startup when booting with nomodeset ("basic graphics" mode) on UEFI (bcotton, 17:34:56)
    1. https://bugzilla.redhat.com/show_bug.cgi?id=2137600 (bcotton, 17:34:57)
    2. https://pagure.io/fedora-qa/blocker-review/issue/986 (bcotton, 17:34:57)
    3. Accepted Blocker, kwin, NEW (bcotton, 17:34:57)
    4. kernel patches exist to address this issue (bcotton, 17:42:28)

  7. Current status - blockers (bcotton, 17:46:11)
    1. 3 Accepted Blockers (bcotton, 17:46:11)

  8. Current status - test matrices (bcotton, 17:52:16)
    1. https://fedoraproject.org/wiki/Category:Fedora_37_Test_Results (bcotton, 17:52:16)
    2. Coverage is great (bcotton, 17:54:24)

  9. Current status - Release Candidate (bcotton, 17:54:25)
    1. We have one. It has blockers (bcotton, 17:54:25)

  10. Go/No-Go decision (bcotton, 17:54:30)
    1. By policy, F37 Final is NO-GO due to outstanding blockers (bcotton, 17:54:58)
    2. The next F37 Go/No-Go meeting will be Thursday, 2022-11-03 at 1700 UTC (bcotton, 17:55:21)
    3. F37 shifts to target date #3: Tuesday 2022-11-08 (bcotton, 17:55:21)
    4. The Release Party will happen prior to the release (bcotton, 17:55:32)
    5. https://fedoramagazine.org/youre-invited-to-the-fedora-linux-37-release-party/ (bcotton, 17:56:01)

  11. Now what? (bcotton, 17:56:01)
    1. There's a rumination on the table to do additional updates (bcotton, 17:56:44)
    2. https://pagure.io/fedora-qa/blocker-review/issue/987#comment-823063 (bcotton, 17:56:46)
    3. AGREED: Target date #3 shifts to 15 November in order to allow time for thorough verification of Tuesday's openssl update. We will vote for FEs through the usual process to allow some important late features to land. (bcotton, 18:26:11)
    4. https://lists.freedesktop.org/archives/dri-devel/2022-October/377407.html (adamw, 18:27:05)
    5. https://bugzilla.redhat.com/show_bug.cgi?id=2138247 - kernel 6.0 FE proposal (adamw, 18:38:43)


Meeting ended at 18:42:14 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. adamw (134)
  2. bcotton (119)
  3. Eighth_Doctor (88)
  4. sgallagh (72)
  5. nirik (52)
  6. cmurf (44)
  7. mattdm (40)
  8. jforbes (28)
  9. zodbot (21)
  10. nb (17)
  11. travier (16)
  12. Penguinpee (13)
  13. frantisekz (11)
  14. dustymabe (8)
  15. bytehackr (6)
  16. mhroncok (5)
  17. copperi[m] (4)
  18. Southern_Gentlem (3)
  19. geraldosimiao (3)
  20. coremodule (1)
  21. dtometzki (1)


Generated by MeetBot 0.4.