fesco
LOGS
17:06:12 <sgallagh> #startmeeting FESCo (2022-07-26)
17:06:12 <zodbot> Meeting started Tue Jul 26 17:06:12 2022 UTC.
17:06:12 <zodbot> This meeting is logged and archived in a public location.
17:06:12 <zodbot> The chair is sgallagh. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:06:12 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:06:12 <zodbot> The meeting name has been set to 'fesco_(2022-07-26)'
17:06:18 <sgallagh> #meetingname fesco
17:06:18 <zodbot> The meeting name has been set to 'fesco'
17:06:27 <sgallagh> #topic Init Process
17:06:32 <sgallagh> .hi
17:06:33 <zodbot> sgallagh: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
17:06:49 <nirik> morning
17:07:23 <mhroncok> .hello churchyard
17:07:24 <zodbot> mhroncok: churchyard 'Miro Hrončok' <mhroncok@redhat.com>
17:07:43 <bcotton> .hello2
17:07:44 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
17:07:57 <decathorpe> .hello2
17:07:58 <zodbot> decathorpe: decathorpe 'Fabio Valentini' <decathorpe@gmail.com>
17:08:26 <salimma> .hi
17:08:27 <zodbot> salimma: salimma 'Michel Alexandre Salim' <michel@michel-slm.name>
17:08:33 <sgallagh> Hmm, maybe we won’t hit quorum :-)
17:08:46 <salimma> we can summon Neal
17:09:07 <Eighth_Doctor> .hello ngompa
17:09:08 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
17:09:08 <sgallagh> I’m short on salt for the circle
17:09:15 <Eighth_Doctor> I'm half dead, but I'm here
17:10:19 <sgallagh> Okay, I got tied up this morning and didn’t have a chance to do the ticket scrub, so I’m basically just going to do this as an Open Floor meeting and folks can suggest tickets as needed.
17:10:31 <sgallagh> I’ll handle the secretary work after the meeting.
17:10:39 <sgallagh> #topic Open Floor
17:11:15 <sgallagh> What needs the most urgent discussion?
17:11:30 * mhroncok goes to check
17:12:08 <mhroncok> I wnated to see what folks think about https://pagure.io/fesco/issue/2842 but it is not urgent (any more)
17:12:16 <sgallagh> (Sorry, also shoveling lunch down while I type)
17:12:18 <sgallagh> Ah right
17:12:47 * nirik is fine with it whenever.
17:13:22 <sgallagh> My thoughts here are that it’s fine to allow post-mass rebuild since we’ve been running it this way in ELN for a long time now.
17:13:34 <mhroncok> but ELN doe snot include everything, does it?
17:13:40 <mhroncok> s/doe/does/, s/snot/not/
17:13:40 <sgallagh> True
17:13:41 <decathorpe> Remind me, how many packages are in ELN, and how many packages are in Fedora?
17:13:59 <decathorpe> (same argument for RHEL 8/9(
17:14:02 <sgallagh> Roughly 5000 packages in ELN currently
17:14:09 <mhroncok> I don'T wan tto deal with random stuff suddenyl failing on me when i need to ship a CVE fix
17:14:13 <sgallagh> Fair
17:14:25 <mhroncok> * I don't want to deal with random stuff suddenly failing on me when I need to ship a CVE fix
17:14:38 <sgallagh> I don’t object to deferring it. But I’m also on board if a majority just says “go ahead”.
17:14:48 <nirik> same
17:14:59 <mhroncok> also, ELN is an even higher baseline, innit?
17:15:12 <sgallagh> Hmm, actually yeah. It’s z14
17:16:05 <mhroncok> ELN has -march=z14 -mtune=z15
17:16:12 <mhroncok> this has -march=z13 -mtune=z14
17:16:26 <mhroncok> I don't know if ELN ever had -march=z13 -mtune=z14 for an extended period or not
17:16:27 * nirik wonders why.
17:16:32 <Eighth_Doctor> wait, so we're downgrading march?
17:16:36 <mhroncok> no
17:16:46 <mhroncok> Fedora Rawhide now has -march=zEC12 -mtune=z13
17:16:54 <mhroncok> See https://src.fedoraproject.org/rpms/redhat-rpm-config/pull-request/207#request_diff
17:17:25 <nirik> yeah, I find it hard to think that people with older mainframes would be using lots of fedora when rhel doesn't work there already...
17:17:44 <mhroncok> ELN was updated 5 months ago, https://src.fedoraproject.org/rpms/redhat-rpm-config/c/04be20e64b522956b90d40e9973957aa4c190690
17:17:52 <mhroncok> It had what this proposal has before
17:18:44 <mhroncok> dropping support for older mainframes doe snot really concern me at all. a mass rebuild has no effect on this, we either do it in f37 or f38, no difference
17:18:53 <mhroncok> s/doe/does/, s/snot/not/
17:19:16 <mhroncok> random subtle buggy behavior in a random package here and there is what I am afraid of
17:20:09 <mhroncok> anyway, we can vote asynchronously, it's tagged with meeting only because it has negative votes
17:20:20 <sgallagh> True. After all, none of the packages in Fedora have other bugs. :-P
17:21:33 <sgallagh> And to be realistic, I highly doubt that more than a few dozen mainframes exist that run Fedora.
17:23:00 <Eighth_Doctor> meh, I'm fine with updating the s390x/Z system baseline
17:23:34 <sgallagh> #chair nirik, decathorpe, zbyszek, sgallagh, mhroncok, dcantrell, music, mhayden, Conan_Kudo, Pharaoh_Atem, Son_Goku, King_InuYasha, Sir_Gallantmon, Eighth_Doctor
17:23:34 <zodbot> Current chairs: Conan_Kudo Eighth_Doctor King_InuYasha Pharaoh_Atem Sir_Gallantmon Son_Goku dcantrell decathorpe mhayden mhroncok music nirik sgallagh zbyszek
17:23:44 <sgallagh> (Forgot to do that earlier)
17:23:51 <mhayden> 👋
17:24:45 <sgallagh> OK, I think we can take this to the ticket now.
17:24:56 <sgallagh> Does anyone want to discuss the RPi 4 topic?
17:25:14 <sgallagh> Or just wait for pbrobinson to update the wiki?
17:26:06 <nirik> I'm not sure whats still unclear here... we are adding accelerated graphics and some net support... so that it's all around supported by fedora...
17:26:26 <mhroncok> sgallagh: That does not make build issues go away :(
17:26:48 <Eighth_Doctor> Stephen Gallagher: I don't care about the RPi 4 topic beyond just approving it
17:26:53 <Eighth_Doctor> it's purely a marketing Change
17:27:00 <Eighth_Doctor> since we're getting it as part of a kernel rebase
17:27:08 <mhroncok> nirik: It's not clear to me at all. What does "offical support" even mean? How does that impact release criteria?
17:27:34 <sgallagh> Right, the main open question is whether RPi4 issues are blocking on the release
17:27:39 <sgallagh> And if so, on which media?
17:27:39 <Eighth_Doctor> it means Peter will hopefully stop being rude to people who ask about Raspberry Pi support in Fedora ARM channels
17:27:46 <nirik> It means "all the various parts work now" and no, it doesn't affect release critera other than adding that device as a device we test?
17:27:51 <Eighth_Doctor> because we'll have a document for him to point to
17:28:22 <pbrobinson> Eighth_Doctor: I've NEVER been rude actually, please don't lie and make false claims
17:28:26 <sgallagh> Conan Kudo: Please don't editorialize.
17:28:40 <mhroncok> I respectfully disagree
17:28:49 <Eighth_Doctor> I completely utterly disagree
17:29:08 <decathorpe> people, this is unnecessarily off-topic :(
17:29:23 <pbrobinson> mhroncok: you're not even on the arm channel
17:29:25 <Eighth_Doctor> the reason why this Change is happening is because Fedora does not historically support RPi4
17:29:32 <Eighth_Doctor> and people keep asking about it
17:29:48 <sgallagh> Please drop this topic or take it elsewhere.
17:29:52 <Eighth_Doctor> otherwise it wouldn't be Change worthy
17:30:03 <pbrobinson> and we don't support it because the core deliverable of Workstation doesn't properly work
17:30:08 <sgallagh> It's not conducive to making a decision or to remaining civil
17:30:36 <sgallagh> (Meaning the parts not relevant to the Change, of course)
17:31:04 <nirik> right, with accelerated graphics, the workstation arm release blocking deliverable will be testable/doable.
17:31:08 <mhayden> so, hopefully this brings us back on topic -- if we approve this change for the rpi4, what are the potential bad outcomes? delayed release because tests fail? more support burden?
17:31:19 <sgallagh> pbrobinson: Can you answer the question about blocking media?
17:31:19 <Eighth_Doctor> the only open question is a consolidation of the declared supported ARM devices
17:31:20 <sgallagh> That's all I need to know for a +1
17:31:21 <Eighth_Doctor> that is, where people find out what is supported
17:32:05 <pbrobinson> sgallagh: I did actually answer that, it makes it the same status as the other arm blocking devices
17:32:18 <pbrobinson> and QE has a process around that (I don't remember it off hand)
17:32:29 <sgallagh> OK, so it does affect the blocker criteria
17:32:49 <mhroncok> which is not describe din the proposal
17:32:53 <mhroncok> s/describe/described/, s/din/in/
17:32:54 <sgallagh> Right, they have a matrix of install media and hardware that is blocking to the release.
17:32:58 <nirik> it doesn't change the critera any, it adds a new device to be tested against that critera
17:33:11 <pbrobinson> not the critera but the criterea will be applied to the rpi4 when previously they weren't
17:33:15 <sgallagh> So if this is adding one or more entries onto that matrix, we need to add it.
17:34:12 <sgallagh> OK, so it's just being treated like different x64 hardware.
17:34:34 <sgallagh> It isn't necessarily blocking unless a large subset of aarch64 hardware is affected.
17:34:42 <sgallagh> Do I have that right?
17:35:31 <pbrobinson> yep
17:35:42 <sgallagh> OK
17:36:12 <sgallagh> Sorry for so many questions, but I'm just trying to make sure the request is clear.
17:36:18 <Eighth_Doctor> so the big question is that the documentation on supported hardware is confusing
17:36:26 <Eighth_Doctor> people can't figure out what is and isn't supported
17:36:32 <sgallagh> That's not exclusive to RPi 4 though
17:36:41 <sgallagh> I'd suggest we open that as its own issue
17:36:46 <Eighth_Doctor> no, but the Raspberry Pis come up way more than anything else
17:36:57 <Eighth_Doctor> frankly, most people don't care about the rest as much
17:37:24 <Eighth_Doctor> so a Change that markets that we support this should also cover us actually documenting this
17:37:38 <Eighth_Doctor> since that's the only real effort required for this Change
17:37:58 <Eighth_Doctor> so when and where is that happening?
17:38:11 <sgallagh> pbrobinson: Would you have a problem if we made acceptance contingent on updating the support documentation to be more clear?
17:38:13 <mhroncok> sorry, I need to drop
17:39:04 <pbrobinson> Eighth_Doctor: that's COMPLETELY not true actually
17:39:33 <pbrobinson> there's been like a whole bunches of patches that I got upstream and a lot of other work
17:40:03 <pbrobinson> and there is a point on documentation in the change too about movigng the rpi docs to docs.fo.o
17:40:41 <decathorpe> If I remember correctly, one problem that was previously mentioned is that there's multiple different Wiki and docs pages about Fedora on ARM and they list different hardware as supported?
17:41:05 <Eighth_Doctor> the patches are already done though, this is a post facto change
17:41:20 <Eighth_Doctor> as the Change is written, it's announcing things that are already done
17:41:21 <sgallagh> Conan Kudo: Please desist from this line of conversation.
17:41:44 <sgallagh> It is becoming unnecessarily hostile.
17:42:07 <Eighth_Doctor> Stephen Gallagher: look, the change, as written, indicates the code work is done
17:42:28 <Eighth_Doctor> so what are we accepting?
17:42:29 <pbrobinson> decathorpe: yes, the plan is to merge all of that overr to docs
17:42:34 <sgallagh> That's not unique to this Change by any stretch of the imagination
17:42:53 <sgallagh> Many Changes come to us as fait accompli for marketing purposes.
17:42:54 <sgallagh> This is fine.
17:43:02 <pbrobinson> Eighth_Doctor: I had to do specific 5.19 PR for Fedora that will land once this is approved
17:43:04 * Eighth_Doctor grumbles
17:43:12 <pbrobinson> Eighth_Doctor: so again you are incorrect
17:43:13 <Eighth_Doctor> fine whatever
17:43:35 <Eighth_Doctor> Stephen Gallagher: fait accompli changes generally get a finger wag
17:43:44 <sgallagh> pbrobinson: Please desist from that line of conversation as well.
17:44:10 <pbrobinson> sgallagh: fair enough, but I'm just replying to accusations
17:44:21 <sgallagh> OK, so let me propose a solution here:
17:45:14 <sgallagh> Proposal: As indicated in the Change, the owners will perform necessary documentation updates and convergence onto docs.fp.o. The Change is approved, contingent upon those doc updates being made by Beta release.
17:45:41 <pbrobinson> that was already in the change so sure
17:45:56 <sgallagh> (If the doc updates are not made, we will simply delist this as a Change, not remove the features)
17:45:57 <Eighth_Doctor> Stephen Gallagher: +1
17:46:12 <decathorpe> meh, +1
17:46:12 <nirik> sure, still +1 :)
17:46:49 <sgallagh> mhayden: ?
17:47:05 <mhayden> I'm a +1 on it
17:47:30 <sgallagh> #agreed As indicated in the Change, the owners will perform necessary documentation updates and convergence onto docs.fp.o. The Change is approved, contingent upon those doc updates being made by Beta release. (+5, 0, -0)
17:47:48 <sgallagh> pbrobinson: Thank you for taking the time to answer our questions. I appreciate it.
17:48:00 <mhayden> pbrobinson: 🫂
17:48:39 <sgallagh> As an aside, I recently got my hands on a Raspberry Pi 400 and stuck Fedora IoT on it; I'd be happy to help with testing if desired.
17:49:59 <decathorpe> will the endless open floor just taper off now?
17:50:09 <decathorpe> I'm starting to get hungry
17:50:25 <sgallagh> #topic Next Week's Chair
17:51:12 <sgallagh> Anyone?
17:51:48 <decathorpe> I guess we'll all be busy with preparing for Nest next week?
17:52:04 <sgallagh> hmm
17:52:54 <sgallagh> OK, do we want to plan on skipping?
17:53:41 <decathorpe> I'd be fine with that. I don't think there's any urgent tickets ... but I can volunteer to run the meeting if we end up needing it.
17:54:28 <sgallagh> #action decathorpe to chair next week meeting if we don't cancel due to Nest
17:54:34 <sgallagh> Thanks for coming, all.
17:54:41 <sgallagh> Sorry for the chaos at the start.
17:55:10 <sgallagh> #endmeeting