fedora-server
LOGS
17:01:45 <pboy> #startmeeting fedora-server
17:01:45 <zodbot> Meeting started Wed Jul  6 17:01:45 2022 UTC.
17:01:45 <zodbot> This meeting is logged and archived in a public location.
17:01:45 <zodbot> The chair is pboy. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:01:45 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:45 <zodbot> The meeting name has been set to 'fedora-server'
17:01:54 <pboy> #topic Welcome / roll call
17:02:03 <pboy> Welcome to our Server WG IRC meeting today!
17:02:12 <pboy> „Same procedure as every year“ We'll give a few minutes for folks to show up
17:02:21 <pboy> I’ll post the agenda in a few minutes.
17:06:19 <eseyman> The server meeting is here, right?
17:06:41 <pboy> Welcome eseyman! Yes it is.
17:06:53 <eseyman> okay, I was worried
17:06:55 <pboy> But we  seem to be in a particularly small crew today.
17:07:33 <cooltshirtguy> .hi
17:07:34 <zodbot> cooltshirtguy: cooltshirtguy 'Jason Beard' <jas_beard@hotmail.com>
17:07:51 <pboy> Welcome Jason!
17:08:50 <pboy> Folks, what should we do?
17:09:11 <cooltshirtguy> thanks
17:10:40 <jwhimpel> .hi
17:10:41 <zodbot> jwhimpel: jwhimpel 'John Himpel' <john@jlhimpel.net>
17:10:43 <pboy> I suggest, we should not decide about the tech. Spec in such a small group
17:10:56 <pboy> Ho John! Welcome!
17:11:07 <jwhimpel> pboy: good afternoon
17:11:36 <pboy> Well, wie are 4 members now, I think we can start.
17:11:55 <pboy> Any Concerns
17:11:57 <eseyman> I'll admit I haven't found the time it merits
17:12:38 <eseyman> but let's start the meeting
17:12:44 <pboy> OK.
17:12:54 <pboy> #topic Agenda
17:13:01 <pboy> #link https://pagure.io/fedora-server/report/Meeting
17:13:11 <pboy> #info Follow up actions
17:13:19 <pboy> #info  Software Raid on UEFI systems
17:13:28 <pboy> #info  Review current Fedora Server Technical Specification
17:13:35 <pboy> #info Open Floor
17:13:45 <pboy> Any additional topic / issue / comment ?
17:13:58 <eseyman> .hello2 eseyman
17:13:59 <zodbot> eseyman: eseyman 'Emmanuel Seyman' <emmanuel@seyman.fr>
17:14:23 <eseyman> no, that's already a pretty big agenda
17:14:25 <pboy> I see none
17:14:33 <pboy> #topic  Follow up actions
17:14:41 <pboy> #info Change proposal to add Server VM is accepted by FESCo
17:14:47 <pboy> #link Tracking Bug: https://bugzilla.redhat.com/show_bug.cgi?id=2100621
17:14:55 <pboy> #info Change Proposal regarding the default hostname configuration is accepted by FESCo
17:15:02 <pboy> #link https://pagure.io/fesco/issue/2804
17:15:10 <pboy> #info DONE: pboy to add test of uefi sw raid
17:15:16 <pboy> #link  https://pagure.io/fedora-server/issue/89
17:15:31 <pboy> No outstanding action items at the moment, as far as I know
17:15:41 <pboy> Did I forget something?
17:16:20 <pboy> Obviiously not
17:16:29 <pboy> #topic Software Raid on UEFI systems
17:16:38 <pboy> #link https://pagure.io/fedora-server/issue/89
17:16:50 <pboy> Discussion:
17:16:59 <pboy> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/YV7XFPYLMVFYLJWISCNPXFBNS6YZKDRK/
17:17:20 <pboy> A short break for reading? The issue is a bit complicated.
17:20:55 <pboy> Well, I don't know enough about the technical details.
17:21:18 <pboy> I would suggest:
17:21:31 <pboy> (a) We use the Anaconda solution with raid. Because that's the best we currently have.
17:21:40 <pboy> (b) We continue to explore negative effects.
17:21:53 <pboy> (c) We ask Chris, if he would like to open a bug  or discussion with Anaconda devs.
17:24:21 <eseyman> well, chris seems to know more both anaconda and RAID than me
17:24:41 <eseyman> I would give with (a) but I'm out of my league
17:24:58 <pboy> Yes, me too. And in short discussion Nirik wondered about that solution, too.
17:25:30 <pboy> I think, (a) is the best we have, and it basically works.
17:25:33 <cooltshirtguy> I would go with a.
17:26:09 <pboy> #proposed We use the Anaconda solution with raid, for the time beeing. Further evaluation on next meeting and mailing list.
17:27:23 <pboy> #agreed We use the Anaconda solution with raid, for the time beeing. Further evaluation on mailing list and next meeting.
17:27:43 <pboy> #topic Review current Fedora Server Technical Specification
17:27:53 <pboy> #link https://pagure.io/fedora-server/issue/58
17:28:10 <pboy> #link https://hackmd.io/9or6pDs3Qq6DzzgVzXgmeQ?view
17:28:26 <eseyman> Sorry, I haven't had the time to do more than skim it
17:28:34 <pboy> What about 5 Mins reading break?
17:28:38 <eseyman> I probably won't until the weekend
17:29:43 <pboy> eseyman what do you propose?
17:29:56 <eseyman> delay until next meeting
17:30:25 <pboy> OK.
17:32:21 <pboy> I think, I'll create a 4. version and include at least the simple comments.
17:33:07 <pboy> Does one of you see a passage / paragraph which is specifically in need of discussion?
17:35:12 <eseyman> nope
17:35:19 <cooltshirtguy> no
17:35:29 <pboy> OK. Next topic.
17:35:43 <pboy> #topic Open Floor
17:36:16 <pboy> Memorable. We never had so much time for this topic.
17:36:29 <pboy> Anything to discuss?
17:37:12 <jwhimpel> I've tried to configure wildfly to use ssl with almost no success.
17:37:32 <jwhimpel> I can get it to work via interactive cli, but not without user inputs.
17:37:47 <jwhimpel> I'm currently trying to get the following procedure to work.
17:37:52 <jwhimpel> https://developer.jboss.org/people/fjuma/blog/2018/08/31/obtaining-certificates-from-lets-encrypt-using-the-wildfly-cli#jive_content_id_Obtaining_a_certificate_from_Lets_Encrypt
17:38:25 <jwhimpel> I am currently stuck on just where to modify standalone.xml as described in  the blog.
17:38:56 <jwhimpel> If anyone could try this blogged procedure on their own and let me know the results, I would be very appreciative.
17:39:31 <jwhimpel> <end of request for help>
17:39:36 <eseyman> I can try and take a look but not before the weekend
17:40:02 <pboy> I too, after the weekend.
17:40:09 <jwhimpel> That would be greatly appreciated.  No rush.
17:40:33 <eseyman> I would have thought howtoforge would have a useful post on the subject specific to Fedora or RHEL (and associated clones)
17:41:11 <pboy> It's very important issue! Wildfly is our model project for Ansible support and the specifically supported sevices or Server role NG.
17:41:50 <jwhimpel> Almost all tutorials & how-to's assume human interaction with jboss-cli (answering questions).
17:42:33 <cooltshirtguy> never used it. maybe i should look at it
17:42:51 <jwhimpel> I am hopeful to get the installation and configuration to work under ansible (non-interactive)
17:43:01 <pboy> cooltshirtguy Yes, please
17:43:50 <eseyman> sorry, have to step out for 10 minutes
17:43:54 <pboy> Maybe, each  of us should give it a try and then we discuss via mailing list end of next week?
17:44:43 <jwhimpel> Sounds good to me.
17:45:03 <pboy> OK, let's do so!
17:45:45 <pboy> I' am very excited about it!
17:45:53 <pboy> Anything else?
17:45:55 <jwhimpel> Specific issue is I can get jboss-cli part to work fine.  It's where to make the modifications inside configuration/standalone.xml that has me baffles.
17:46:33 <jwhimpel> That's all from me.
17:46:59 <pboy> jwhimpel maybe we should find a jboss / wildfly expert we can ask? But let's first try it ourself.
17:47:13 <jwhimpel> Agreed
17:47:16 <cooltshirtguy> ok
17:47:40 <pboy> Well, something else?
17:48:52 <pboy> I see nothing. So I'll close the meeting.
17:48:55 <pboy> 3
17:49:02 <pboy> 2
17:49:11 <pboy> 1
17:49:21 <pboy> #endmeeting