magazine
LOGS
15:00:27 <zinebot[m]> #startmeeting magazine
15:00:27 <zodbot> Meeting started Thu May 19 15:00:27 2022 UTC.
15:00:27 <zodbot> This meeting is logged and archived in a public location.
15:00:27 <zodbot> The chair is zinebot[m]. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
15:00:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:27 <zodbot> The meeting name has been set to 'magazine'
15:00:27 <glb> 🔹 next topic
15:00:28 <zinebot[m]> #meetingname magazine
15:00:28 <zodbot> The meeting name has been set to 'magazine'
15:00:28 <zinebot[m]> #topic roll call
15:00:29 <zinebot[m]> #chair zinebot glb rlengland theevilskeleton
15:00:29 <zodbot> Current chairs: glb rlengland theevilskeleton zinebot zinebot[m]
15:00:50 <glb> .hello glb
15:00:53 <zodbot> glb: glb 'Gregory Bartholomew' <gregory.lee.bartholomew@gmail.com>
15:01:17 <rlengland[m]> .hello rlengland
15:01:18 <zodbot> rlengland[m]: rlengland 'Richard England' <rlengland@gmail.com>
15:02:06 <glb> Are we ready to get this show started?
15:02:39 <rlengland[m]> Start your engines
15:02:59 <glb> 🔹 next topic
15:02:59 <zinebot[m]> #link https://docs.fedoraproject.org/en-US/fedora-magazine/workflow/
15:03:00 <zinebot[m]> #topic agenda
15:03:00 <zinebot[m]> #info -- 1/ last week's stats --
15:03:00 <zinebot[m]> #info -- 2/ articles in progress --
15:03:00 <zinebot[m]> #info -- 3/ articles to review --
15:03:00 <zinebot[m]> #info -- 4/ articles to edit --
15:03:01 <zinebot[m]> #info -- 5/ publishing schedule --
15:03:01 <zinebot[m]> #info -- 6/ editor of the week --
15:03:02 <zinebot[m]> #info -- 7/ open floor --
15:03:08 <glb> 🔹 next topic
15:03:09 <zinebot[m]> #topic 1/ last week's stats
15:03:19 <glb> #info Week of May 09: 105K pageviews -- more than twice the previous week; this is normal for a release week
15:03:27 <glb> 🔹 next topic
15:03:36 <zinebot[m]> #info Looking at the 'in-progress' column, is there something that's been finished? Anything to follow up on with its author?
15:03:37 <zinebot[m]> #topic 2/ articles in progress
15:03:37 <zinebot[m]> #link board: https://pagure.io/fedora-magazine-newsroom/boards/articles
15:03:38 <zinebot[m]> #info 087: Introducing Phyllome OS, a Fedora Remix targeting Desktop Virtualization (author: luzeal) (fpca: signed) (status: in-progress)
15:03:38 <zinebot[m]> #info status: https://pagure.io/fedora-magazine-newsroom/issue/87
15:03:38 <zinebot[m]> #info 059: Commands providing views into the system (author: zexcon) (fpca: signed) (status: in-progress)
15:03:38 <zinebot[m]> #info status: https://pagure.io/fedora-magazine-newsroom/issue/59
15:03:38 <zinebot[m]> #info preview: https://fedoramagazine.org/?p=34935&preview=true
15:03:39 <zinebot[m]> #info 068: Spam classification with neural networks (author: fed500) (fpca: signed) (status: in-progress)
15:03:39 <zinebot[m]> #info status: https://pagure.io/fedora-magazine-newsroom/issue/68
15:03:40 <zinebot[m]> #info 072: Introduction to OpenFOAM (author: thunderbirdtr) (fpca: signed) (status: in-progress)
15:03:40 <zinebot[m]> #info status: https://pagure.io/fedora-magazine-newsroom/issue/72
15:04:12 <zinebot[m]> #info status: https://pagure.io/fedora-magazine-newsroom/issue/60
15:04:12 <zinebot[m]> #info preview: https://fedoramagazine.org/?p=33868&preview=true
15:04:13 <zinebot[m]> #info 102: Joining clients to Samba Domain Controller (author: dklima) (fpca: signed) (status: in-progress)
15:04:13 <zinebot[m]> #info status: https://pagure.io/fedora-magazine-newsroom/issue/102
15:04:13 <zinebot[m]> #info 120: Introduction to DIY Embroidery with Inkscape and Ink/Stitch (author: fed500) (fpca: signed) (status: in-progress)
15:04:14 <zinebot[m]> #info status: https://pagure.io/fedora-magazine-newsroom/issue/120
15:04:14 <zinebot[m]> #info 103: Fedora Linux editions part 1: Official Editions (author: armanwu) (fpca: signed) (status: in-progress)
15:04:14 <zinebot[m]> #info status: https://pagure.io/fedora-magazine-newsroom/issue/103
15:04:14 <zinebot[m]> #info preview: https://fedoramagazine.org/?p=36288&preview=true
15:04:28 <glb> I guess since we skipped going through these last week we should go through them this week?
15:06:17 <rlengland[m]> Probably.  87  No response last two pings, latest 13 days ago
15:07:22 <glb> OK. So I'll move that one to stalled then.
15:07:53 <glb> At some point we might even delete some of these if we don't think there is much chance of them being picked up.
15:08:02 <rlengland[m]> 59 no response for last 4 months lastest was one month
15:08:09 <glb> But for now, stalled is a good place to archive them.
15:08:20 <rlengland[m]> 👍️.
15:08:27 <zinebot[m]> #info 087: Introducing Phyllome OS, a Fedora Remix targeting Desktop Virtualization (author: luzeal) (fpca: signed) (status: in-progress)
15:08:27 <glb> 🔹 next card
15:08:28 <zinebot[m]> #info status: https://pagure.io/fedora-magazine-newsroom/issue/87
15:08:39 <glb> 🔹 move 87 stalled
15:08:40 <zinebot[m]> card 87 moved to 'stalled'
15:08:43 <TheEvilSkeleton> .hello theevilskeleton
15:08:44 <zodbot> TheEvilSkeleton: theevilskeleton 'Hari Rana' <theevilskeleton@riseup.net>
15:08:48 <glb> 🔹 next card
15:08:49 <zinebot[m]> #info 059: Commands providing views into the system (author: zexcon) (fpca: signed) (status: in-progress)
15:08:49 <zinebot[m]> #info status: https://pagure.io/fedora-magazine-newsroom/issue/59
15:08:49 <zinebot[m]> #info preview: https://fedoramagazine.org/?p=34935&preview=true
15:09:14 <TheEvilSkeleton> zinebot update? The colors look pretty
15:09:24 <glb> 🔹 move 59 stalled
15:09:27 <zinebot[m]> card 59 moved to 'stalled'
15:09:36 <rlengland[m]> 68 responded 13 days ago
15:10:06 <glb> TheEvilSkeleton: no, zinebot has produced that color-coded output for quite a while now. 🙂
15:10:21 <glb> 🔹 card 68 comments
15:10:28 <zinebot[m]> comments:... (full message at https://libera.ems.host/_matrix/media/r0/download/libera.chat/2a8f759df71562510a3edb1d57981871e1541677)
15:10:35 <TheEvilSkeleton> glb: I see. I never saw those colors on desktop. I'm using my phone right now
15:11:11 <glb> They probably only show up when you are using a Matrix client that supports them.
15:11:17 <zinebot[m]> #info status: https://pagure.io/fedora-magazine-newsroom/issue/68
15:11:17 <glb> 🔹 next card
15:11:18 <zinebot[m]> #info 068: Spam classification with neural networks (author: fed500) (fpca: signed) (status: in-progress)
15:11:23 <glb> 🔹 next card
15:11:24 <zinebot[m]> #info status: https://pagure.io/fedora-magazine-newsroom/issue/72
15:11:25 <zinebot[m]> #info 072: Introduction to OpenFOAM (author: thunderbirdtr) (fpca: signed) (status: in-progress)
15:11:25 <zinebot[m]> #info preview: https://fedoramagazine.org/?p=35214&preview=true
15:11:35 <glb> 🔹 card 72 comments
15:11:38 <zinebot[m]> comments:... (full message at https://libera.ems.host/_matrix/media/r0/download/libera.chat/159a95eb5cb17c90e2ba130cd0978231e70e2ea8)
15:12:50 <glb> I think thunderbirdtr has been super busy with things on the websites and apps team. We should probably just be patient with this one.
15:12:55 <glb> 🔹 next card
15:12:56 <zinebot[m]> #info status: https://pagure.io/fedora-magazine-newsroom/issue/60
15:12:57 <zinebot[m]> #info 060: Using Fedora Server to build a minimal desktop (author: nekon) (fpca: signed) (status: in-progress)
15:12:57 <zinebot[m]> #info preview: https://fedoramagazine.org/?p=33868&preview=true
15:13:12 <glb> 🔹 card 60 comments
15:13:12 <zinebot[m]> comments:... (full message at https://libera.ems.host/_matrix/media/r0/download/libera.chat/8cf62ab09a9b908ac473750437e7b2d78849f7df)
15:13:58 <glb> This one still doesn't look finished.
15:14:05 <glb> Should I ping him?
15:14:40 <rlengland[m]> One more time perhaps.
15:15:32 <glb> 🔹 ping 60 @glaringgibbon: any status update for this article?
15:15:35 <zinebot[m]> Comment added
15:15:40 <glb> 🔹 next card
15:15:40 <zinebot[m]> #info status: https://pagure.io/fedora-magazine-newsroom/issue/102
15:15:41 <zinebot[m]> #info 102: Joining clients to Samba Domain Controller (author: dklima) (fpca: signed) (status: in-progress)
15:15:56 <glb> 🔹 card 102 comments
15:15:57 <zinebot[m]> comments:... (full message at https://libera.ems.host/_matrix/media/r0/download/libera.chat/2f5272b09fb6ac5215f0f6c9176c08eb53047b69)
15:16:27 <glb> Oh. The comments got a little cross-wired on this one.
15:16:43 <glb> Some of those comments are actually in reference to the previous article he wrote.
15:17:13 <glb> But it has been over a month. So we should probably ping him again.
15:17:42 <glb> 🔹 ping 102 @dklima: any status updates for this article?
15:17:44 <zinebot[m]> Comment added
15:17:45 <rlengland[m]> 👍️.
15:17:53 <glb> 🔹 next card
15:17:53 <zinebot[m]> #info status: https://pagure.io/fedora-magazine-newsroom/issue/120
15:17:54 <zinebot[m]> #info 120: Introduction to DIY Embroidery with Inkscape and Ink/Stitch (author: fed500) (fpca: signed) (status: in-progress)
15:18:31 <glb> Hmm. This one is a bit of a mess. It looks like the author uploaded the draft to the Pagure card.
15:19:49 <glb> Figuring out how to tell people not to do that might be a good issue for the workflow/theme revision work that we have slated to do.
15:20:16 <glb> Anyone want to volunteer to work with this author to get the content in the right place?
15:20:27 <rlengland[m]> Also, this opened by the author and I didn't find a proposal for it.
15:21:04 <glb> Oh. I missed that.
15:21:16 <glb> I wonder how we should handle this situation?
15:21:38 <rlengland[m]> fed500 has written before, have the not?
15:22:11 <rlengland[m]> *they
15:22:11 <rlengland[m]> Yes this is Benson
15:22:51 <rlengland[m]> I'll see if I can connect and get him to move the article to WordPress
15:23:04 <glb> Uh, wait ...
15:23:24 <glb> https://discussion.fedoraproject.org/t/introduction-to-diy-embroidery-with-inkscape-and-ink-stitch/39147
15:23:48 <glb> It looks like you approved the proposal and created the card?
15:24:06 <rlengland[m]> Yeah,  sorry,  brain fade
15:24:51 <glb> Whew. I guess it is just a matter of getting the content moved to WordPress and edited for publication then.
15:25:16 <rlengland[m]> I added the link to the proposal. I'll contact him.
15:25:20 <glb> We want the author to created the WordPress article though so that it is "owned" by the right person.
15:25:30 <rlengland[m]> Yep
15:25:54 <glb> So we'll leave this in the "in-progress" column until he gets that done.
15:25:54 <glb> 🔹 next card
15:25:56 <zinebot[m]> #info 103: Fedora Linux editions part 1: Official Editions (author: armanwu) (fpca: signed) (status: in-progress)
15:25:56 <zinebot[m]> #info status: https://pagure.io/fedora-magazine-newsroom/issue/103
15:25:56 <zinebot[m]> #info preview: https://fedoramagazine.org/?p=36288&preview=true
15:26:13 <glb> 🔹 card 103 comments
15:26:15 <zinebot[m]> comments:... (full message at https://libera.ems.host/_matrix/media/r0/download/libera.chat/c1a9742b0c1a28458609710929f7e4537a4d7f5f)
15:27:03 <glb> This author has written several articles for us in the past. I'm sure we just need to give him more time.
15:27:08 <zinebot[m]> card not found or end of column
15:27:08 <glb> 🔹 next card
15:27:51 <glb> yay \o/
15:28:12 <rlengland[m]> :-)
15:28:23 <glb> I was looking for an emoji for that, but I couldn't get one to autocomplete. 🙂
15:28:36 <glb> Ah, yes, the tada.
15:28:48 <glb> 🎉
15:29:02 <glb> That works. 🙂
15:29:10 <glb> 🔹 next topic
15:29:10 <zinebot[m]> #info Are there any upcoming test days?
15:29:11 <zinebot[m]> #link https://calendar.fedoraproject.org/QA/
15:29:19 <glb> 🔹 show testdays
15:29:19 <zinebot[m]> #info no test days found between 2022-05-15 and 2022-06-05
15:29:26 <glb> 🔹 next topic
15:29:26 <zinebot[m]> #info Check the release schedule.
15:29:27 <zinebot[m]> #link https://fedorapeople.org/groups/schedule/f-36/f-36-magazine-tasks.html
15:29:32 <glb> 🔹 next topic
15:29:38 <zinebot[m]> #info Looking at the 'review' column, let's decide which articles are good to go. Move each either to the 'to-edit' (finished) column or to the 'in-progress' (needs more work) column and provide feedback.
15:29:39 <zinebot[m]> #topic 3/ articles to review
15:29:39 <zinebot[m]> #link board: https://pagure.io/fedora-magazine-newsroom/boards/articles
15:29:39 <zinebot[m]> no cards found in the 'review' column
15:30:06 <glb> It looks like it is going to be another slow week. 😕
15:31:43 <glb> On the plus side, I guess that will give us more time to work on the theme. 🙂
15:31:50 <glb> 🔹 next topic
15:31:57 <zinebot[m]> #topic 4/ articles to edit
15:31:58 <zinebot[m]> #info Looking at the 'to-edit' column, assign an editor and a cover image creator.
15:31:58 <zinebot[m]> #link board: https://pagure.io/fedora-magazine-newsroom/boards/articles
15:31:58 <zinebot[m]> no cards found in the 'to-edit' column
15:32:23 <rlengland[m]> And you'll be down one person, since I won't be here
15:32:49 <glb> rlengland: will you be here for the meeting next week?
15:33:43 <rlengland[m]> No, I depart on Wed. and won' be here for the next 2
15:34:03 <glb> I may cancel those meetings then.
15:34:21 <glb> Will you be doing any work async?
15:35:12 <rlengland[m]> For the most part I'll be moving boxes and driving a truck so it will be sporadic
15:35:49 <rlengland[m]> Perhaps in the evenings I can check in and get something done but I'd not plan on any great throughput
15:35:54 <glb> I won't wait on you to approve article proposals that might come in over the next two weeks then.
15:36:40 <glb> Though I guess TheEvilSkeleton could still give the second +1 for the article proposals?
15:36:46 <rlengland[m]> Good idea
15:37:03 <TheEvilSkeleton> +1
15:38:26 <glb> OK then. Be sure that you are following the Fedora Magazine workflow topic on the Discussion forum and I'll give you a little bit of time to provide feedback on article proposals. Whoever gives the second +1 is supposed to create the Pagure card.
15:39:29 <TheEvilSkeleton> Sure. I there a way I can get notifications?
15:39:47 <TheEvilSkeleton> Email notifications preferably
15:39:51 <glb> #action rlengland to work with author of #120 to get content moved to WordPress.
15:40:03 <rlengland[m]> +1
15:40:43 <glb> TheEvilSkeleton: yes, you should be able to configure email notifications by following that category.
15:41:00 <glb> It is under your profile preferences somewhere.
15:41:17 <glb> That might be another thing that should be documented somewhere.
15:41:31 <TheEvilSkeleton> glb: Thanks. I just configured it
15:41:50 <glb> 🔹 next topic
15:41:54 <zinebot[m]> #topic 5/ publishing schedule
15:41:55 <zinebot[m]> #info Looking at the 'to-edit' column, decide the publishing schedule for the upcomming week.
15:41:55 <zinebot[m]> #info If there is not enough content, we might also need to look at the 'in-progress' or even the 'ideas' columns come up with additional content.
15:41:55 <zinebot[m]> #link board: https://pagure.io/fedora-magazine-newsroom/boards/articles
15:41:55 <zinebot[m]> no cards found in the 'to-edit' column
15:42:00 <glb> 🔹 show proposed
15:42:04 <zinebot[m]> #proposed PUBLISHING SCHEDULE: There are no articles to be edited.
15:42:19 <glb> I guess there isn't much to "+1".
15:42:25 <glb> 🔹 show agreed
15:42:29 <zinebot[m]> #agreed PUBLISHING SCHEDULE: There are no articles to be edited.
15:42:35 <glb> 🔹 next topic
15:42:35 <zinebot[m]> #topic 6/ editor of the week
15:42:48 <glb> 🔹 eotw glb
15:42:48 <zinebot[m]> #info glb will be editor of the week starting Sun 22 May 2022
15:42:53 <zinebot[m]> #topic 7/ open floor
15:42:53 <glb> 🔹 next topic
15:43:38 <glb> OK. Since there aren't any articles to edit, we should have plenty of time for theme updates. 🙂
15:43:58 <TheEvilSkeleton> I was gonna ask about that lol
15:44:01 <glb> Have people had time to review the usability study?
15:44:32 <TheEvilSkeleton> I only watched 10 minutes but I had to go after that. I forgot about it later
15:44:34 <rlengland[m]> I've not, regrettabley
15:44:49 <rlengland[m]> 😦.
15:44:57 <glb> It's OK.
15:45:08 <glb> It's not really part of our "normal" workflow.
15:45:23 <rlengland[m]> I know...."slackers"
15:45:24 <glb> But it probably is something that we should review from time to time.
15:46:01 <glb> Are there any questions about what needs to be done or how to do it?
15:46:02 <rlengland[m]> I did, however, do the sidebar update text.
15:46:31 <rlengland[m]> Are there any process changes for testing the edits?  Are the docs up to date for that?
15:46:59 <glb> And I saw that you approved my documentation update PR too. Thanks for that! 🙂
15:48:30 <glb> Well, yes, I changed the testing system to use Podman instead of Vagrant. But had any of you used the previous Vagrant system before?
15:49:04 <rlengland[m]> I believe I did when we moved to Pagure
15:49:12 <glb> If you had used the previous system, then I guess it wasn't a "change" from your perspective?!
15:49:30 <glb> You've done a theme update before?
15:49:57 <rlengland[m]> oh..oops,  not the theme that was the documentation update, sorry.
15:50:06 <rlengland[m]> I'm not awake, it would seem
15:50:15 <glb> Yeah, so the documentation has always used Podman.
15:50:30 <glb> But the theme previously used Vagrant.
15:51:02 <glb> I tried to rename the scripts and processes for updating the theme so that they would be similar to how the documentation is updated.
15:52:06 <glb> Most everything is just text files. So just edit whatever needs changed, test it locally, and submit a PR.
15:52:46 <glb> One thing to note about the theme repo is that what it there doesn't automatically go live (unlike with the documentation repo).
15:53:34 <glb> Rather, a WordPress admin has to create a zip archive of the contents of the repo and upload that to the WordPress site through the admin control panel.
15:53:58 <glb> So you don't have to worry too much about submitting a bad PR.
15:54:54 <glb> But whoever is going to actually update the theme should definitely test the repo locally before the zip it and upload it.
15:56:10 <glb> Please also be sure you are working from the latest version of the repo (as always). Try to submit your PRs against the current head/tip on the upstream repo.
15:56:50 <glb> s/the/they/
15:57:23 <rlengland[m]> In summary then  the process is similar to the magazine docs except for the zip/upload steps
15:57:25 <glb> s/it/is/
15:57:41 <glb> rlengland: Yep. It is now. 🙂
15:58:10 <rlengland[m]> :-)
15:58:22 <rlengland[m]> Good work.
15:59:11 <glb> So I'll let you guys go ahead and have a few tries at updating things. I'll just be keeping an eye out for PRs and approving them. 🙂
15:59:56 <glb> Well, it looks like we are out of time.
16:00:35 <rlengland[m]> This could tax my git abilities but we'll give it a shot.
16:00:45 <rlengland[m]> :-)
16:00:58 <TheEvilSkeleton> I might try to contribute a bit
16:01:15 <TheEvilSkeleton> Do you have an update on the suggestions I made in the issue tracker?
16:02:05 <glb> I don't recall any of them being too problematic. I think you can go ahead at try to implement a few of them if you want.
16:02:16 <TheEvilSkeleton> Sure
16:02:27 <TheEvilSkeleton> They're not problematic, but they're visually better
16:03:08 <glb> Beauty is in the eye of the beholder, as they say. 🙂
16:03:41 <glb> OK then ...
16:03:45 <glb> #endmeeting