fedora-server
LOGS
17:00:10 <pboy> #startmeeting fedora-server
17:00:10 <zodbot> Meeting started Wed Feb 16 17:00:10 2022 UTC.
17:00:10 <zodbot> This meeting is logged and archived in a public location.
17:00:10 <zodbot> The chair is pboy. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
17:00:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:10 <zodbot> The meeting name has been set to 'fedora-server'
17:00:19 <pboy> #topic Welcome / roll call
17:00:28 <pboy> Welcome to our Server WG IRC meeting today!
17:00:35 <pboy> „Same procedure as every year“ We'll give a few minutes for folks to show up
17:00:42 <pboy> Please, everybody who is lurking, say either .hello2 or .hello <fasname>
17:00:52 <pboy> I’ll post the agenda in a few minutes.
17:02:09 <eseyman> .hello eseyman
17:02:10 <zodbot> eseyman: eseyman 'Emmanuel Seyman' <emmanuel@seyman.fr>
17:02:17 <eseyman> hello pboy
17:02:42 <pboy> hello eseyman nice to see you!
17:03:00 <cooltshirtguy> hello
17:03:07 <xtify21> hello
17:03:09 <copperi[m]> .hello <fasname>
17:03:10 <zodbot> copperi[m]: Sorry, but user '<fasname>' does not exist
17:03:15 <eseyman> hello, all
17:03:47 <pboy> Welcome copperi! Missed you already
17:03:59 <jwhimpel> .hello jwhimpel
17:04:00 <zodbot> jwhimpel: jwhimpel 'John Himpel' <john@jlhimpel.net>
17:04:14 <cooltshirtguy> .hello pboy
17:04:15 <zodbot> cooltshirtguy: pboy 'Peter Boy' <pboy@uni-bremen.de>
17:04:38 <mowest[m]> I'm here
17:05:22 <pboy> Hi  jwhimpel! Sorry not having responded to your last email. I was was so busy. But I will do better!
17:05:27 <dcavalca> .hi
17:05:28 <zodbot> dcavalca: dcavalca 'Davide Cavalca' <dcavalca@fb.com>
17:06:12 <jwhimpel> pboy: No problem.  I've been busy with other stuff.
17:06:30 <pboy> jwhimpel: Thanks.
17:06:44 <pboy> Welcome all. I can't type that fast right now.
17:06:56 <pboy> I give the agenda now.
17:07:06 <pboy> #topic Agenda
17:07:12 <pboy> #link https://pagure.io/fedora-server/report/Meeting
17:07:18 <pboy> 1. Follow up actions
17:07:25 <pboy> 2. Cockpit file-sharing update Change Proposal
17:07:31 <pboy> 3. Specifying F36 manual test requirements
17:07:39 <pboy> 4.  Open Floor
17:07:45 <pboy> Any additional topic ?
17:08:10 <pboy> By the way, I created a board to track our activities and outstanding tasks:
17:08:17 <pboy> #link https://pagure.io/fedora-server/boards/Works%20in%20progress
17:08:24 <pboy> Just in case someone has a bit of spare time and is in need of some inspiration.
17:09:26 <eseyman> spare time is short supply these days...
17:09:41 <mowest[m]> I submitted a PR#75 to pull our meeting minutes into docs from the wiki.
17:09:48 <pboy> You say it
17:10:33 <xtify21> new to channel and looking for ways to help out
17:10:39 <pboy> mowest[m]>: Yes, I saw it. Unfortunately, I was so busy.  So much for short supply
17:10:52 <cooltshirtguy> looking to help too
17:11:27 <mowest[m]> No problem, I still need to work on the old archive of minutes page, pre December 2020 stuff.
17:11:50 <pboy> Welcome xtify21 and cooltshirtguy! We are  happy!
17:12:15 <pboy> Maybe, you will introduce yourself shortly?
17:12:26 <pboy> (both of you, of course)
17:13:06 <cooltshirtguy> here are on the mailing list?
17:13:29 <pboy> Probably sshortly here, and more details on mailing list?
17:14:01 <xtify21> ok, whats the mailing list for fedora server? fedora-server?
17:14:32 <pboy> Mailing List:  server@lists.fedoraproject.org
17:15:26 <pboy> OK, mailing list may be easier and more appropriate? (I'm just so curious ...)
17:15:40 <pboy> I switch to next topic.
17:15:42 <pboy> 3
17:15:48 <xtify21> sure, work as a sysadmin by day, hack around and getting more into security stuff, help out the almalinux project as well doing some system maintenance stuff for and trying to get more into packing as well with alma and fedora. knowledable of python, shell scripting, and some php
17:15:48 <pboy> 2
17:16:11 <xtify21> packaging**
17:16:59 <pboy> xtify21: Thank you. I see you can contribute a lot here.
17:17:20 <pboy> Again: I switch to next topic.
17:17:25 <pboy> 3
17:17:30 <pboy> 2
17:17:32 <cooltshirtguy> Technical Account Manager, was a SysAdmin for 10 years. father, husband, DIY'er. Learning Ansible. my youngest went to college so I have some free time again
17:18:22 <eseyman> ansible \o/
17:18:27 <pboy> cooltshirtguy: Very good! Ansible is a main project here for the coming years!
17:18:38 <cooltshirtguy> woohoo
17:18:50 <pboy> Thanks both of you. probably more details on mailing list!
17:19:02 <pboy> #topic Follow up actions
17:19:14 <pboy> #info Action: All outstanding articles are published except for two where reviews are available.
17:19:25 <pboy> Unfortunately, I have not been able to respond to the reviews yet. Eseyman and mowest, a big big apology. I will get back to you in the next few days.
17:19:40 <pboy> Any other open action  that I missed?
17:20:33 <pboy> OK. I switch to next topic
17:20:36 <eseyman> I have to respond to a reply on the list to my review
17:20:36 <pboy> 3
17:21:15 <pboy> eseyman: Yes,I saw that. Let's try to get in done in the next days.
17:21:26 <pboy> And do better infuture.
17:21:46 <eseyman> yes
17:21:46 <pboy> 3
17:21:52 <pboy> 2
17:21:55 <pboy> 1
17:21:57 <pboy> #topic Cockpit file-sharing update Change Proposal
17:22:06 <pboy> #link  https://pagure.io/fedora-server/issue/73
17:22:15 <pboy> The change is accepted. How will we proceed?
17:25:15 <mowest[m]> According to the Issue, we now need a plan in place to get this feature tested before F36 or we move it to F37?
17:25:51 <mowest[m]> So are we looking for volunteers that can test this in time for F36?
17:25:59 <pboy> mowest[m]: yes. My problem, I don't have any Windows machine here
17:26:22 <pboy> So, I'm a bit of stuck.
17:26:41 <jwhimpel> I can test NFS, but I don't know where to find the current test image.
17:26:49 <pboy> Well, and we need a bit of docu
17:27:28 <pboy> jwhimpel: Great! I can send you how to get it tomorrow.
17:28:35 <pboy> Anyone with a working Windows machine here?
17:28:55 <cooltshirtguy> yea
17:29:00 <xtify21> can it be a vm?
17:29:31 <pboy> Yes, I think so. You need a network connection.
17:29:43 <cooltshirtguy> I have a VM and physical
17:30:41 <pboy> cooltshirtguy and xtify21, please could you try to test? I give more information tomorrow on mailing list.
17:31:16 <cooltshirtguy> sure, just let me know what I need to do
17:31:48 <pboy> Great! I will post some detailed information tomorros on mailing list.
17:31:57 <pboy> #action: jwhimpel will test Cockpit Module with NFS.
17:32:26 <pboy> #action: cooltshirtguy will test Cockpit Module with Windows.
17:32:33 <pboy> Thanks a lot!
17:32:47 <xtify21> sorry, forgot my vm got corrupted
17:33:20 <pboy> xtify21: So to say, shi.. happens   :-)
17:33:31 <cooltshirtguy> typical windows
17:33:33 <cooltshirtguy> :)
17:33:39 <xtify21> lol
17:33:46 <pboy> when you get it running again, please try also to test
17:33:55 <xtify21> sure will do
17:34:01 <pboy> Thanks!
17:34:08 <pboy> I'll switch
17:34:12 <pboy> 3
17:34:17 <pboy> 2
17:34:22 <pboy> 1
17:34:31 <pboy> #topic Specifying F36 manual test requirements
17:34:40 <pboy> #link https://pagure.io/fedora-server/issue/64
17:34:53 <pboy> Part of this is bug 2054625I’ll switch to next topic
17:35:02 <pboy> #link https://pagure.io/fedora-server/issue/64#comment-781570
17:35:13 <pboy> Maybe, we discuss that first?
17:35:22 <pboy> My idea about that:
17:35:30 <pboy> #proposed Processing of bug 2054625 is postponed to release F37
17:35:42 <pboy> I wouldn’t like to make a substantial change to the DVD composition that late in the release circle, given all the issues we had with the max size of the images.
17:36:41 <pboy> As an additional remark: The nano issue was fixed by Matthew Miller, Nov. last year (as a proven packager).
17:36:50 <pboy> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/message/UKOZ23HY2XSSPK27U2S22Z3SLOJB2WEE/
17:36:58 <pboy> So, it is done,  we don’t need to care about it any more.
17:37:14 <eseyman> perfect
17:37:42 <eseyman> FTR, in the pagure issue, 2 should come before 1
17:38:15 <pboy> eseyman: Indeed.
17:38:46 <pboy> I'm writing a new specification. We'll discuss that next meeting, hopefully.
17:39:00 <pboy> Sometimes things are out of order. :-)
17:39:48 <pboy> Concerns about the above proposal? (bug 2054625)
17:40:16 <pboy> 3
17:40:25 <pboy> 2
17:40:34 <pboy> 1
17:40:46 <pboy> #agreeed:  Processing of bug 2054625 is postponed to release F37.
17:41:03 <pboy> #agreed Processing of bug 2054625 is postponed to release F37.
17:41:13 <pboy> (Oh, these typos)
17:41:43 <pboy> The current change set is at
17:41:52 <pboy> #link https://www.fedoraproject.org/wiki/Releases/36/ChangeSet
17:42:24 <pboy> Maybe, everyone should have a short look?
17:42:47 <pboy> And check for potential problems?
17:44:00 <jwhimpel> Ansible 5 may affect many of our ilk.  It jumps ahead several ansible releases and packaging is completely different.
17:44:51 <pboy> That sounds critical.
17:45:28 <pboy> My concerns are:
17:45:30 <pboy> F36 Change: Users are administrators by default in the installer GUI.
17:45:37 <pboy> F36 Change: Make Rescue Mode Work With Locked Root
17:45:45 <pboy> F36 Change proposal: No ifcfg by default
17:45:55 <pboy> Current configuration of /etc/resolve.conf
17:45:59 <jwhimpel> The other "big" change is "No ifcfg by default".  I don't know how many scripts people may have that reference/manipulate those files.
17:46:43 <cooltshirtguy> I've gotten use to nmcli and dont even look at ifcfg-x files anymore.
17:46:53 <pboy> jwhimpel: Indeed. It is promised a tutorial for update.
17:47:04 <eseyman> yes, I welcome there being no ifcfg by default
17:47:08 <xtify21> yah or just use native systemd-networkd
17:47:18 <xtify21> but please no netplan lol
17:47:24 <jwhimpel> I've switched to nmcli also, but I'm sure there's a bunch of folks who might be unaware.
17:47:27 <pboy> cooltshirtguy: Me too, but it was hard to migrate all the ifcfg scripts!
17:47:56 <eseyman> there's going to be A LOT of documentation to update
17:48:20 <pboy> eseyman: Yes, indeed. A lot of work.
17:48:28 <cooltshirtguy> I'm sure that wasn't a fun task
17:48:29 <xtify21> are there any plans for a front-end configuration to manuiplate files in /etc/systemd/network ?
17:48:54 <pboy> xtify21: Yes, as far as I know: vim. :-)
17:49:17 <pboy> And otherwise nmcli
17:49:32 <xtify21> lol something like netplan, but without the netplan and yaml lol
17:50:36 <pboy> Quick reminder: we have 8 mins left.
17:50:56 <eseyman> xtify21: nmcli is actually quite easy to use
17:51:29 <pboy> We should use the time to collect more potential problem.
17:51:30 <xtify21> yah I use it on my raspberry pi, laptop to join wifi
17:52:02 <pboy> I would compile a list from our discussion.
17:54:08 <pboy> I don't see any other concerns at this point.
17:54:22 <pboy> I will put together a list that we can discuss further on the mailing list.
17:54:29 <pboy> switch to net topic
17:54:39 <pboy> net -> next
17:54:44 <pboy> 3
17:54:50 <jwhimpel> You can assign testing of Ansible 5 installation and basic testing to me.
17:54:51 <pboy> 2
17:55:02 <pboy> jwhimpel: +1 !
17:55:56 <pboy> #action: jwhimpel will work on Ansible 5 installation and basic testing
17:56:13 <pboy> 3
17:56:19 <pboy> 2
17:56:23 <pboy> 1
17:56:26 <ChrisMurphy[m]> <pboy> "F36 Change: Make Rescue Mode..." <- I think this is removed, I'm not seeing it in https://fedoraproject.org/wiki/Releases/36/ChangeSet
17:57:06 <ChrisMurphy[m]> yeah it's moved to f37
17:57:08 <ChrisMurphy[m]> https://pagure.io/fesco/issue/2713
17:57:31 <pboy> ChrisMurphy[m]: Thanks!  I collected that one from mailing list! So we can remove it.
17:58:14 <pboy> Well, so we already have a topic for F37. :-)
17:59:12 <pboy> #topic Open Floor
17:59:34 <pboy> Unfortunately, our time is quite up now.
17:59:39 <pboy> Any remarks?
18:00:04 <cooltshirtguy> nope, I'm good
18:00:38 <pboy> OK. Many thanks to everybody! See you on mailing list and #fedora-server
18:00:52 <pboy> #endmeeting