magazine
LOGS
16:00:51 <zinebot[m]> #startmeeting magazine
16:00:51 <zodbot> Meeting started Thu Jan 20 16:00:51 2022 UTC.
16:00:51 <zodbot> This meeting is logged and archived in a public location.
16:00:51 <zodbot> The chair is zinebot[m]. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
16:00:51 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:51 <zodbot> The meeting name has been set to 'magazine'
16:00:52 <zinebot[m]> #meetingname magazine
16:00:52 <zodbot> The meeting name has been set to 'magazine'
16:00:52 <zinebot[m]> #topic roll call
16:00:52 <zinebot[m]> #chair zinebot glb rlengland theevilskeleton
16:00:52 <zodbot> Current chairs: glb rlengland theevilskeleton zinebot zinebot[m]
16:01:30 <RichardEngland[m> .hello rlengland
16:01:30 <glb> .hello glb
16:01:31 <zodbot> RichardEngland[m: rlengland 'Richard England' <rlengland@gmail.com>
16:01:34 <zodbot> glb: glb 'Gregory Bartholomew' <gregory.lee.bartholomew@gmail.com>
16:02:10 <RichardEngland[m> β‹„ next topic
16:02:10 <zinebot[m]> #link https://docs.fedoraproject.org/en-US/fedora-magazine/workflow/
16:02:11 <zinebot[m]> #topic agenda
16:02:11 <zinebot[m]> #info -- 1/ last week's stats --
16:02:11 <zinebot[m]> #info -- 2/ articles in progress --
16:02:11 <zinebot[m]> #info -- 3/ articles to review --
16:02:11 <zinebot[m]> #info -- 4/ articles to edit --
16:02:11 <zinebot[m]> #info -- 5/ publishing schedule --
16:02:12 <zinebot[m]> #info -- 6/ editor of the week --
16:02:12 <zinebot[m]> #info -- 7/ open floor --
16:03:27 <RichardEngland[m> β‹„ next topic
16:03:27 <zinebot[m]> #topic 1/ last week's stats
16:04:00 <RichardEngland[m> 7.8k views. About comparable to last week
16:04:17 <glb> Um, that seems a little low.
16:04:40 <glb> Maybe you are looking at the daily view?
16:05:05 <glb> Also, beware that the weekly stats are for "weeks" that begin on Monday.
16:06:35 <RichardEngland[m> I'm getting caught in "login" hell right now....
16:07:15 <glb> It's always something. πŸ™‚
16:07:50 <glb> I set up SSO a long time ago and that seems to work pretty good.
16:08:45 <RichardEngland[m> Okay 44.8k views  for the week.  But still comparable to last week which was ~46k
16:09:15 <glb> That should be prefixed with #info though so that it will go into the record.
16:09:57 <RichardEngland[m> #info 44.8k views  for the week. Slightly lower but comparable to last week
16:10:16 <glb> Works for me. πŸ™‚
16:10:28 <RichardEngland[m> β‹„ next topic
16:10:36 <zinebot[m]> #topic 2/ articles in progress
16:10:37 <zinebot[m]> #link board: https://pagure.io/fedora-magazine-newsroom/boards/articles
16:10:38 <zinebot[m]> #info Looking at the 'in-progress' column, is there something that's been finished? Anything to follow up on with its author?
16:10:38 <zinebot[m]> #info 059: Commands providing views into the system (author: zexcon) (fpca: signed) (status: in-progress)
16:10:38 <zinebot[m]> #link status: https://pagure.io/fedora-magazine-newsroom/issue/59
16:10:38 <zinebot[m]> #link preview: https://fedoramagazine.org/?p=34935&preview=true
16:10:38 <zinebot[m]> #info 068: Spam classification with neural networks (author: fed500) (fpca: signed) (status: in-progress)
16:10:39 <zinebot[m]> #link status: https://pagure.io/fedora-magazine-newsroom/issue/68
16:10:39 <zinebot[m]> #info 069: Build a file server solution with Microsoft AD authentication using Fedora server and samba (author: dklima) (fpca: signed) (status: in-progress)
16:10:40 <zinebot[m]> #link status: https://pagure.io/fedora-magazine-newsroom/issue/69
16:10:40 <zinebot[m]> #info 070: Fedora server edition on a raspbery pi (author: pboy) (fpca: signed) (status: in-progress)
16:11:10 <glb> I wonder if adding a small delay would help?
16:11:12 <zinebot[m]> #link status: https://pagure.io/fedora-magazine-newsroom/issue/52
16:11:12 <zinebot[m]> #link preview: https://fedoramagazine.org/?p=35824&preview=true
16:11:13 <zinebot[m]> #info 072: Introduction to OpenFOAM (author: thunderbirdtr) (fpca: signed) (status: in-progress)
16:11:13 <zinebot[m]> #link status: https://pagure.io/fedora-magazine-newsroom/issue/72
16:11:13 <zinebot[m]> #link preview: https://fedoramagazine.org/?p=35214&preview=true
16:12:07 <glb> There is obviously a rate limit for how fast posts can be made to matrix.
16:12:37 <RichardEngland[m> πŸ™‚ I leave that to the "engine room" team πŸ™‚
16:13:47 <RichardEngland[m> I've reviewed the in progress and I didn't see any that could take further prompting (without seeming to be pushy).  Any that you see that could be pinged?
16:14:22 <glb> Nah. I think we actually have enough for the upcoming week anyway.
16:15:05 <glb> I'm assuming that the test days article will be ready for Monday.
16:15:36 <RichardEngland[m> :crossed_finger:.
16:16:02 <RichardEngland[m> β‹„next topic
16:16:22 <RichardEngland[m> β‹„ next topic
16:16:23 <zinebot[m]> #info Are there any upcoming test days?
16:16:23 <zinebot[m]> #link https://calendar.fedoraproject.org/QA/
16:16:34 <RichardEngland[m> Need a space in there...
16:17:17 <glb> Let's go ahead and move that test days card (#82) to the to-edit column so we can get it on the schedule.
16:17:54 <RichardEngland[m> #info F36 Kernel 5.16 test week start on 23 jan
16:18:07 <glb> β‹„ show testdays
16:18:08 <zinebot[m]> Sun 23 Jan 2022: [F36] Kernel 5.16 Test Day (8 days)
16:19:00 <RichardEngland[m> (thank you)
16:19:41 <glb> We probably ought to have zinebot prefix that with '#info" whenever there is a test day.
16:20:16 <glb> You're taking notes on all this right Richard. πŸ™‚
16:20:30 <RichardEngland[m> ahhh.....right
16:22:32 <RichardEngland[m> I've moved the test day article, Pagure is being a bit of a problem child for me today
16:23:24 <glb> I find that I sometimes have to press F5 (refresh) after doing something in Pagure before it shows up.
16:23:58 <glb> If you know the card number, zinebot also has a function for moving cards around.
16:24:28 <RichardEngland[m> πŸ‘οΈ .
16:24:39 <RichardEngland[m> β‹„ show schedule
16:24:42 <zinebot[m]> Tue 08 Mar 2022: Prepare Beta release announcement... (full message at https://libera.ems.host/_matrix/media/r0/download/libera.chat/5c1b4a8808fafc34672dca4b57d6383131bd4404)
16:25:37 <RichardEngland[m> #info nothing scheduled until March
16:26:22 <glb> We ought to have that 'show schedule' function refuse to run if we aren't in the right topic.
16:26:36 <glb> Make note of that Richard. πŸ˜›
16:26:56 <glb> Maybe I'm having too much fun. πŸ˜›
16:27:30 <RichardEngland[m> Was that schedule out of order?  That's in the current topic, correct?
16:27:41 <glb> Sort of.
16:28:08 <glb> The testday and schedule "topics" each have their own heading.
16:28:30 <glb> The headings are printed out when you enter "next topic".
16:29:03 <glb> Maybe things could be rearranged or merged if you see a better way to do it though.
16:29:07 <RichardEngland[m> ...This is why I thing we need a "roadmap" for using zinebot in the docs.  Other wise a newby doesn't know when to move to the next topic
16:29:25 <RichardEngland[m> thing - think
16:29:49 <glb> I thought that was the meeting script that is in the docs?
16:30:20 <glb> Maybe it would help if zinebot presented a preview of what was coming up next though?
16:30:21 <RichardEngland[m> It doesn't call out how to use zinebot and that is where the "roadmap" could be included.
16:30:31 <RichardEngland[m> I'll work on adding that.
16:30:41 <glb> Sounds good to me. πŸ™‚
16:30:54 <RichardEngland[m> back at it...
16:31:02 <RichardEngland[m> β‹„ next topic
16:31:02 <zinebot[m]> #info Check the release schedule.
16:31:03 <zinebot[m]> #link https://fedorapeople.org/groups/schedule/f-36/f-36-magazine-tasks.html
16:31:22 <RichardEngland[m> β‹„ show scheduel
16:31:31 <RichardEngland[m> β‹„ show schedule
16:31:33 <zinebot[m]> Tue 08 Mar 2022: Prepare Beta release announcement... (full message at https://libera.ems.host/_matrix/media/r0/download/libera.chat/5c1b4a8808fafc34672dca4b57d6383131bd4404)
16:31:39 <RichardEngland[m> Again....
16:31:54 <RichardEngland[m> # nothing until March
16:32:02 <glb> I skip it sometimes because I know it doesn't change much.
16:32:16 <glb> Wow, so loud.
16:32:20 <RichardEngland[m> πŸ™‚
16:32:39 <RichardEngland[m> β‹„ next topic
16:32:43 <zinebot[m]> #topic 3/ articles to review
16:32:44 <zinebot[m]> #info Looking at the 'review' column, let's decide which articles are good to go. Move each either to the 'to-edit' (finished) column or to the 'in-progress' (needs more work) column and provide feedback.
16:32:44 <zinebot[m]> #link board: https://pagure.io/fedora-magazine-newsroom/boards/articles
16:32:45 <zinebot[m]> #info 081: Using Quarkus and Mutiny to write Java asynchronous code (author: daveome) (fpca: signed) (status: review)
16:32:45 <zinebot[m]> #link status: https://pagure.io/fedora-magazine-newsroom/issue/81
16:32:45 <zinebot[m]> #link preview: https://fedoramagazine.org/?p=35869&preview=true
16:33:23 <glb> I saw 81 being worked on earlier.
16:34:10 <glb> I think he is just trying to fix up some of the formatting in the code blocks.
16:34:22 <glb> Otherwise, I think this one is ready for editing.
16:34:58 <RichardEngland[m> I picked up #13 since I've recently worked on that a bit on my own
16:35:09 <RichardEngland[m> Any chance you can get 81?
16:35:10 <glb> I'll take 81
16:35:44 <glb> I guess there ought to be a zinebot command to assign and editor. πŸ™‚
16:36:24 <glb> s/and/an/
16:37:23 <RichardEngland[m> looks like daveome has done an image
16:37:36 <RichardEngland[m> I've assigned it to you.
16:39:09 <RichardEngland[m> I can pick up  #82 when it comes in unless you want it.
16:39:17 <RichardEngland[m> (the test week)
16:39:31 <glb> It doesn't matter to me.
16:39:39 <glb> That one should be very easy.
16:39:47 <glb> It is just a template.
16:39:58 <glb> We've pinned those in the past.
16:40:07 <glb> But I think maybe we should stop doing that.
16:41:02 <glb> Part of the reason that I started pinning them was because there was another pinned article (the IRC announcement) that would prevent newer non-pinned articles from showing up as the first item.
16:41:19 <glb> So it was a battle of the pinned articles for a while there.
16:41:28 <glb> But that is no longer necessary IMO.
16:41:53 <RichardEngland[m> πŸ‘Œ
16:42:15 <RichardEngland[m> gotta remember that size of those... or not use them
16:42:25 <RichardEngland[m> β‹„ next topic
16:42:31 <zinebot[m]> #topic 4/ articles to edit
16:42:32 <zinebot[m]> #info Looking at the 'to-edit' column, assign an editor and a cover image creator.
16:42:32 <zinebot[m]> #link board: https://pagure.io/fedora-magazine-newsroom/boards/articles
16:42:32 <zinebot[m]> #info 013: VNC Server in Fedora Linux (author: lruzicka) (fpca: signed) (status: to-edit)
16:42:32 <zinebot[m]> #link status: https://pagure.io/fedora-magazine-newsroom/issue/13
16:42:33 <zinebot[m]> #link preview: https://fedoramagazine.org/?p=35875&preview=true
16:42:33 <zinebot[m]> #info 082: [Fedora Test Week] Fedora Kernel 5.16 from 2022-01-23 through 2022-01-29 (author: sumantrom) (fpca: signed) (status: to-edit)
16:42:33 <zinebot[m]> #link status: https://pagure.io/fedora-magazine-newsroom/issue/82
16:42:34 <zinebot[m]> #info 081: Using Quarkus and Mutiny to write Java asynchronous code (author: daveome) (fpca: signed) (status: to-edit)
16:42:34 <zinebot[m]> #link status: https://pagure.io/fedora-magazine-newsroom/issue/81
16:42:34 <zinebot[m]> #link preview: https://fedoramagazine.org/?p=35869&preview=true
16:43:18 <RichardEngland[m> I've got #13 down for tomorrow (with luck I can get through the testing today)
16:43:24 <RichardEngland[m> editing is done
16:43:42 <RichardEngland[m> #82 ASAP I assume
16:43:53 <glb> Scheduling is actually the next section
16:44:08 <RichardEngland[m> (oy)
16:44:09 <glb> That has thrown me off several times too.
16:44:26 <glb> I think this section is actually for assigned the editors.
16:44:36 <glb> s/assigned/assigning/
16:45:57 <RichardEngland[m> yes, your right.  Any way I've got #13 and you have #81.  I'll take 82
16:46:07 <glb> I guess 82 should go out Monday.
16:46:47 <glb> I probably ought to have zinebot automatically show the editor for the cards when we get to this section.
16:46:58 <glb> β‹„ card 82 editor
16:46:58 <zinebot[m]> editor: @rlengland
16:47:15 <glb> β‹„ card 81 editor
16:47:15 <zinebot[m]> editor: @glb
16:47:27 <glb> Looks good. πŸ™‚
16:48:15 <RichardEngland[m> β‹„ list
16:48:21 <zinebot[m]> #info 013: VNC Server in Fedora Linux (author: lruzicka) (fpca: signed) (status: to-edit)
16:48:22 <zinebot[m]> #link status: https://pagure.io/fedora-magazine-newsroom/issue/13
16:48:23 <zinebot[m]> #link preview: https://fedoramagazine.org/?p=35875&preview=true
16:48:23 <zinebot[m]> #info 082: [Fedora Test Week] Fedora Kernel 5.16 from 2022-01-23 through 2022-01-29 (author: sumantrom) (fpca: signed) (status: to-edit)
16:48:23 <zinebot[m]> #link status: https://pagure.io/fedora-magazine-newsroom/issue/82
16:48:23 <zinebot[m]> #info 081: Using Quarkus and Mutiny to write Java asynchronous code (author: daveome) (fpca: signed) (status: to-edit)
16:48:23 <zinebot[m]> #link status: https://pagure.io/fedora-magazine-newsroom/issue/81
16:48:24 <zinebot[m]> #link preview: https://fedoramagazine.org/?p=35869&preview=true
16:48:45 <glb> I take that back. 82 (test day) should go out Sunday (if you can manage it) since that is when the test week begins.
16:49:18 <glb> We won't need to run anything Monday though since we ran something on Sunday instead.
16:49:44 <RichardEngland[m> I figure ASAP Whne 82 shows up I'll push it out
16:50:00 <glb> Or that. πŸ™‚
16:51:48 <RichardEngland[m> β‹„ next topiic
16:51:56 <RichardEngland[m> β‹„ next topic
16:52:03 <zinebot[m]> #topic 5/ publishing schedule
16:52:04 <zinebot[m]> #info Looking at the 'to-edit' column, decide the publishing schedule for the upcomming week.
16:52:05 <zinebot[m]> #info If there is not enough content, we might also need to look at the 'in-progress' or even the 'ideas' columns come up with additional content.
16:52:05 <zinebot[m]> #link board: https://pagure.io/fedora-magazine-newsroom/boards/articles
16:52:05 <zinebot[m]> #info 013: VNC Server in Fedora Linux (author: lruzicka) (fpca: signed) (status: to-edit)
16:52:05 <zinebot[m]> #link status: https://pagure.io/fedora-magazine-newsroom/issue/13
16:52:06 <zinebot[m]> #link preview: https://fedoramagazine.org/?p=35875&preview=true
16:52:06 <zinebot[m]> #info 082: [Fedora Test Week] Fedora Kernel 5.16 from 2022-01-23 through 2022-01-29 (author: sumantrom) (fpca: signed) (status: to-edit)
16:52:07 <zinebot[m]> #link status: https://pagure.io/fedora-magazine-newsroom/issue/82
16:52:08 <zinebot[m]> #info 081: Using Quarkus and Mutiny to write Java asynchronous code (author: daveome) (fpca: signed) (status: to-edit)
16:52:08 <zinebot[m]> #link status: https://pagure.io/fedora-magazine-newsroom/issue/81
16:52:10 <RichardEngland[m> (need a spell checker on zinebot)
16:52:23 <glb> I'll leave that one to you. πŸ˜›
16:53:02 <RichardEngland[m> 13 tomorrow,  82 Sunday,  81 Wednesday or Friday?
16:53:16 <glb> Sounds good to me. πŸ™‚
16:53:35 <RichardEngland[m> 81 is yours how is your schedule?
16:53:48 <glb> Wednesday should be fine.
16:55:00 <RichardEngland[m> β‹„ show proposed
16:55:00 <zinebot[m]> #proposed PUBLISHING SCHEDULE: Fri 21 Jan 2022: #13 VNC Server in Fedora Linux (editor: @rlengland) β€– Mon 24 Jan 2022: #82 [Fedora Test Week] Fedora Kernel 5.16 from 2022-01-23 through 2022-01-29 (editor: @rlengland) β€– ??? ?? ??? ????: #81 Using Quarkus and Mutiny to write Java asynchronous code (editor: )
16:55:04 <glb> +1
16:55:29 <glb> Assuming the question marks mean Wednesday. πŸ™‚
16:56:40 <RichardEngland[m> That's interesting.   Pagure shows the data for 81 but zinebot didn't pick it up.  Timing issue?
16:56:55 <glb> Oh yeah.
16:56:58 <RichardEngland[m> shall I try that again?
16:57:15 <glb> Actually, I'm not sure.
16:57:38 <glb> I didn't think that should be running from cached data.
16:57:58 <glb> Go ahead and try again.
16:58:02 <RichardEngland[m> β‹„ show proposed
16:58:03 <zinebot[m]> #proposed PUBLISHING SCHEDULE: Fri 21 Jan 2022: #13 VNC Server in Fedora Linux (editor: @rlengland) β€– Mon 24 Jan 2022: #82 [Fedora Test Week] Fedora Kernel 5.16 from 2022-01-23 through 2022-01-29 (editor: @rlengland) β€– ??? ?? ??? ????: #81 Using Quarkus and Mutiny to write Java asynchronous code (editor: )
16:58:13 <glb> How about if you run the list command?
16:58:22 <RichardEngland[m> β‹„ list
16:58:32 <zinebot[m]> #info 013: VNC Server in Fedora Linux (author: lruzicka) (fpca: signed) (status: to-edit)
16:58:32 <zinebot[m]> #link status: https://pagure.io/fedora-magazine-newsroom/issue/13
16:58:32 <zinebot[m]> #link preview: https://fedoramagazine.org/?p=35875&preview=true
16:58:33 <zinebot[m]> #info 082: [Fedora Test Week] Fedora Kernel 5.16 from 2022-01-23 through 2022-01-29 (author: sumantrom) (fpca: signed) (status: to-edit)
16:58:33 <zinebot[m]> #link status: https://pagure.io/fedora-magazine-newsroom/issue/82
16:58:33 <zinebot[m]> #info 081: Using Quarkus and Mutiny to write Java asynchronous code (author: daveome) (fpca: signed) (status: to-edit)
16:58:34 <zinebot[m]> #link status: https://pagure.io/fedora-magazine-newsroom/issue/81
16:58:34 <zinebot[m]> #link preview: https://fedoramagazine.org/?p=35869&preview=true
16:58:36 <glb> I'll have to fix that if it is pulling from the cache instead of directly from Pagure.
16:59:06 <RichardEngland[m> β‹„ show proposed
16:59:06 <zinebot[m]> #proposed PUBLISHING SCHEDULE: Fri 21 Jan 2022: #13 VNC Server in Fedora Linux (editor: @rlengland) β€– Mon 24 Jan 2022: #82 [Fedora Test Week] Fedora Kernel 5.16 from 2022-01-23 through 2022-01-29 (editor: @rlengland) β€– Wed 26 Jan 2022: #81 Using Quarkus and Mutiny to write Java asynchronous code (editor: @glb)
16:59:19 <glb> Yep. It looks like that is the problem.
16:59:23 <glb> I'll get that fixed.
16:59:25 <RichardEngland[m> +1
16:59:30 <glb> +1
16:59:48 <RichardEngland[m> β‹„ show agreed
16:59:49 <zinebot[m]> #agreed PUBLISHING SCHEDULE: Fri 21 Jan 2022: #13 VNC Server in Fedora LinuxπŸ”Έ (editor: @rlengland) β€– Mon 24 Jan 2022: #82 [Fedora Test Week] Fedora Kernel 5.16 from 2022-01-23 through 2022-01-29πŸ”Έ (editor: @rlengland) β€– Wed 26 Jan 2022: #81 Using Quarkus and Mutiny to write Java asynchronous codeπŸ”Έ (editor: @glb) {πŸ”Ή=β€―forum calendar update succeeded, πŸ”Έ=β€―forum calendar update failedβ€―}
17:00:10 <glb> Hmm, it is failing to update the forum.
17:00:36 <glb> This is the first time we've had something for it to actually try to post.
17:01:04 <glb> One of us should update the forum calendar manually.
17:01:17 <glb> And I'll have to figure out why that didn't work.
17:01:40 <RichardEngland[m> I'm EOW so I guess that would fall to me. πŸ™‚
17:02:11 <RichardEngland[m> We're out of time
17:02:23 <glb> Wow that went fast.
17:02:28 <RichardEngland[m> β‹„ next topic
17:02:28 <zinebot[m]> #topic 6/ editor of the week
17:03:11 <RichardEngland[m> more crickets.  πŸ™‚
17:03:19 <glb> OK. I'll do it. πŸ™‚
17:03:30 <RichardEngland[m> β‹„ king glb
17:03:31 <zinebot[m]> #info glb will be editor of the week starting Sun 23 Jan 2022
17:03:43 <RichardEngland[m> β‹„ next topic
17:03:44 <zinebot[m]> #topic 7/ open floor
17:03:49 <RichardEngland[m> nada here
17:04:16 <glb> Jim Hall will be posting some bogus article proposals in the coming weeks.
17:04:40 <glb> He has a class doing a usability study on Fedora Magazine's workflow.
17:04:58 <RichardEngland[m> okay.  How will we know them?
17:05:28 <glb> He said he would put a note in the proposals and dummy articles so we could identify them.
17:05:47 <RichardEngland[m> okay
17:05:47 <glb> I guess we are supposed to just leave them alone for the most part.
17:06:13 <RichardEngland[m> clean up on aisle 7 hten  πŸ™‚
17:06:30 <RichardEngland[m> I guess we should go
17:06:51 <glb> Good meeting. You'll have to do it again sometime. πŸ™‚
17:06:54 <RichardEngland[m> β‹„ next topic
17:07:17 <glb> Trying to change the topic huh.
17:07:18 <RichardEngland[m> How is your schedule for next week? πŸ™‚
17:07:30 <glb> It's pretty open.
17:07:44 <RichardEngland[m> #endmeeting
17:08:16 <glb> I'm slightly busier than usual because the semester just started. But it hasn't been bad so far.
17:08:29 <glb> I wonder why zodbot isn't responding.
17:08:37 <glb> Do you want me to give it a try?
17:08:50 <misc> #endmeeting
17:09:30 <glb> Thanks for coming to the rescue misc. πŸ™‚
17:09:36 <misc> didn't work tho :(
17:09:56 <glb> It might be because you aren't on the list of chairs.
17:10:01 <glb> #chair misc
17:10:01 <zodbot> Current chairs: glb misc rlengland theevilskeleton zinebot zinebot[m]
17:10:45 <misc> #endmeeting