fedora-qa
LOGS
15:06:47 <adamw> #startmeeting Fedora QA meeting
15:06:47 <zodbot> Meeting started Mon Nov  1 15:06:47 2021 UTC.
15:06:47 <zodbot> This meeting is logged and archived in a public location.
15:06:47 <zodbot> The chair is adamw. Information about MeetBot at https://fedoraproject.org/wiki/Zodbot#Meeting_Functions.
15:06:47 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:06:47 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:06:52 <adamw> #meetingname fedora-qa
15:06:52 <zodbot> The meeting name has been set to 'fedora-qa'
15:06:57 <adamw> #topic Roll Call
15:07:31 <bcotton> .hello2
15:07:32 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
15:07:43 <adamw> ahoyhoy, anyone else around for qa meeting fun?
15:08:09 * coremodule is here, ready for fun
15:08:12 <adamw> kparal: quit hiding at the back there
15:08:31 * kparal sighs
15:08:58 <kparal> I was actually working, but I can stop...
15:09:07 <adamw> if you were breaking things, yes
15:09:18 <kparal> populating CommonBugs 🙂
15:09:59 <kparal> I'll leave a few items for you, so you don't feel neglected
15:10:25 <adamw> don't worry, i'll rewrite all of yours later
15:10:45 <adamw> alright, since i'm late, let's get going
15:10:50 <adamw> #topic Previous meeting follow-up
15:12:02 <adamw> #info "adamw to draft vaguer and more general startup time criterion (but not too vague)" - still didn't get done, thanks to F35 crunch, i really will get to it soon
15:12:34 <adamw> #info "adamw to check with sumantro on status of remaining planned test days" - sumantro actually showed up later in the meeting and updated us there
15:12:44 <adamw> any other follow-up?
15:12:50 <cmurf[m]> .hello chrismurphy
15:12:51 <zodbot> cmurf[m]: chrismurphy 'Chris Murphy' <bugzilla@colorremedies.com>
15:14:20 <adamw> hi chris
15:14:39 <cmurf[m]> hi
15:15:37 <adamw> #topic Fedora 35 status and final pre-release plans
15:15:53 <adamw> #info Fedora 35 RC 1.2 was signed off for release last week, will come out tomorrow
15:16:15 <adamw> i don't think we have any loose ends to tidy in terms of important updates to push or anything...
15:17:02 <adamw> #info kparal and adamw will complete commonbugs page today
15:17:39 <adamw> coremodule: how's heroes of fedora 34 final coming?
15:17:44 <coremodule> I'm going to write the HoF for F35 final today and get it ready for publication
15:18:20 <adamw> awesome, thanks
15:18:43 <adamw> #info coremodule will write Heroes of Fedora 35 Final today and get it published ASAP
15:20:10 <adamw> i think that's all...
15:20:25 <adamw> #info thanks again to everyone who helped test and prepare F35 final for release
15:22:38 <adamw> #topic Fedora 36 cycle preview
15:23:26 <adamw> so, just looking ahead to f36...beta freeze lands on February 22, Final release is scheduled for April 19
15:23:58 <adamw> systemwide change deadline is December 28th, so still plenty of time for more changes to be submitted
15:24:52 <Southern_Gentlem> anything we want to change the blocker critieria now than later
15:25:07 <adamw> the ones we have so far already look interesting/terrifying..authselect changes, and dnf/rpm copy-on-write look interesting in particular
15:25:38 <adamw> #info F36 dates: beta freeze 2022-02-22, final release 2022-04-19, systemwide change deadline 2021-12-28
15:25:43 <adamw> #info current F36 changes: https://fedoraproject.org/wiki/Releases/36/ChangeSet
15:27:19 <adamw> anything else on f36?
15:28:42 * kparal has a note on F35
15:28:55 <adamw> note away
15:29:52 <kparal> according to https://bugzilla.redhat.com/show_bug.cgi?id=2016253#c34 the "sound is gone" upgrade bug might not be resolved, because it is related to systemd, not fedora-release ordering
15:30:05 <kparal> so we should probably act on it quickly
15:30:27 <kparal> I'm not able to verify whether the comment is true or not
15:32:48 <adamw> it seems plausible, anyway
15:33:08 <adamw> Conan Kudo: around?
15:34:31 <adamw> #action adamw to look into https://bugzilla.redhat.com/show_bug.cgi?id=2016253#c34 (f35 audio upgrade bug) more after the meeting
15:35:18 <adamw> kparal: ok if we leave it there and move on?
15:35:38 <kparal> sure
15:36:00 <adamw> #topic Release criteria / validation test changes from Fedora 35 cycle
15:36:12 <adamw> so, i proposed a quick tweak to the keyboard layout criterion already
15:36:28 <adamw> i think there were several other cases where we talked about revising the criteria, trying to remember what they all were...
15:38:56 <adamw> #info there were several cases where we noted potential criteria improvements during f35 blocker review
15:39:46 <adamw> #info in discussion of bug 2006393 in the 2021-10-04 blocker review meeting we agreed "we will also start a discussion about explicit (wireless) networking criteria for F36"
15:43:12 <adamw> #info we also noted a small tweak needed to a criterion that references x86_64 specifically in the 2021-09-20 meeting, and noted the keyboard layout criterion doesn't cover the installer in the 2021-10-25 meeting
15:43:42 <adamw> #info adamw already proposed a change to the keyboard layout criterion on-list, feedback welcome
15:44:17 <adamw> #action adamw to edit 'basic functionality' criterion to not specify only x86_64
15:44:32 <adamw> does anyone want to jump on the 'networking criteria' grenade?
15:45:52 <kparal> > #action adamw to edit 'basic functionality' criterion to not specify only x86_64
15:45:52 <kparal> what is this change about?
15:46:21 <adamw> kparal: it says "All applications that can be launched using the standard graphical mechanism after a default installation of Fedora Workstation on the x86_64 architecture must start successfully and withstand a basic functionality test"
15:46:33 <adamw> but since aarch64 is release-blocking it seems like it should say "x86_64 or aarch64"
15:46:43 <adamw> or "x86_64 and aarch64"...
15:46:55 <adamw> or just be reworded to refer to the generic concept of 'release-blocking arches' or whatever.
15:47:01 <kparal> no, read the next paragraph:
15:47:01 <kparal> "For other release-blocking desktops (on any architecture), the requirements only apply to the following types of applications: "
15:47:26 <kparal> so workstation on aarch64 should have just the reduced coverage
15:47:32 <kparal> it could be phrased better, yes
15:47:42 <adamw> oh, right...
15:47:42 <kparal> but I don't think the idea is to have aarch64 blocking on everything
15:47:45 <adamw> i missed that wrinkle
15:47:54 <adamw> #undo
15:47:54 <zodbot> Removing item from minutes: ACTION by adamw at 15:44:17 : adamw to edit 'basic functionality' criterion to not specify only x86_64
15:48:59 <adamw> #action adamw to try and clarify intent of "default application functionality" criterion regarding arches
15:49:01 <adamw> thanks
15:49:19 <kparal> the idea was that only workstation on x86_64 gets all apps covered, everything else just the "important apps" set
15:49:31 <kparal> ok
15:50:18 <adamw> yeah, now i see it, but indeed it could probably be clarified...
15:50:37 <adamw> so the other thing i had for this topic was, do we want to extend the packaging criteria?
15:51:00 <adamw> aka the Stop Kparal Trying To Define Everything A Package Manager Can Do As Basic Functionality question :P
15:51:48 <kparal> I'd be +1 to define package manager as having to work perfectly in all it offers
15:52:44 <adamw> you never want us to release again, do you
15:53:03 <adamw> revised F36 release date: 2047
15:53:11 <kparal> if you don't buy that, then a concrete coverage for a package manager would probably be a good idea
15:53:28 <adamw> that sounds like the sweet sound of somebody volunteering to me!
15:53:33 <kparal> I plan to propose a concrete coverage from system settings as well
15:53:41 <kparal> because you butchered it during go/no-go
15:53:46 <kparal> *for
15:55:21 <kparal> we already have this, btw: https://fedoraproject.org/wiki/Fedora_35_Beta_Release_Criteria#Installing.2C_removing_and_updating_software
15:55:45 <adamw> yup, but that doesn't cover a lot of stuff you brought up this cycle
15:55:46 <kparal> but we don't stick to it always, like when Discover can't install&remove app at one go
15:55:57 <adamw> managing sources and multiple operations during the same run, for e.g.
15:56:02 <adamw> to me, it doesn't cover that
15:56:07 <adamw> discover can install things, and it can remove things
15:56:16 <kparal> I could propose to extend it for Final, then
15:56:19 <adamw> the criterion doesn't say it has to be able to install and remove the same app on the same run
15:56:25 <kparal> sigh, so I'm a volunteer now
15:56:35 <adamw> man, i might make it as a manager after all!
15:56:37 <kparal> adamw: and that's were we differ 🙂
15:56:43 <kparal> to me, it does say it
15:57:19 <adamw> i mean, you can't logically read the sentence as referring to a series of operations on the same package, because you can't update it after removing it. ;)
15:57:40 <kparal> no, it must simply work, no exceptions 🙂
15:57:44 <adamw> hehe
15:57:45 <adamw> ok
15:57:56 <adamw> i've got a hard stop at the top of the hour, so cognratulations, you volunteered
15:58:06 <kparal> ok...
15:58:09 <adamw> #action kparal to draft revised/extended criteria for package management and system settings
15:58:37 <adamw> anyone wanna take networking, or shall i leave it open for now?
15:59:28 <adamw> #info still looking for a volunteer for networking criteria
15:59:32 <adamw> #topic Open floor
15:59:34 <adamw> any other business, folks?
16:04:04 <kparal> no
16:04:11 <adamw> alrighty, thanks everyone!
16:04:15 <adamw> have a good week
16:04:18 <adamw> #endmeeting