fedora-server
LOGS
17:00:35 <pboyHB> #startmeeting fedora-server
17:00:35 <zodbot> Meeting started Wed Aug 18 17:00:35 2021 UTC.
17:00:35 <zodbot> This meeting is logged and archived in a public location.
17:00:35 <zodbot> The chair is pboyHB. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:35 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:35 <zodbot> The meeting name has been set to 'fedora-server'
17:00:45 <pboyHB> #topic Welcome / roll call
17:00:56 <pboyHB> Hi! A warm Welcome to our IRC meeting!
17:01:03 <pboyHB> I’ll post the agenda in a few minutes.
17:01:10 <dcavalca> .hi
17:01:11 <zodbot> dcavalca: dcavalca 'Davide Cavalca' <dcavalca@fb.com>
17:01:12 <pboyHB> Please, everybody who is lurking, say either .hello2 or .hello <fasname>
17:01:24 <jwhimpel> .hello
17:01:24 <zodbot> jwhimpel: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
17:01:32 <jwhimpel> .hello jwhimpel
17:01:33 <zodbot> jwhimpel: jwhimpel 'John Himpel' <john@jlhimpel.net>
17:04:18 <pboyHB> #topic Agenda
17:04:26 <pboyHB> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/WVRMJ3PVBRR44WLQEK5BNYJ2GU7UYT7R/
17:04:34 <pboyHB> 1. Follow up actions
17:04:43 <pboyHB> 2. Facilitated deployment of key services by combining rpm and Ansible
17:04:52 <pboyHB> 3. Work planning update
17:05:00 <pboyHB> 4. Open Floor
17:05:12 <pboyHB> Any additions?
17:05:47 <pboyHB> OK. no additions
17:05:56 <pboyHB> #topic Follow up actions
17:06:06 <pboyHB> #info Server docs: (2021-07-21) AGREED: : pboy will wait until next week Wednesday and than ask if we can anything do to make it happen. STATUS:DONE 2021-08-04
17:06:17 <pboyHB> Status 2021-08-18: No results so far (for about 2 months).
17:06:29 <pboyHB> Any ideas?
17:07:01 <pboyHB> Da we have to wait, howl long? What dan we do?
17:07:37 <langdon> .hello2
17:07:38 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
17:08:10 <jwhimpel> pboyHB: Is this something that we can go ahead and do or does it actually require permission?
17:08:49 <pboyHB> It requires permission to write to the doc repository
17:11:04 <jwhimpel> pboyHB: I'd try posting on their mailing list again.  I'm not familiar with how they track work/issues, do they have a tracker?
17:11:13 <pboyHB> And, of course, may be a member of the doc team would like to review and to decide about design
17:11:26 <pboyHB> I posted on the tracker.
17:11:34 <langdon> can someone drop a link to give context? I am not sure what we are discussing
17:11:45 <pboyHB> Mailing list is rather "quite"
17:12:31 <pboyHB> #link https://pagure.io/fedora-docs/docs-fp-o/issue/169
17:14:50 <pboyHB> Basically, pbokoc seems to be the only one left over from the docs group
17:17:26 <pboyHB> The last IRC meetings of the docs group were held 2 years ago. Last time only with pbokoc and zodbot as participants.
17:18:08 <jwhimpel> pboyHB: I'd ping Mathew M.  He has a knack for drawing attention to things like this and getting things moving.
17:18:24 <langdon> pboyHB: let's "escalate" ... bcotton or mattdm you here?
17:18:51 * bcotton never leaves
17:18:54 <langdon> hahahhaha
17:19:06 <pboyHB> jwhimpel:: OK, I'll write to Matthew
17:19:07 <langdon> bcotton: we have a ticket against docs that isn't making any progress..
17:19:15 <langdon> how can we move it forward?
17:19:17 <pboyHB> and bcotton
17:19:38 <bcotton> pboyHB: matthew is out of the office this week (and next, maybe? i don't remember)
17:20:06 <bcotton> ah, i see i've been pinged in the issue already, too :-)
17:20:07 <bcotton> so many pings
17:20:15 <pboyHB> bcotton: Can you help us with this?
17:20:29 <bcotton> has anyone dropped in to the docs channel? petr is pretty responsive there last I knew
17:20:31 <bcotton> if not, I'll talk to him
17:21:13 <langdon> not to my knowledge ... pboyHB?
17:21:51 <pboyHB> bcotton: I think I can make the necessary change to the code, but I can't write to the repo.
17:23:46 <bcotton> pboyHB: okay. submit a pull request and i can review it. i have commit privileges on the repo
17:24:18 <pbokoc> what what?
17:24:38 <pboyHB> #proposed pboy and bcotton will work on getting the server box onto the docs page.
17:24:53 <pbokoc> oh the server docs. Christ, I totally forgot about that, I'm sorry
17:25:04 <pboyHB> pbokoc: Welcome!
17:25:22 <pboyHB> pbokoc: shi.... happens. :-)
17:25:33 <langdon> blame covid.. i do :)
17:25:36 <pboyHB> can we get it forward?
17:25:44 <pbokoc> haha yes, let's blame covid :)
17:25:59 <pboyHB> langdon. +1
17:26:44 <pbokoc> pboyHB, yeah, I don't have a problem with it, I'll get on it right away. I'm not sure how long it's going to take because I don't know what the frontpage will look like when I add another "box" to it, but it shouldn't be more than an hour.
17:27:34 <copperi> pbokoc ++
17:27:56 <pboyHB> pbokoc: Great!! As I have studiied the page, the css seems to be fluid enough. But the proof of the pudding is in the eating, ob course.
17:28:13 <pbokoc> yeah, exactly :)
17:29:02 <pbokoc> I'll close the issue when it's up
17:29:06 <pboyHB> OK, next item.
17:29:09 <langdon> pbokoc++
17:29:10 <zodbot> langdon: Karma for pbokoc changed to 4 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:29:41 <pboyHB> #info Ansible/Wildfly (2021-08-04) ACTION: jwhimpel will write a first draft how to handle the wildfly example case for discussion next meeting. Status DONE
17:29:55 <pboyHB> Just for the record. see next top.
17:30:15 <pboyHB> #info TASK: Synchronize Server full install and net install iso images (ticket 32&48)  ACTION various;  Eighth_Doctor, nirik, langdon will check growth of the file size
17:30:30 <pboyHB> Anything new here?
17:31:52 <pboyHB> OK, nothing new. Let's keep it open
17:32:07 <pboyHB> #info ACTION: pboyHB opens a thread about work projects on the mailing list STATUS:DONE
17:32:17 <pboyHB> see top 3
17:32:30 <pboyHB> #info ACTION: langdon to file a ticket with qe team to ask for a test day for libvirt; STATUS:DONE
17:32:50 <pboyHB> anything new here? Is there a test day scheduled?
17:33:07 <langdon> i should really follow up on that :)
17:33:34 <pboyHB> langdon: +1
17:33:56 <pboyHB> #agreed: langdon will follow up on test day
17:34:17 <pboyHB> #topic Facilitated deployment of key services by combining rpm and Ansible
17:34:28 <pboyHB> Some introductory remarks: Last meeting we had decided to start with installation support for wildfly. Jwhimpel offered to write a first draft:
17:34:42 <pboyHB> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/PB2LK5LBNVNZXT3YGFGH2TGU5FG5EVAX/
17:34:52 <pboyHB> So let us concentrate in a first step on Wildfly installation support.
17:35:00 <pboyHB> Floor is open
17:35:31 <jwhimpel> I suggest that for non-packaged content, we install in /opt.
17:36:02 <pboyHB> jwhimpel: that would be FSH complieant.
17:36:26 <pboyHB> But how to separate system and user data?
17:37:19 <jwhimpel> I believe most sofware of any significance allows configuration settings for data locations.
17:38:48 <pboyHB> As far as I know there is no regular option in Wildfly itself. But I'm not sure about it.
17:39:02 <jwhimpel> I would suggest that we configure data to be stored where normal packaging rules would require.
17:39:47 <pboyHB> According to FSH it is either /var/something oder /src/something
17:40:07 <jwhimpel> I'm not far enough into wildfly to know for certain.  I know the playbook that I'm working on allows for a configurable user data area.
17:41:16 <pboyHB> jwhimpel: That sounds fine
17:41:20 <jwhimpel> In general, I would favor putting all data into /var/<service> if possible.
17:42:22 <pboyHB> OK, so we have several options to separate system and user data and have evaluate which one to use.
17:43:43 <dcavalca> if you're installing under /opt, the usual convention is to use /var/opt for the data
17:44:02 <jwhimpel> RPM based installed software is not too flexible, but in general follows the FHS.  It's non-packaged software that may present a problem if it's not configurable.  If it is configurable, follow the FHS and Fedora guidelines.
17:46:12 <jwhimpel> Let me move on in the interest of time.  I would suggest we setup our own Ansible Galaxy server to store our playbooks and roles.  Hopefully, this could reside inside the Fedora Infrastructure.  If not, we could research what Fedora Infrastructure uses and see if we can piggy-back off that.
17:46:16 <pboyHB> dcavalca: I don't remember that, but it would be fine for me, too.
17:46:42 <pboyHB> jwhimpel: ++
17:47:08 <pboyHB> I would prefer inside Fedora infrastructure.
17:48:06 <jwhimpel> pboyHB: I would too, but we would need to talk to Kevin Fenzi to see what is allowed/possible.
17:48:30 <pboyHB> Many fedorians deal with Ansible. There must be a way. Or it must be created.
17:49:06 <pboyHB> Oh, I see, time is running. What do we next? What is the next step?
17:49:57 <jwhimpel> I would like for folks to review the suggestions I posted on the M/L and provide feedback. That would help me a lot.
17:50:55 <pboyHB> #proposed The WG will review the suggestions jwhimpel posted on the M/L  and provide feedback.
17:51:17 <pboyHB> until next meeting in 2 weeks!
17:51:35 <langdon> bye all!
17:53:10 <pboyHB> #agreed The WG members will review the suggestions jwhimpel posted on the M/L  and provide feedback until next meeting in 2 weeks
17:53:18 <langdon> ohh ha..
17:53:24 <copperi> bye langdon
17:53:28 <langdon> i thought that was a signoff :)
17:54:00 <pboyHB> Sorry, no sign off, just a unwelcome line break
17:54:06 <langdon> ha
17:54:21 <pboyHB> #topic Work planning update
17:54:32 <pboyHB> Some introductory remarks:We had removed our goals from the product requirement document because it doesn't belong there.
17:54:32 <pboyHB> I included it into our wiki page instead.
17:54:43 <pboyHB> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/Y3WDS4CSLAXGM7YTO6PTMW323YHSA7RA/
17:54:55 <pboyHB> It is a combination of our PRD text and some goals we agreed upon while updating the wiki.
17:55:03 <pboyHB> Floor is open.
17:56:11 <pboyHB> #proposed  The WG agrees on work objectives at https://fedoraproject.org/wiki/Server, "Currently Ongoing Work Projects." (2021-08-04)
17:56:42 <pboyHB> Any objections?
17:56:50 <pboyHB> 3
17:56:57 <pboyHB> 2
17:57:05 <pboyHB> 1
17:57:15 <pboyHB> #agreed The WG agrees on work objectives at https://fedoraproject.org/wiki/Server, "Currently Ongoing Work Projects." (2021-08-04)
17:57:36 <pboyHB> #topic Open Floor
17:58:36 <pboyHB> Maybe we should discuss the next chair? I did it for some time. But maybe someone else is willing to step in?
17:59:05 <pboyHB> (I don't want to occupy the chair without discussion)
17:59:26 <langdon> i vote pboyHB remains :)
17:59:40 <copperi> +1 on that
17:59:47 <jwhimpel> Anybody but me!
18:00:47 <pboyHB> Ok.  Thanks! Next chaer me again.
18:00:59 <pboyHB> anything  else?
18:01:35 <pboyHB> 3
18:01:40 <pboyHB> 2
18:01:43 <pboyHB> 1
18:01:50 <pboyHB> #endmeeting