fedora-server
LOGS
17:00:27 <pboyHB> #startmeeting fedora-server
17:00:27 <zodbot> Meeting started Wed Aug  4 17:00:27 2021 UTC.
17:00:27 <zodbot> This meeting is logged and archived in a public location.
17:00:27 <zodbot> The chair is pboyHB. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:27 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:27 <zodbot> The meeting name has been set to 'fedora-server'
17:00:34 <pboyHB> Hi! A warm Welcome to our IRC meeting!
17:00:43 <pboyHB> My great regret for the late agenda today. I just could not do it any other way. Sorry.
17:00:50 <pboyHB> I’ll post the agenda in a few minutes.
17:00:58 <pboyHB> Please, everybody who is lurking, say either .hello2 or .hello <fasname>
17:01:11 <jwhimpel> .hello jwhimpel
17:01:12 <zodbot> jwhimpel: jwhimpel 'John Himpel' <john@jlhimpel.net>
17:01:30 <dcavalca> .hi
17:01:31 <zodbot> dcavalca: dcavalca 'Davide Cavalca' <dcavalca@fb.com>
17:03:32 <pboyHB> Welcome jwhimpel Welcome dcavalca
17:03:44 <pboyHB> Glad to meet you
17:03:57 <coremodule> .hello2
17:03:59 <zodbot> coremodule: coremodule 'Geoffrey Marr' <gmarr@redhat.com>
17:04:12 <pboyHB> Welcome coremodule!
17:04:19 * coremodule is lurking, haven't ever attended, but was still on-channel.
17:04:22 <coremodule> thank you!
17:05:20 <langdon_> .hello langdon
17:05:21 <zodbot> langdon_: langdon 'Langdon White' <langdon@redhat.com>
17:05:37 <pboyHB> Ho langdon
17:05:49 <langdon_> hey.. sorry i was a little late
17:05:56 <cmurf[m]> .hello chrismurphy
17:05:57 <zodbot> cmurf[m]: chrismurphy 'Chris Murphy' <bugzilla@colorremedies.com>
17:05:59 <pboyHB> langdon: Can we have a short chat afterwards at fedora-server?
17:06:11 <langdon_> sure
17:06:13 <pboyHB> Welcome Chris
17:06:27 <pboyHB> e seem in small formation today. Nevertheless, the agenda
17:06:35 <pboyHB> #topic Agenda
17:06:43 <pboyHB> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/PWJNVPZYMAAQZWJZQKB5TDWE5KYY7ID4/
17:06:51 <pboyHB> 1. Follow up actions
17:06:59 <pboyHB> 2. Facilitated deployment of key services by combining rpm and Ansible
17:07:05 <pboyHB> 3. Work planning update
17:07:11 <pboyHB> 4. Open Floor
17:07:23 <pboyHB> We wanted to concentrate on topic 2 today
17:07:30 <pboyHB> Any additions / comments?
17:08:30 <pboyHB> OK, lets proceed
17:08:34 <pboyHB> #topic Follow up actions
17:09:06 <pboyHB> 1. AGREED: : pboy will wait until next week Wednesday and. than ask if we can anything do to make it happen.
17:09:15 <pboyHB> Status: Done today, therefore no results yet.
17:09:35 <pboyHB> 2. ACTION: langdon will open a separate ticket for the file size question.
17:10:06 <pboyHB> Status: Done, any results so far?
17:10:45 <pboyHB> 3. ACTION: pboyHB opens a thread about work projects on the mailing list
17:11:05 <pboyHB> Status: DONE, see topic 3
17:11:19 <pboyHB> any info or comments?
17:11:43 <langdon_> re 2: that should be assigned to Eighth_Doctor and maybe nirik
17:11:48 <langdon_> im just "support"
17:12:25 <pboyHB> langdon: YES, the action is assigned to Eighth_Doctor. I asked for info in general.
17:12:27 <cmurf[m]> what is the file size issue?
17:12:53 <langdon_> just figure out how big the install media would be if all recommends were on (IIRC)
17:13:30 <cmurf[m]> ahh ok
17:13:32 <pboyHB> cmurf: The only open ticket. We have differt rules for net install and full install, because we wanted to limit full install file size.
17:13:45 <pboyHB> That resulted in some issues.
17:14:53 <pboyHB> It is issue 32
17:15:17 <pboyHB> #link https://pagure.io/fedora-server/issue/32
17:16:16 <pboyHB> If there are no any questions or comments, I will switch to the next topic
17:16:40 <pboyHB> 3
17:16:48 <pboyHB> 2
17:16:54 <pboyHB> 1
17:17:02 <pboyHB> #topic Facilitated deployment of key services by combining rpm and Ansible
17:17:11 <pboyHB> Some infos in advance:
17:17:19 <pboyHB> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/VDTJUSXFNA6U5UAWH6ZRKNN6L3Z3VDBC/
17:17:28 <pboyHB> #link https://fedoraproject.org/wiki/Server/Using_Ansible
17:17:36 <pboyHB> We had discussed 3 possible test cases / sample cases,  which have different requirements and peculiarities
17:17:45 <pboyHB> (a) Installation of (Java) Application Server - the Wildfly Example
17:17:52 <pboyHB> (b) Installation of a complex service using different Fedora packages - the example Mail Service
17:17:59 <pboyHB> (c ) Installation of a typical piece of software, the example of postgresql
17:18:08 <pboyHB> IMHO among other things, we should discuss
17:18:11 <jwhimpel> I've been working on this.  Attempting to automate instructions for email found on linuxbabe.com.
17:18:15 <pboyHB> (a) how to proceed
17:18:23 <pboyHB> (b) a more detailed description of the goal
17:18:29 <pboyHB> floor is open
17:19:09 <pboyHB> jwhimpel:  Great
17:19:32 <jwhimpel> Progress is being made on Fedora version.  Also attempting to do Ubuntu version due to ownership of several ARM SOC's not supported by Fedora.  Since apt allows for interactive installs, that is proceeding much slower.
17:19:48 <jwhimpel> Plan to pause Ubuntu effort and just concentrate on Fedora.
17:20:08 <pboyHB> jwimpel: ++
17:20:26 <langdon_> jwhimpel: this is installing email server, right?
17:20:40 <langdon_> might be worth trying to involve the maintainers.. they usually know a lot ;)
17:20:47 <jwhimpel> My opinion on Wildfly is that unless there is some sort of automated monitoring of all the necessary artifacts for updates, this is probably not a doable task for a small group of folks.
17:21:18 <pboyHB> jwhimpel: There are so many topics on that page. Which is it?  (linuxbabe.com)
17:21:24 <jwhimpel> It is for installing and configuring email with lots of optional addons (TLS, DMARK, etc).
17:22:32 <pboyHB> jwhimpel: very interesting, a spedific link? (I'm paging througt the site)
17:22:33 <langdon_> which server are you doing?
17:22:46 <jwhimpel> I'm hunting for the base url now.
17:23:35 <pboyHB> jwhimpel: I'm specifically interested in email server and in wildfly
17:24:34 <jwhimpel> https://www.linuxbabe.com/redhat/run-your-own-email-server-centos-postfix-smtp-server
17:25:05 <langdon_> gotcha
17:25:12 <pboyHB> jwhimpel: thanks did'n know that article
17:26:10 <jwhimpel> I looked at the depencency list in the pom for Wildfly and it showed over 200 individual jars from lots of different repositories are required for the build.
17:27:22 <pboyHB> jwhimpel: re: wildfly: The idea is to install the wildfly project binary. Anf that is the issue regarding fedory rules.
17:28:51 <jwhimpel> pboyHB: Seeking permission from FESCO for a binary only is probably a wasted effort.  I do not believe they would ever approve that.
17:29:31 <langdon_> because you want to put the jars in rpms? like what is the challenge?
17:29:34 <pboyHB> But they did. There are several rpms which assist the admin to install foreign software, even complete VMs
17:30:10 <jwhimpel> The basic problem with java stuff is the java ecosystem for packaging is architecturally quite different than the fedora packaging requirements.
17:31:01 <pboyHB> langdon_: The challenge is to download third party binary in a acceptable way. That is not automatically, but assisting the admin.
17:31:07 <jwhimpel> Jars are binary only.  Bundling of jars is prohibited by policy.
17:31:42 <langdon_> right .. so you would need an rpm per jar.. which don't exist?
17:32:03 <pboyHB> jwhimpel: Yes, For good reason
17:32:18 <jwhimpel> Agreed there is a good reason.
17:32:44 <pboyHB> langdon_: No rpm, ansible to assist the admin to install in a systematic way.
17:33:11 <jwhimpel> Java libraries do not guarantee backwards compatibility.  So version 1.2 may not be backwards compatibible with version 1.1.
17:33:29 <langdon_> so.. i am not sure what policy there would be against that with warnings at least.. i can install extensions in eclipse.. they aren't coming from fedora repos
17:33:34 <jwhimpel> Different java apps require conflicting specific versions of the same library.
17:34:05 <langdon_> which is fine.. because java is smart enough to require you to declare versions.. so you can have multiple copies of the same lib..
17:34:07 <pboyHB> langdon_: I hope so
17:34:42 <jwhimpel> 3rd party Extensions are covered by different policy rules.
17:34:49 <langdon_> you might want to put the "special" jars in opt or something because of assumptions made by other java packages
17:35:06 <langdon_> s/packages/packagers
17:35:46 <jwhimpel> So far, they have rejected xalan-1.1.1 and xalan-1.1.2 both being packaged and installed simultaneously.  I believe the version numbers are stripped when being installed via rpm.
17:36:36 <langdon_> this is what modules are *for*
17:37:21 <jwhimpel> Langdon:  If I want to install wildfly via rpm, all of the wildfly base code and all of the supporting libraries (jars) must be individually packaged.  Current module rules requires they only be built from rpms.
17:38:09 <jwhimpel> Langdon: Let me rephrase.  Current rules for building modules require they only be built from rpms.
17:38:12 <langdon_> right.. but the xalan problem can be resolved.. and.. we could also petition to change the module rules to include jars.. the design is meant to support not-rpm.. but that will be harder
17:39:27 <pboyHB> jwhimpel: It seems not doable with existing resources to package a wildfly rpm. We had one some time ago for a sort period. the long term work was too much.
17:39:46 <jwhimpel> Langdon: If you can get that though FPC and FESCO, I would be forever grateful.
17:40:08 <pboyHB> So we should try ansible to download and install in a systematic way.
17:40:22 <langdon_> jars in modules? or xalan having a different option in a module? the 2nd one should be doable right now
17:40:32 <jwhimpel> pboyHB: I remember that and I can certainly understand why it fell into disrepair.
17:41:02 <jwhimpel> landon_: jars in a module.
17:41:42 <langdon_> let me ask around if it is in the realm of politically possible.. java is a drama in fedora all the time
17:42:16 <jwhimpel> langdon_: You would have to ask the folks on the java mailing list why they told me they would not support multiple versions of the same basic library (jar).  I don't want to mis-quote them.
17:43:21 <pboyHB> jwhimpel: There must be some kind of missunderstanding. I'be several libs in different versions nstalled in parallel.
17:43:25 <langdon_> jwhimpel: not opening that bucket of worms.. i though you were planning on maintaining it.. most of the people who remain for java are anti module and have had a number of personality conflicts
17:43:59 <jwhimpel> I think we could consider a goal of using ansible to install third party software (Wildfly, eclipse, etc).  It just would not involve rpms.
17:44:16 <pboyHB> Folks! Time is running out. Let's sum up: What do we want to do next?
17:44:18 <langdon_> pboyHB: someone still has to *do the work* .. and if you are asking java sig to do 2 versions of the same lib.. thats more work than one version.. so they may not have the time/energy.. it may be technically possibl ebut you need humans
17:44:29 <jwhimpel> pboyHB:  They allow multiple versions of libraries in several other languages, but not java for some reason.
17:44:59 <pboyHB> OK. I'll discuss that on the Java list.
17:45:00 <langdon_> jwhimpel: i love the idea of using ansible.. i am not in love with pulling from untrusted sources.. rpms, jars, wheels, whatever..
17:45:51 <pboyHB> Again Folks! Time is running out. Let's sum up: What do we want to do next?  How will we proceed?
17:46:30 <jwhimpel> If we can hold off pursuing this for a week, I will raise the issue on the java list.
17:46:50 <langdon_> how about "do it w/ ansible" if we can solve "where ansible gets it from" with modules, fedora, koji, whatever, we can cross that bridge later..
17:47:03 <pboyHB> jwhimpel: We can, of course.
17:47:21 <langdon_> we probably want ansible in the mix any way for questions/config/etc.. changing the urls to the repos is the smallest part of the work
17:48:11 <jwhimpel> I'll try to writeup a proposal and post it on the server email list sometime next week.
17:49:17 <pboyHB> Regarding how to proceed. One idea was to discuss such projects through the ticket system. The wiki is too unfamiliar for many. Would that help?
17:49:54 <pboyHB> jwhimpel:  proposal regarding email or wildfly?  (or both?)
17:50:19 <jwhimpel> Let's just start with wildfly, if you do not mind.
17:50:47 <jwhimpel> I find email lists the most interactive across timezones.
17:51:08 <pboyHB> jwhimpel:  On the contrary, would be very fine with me.
17:52:10 <pboyHB> jwhimpel: But we probably need a way to bring together a longer discussion. Is that possible via email?
17:52:58 <jwhimpel> Have you read the "Development" email list and threads lately?  Some of those discussions go on for weeks and involve hundreds of posts.
17:53:10 <langdon_> i would make a ticket for the "task".. and then put the "result" in the ticket
17:53:24 <jwhimpel> langdon_: +1
17:53:26 <langdon_> that doesn't mean the proposal needs to be authored/edited/etc in the ticket
17:53:28 <pboyHB> OK with both
17:54:33 <pboyHB> #proposed jwhimpel will write a first draft how to handle the wildfly example case.
17:54:52 <pboyHB> Discussion about that next meeting
17:55:01 <langdon_> i have to step out early to get ready for my next meeting.. ill stlil be here.. but afk for 5-10
17:55:21 <pboyHB> langdon_: Thanks
17:56:26 <pboyHB> #agreed jwhimpel will write a first draft how to handle the wildfly example case for discussion next meeting
17:56:49 <pboyHB> #action  jwhimpel will write a first draft how to handle the wildfly example case for discussion next meeting
17:56:52 <jwhimpel> I've already said more than enough for today.  I'm usually not this loquacious. Sorry about that.
17:57:50 <pboyHB> jwhimpel: I did apriciate your contributions very much!
17:58:25 <pboyHB> OK, time is up, I switch to last topic
17:58:46 <pboyHB> #topic Open floor
17:58:57 <pboyHB> floor is open
17:59:52 <jwhimpel> I've got nothing.
18:00:41 <pboyHB> OK. so I close.
18:00:49 <pboyHB> Many thanks to everybody!
18:00:58 <pboyHB> #endmeeting