fedora-server
LOGS
17:00:46 <pboyHB> #startmeeting fedora-server
17:00:46 <zodbot> Meeting started Wed Jul 21 17:00:46 2021 UTC.
17:00:46 <zodbot> This meeting is logged and archived in a public location.
17:00:46 <zodbot> The chair is pboyHB. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:46 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:46 <zodbot> The meeting name has been set to 'fedora-server'
17:00:55 <pboyHB> #topic Welcome / roll call
17:00:57 <eseyman> that's us
17:01:06 <pboyHB> Hi! Welcome to our IRC meeting!
17:01:11 <langdon> i angered zod
17:01:14 <langdon> .hello2
17:01:15 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
17:01:18 <pboyHB> Please, everybody who is lurking, say either .hello2 or .hello <fasname>
17:01:24 <eseyman> .hello2
17:01:25 <zodbot> eseyman: eseyman 'Emmanuel Seyman' <emmanuel@seyman.fr>
17:01:32 <pboyHB> I’ll post the agenda in a few minutes.
17:02:03 <dcavalca> .hi
17:02:04 <zodbot> dcavalca: dcavalca 'Davide Cavalca' <dcavalca@fb.com>
17:03:54 <pboyHB> #topic Agenda
17:04:03 <pboyHB> Unfortunately I did'nt manage to prepare an aganda in advance. So we have to improvise a bit.
17:04:12 <pboyHB> 1. Follow up actions
17:04:19 <pboyHB> 2. Open ticket(s)
17:04:21 <jdubby> .hello
17:04:21 <zodbot> jdubby: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
17:04:26 <pboyHB> 3. Work planning update
17:04:33 <pboyHB> 4. Fedora 35
17:04:36 <jdubby> .hello jwhimpel
17:04:37 <zodbot> jdubby: jwhimpel 'John Himpel' <john@jlhimpel.net>
17:04:42 <pboyHB> 5, Open Floor
17:04:56 <pboyHB> Any additions or remarks?
17:05:16 <eseyman> Looks good to me
17:05:34 <pboyHB> OK. So let's start.
17:05:43 <pboyHB> #topic Follow up actions
17:05:52 <pboyHB> #info Action x3mboy: remove hackmd.io PRD versions: DONE (now private)
17:05:59 <pboyHB> #info Action pboy, Modify the info text for the intended server "box" on the docs landing page - DONE
17:06:16 <pboyHB> I suppose there is no need to discuss about those?
17:06:50 <pboyHB> #info Our updated Server PRD is approved by Council
17:06:51 <eseyman> don't think so
17:07:00 <pboyHB> #link https://pagure.io/Fedora-Council/tickets/issue/375
17:07:00 <eseyman> woot \o/
17:07:04 <langdon> \o/
17:07:20 <pboyHB> Yes, so we can finally close that topic.
17:07:45 <pboyHB> #info Status publishing Server documentation: pbokoc asked some details, otherwise no visible changes or further info so far
17:08:11 <pboyHB> I suppose, we have to waot another 2 weeks?
17:08:58 <pboyHB> #link  https://pagure.io/fedora-docs/docs-fp-o/issue/169
17:09:41 <pboyHB> Open actions:
17:09:55 <pboyHB> We have several open actions regardig our Ansible working projects where I’m in charge.
17:10:06 <pboyHB> Those are still in progress. Unfortunately, I got completely swamped. Sorry.
17:10:10 <langdon> maybe drop a "bump" in the ticket or ping pbokoc to see if it can move
17:10:20 <pboyHB> I hope for our next meeting in 14 days.
17:10:30 <langdon> move == like move forward
17:11:17 <pboyHB> langdon: I'm not sure wether someone already works in the background
17:11:35 <pboyHB> Maybe it needs a bit of web design work?
17:12:13 <langdon> right now it is in "limbo" cause you were asked something, you answered, but we need that team to say  "yes, thats a good answer, we will get on it"
17:12:46 <langdon> then they can proceed with whatever is reqd
17:13:53 <pboyHB> #proposed  I wait until next week Wednesday and. than ask if we can anything do.
17:14:09 <langdon> works
17:14:48 <pboyHB> #agreed: pboy will wait until next week Wednesday and. than ask if we can anything do to make it happen.
17:15:04 <pboyHB> Any additional information or comments?
17:15:45 <pboyHB> #topic Open ticket(s)
17:15:47 <eseyman> sounds good
17:15:56 <pboyHB> We discussed the ticket about Fedora Server installation ISO
17:16:03 <pboyHB> #link https://pagure.io/fedora-server/issue/32
17:16:10 <pboyHB> As a brief reminder:
17:16:18 <pboyHB> (a) The issue is: composition of net install iso and (full) installation iso is currently different.
17:16:26 <pboyHB> (b) Question is, how large would the installation iso grow if it includes all recommended packages.
17:16:33 <pboyHB> (c) To decide is: Do we want to accept the size or take other measures.
17:16:47 <pboyHB> e had agreed: Eighth_Doctor, nirik and langdon will look for a solution to the compose question
17:16:56 <pboyHB> The floor is open.
17:17:31 <langdon> am i the only one of the 3 here? i think i was the least useful member of the group :)
17:18:28 <eseyman> I think you are, langdon
17:18:38 <langdon> let's make a ticket for it.. separate from the #32 and assign it to the 3 of us..  for just this one task
17:18:49 <langdon> to my knowledge, it hasn't moved
17:18:58 <pboyHB> I dee ,   Eighth_Doctor. is onlne. ping!
17:19:14 <pboyHB> dee -> see
17:19:43 <langdon> he is probably at work though
17:19:56 <pboyHB> yes, obviously.
17:20:13 <pboyHB> langdon: can you create that ticket?
17:20:27 <langdon> yeah.. and lets move on
17:20:31 <pboyHB> OK.
17:20:59 <pboyHB> #agreed landgon will open a separate ticket for the file size question.
17:21:17 <pboyHB> #action langdon will open a separate ticket for the file size question.
17:21:19 <langdon> yeah.. ill post here when its done.. but my other chat window has to stop talking to me :)
17:21:24 <pboyHB> sorry, my typos.
17:21:32 <langdon> trying to sort out the speaker swag for devconf.us :)
17:21:56 <pboyHB> Work Planing update
17:22:10 <pboyHB> #topic Work Planing update
17:22:21 <pboyHB> An introductory remark:
17:22:30 <pboyHB> We removed the section about our goals from the PRD because it doesn#t belong there.
17:22:41 <pboyHB> Therefore I integrated it into the wiki page as a proposal!
17:22:48 <pboyHB> #link https://fedoraproject.org/wiki/Server
17:22:56 <pboyHB> We should check and discuss the section.
17:24:16 <pboyHB> I mean the section "Currently Ongoing Work Projects"
17:25:06 <eseyman> I suspect it would be better if the discussion were held on the mailing-list
17:26:40 <pboyHB> #proposed  Open a discussion about work projects on the mailng list
17:28:41 <pboyHB> #agreed   Open a discussion about work projects on the mailing list
17:29:09 <pboyHB> #action. pboyHB opens a thread about work projects on the mailing list
17:29:29 <pboyHB> #topic Fedora 35
17:29:48 <pboyHB> There ar a lot of changes, again.
17:30:09 <pboyHB> What do we have to do regarding Fedora Server?
17:30:55 <langdon> i actually haven't looked hard tbh.. can i propose we add the list to the agenda for next time and just flip through them all?
17:31:17 <jdubby> I think we need to continue monitoring the usage of btrfs for potential issues.  If it seems okay in f35, we should discuss changing defaults in f36.
17:32:01 <pboyHB> I'm a bit concerned about the change in Libvirt
17:32:06 <langdon> knock wood... i have been running it on various machines for like a year with no iissues
17:32:14 <langdon> ^^ btrfs
17:32:16 <pboyHB> #link https://fedoraproject.org/wiki/Changes/LibvirtModularDaemons
17:33:36 <pboyHB> Ad btrfs: I'm not sure if it is compatible with our storage and partitioning rationale.
17:34:55 <pboyHB> (see our Server documentation about installation)
17:35:10 <dcavalca> the main missing thing in btrfs for Server IMO is good support for raid5/6, which is being worked on
17:35:14 <langdon> re: libvirt ) yeah.. that looks like it will be fun.. i might ask the change wrangle (bcotton) to push for a test day at least..  i would also ask for a set of instructions about how to roll back to monolithic libvirt on new installs if you run in to problems
17:35:48 <jdubby> The original "Server Sig" annointed postgresql as the preferred database solution.  If we chose to continue that preference, we should ask kevin fenzi if he would create the rpm for the ansible postgresql module in f35.
17:36:15 <bcotton> langdon: for a test day, ask QA (specifically sumantrom)
17:36:48 * langdon notes a wild cotton appears
17:36:48 <eseyman> humm... I thought we were done with modules
17:37:07 <langdon> eseyman: i am VERY in support of modules... but this isn't modules.. just modular
17:37:13 <pboyHB> jdubby: Postgres & Ansible is one of the subprojects of our "Facilitated deployment of key services by combining rpm and Ansible" project
17:37:21 <eseyman> anyway, +1 to keeping pg as our preferred solutons
17:37:32 <pboyHB> +1 indeed
17:37:42 <langdon> bcotton: how do we ask for better rollback instructions? ticket with fesco?
17:37:48 <jdubby> eseyman:  It's ansible module not Fedora modules.  Sorry for the confusion.
17:38:35 <bcotton> langdon: contact the change owner, since the change is already approved
17:38:39 <eseyman> got it,thanks
17:39:00 <jdubby> Then I'll file a ticket for adding the postgresql ansible module.
17:39:50 <langdon> im confused.. did we change topics? what does postgres have to do with libvirt? or ansible modules? or modularity modules?
17:40:25 <eseyman> we did get side-tracked, for a minute
17:40:49 <jdubby> langdon.  I was just slow entering my topic into IRC.  So the two topics got interleaved.  Sorry
17:41:59 <langdon> its cool.. it happens.. but can we clarify what topic we are on and what we are talking about ? :)
17:42:07 <langdon> cause im still confused
17:42:52 <pboyHB> Back to main track. :-)
17:42:56 <pboyHB> #proposed Server WG would like to dedicate a test day for libvirt change.
17:43:02 <eseyman> Fedora 35 and its changes
17:43:52 <pboyHB> eseyman: I'm not sure what you mean
17:45:10 <eseyman> I was signaling to langdon that the topic was "Fedora 35 and its changes"
17:45:30 <pboyHB> OK git it
17:45:35 <pboyHB> git -> got
17:45:47 <langdon> yeah.. i got that .. but we seem to have a mixed a bunch of changes together :)
17:45:53 <pboyHB> What about the proposal?
17:46:09 <eseyman> +1 to the proposal
17:46:12 <langdon> well.. the proposal is more "we need to file a ticket with qe"
17:46:43 <pboyHB> Yes, but afterwards we need some people to test !
17:47:23 <langdon> qe should help /handle that.. if we ask for a test day.. they will drum up testers
17:47:28 <pboyHB> And to spend some work on it that day
17:48:15 <eseyman> yes, that's a whole point of setting up a test day
17:48:50 <pboyHB> Nevertheless, If we initiate this, we should also participate afterwards,
17:49:05 <langdon> yeah
17:49:34 <pboyHB> Langdon: regarding the ticket, Would you take that in hand?
17:49:45 <langdon> i did.. want to switch to that
17:49:50 <langdon> cause i have a q or two
17:51:10 <pboyHB> Now I got lost. What is the current state?
17:51:57 <langdon> like #topic current sizing exercise
17:53:15 <pboyHB> Hm, I thin we need a proposal for either agreed or action
17:53:27 <langdon> on f35?
17:53:48 <pboyHB> on libvirt change in f35 and a test day
17:54:34 <langdon> yeah.. i agree
17:54:57 <pboyHB> angdon: Specifically, have you opened a ticket yet?
17:54:57 <langdon> #proposed action pboy to file a ticket with qe team to ask for a test day for libvirt
17:55:04 <langdon> pboyHB: yes..
17:55:40 <pboyHB> A modification:
17:55:55 <pboyHB> #proposed action langdon to file a ticket with qe team to ask for a test day for libvirt
17:56:37 <pboyHB> I am not familiar enough with these procedures.
17:57:03 <langdon> hahahahhahaha
17:57:08 <langdon> that will teach me
17:57:09 <langdon> sure
17:57:52 <pboyHB> I'll take that as an okay.   :-)
17:58:13 <pboyHB> #action langdon to file a ticket with qe team to ask for a test day for libvirt
17:58:36 <pboyHB> Time is up now. I switch to next topic
17:58:57 <pboyHB> #topic 6. Open Floor
17:59:09 <pboyHB> floot is open
17:59:17 <langdon> so.. briefly, i filed https://pagure.io/fedora-server/issue/48 but I can't assign it to myself or anyone else
17:59:19 <langdon> not sure why
17:59:38 <pboyHB> langdon: Thanks. That was quick
18:00:36 <pboyHB> I would like to dedicate next meeting to the Ansible projects and continue Fedora 35.
18:00:48 <pboyHB> Any thoughts?
18:00:56 <langdon> pboyHB: so, can you assign? or is this me not sure how to work pagure?
18:01:07 <langdon> pboyHB: +1 on next time agenda
18:01:14 <bcotton> langdon: you're not a member of that repo
18:02:01 <langdon> bcotton: ah ha..
18:02:10 <langdon> my pagure skills are meh
18:03:25 <pboyHB> OK, I don't see any other comments and I would close our meeting right now.
18:03:51 <pboyHB> Many thanks to everybody!
18:04:01 <pboyHB> #endmeeting