fesco
LOGS
19:00:36 <decathorpe> #startmeeting FESCo (2021-07-19)
19:00:36 <zodbot> Meeting started Mon Jul 19 19:00:36 2021 UTC.
19:00:36 <zodbot> This meeting is logged and archived in a public location.
19:00:36 <zodbot> The chair is decathorpe. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:36 <zodbot> The meeting name has been set to 'fesco_(2021-07-19)'
19:00:41 <decathorpe> #meetingname fesco
19:00:41 <zodbot> The meeting name has been set to 'fesco'
19:00:46 <defolos> .helo2
19:00:57 <decathorpe> #chair nirik, decathorpe, zbyszek, sgallagh, mhroncok, dcantrell, defolos, mboddu, Conan_Kudo, Pharaoh_Atem, Son_Goku, King_InuYasha, Sir_Gallantmon, Eighth_Doctor
19:00:57 <zodbot> Current chairs: Conan_Kudo Eighth_Doctor King_InuYasha Pharaoh_Atem Sir_Gallantmon Son_Goku dcantrell decathorpe defolos mboddu mhroncok nirik sgallagh zbyszek
19:01:04 <defolos> .hello2
19:01:05 <zodbot> defolos: defolos 'Dan Čermák' <dan.cermak@cgc-instruments.com>
19:01:06 <decathorpe> hello defolos o/
19:01:13 <mhroncok> .hello churchyard
19:01:13 <zodbot> mhroncok: churchyard 'Miro Hrončok' <mhroncok@redhat.com>
19:01:16 <defolos> Hi Fabio Valentini (decathorpe)
19:01:17 <zbyszek> .hello2
19:01:18 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
19:01:40 <mboddu> .hello mohanboddu
19:01:41 <decathorpe> #topic Init Process
19:01:41 <zodbot> mboddu: mohanboddu 'Mohan Boddu' <mboddu@bhujji.com>
19:01:57 <zbyszek> Sorry for the absence last week. I somehow managed to forget about the meeting after sending the agenda.
19:02:11 <mhroncok> .hello churchyard
19:02:12 <zodbot> mhroncok: churchyard 'Miro Hrončok' <mhroncok@redhat.com>
19:02:28 <defolos> Sorry for my absence as well, I was on vacation
19:02:46 <defolos> (I might miss next week as well, I'll be away again)
19:03:20 <decathorpe> defolos: then you probably shouldn't volunteer for running next week's meeting, eh?
19:03:23 <defolos> right
19:04:13 <decathorpe> technically we're already at quorum, but I'm going to give the others until :05
19:05:22 <decathorpe> alright ...
19:05:30 <decathorpe> #link https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/RRV4E5P3QRBCJ7LZMUB73YW22E5SVSAE/ Schedule
19:05:43 <zbyszek> Are our invited guests here?
19:06:00 <decathorpe> #topic #2648 F35 Change: GHC 8.10 and Stackage lts-18
19:06:05 <decathorpe> .fesco 2648
19:06:06 <zodbot> decathorpe: Issue #2648: F35 Change: GHC 8.10 and Stackage lts-18 - fesco - Pagure.io - https://pagure.io/fesco/issue/2648
19:06:24 <decathorpe> .fasinfo petersen
19:06:25 <zodbot> decathorpe: User: petersen, Name: Jens Petersen, email: petersen@redhat.com, Creation: 2005-04-13, IRC Nick: petersen, Timezone: Asia/Singapore, Locale: en, GPG key ID: EF27EDD1, Status: active
19:06:28 <zodbot> decathorpe: Approved Groups: @gitliberation-fonts cvsredhat-config-language cla_done fedorabugs cvsfedora +packager sysadmin @cvslohit-fonts @haskell-lang-sig cla_redhat cla_fedora @giti18n gitspin-kickstarts @gitcabal2spec provenpackager sysadmin-web @githaskell-sig proventesters @gityum-langpacks qa @haskell
19:06:58 <decathorpe> probably not, looks like it's night already for Jens
19:08:14 <defolos> he also didn't file a vacation on fedocal
19:08:27 <defolos> but I'm not sure if people actually do that a lot
19:09:04 <zbyszek> How many packages are we talking about here? I guess they can be rebuilt in a side tag…
19:09:05 <mboddu> ghc has been updated to 8.10, so next mass rebuild on this wed should pick it up
19:09:30 <mboddu> nvm, they are built in side tag
19:09:32 <defolos> oh well, so they already did it?
19:10:04 <defolos> ah ok
19:10:05 <decathorpe> I don't think so.
19:10:18 <mboddu> So, 8.10 is being built in side tag. Not sure how stable it is to merge into f35
19:10:46 <defolos> the timing is pretty unfortunate given the mass rebuild
19:10:51 <mhroncok> Build Target: f35-build-side-43587
19:11:18 <decathorpe> so ... proposal: Ask change owners to come up with a proposal for building stuff after the mass rebuild, and to coordinate with releng ?
19:11:50 <zbyszek> decathorpe: sounds reasonable
19:11:52 <mboddu> +1
19:11:58 <defolos> sounds good to me
19:12:05 <mhroncok> note that releng would need to exclude ghc from the mass rebuild
19:12:12 <mhroncok> because the git content is 8.10
19:12:29 <decathorpe> yeah. that's why I included "coordinate with releng" :)
19:13:12 <defolos> mboddu you're involved with releng, right?
19:13:17 <mhroncok> I am confortable with either option, before or after the mass rebuild
19:13:44 <mboddu> defolos: Yes, we can exclude it as part of mass rebuild, unless petersen says otherwise
19:14:03 <defolos> then that sounds like the best way forward
19:14:10 <defolos> (to me)
19:14:14 <Eighth_Doctor> .hello ngompa
19:14:15 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
19:14:33 <defolos> 👋
19:14:33 <decathorpe> yeah. pushing back the mass rebuild and rushing in all ghc builds before that sounds stressful for little gain
19:14:38 * mboddu bbiab
19:14:39 <decathorpe> hey Neal
19:15:13 <mhroncok> consider me +1 as well
19:15:24 * Eighth_Doctor is getting a sandwich
19:15:35 <Eighth_Doctor> +1
19:15:40 * defolos requests a sandwich as well
19:16:05 <zbyszek> sudo get me a sandwich ?
19:16:20 <decathorpe> heh
19:17:37 <decathorpe> #info Ask Change owner(s) to adapt, if possible, to building after the F35 Mass rebuild, and to coordinate with releng (+6, 0, -0)
19:18:23 <decathorpe> there have been no votes on the change proposal itself other than the temporary -1. should we wait with the final approval until the Change is amended?
19:18:49 <zbyszek> I'm +1 for approving the Change with the #info above.
19:19:00 <defolos> yes
19:19:09 <mhroncok> +1 to approve with the above info
19:19:48 <decathorpe> works for me.
19:20:06 <defolos> I'm for aproving it after we have a decision from releng & the change owners
19:21:09 <zbyszek> defolos: this will introduce a delay, and petersen is actively working on the change. I don't see any scenario where we would say "no, let's wait for F36 with this".
19:21:11 * decathorpe sighs
19:21:35 * zbyszek asks decathorpe to explain
19:21:50 <mhroncok> zbyszek: and even if they decide to do that, they can
19:21:52 <decathorpe> zbyszek: I think the only way to get it postponed is if it's impossible to build after the mass rebuild, which I don't think is the case
19:22:21 <defolos> ok, then no objections to approving from my side
19:23:54 * mboddu is back, sorry for the delay
19:23:56 <decathorpe> ok, so we are at: +1 to approve Change assuming aforementioned #info: defolos, zbyszek, mhroncok, decathorpe
19:24:26 <decathorpe> mboddu, ngompa: do you want to vote as well?
19:25:14 <mboddu> decathorpe: Yeah, +1 to approve the change with the info mentioned
19:25:28 <decathorpe> great
19:25:54 <decathorpe> that must be a helluva sandwich Neal is fetching
19:26:25 * defolos wants now one even more
19:26:42 <Eighth_Doctor> defolos, zbyszek: no sandwiches for you 😛
19:26:43 <mboddu> Neal wants everything on that sandwich but instead of saying "everything" he is mentioning each and every ingredient :P
19:26:50 <Eighth_Doctor> +1
19:26:58 <decathorpe> awesome
19:27:26 <decathorpe> #agreed APPROVED assuming the #info item (+6, 0, -0)
19:27:47 <decathorpe> #topic Next week's chair
19:28:04 <decathorpe> ugh I think that didn't work ... undo undo undo
19:28:06 <decathorpe> #undo
19:28:06 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7f473413fe50>
19:28:18 <decathorpe> #agree APPROVED assuming the #info item (+6, 0, -0)
19:28:27 <decathorpe> #topic Next week's chair
19:28:37 <decathorpe> now it should be correct
19:28:43 <defolos> I'd like to not chair, as I'll be traveling and might have a baaad internet connection
19:29:21 <decathorpe> I can theoretically run the meeting again next week, but if there are other volunteers ...
19:29:29 <zbyszek> I'm not sure about my schedule for next week, I might be on PTO actually. But I can chair if nobody else wants.
19:29:48 <mboddu> My Monday's (and Fri's) are iffy until the end of Aug
19:30:04 <decathorpe> okay, then I'll do it
19:30:13 <decathorpe> #action decathorpe to chair next week's meeting
19:30:20 <decathorpe> #topic Open Floor
19:30:53 <defolos> Can anyone give a tl;dr; about the thread on devel about guile + make?
19:31:06 <defolos> I haven't managed to catch up on that one yet
19:31:10 * decathorpe sighs
19:31:40 <defolos> Fabio Valentini (decathorpe) nevermind if it's mostly drama
19:31:44 <decathorpe> as far as I understand, the rejection by FESCo was interpreted as "you have to keep maintaining this", instead of "give us a better reason to approve this"
19:32:02 <defolos> I see
19:32:22 <decathorpe> Conan Kudo: is that a fair summary?
19:32:23 <mhroncok> people are outraged by our ruling
19:32:27 <Eighth_Doctor> yes
19:32:46 * Eighth_Doctor shrugs
19:32:55 * decathorpe looks for torches and pitchforks in the distance
19:32:56 <Eighth_Doctor> it's the same thing that happened with IMA
19:33:07 <Eighth_Doctor> nobody was able to justify it well enough
19:33:51 <defolos> <Eighth_Doctor "it's the same thing that happene"> Was that this rpm signature thingy?
19:33:53 <Eighth_Doctor> yes
19:34:23 <decathorpe> right ... if people can only point to the bad side of things but can't talk about the benefits clearly, it's hard to make a balanced decision based on cost-benefit analysis
19:35:02 <decathorpe> but oh well. torches and pitchforks it is
19:35:45 <decathorpe> side note: there's another open fesco ticket, which I have not included in the meeting schedule because I think there's nothing to talk about
19:35:50 <decathorpe> .fesco 2647
19:35:51 <zodbot> decathorpe: Issue #2647: F35 Change: tzdata-minimal - fesco - Pagure.io - https://pagure.io/fesco/issue/2647
19:36:08 <decathorpe> any objections to waiting for more info from the discussions with upstream?
19:36:16 <Eighth_Doctor> nah, I'm good with that
19:36:18 <Eighth_Doctor> +1
19:36:20 <mboddu> +1
19:36:51 <decathorpe> great
19:36:58 <zbyszek> yep, the discussion seems not done yet.
19:36:58 <decathorpe> any comments on my poposal here? https://pagure.io/fesco/issue/2646#comment-743791
19:37:47 <mhroncok> decathorpe: I like it
19:38:01 <defolos> <decathorpe "any comments on my poposal here?"> Sounds good to me
19:38:16 <defolos> quite simple and makes everyone's life better
19:38:37 <decathorpe> I think those two are the only "easy" things we can do to streamline the process ... everything else involves automation or implementing new pagure features
19:38:43 <zbyszek> decathorpe: the second part seems unnecessary. People are mentioned by @nick in the ticket description by the change wrangler, so they are already subscribed without any action.
19:38:47 <mboddu> decathorpe: +1 from me and easy to do and super useful
19:38:59 <decathorpe> zbyszek: they're not, AFAIK
19:39:04 <Eighth_Doctor> mentions do not subscribe
19:39:09 <defolos> <zbyszek "Fabio Valentini (decathorpe): th"> I don't think that you get subscribed by being mentioned
19:39:25 <mhroncok> you only get that one comment notification
19:39:58 * mhroncok brainstorms: we could also mention them in the comment about the meeting, that does not sound that complicated
19:39:59 <Eighth_Doctor> we'd need to add an API to allow Ben Cotton (he/him/his) to arbitrarily subscribe people
19:40:00 <mboddu> When mentioned, you only get that one email, but wont be subscribed
19:40:02 <decathorpe> @-mentioning them in the "this is going to be discussed in the next meeting" comment should do it.
19:40:10 <zbyszek> Oh, so should we simply mention the change owners by @nick (
19:40:15 <Eighth_Doctor> yes
19:40:16 <zbyszek> ... what decathorpe said.
19:40:29 <Eighth_Doctor> mentioning them in the comment should be enough
19:40:56 <zbyszek> If we ask people to subscribe, this will work sometimes, and sometimes not.
19:40:58 <Eighth_Doctor> assuming they don't filter out all the emails, that should work
19:41:09 <decathorpe> but that won't make them get the whole discussion, which is why I would encourage change owners to additionally subscribe to tickets for their changes.
19:41:24 <mboddu> Its only encouragement, so its up to them
19:41:27 <decathorpe> @-mentioning them should always work, so that's a safeguard.
19:41:29 <mhroncok> yeah, I would encourage them to subscribe as well
19:41:48 <mhroncok> but mentioning them is safer
19:41:59 <decathorpe> well, we can continue bikeshedding in the ticket, that's not time sensitive
19:42:16 <defolos> 👍
19:42:17 <mhroncok> :)
19:42:52 <zbyszek> Doing both also seems fine.
19:43:04 <decathorpe> better safe than sorry
19:43:23 <decathorpe> well, that's all from my side. really open floor now :)
19:43:43 <mboddu> None from me
19:44:22 <defolos> nothing from my side as well
19:44:36 <defolos> except a reminder for nest ;-)
19:45:10 <decathorpe> oh ... that reminds me. I might submit a proposal for a talk about modern Rust packaging and how nice it is now :D
19:45:40 <defolos> please do so!
19:45:55 <mhroncok> is submitting proposals still possible?
19:46:06 <defolos> until the 23rd
19:46:09 <decathorpe> CfP extended until July23
19:46:10 <zbyszek> mhroncok: the deadline has been extended
19:46:16 <mhroncok> Round 2 selection starts on: 16 July 2021
19:46:24 <mhroncok> zbyszek: until?
19:46:27 <defolos> s/starts/started/
19:46:32 <defolos> ;-)
19:47:49 * decathorpe going to close meeting at :50 if there's nothing else
19:47:54 <defolos> mhroncok https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/AK42WP2CHGTXEIOZA6ILRO7ITXP4KYOX/
19:48:34 <decathorpe> defolos++
19:48:39 <mhroncok> defolos: thanks
19:49:17 <mboddu> Thanks decathorpe
19:49:23 <mhroncok> decathorpe++
19:49:40 <defolos> Thanks Fabio Valentini (decathorpe) for running the metting
19:49:44 <defolos> decathorpe++
19:49:58 <decathorpe> no mo cookies :(
19:50:01 <zbyszek> decathorpe: thanks
19:50:05 <decathorpe> thanks all for coming, see you next week
19:50:07 <decathorpe> #endmeeting