fesco
LOGS
17:00:04 <sgallagh[m]> #startmeeting FESCO (2021-06-15)
17:00:04 <zodbot> Meeting started Tue Jun 15 17:00:04 2021 UTC.
17:00:04 <zodbot> This meeting is logged and archived in a public location.
17:00:04 <zodbot> The chair is sgallagh[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:04 <zodbot> The meeting name has been set to 'fesco_(2021-06-15)'
17:00:04 <sgallagh[m]> #meetingname fesco
17:00:04 <sgallagh[m]> #chair nirik, decathorpe, zbyszek, sgallagh, mhroncok, dcantrell, defolos, mboddu, Conan_Kudo, Pharaoh_Atem, Son_Goku, King_InuYasha, Sir_Gallantmon, Eighth_Doctor
17:00:04 <sgallagh[m]> #topic init process
17:00:04 <zodbot> The meeting name has been set to 'fesco'
17:00:04 <zodbot> Current chairs: Conan_Kudo Eighth_Doctor King_InuYasha Pharaoh_Atem Sir_Gallantmon Son_Goku dcantrell decathorpe defolos mboddu mhroncok nirik sgallagh sgallagh[m] zbyszek
17:00:17 <dcantrell> .hello2
17:00:18 <zodbot> dcantrell: dcantrell 'David Cantrell' <dcantrell@redhat.com>
17:00:22 <nirik> morning
17:00:27 <dcantrell> greetings
17:00:29 <sgallagh[m]> .hello2
17:00:30 <defolos> .hello2
17:00:30 <zodbot> sgallagh[m]: Sorry, but you don't exist
17:00:33 <zodbot> defolos: defolos 'Dan Čermák' <dan.cermak@cgc-instruments.com>
17:00:34 <mhroncok> .hello churchyard
17:00:36 <zodbot> mhroncok: churchyard 'Miro Hrončok' <mhroncok@redhat.com>
17:00:41 <decathorpe> .hello2
17:00:42 <decathorpe> good evening
17:00:42 <zodbot> decathorpe: decathorpe 'Fabio Valentini' <decathorpe@gmail.com>
17:00:49 <sgallagh[m]> .hello sgallagh
17:00:50 <zodbot> sgallagh[m]: sgallagh 'Stephen Gallagher' <sgallagh@redhat.com>
17:00:56 <mboddu> .hello mohanboddu
17:00:59 <zodbot> mboddu: mohanboddu 'Mohan Boddu' <mboddu@bhujji.com>
17:02:20 <zbyszek> .hello2
17:02:21 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
17:02:41 <Eighth_Doctor> .hello ngompa
17:02:42 <zodbot> Eighth_Doctor: ngompa 'Neal Gompa' <ngompa13@gmail.com>
17:02:45 <sgallagh[m]> We have a quorum, may as well get started
17:03:12 <sgallagh[m]> #topic New Meeting Time
17:03:12 <sgallagh[m]> #link https://whenisgood.net/fesco2021-again/results/2nddce4
17:03:24 <sgallagh[m]> So we almost have a time that everyone can make.
17:03:41 <sgallagh[m]> Except that mhroncok had to go and ruin it :-)
17:03:44 <michel> .hello salimma
17:03:45 <zodbot> michel: salimma 'Michel Alexandre Salim' <michel@michel-slm.name>
17:03:50 <mhroncok> sgallagh[m]: my pleasure
17:03:51 <dcavalca> .hi
17:03:52 <zodbot> dcavalca: dcavalca 'Davide Cavalca' <dcavalca@fb.com>
17:04:20 <sgallagh[m]> mhroncok: I don't suppose that's in any way negotiable?
17:04:21 <mhroncok> sgallagh[m]: I am ready to take all sort of bribes to chnage my vote
17:04:30 <zbyszek> sgallagh[m]: strictly speaking, it's also a time when some of us are already half asleep, so I'm very much with mhroncok on trying to find an earlier slot.
17:04:38 <defolos> mhroncok: I bake a pretty good pizza…
17:04:54 <mhroncok> defolos: do you also dliver? :)
17:05:11 <defolos> mhroncok: depends on the location 😉
17:05:22 <mhroncok> yeah, the reason the slot at 1900 UTC is marked as not avaiable is that I only marked slots up to 1800 UTC
17:05:32 <sgallagh[m]> Just to be sure: did everyone remember to pick their timezone?
17:05:43 <defolos> do we have any alternative time slots that are earlier besides monday 7pm utc?
17:05:43 <sgallagh[m]> (Just in case some of the US folks accidentally responded in UTC...
17:06:01 <nirik> I did respond in UTC... but deliberately to avoid timezone fun
17:06:28 <mboddu> .time mohanboddu
17:06:28 <zodbot> mboddu: mohanboddu
17:06:31 <Eighth_Doctor> I learned my lesson after last time :D
17:06:47 <mhroncok> the meeting as it is now is already when I feel not productive and can get more irritated which might lead to conversations that sound unfriednly
17:06:48 <nirik> mboddu: you want .localtime?
17:06:55 <mboddu> I think I selected UTC , but I am confused with the results
17:07:01 <mboddu> .localtime mohanboddu
17:07:02 <zodbot> mboddu: The current local time of "mohanboddu" is: "13:07" (timezone: US/Eastern)
17:07:05 <defolos> .localtime defolos
17:07:07 <zodbot> defolos: The current local time of "defolos" is: "19:07" (timezone: Europe/Prague)
17:07:09 <mhroncok> one hour later is technically doable, but I warn you :D
17:07:22 <zbyszek> .localtime zbyszek
17:07:23 <zodbot> zbyszek: The current local time of "zbyszek" is: "13:07" (timezone: US/Eastern)
17:07:27 <decathorpe> yeah, same here ...
17:07:33 <zbyszek> hmm
17:07:37 <Eighth_Doctor> .localtime ngompa
17:07:38 <zodbot> Eighth_Doctor: The current local time of "ngompa" is: "13:07" (timezone: US/Eastern)
17:07:39 <mhroncok> zbyszek: outdated info
17:07:54 <dcantrell> .localtime
17:07:54 <zodbot> dcantrell: (localtime <username>) -- Returns the current time of the user. The timezone is queried from FAS.
17:07:59 <dcantrell> .localtime dcantrell
17:08:00 <zodbot> dcantrell: The current local time of "dcantrell" is: "13:07" (timezone: US/Eastern)
17:08:19 <mhroncok> I think zbyszek, defolos, decathorpe and me are all CEST
17:08:35 <decathorpe> yup
17:08:36 <defolos> indeed
17:08:44 <mhroncok> nirik is deep deep west and the rest is eastern
17:08:46 <decathorpe> and 8 PM is really late for meetings
17:08:48 <mboddu> mhroncok: But zbyszek seems to be working in US/Eastern time :P
17:08:54 <mhroncok> technically bcotton also is not eastern
17:08:57 <sgallagh[m]> FWIW, I just opened up my availability to "before I usually wake up", if that helps at all.
17:08:59 <sgallagh[m]> (Looks like it doesn't)
17:09:08 <nirik> yeah, I skew things sadly. ;( PDT
17:09:25 <bcotton> i'm not?
17:09:25 <Eighth_Doctor> he is eastern
17:09:28 <Eighth_Doctor> .localtime bcotton
17:09:29 <zodbot> Eighth_Doctor: The current local time of "bcotton" is: "13:09" (timezone: America/Indiana/Indianapolis)
17:09:34 <Eighth_Doctor> he lives in Indiana, which is in EDT
17:09:39 <mhroncok> oh, ok
17:09:46 <sgallagh[m]> EDT is much wider than makes any rational sense
17:09:50 * bcotton exists in all times
17:09:58 <nirik> I mean I can do 13UTC monday, but thats 6am. ;( and Eighth_Doctor and zbyszek are not available then either.
17:10:02 <bcotton> sgallagh: don't you dare suggest taking away my 930pm sunsets!
17:10:03 <Eighth_Doctor> yes, Indiana really should be in Central Time, but man...
17:10:06 <mboddu> mhroncok: bcotton needs to drive couple of hours west and it will change his TZ ;)
17:10:08 <mhroncok> right, I remember that bcotton is in Indiana, but I had no idea it is Eastern
17:10:20 <Eighth_Doctor> the state legislature went full stupid on that twenty years ago
17:10:20 <sgallagh[m]> (and is why parts of New England are considering shifting to Atlantic Time instead)
17:10:25 <Eighth_Doctor> yup, that and getting out of DST
17:10:35 <mhroncok> anyway I'll take that pizza from defolos and we can try 1900 UTC
17:10:43 <Eighth_Doctor> Indiana is... special
17:10:50 <dcantrell> https://en.wikipedia.org/wiki/Time_in_Indiana
17:10:57 <dcantrell> Indiana really got screwed on US time zones
17:11:06 <sgallagh[m]> mhroncok: Thank you for that. Sorry it's so late in Europe.
17:11:13 * Eighth_Doctor used to live in Indiana when it was worse
17:11:23 <michel> dcantrell: isn't Indiana at least mostly on ET now? it used to be worse
17:11:23 <nirik> mhroncok: I can promise to buy you a beer for your pizza next time I see you in person. ;)
17:11:27 <sgallagh[m]> I wonder if we should consider alternating FESCo meetings?
17:11:38 <michel> I remember when it was EST/EDT, EST only, and CST/CDT
17:11:41 <Eighth_Doctor> I didn't learn about the concept of Daylight Saving Time until I moved to Mississippi in 2004 :)
17:11:46 <sgallagh[m]> One week that's US-friendly, one week that's EU-friendly?
17:11:50 <defolos> <sgallagh[m] "I wonder if we should consider a"> that sounds like a viable option
17:11:51 <nirik> sgallagh[m]: might help some, but also adds confusion
17:11:58 <michel> Conan Kudo: so you moved *south* and encountered daylight saving ;)
17:12:03 <Eighth_Doctor> Michel Alexandre Salim: Yup!
17:12:03 <dcantrell> michel: I think so?  The main issue is their major metro areas border other states and so the effective time zones used follow those border cities and then Indiana gets messed up
17:12:12 <sgallagh[m]> Might be better for participation from other contributors too
17:12:37 <michel> dcantrell: yeah, South Bend etc follows Chicago and the eastern parts (forgot which metro) follows Ohio I guess
17:12:44 <mhroncok> well if we alter and half of os never shows up on the alternate one, it's not any good :/
17:12:46 <defolos> <mhroncok "anyway I'll take that pizza from"> well settle the terms off meeting
17:12:49 <michel> I missed not having daylight saving :)
17:12:54 <Eighth_Doctor> aside from Monday and Tuesday, I can be up as early as 7am EDT if need be
17:13:05 <sgallagh[m]> As Chair, I'm going to ask that we terminate the side-topic of timezones
17:13:05 <dcantrell> I used to live in Hawaii which does not have Daylight Saving Time.  However that didn't matter for work meetings.  Also, Zimbra didn't handle the HAST zone correctly (nor did Google), both automatically changed clocks.  I filed a bug with Zimbra and they said "meh"
17:13:18 <dcantrell> sgallagh[m]: you're saying we don't have time for this kind of talk?
17:13:43 <sgallagh[m]> .fire dcantrell bad puns are where I draw the line.
17:13:43 <zodbot> adamw fires dcantrell bad puns are where I draw the line.
17:13:47 <Eighth_Doctor> 🤦‍♂️
17:13:48 <nirik> lets try monday at 19 and revisit if unworkable for some reason?
17:13:57 <michel> .hire dcantrell
17:13:57 <zodbot> adamw hires dcantrell
17:14:06 <dcantrell> michel++ thank you
17:14:06 <zodbot> dcantrell: Karma for michel changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:14:09 <Eighth_Doctor> worksforme
17:14:10 <defolos> agreed
17:14:14 <sgallagh[m]> OK, thank you for your sacrifice, mhroncok (and other EU folks)
17:14:14 <decathorpe> wfm
17:14:16 <mboddu> +1 for me
17:14:29 <dcantrell> sgallagh[m]: you just you had that pun first  :)
17:14:30 <Eighth_Doctor> maybe my meeting slots will free up once the pandemic is over
17:14:39 <sgallagh[m]> #agreed FESCo meetings will occur at 1900 UTC beginning June 21st
17:14:44 <defolos> mhroncok++ for taking one for the team
17:14:44 <zodbot> defolos: Karma for churchyard changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:14:49 <Eighth_Doctor> most of my inflexibility comes from pandemic-era meeting slots
17:14:52 <sgallagh[m]> dcantrell: You are... not wrong.
17:14:54 <dcantrell> mhroncok++ thank you for your service
17:15:01 <sgallagh[m]> mhroncok++
17:15:12 <defolos> Fabio Valentini (decathorpe): your availability is legendary
17:15:12 <sgallagh[m]> OK, let's move along
17:15:14 <nirik> Yeah, many thanks
17:15:18 <Conan_Kudo> mhroncok++
17:15:18 <zodbot> Conan_Kudo: Karma for churchyard changed to 6 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:15:22 <mboddu> mhroncok++ sorry but thanks :)
17:15:22 <zodbot> mboddu: Karma for churchyard changed to 7 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:15:22 <sgallagh[m]> #topic #2617 F35 Change: Make btrfs the default file system for Fedora Cloud
17:15:22 <sgallagh[m]> .fesco 2617
17:15:25 <zodbot> sgallagh[m]: Issue #2617: F35 Change: Make btrfs the default file system for Fedora Cloud - fesco - Pagure.io - https://pagure.io/fesco/issue/2617
17:15:39 <decathorpe> defolos: summer holidays are coming up ;)
17:16:10 <decathorpe> I think the Cloud WG meeting where this is being discussed is happening today?
17:16:16 <mhroncok> I think the recent comment makes it good for me
17:16:20 <Eighth_Doctor> nope
17:16:21 <sgallagh[m]> Conan Kudo: Would you mind summarizing the updates from this last week?
17:16:26 <defolos> are there any reasons why grub2-mount wouldn't work for the RHEL case?
17:16:39 <Eighth_Doctor> sgallagh: sure, I suppose
17:16:43 <nirik> there was a bit more talk on the list, but not much really.
17:17:05 <mhroncok> https://pagure.io/fesco/issue/2617#comment-737963 has the most recent information and is not long
17:17:05 <dcavalca> defolos: grub2-mount should work, as long as it gets enabled in the RHEL build
17:17:08 <Eighth_Doctor> so dcavalca and I deliberated on options for RHEL to read Fedora images, and we added those to the change page
17:17:10 <dcavalca> I put up a PR to that end
17:17:22 <Eighth_Doctor> additionally, dcavalca made the libguestfs container which can't build because borked OpenShift Build Service
17:17:59 <Eighth_Doctor> and finally, dcavalca made PRs to backport zstd btrfs enablement to rhel8.5 grub and enable grub2-mount in el8 grub
17:18:03 <Eighth_Doctor> so we have at least fuse-based read support from grub code
17:18:03 <nirik> I'd just like to note again that updating things right before the meeting (I know, there's much more incentive to do that then) means many of us haven't read and digested those things. :(
17:18:03 <zbyszek> dcavalca, Eighth_Doctor: thanks, this helps a lot.
17:18:09 <sgallagh[m]> OK, I hadn't seen that last update, but indeed that makes me much more comfortable
17:18:31 <Eighth_Doctor> the libguestfs container will enable read-write of Fedora Cloud images with btrfs on RHEL
17:18:32 <zbyszek> FWIW, I'm ready to vote.
17:18:51 <Eighth_Doctor> because the bundled Fedora kernel and btrfs-progs in the bundled appliance
17:19:04 * defolos is as well
17:19:16 <Eighth_Doctor> libguestfs boots a tiny VM to mediate fs access between host and guest
17:19:16 <sgallagh[m]> Proposal: FESCo accepts the "Cloud Images on btrfs".
17:19:19 <Eighth_Doctor> so that's how that works
17:19:23 <sgallagh[m]> err, patch
17:19:24 <Eighth_Doctor> sgallagh: +1
17:19:30 <mhroncok> +1
17:19:35 <defolos> +1
17:19:35 <sgallagh[m]> * Proposal: FESCo accepts the "Cloud Images on btrfs" Change for F35.
17:19:36 <zbyszek> +1
17:19:42 <sgallagh[m]> +1
17:19:50 <decathorpe> +1
17:19:54 <mboddu> +1
17:20:04 <dcantrell> 0
17:20:20 <nirik> weak +1 I guess. if it breaks lots of things we can always revert.
17:20:31 <sgallagh[m]> #agreed FESCo accepts the "Cloud Images on btrfs" Change for F35. (+8, 1, -0)
17:20:38 <sgallagh[m]> \o/
17:20:50 <defolos> 🎉
17:20:55 <Eighth_Doctor> 🎉
17:21:15 <sgallagh[m]> Thank you very much to the Change Proposal Owners who put in a lot of effort to satisfy the various concerns.
17:21:34 <cmurf> 🐄
17:21:37 <defolos> indeed, without the RHEL options this would've been a really tough one
17:21:41 <cmurf> :D that is a cow
17:21:48 <mhroncok> :D
17:21:51 <dcavalca> thank you all!
17:21:51 <defolos> so thanks folks
17:21:52 <mboddu> Yeah, thanks a lot to the change proposal owners
17:21:56 <Eighth_Doctor> wow, that's quite the 🐄
17:21:57 <mhroncok> is it spherical?
17:22:00 <michel> cmurf: is that a CoW joke ;)
17:22:00 <sgallagh[m]> cmurf: Shouldn't it be... rounder?
17:22:19 <michel> mhroncok: in vacuum
17:22:19 <Eighth_Doctor> 🐮 is kind of round, does that work?
17:22:20 * decathorpe thought bad puns were banned
17:22:21 <cmurf> 🐮
17:22:21 <sgallagh[m]> mhroncok: You're right, this is too late a meeting time for you. I beat you to that joke ;-)
17:22:22 <cmurf> haha
17:22:48 <mhroncok> sgallagh[m]: in my log, I beat you :D
17:22:51 * defolos gets the joke now…
17:22:52 <sgallagh[m]> #topic Next week's chair
17:23:16 <sgallagh[m]> mhroncok: I guess we'll see which zodbot saw first, then!
17:23:22 <Eighth_Doctor> I can't do it, I'm in too many conference things at once :(
17:23:36 <sgallagh[m]> I will be in a training class next week
17:23:40 <michel> sgallagh: I saw you first
17:23:48 <nirik> oh since we are meeting later now, I guess I can do it... :)
17:23:48 <mhroncok> so, that is monday, right?
17:23:57 <sgallagh[m]> Correct
17:24:37 <mhroncok> I could do it, but since nirik volunteered, I let him do it :)
17:25:19 <nirik> sure, sign me up
17:26:07 <mhroncok> sgallagh[m]: are you still with us. am I still with the rest of you?
17:26:16 <sgallagh[m]> #action nirik will chair the June 21 meeting
17:26:28 <sgallagh[m]> Sorry, got a phone call from my vet just now
17:26:47 <mhroncok> I hope it wasn't a  bad call
17:26:49 <sgallagh[m]> #topic Open Floor
17:27:12 <sgallagh[m]> Thanks
17:28:22 <mboddu> I hope everything is okay sgallagh[m]
17:28:26 <sgallagh[m]> My 17-year-old cat is basically on hospice care; this was a follow-up.
17:28:30 <Eighth_Doctor> oh dear
17:28:50 <sgallagh[m]> Anyway, does anyone have anything for Open Floor?
17:28:54 <michel> sgallagh: so sorry to hear
17:28:57 <mhroncok> doesn't seem so
17:28:57 <sgallagh[m]> I appreciate that.
17:29:08 <defolos> sorry to hear that sgallagh
17:29:28 <mhroncok> sgallagh[m]: let me know if I shall send the minutes on your behalf in case you need to go deal with the vet
17:29:31 <defolos> maybe the python packaging guidelines being discussed on devel?
17:29:43 <mboddu> sgallagh[m]: Sorry to hear that sgallagh[m]
17:29:43 <defolos> appears a bit controversial atm
17:29:45 <sgallagh[m]> defolos: I think that probably should stay on Devel
17:29:50 <mhroncok> I agree
17:29:51 <nirik> 🙁
17:29:57 <sgallagh[m]> mhroncok: No, I can cover it, but thanks
17:30:29 <defolos> sgallagh: makes sense
17:31:12 <defolos> then just a shameless plug for this friday & saturday: there's going to be the opensuse conference
17:31:30 <defolos> including a cross colab panel including mattdm & adamw and Neal
17:31:38 <defolos> and marie
17:31:56 <adamw> be there! or...don't
17:32:06 <zbyszek> defolos: link?
17:32:16 <defolos> <adamw "be there! or...don't"> what a threat 😛
17:32:16 <Eighth_Doctor> also a plug for this weekend (and into next week): Akademy 2021 (the KDE community conference)
17:32:16 <bcotton> https://opensuse.venueless.events/schedule/talks/26
17:32:25 <Eighth_Doctor> Fedora is sponsoring and there's a couple of talks from the KDE SIG too
17:33:09 <michel> ooh, Venueless this time, nice
17:33:28 <defolos> it's big blue button afaik
17:33:39 <michel> <bcotton "https://opensuse.venueless.event"> that seems to break if you're not already registered and logged in
17:33:48 <bcotton> sadness
17:33:51 <Eighth_Doctor> you need to register through events.opensuse.org first
17:33:55 <michel> hmm, going to the root path also fails
17:33:55 <michel> aha
17:34:00 <sgallagh[m]> #info Fedora is sponsoring an openSUSE conference this weekend. Join us there!
17:34:03 <defolos> https://events.opensuse.org/conferences/oSVC21/program/proposals/3501
17:34:09 <Eighth_Doctor> https://events.opensuse.org/conferences/oSVC21
17:34:10 <sgallagh[m]> #link https://opensuse.venueless.events/schedule/talks/26
17:34:10 <defolos> that should be it
17:34:17 <michel> that's ... a bad UI, maybe venueless should redirect to the sign up page :)
17:34:28 <Eighth_Doctor> 🤷‍♂️
17:34:39 <sgallagh[m]> #link https://events.opensuse.org/conferences/oSVC21/program/proposals/3501
17:34:50 <defolos> the times on events.opensuse.org are in UTC
17:34:51 <sgallagh[m]> Anything else? I'll close out the meeting if not.
17:34:54 <defolos> keep that in mind
17:35:07 <defolos> nope, nothing from me
17:35:07 <sgallagh[m]> defolos: Oh PLEASE don't start that back up! ;-)
17:35:25 <defolos> it cost me two cospeakers today
17:35:35 <defolos> they thought it was their timezone :(
17:35:42 <sgallagh[m]> ouch
17:35:42 <Eighth_Doctor> oh geeze
17:35:42 <defolos> just wanted to make sure…
17:35:44 <mhroncok> ouch
17:35:48 <mboddu> None from me
17:35:55 <Eighth_Doctor> I knew of one of those (I saw the email thread...)
17:36:14 <defolos> +1 for close from me
17:36:29 <sgallagh[m]> #endmeeting