fedora-server
LOGS
17:00:13 <pboyHB> #startmeeting fedora-server
17:00:13 <zodbot> Meeting started Wed Apr 28 17:00:13 2021 UTC.
17:00:13 <zodbot> This meeting is logged and archived in a public location.
17:00:13 <zodbot> The chair is pboyHB. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:13 <zodbot> The meeting name has been set to 'fedora-server'
17:00:23 <pboyHB> #topic roll call
17:00:30 <pboyHB> hi everyone!
17:00:37 <pboyHB> As usual we should give a few minutes for folks to show up
17:00:42 <jwhimpel> .helo jwhimpel
17:00:45 <pboyHB> #info please say either .hello2  or .hello <fasname>
17:00:51 <pboyHB> I’ll post the agenda in a few minutes.
17:00:54 <jwhimpel> .hello jwhimpel
17:00:55 <zodbot> jwhimpel: jwhimpel 'John Himpel' <john@jlhimpel.net>
17:01:15 <dcavalca> .hi
17:01:16 <zodbot> dcavalca: dcavalca 'Davide Cavalca' <dcavalca@fb.com>
17:03:08 <pboyHB> #topic Agenda
17:03:18 <pboyHB> #link https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/32IQLMZDPUS7JCF2FFRVJO5IAYYQLEL4/
17:03:24 <pboyHB> 1. Welcome
17:03:30 <pboyHB> 2. Agenda
17:03:37 <pboyHB> 3. Status Server PRD (Info)
17:03:44 <pboyHB> 4. Fedora release criteria and process
17:03:53 <pboyHB> 5. Issue: Release composition
17:03:59 <pboyHB> 6. Planing for next Fedora release
17:04:07 <pboyHB> 7. Marketing Improvement / Ambassadors Material
17:04:14 <pboyHB> 8. Open Floor
17:04:45 <pboyHB> #topic Status Server PRD
17:04:54 <pboyHB> #link   https://hackmd.io/@x3mboy/HyB92cVl_
17:05:02 <pboyHB> #link  https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/NAQLPATYHK3EPY3DHHU7HS5CQ7NPLVVR/
17:05:09 <x3mboy> .hi
17:05:10 <zodbot> x3mboy: x3mboy 'Eduard Lucena' <eduardlucena@gmail.com>
17:05:14 <pboyHB> Short summary:
17:05:21 <pboyHB> Latest version at first link above
17:05:28 <pboyHB> Waiting for Text from ab and michel_slm
17:05:36 <pboyHB> Planning: final decision next meeting or 12 May latest
17:05:47 <pboyHB> Now and in the next 3-4 days it is still possible to make substantial changes / additions / deletions without delaying everything even further.
17:05:57 <pboyHB> Any ideas / comments / concerns?
17:06:40 <ab> I'll work on my part this week but I didn't have much time yet, sorry. Family care.
17:06:52 * ab is not really present here due to that
17:07:27 <pboyHB> ab: that's fine for me. Maybe, we should directly target May 12?
17:08:23 <ab> perhaps. I'll respond to the thread on server mailing list
17:08:36 <ab> I'd like to give some time for discussion
17:09:37 <pboyHB> OK. We should not rush. Therefore: last chance for any modification: May 5, final discussion and voting: May 12
17:09:44 <pboyHB> objections?
17:09:50 <ab> +1
17:10:12 <jwhimpel> +1
17:10:13 <pboyHB> #agreed  last chance for any modification: May 5, final discussion and voting: May 12
17:10:20 <x3mboy> +1
17:11:02 <pboyHB> langdon is working on the wording, so he will finalize after May 5
17:11:03 <michel_slm> Can't make this meeting, I have some urgent errands. What text do we need? I think I updated the markdown
17:11:43 <pboyHB> It is the latest version at https://hackmd.io/@x3mboy/HyB92cVl_
17:12:13 <pboyHB> That is not the side-by-side version, but a follow-up
17:13:58 <pboyHB> OK, obviously nothing else, I'll switch topic next
17:14:18 <pboyHB> #topic Fedora release criteria and process
17:14:26 <pboyHB> #link  https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/thread/GSJM6TE76QKSNPNU7EX63AATOB4ZP5IU/
17:14:57 <pboyHB> see the post by Stephen Gallagher, April 19 in that thread
17:15:09 <pboyHB> The issue came up when Cockpit did not work correctly in Fedor34 release candidate.
17:15:23 <pboyHB> Was a bit of a mess
17:16:41 <pboyHB> Any comment? Any idea?
17:17:17 <jwhimpel> Did the missing service show up in the menu as "dimmed" or did it not show up at all?
17:18:23 <pboyHB> In cockpit the device list was missing, You couldn't create a new LV, could do hothing but create a partition (but no filesystem in a created partition)
17:19:12 <pboyHB> Reason was: A package was declared as "recommended" and not included in installation by default.
17:19:46 <pboyHB> And recommended packages are not included in the current Server installation due to space restrictions (DVD capacity)
17:20:20 <jwhimpel> It seems that if documented functionality is not "enabled" or the required sub-package isn't installed, that should somehow be communicated back to the user.
17:21:16 <pboyHB> jwhimpel: Yes, it was in the release note- burried. :-)
17:22:05 <jwhimpel> I wasn't specific enough.  It should be communicated back to the user via the user interface.
17:22:15 <pboyHB> I suppose nobody read that Cockpit release note, and most ot us including me knew, that recommended packages get not included in hull install image
17:22:44 <pboyHB> But are included in network install (That is the issue of next topic)
17:24:48 <pboyHB> Any suggestion how to proceed here?
17:25:06 <jwhimpel> Anyone want to make a guestimate of how many server installs do not have access to the internet?  Maybe we just support netinstall?
17:26:05 <pboyHB> Yes, I mostly use netinstall. But it is sometimes skimpy to enter the repo address.
17:28:52 <jwhimpel> Any idea on how much work to put a text based gui into netinstall that allowed the Admin to select an installation and the installer find the appropriate repo?
17:28:56 <pboyHB> I think we should open an issue about Stephen suggestion. So we can tack the issue later and ask Stephen about it?
17:29:44 <pboyHB> jwhimpel: I don't know, but my impression is that the Anaconda team is quite busy.
17:30:17 <pboyHB> But indeed, we should try that and make netinstall the recommended way.
17:31:21 <pboyHB> But we are know on the next topic. So i'll create an issue about that and switch for now
17:31:28 <jwhimpel> Stephen's suggestion seems reasonable.
17:31:45 <pboyHB> topic: Issue: Release composition
17:32:02 <pboyHB> This also came up because of the same problem. Question is whether we should change the composition of the server release.
17:32:12 <pboyHB> Due to the trend towards smaller images for containers and cloud images, it should be attractive for packages to reduce the number of dependencies. Thus, this problem could occur more often in the future and is hardly manageable.
17:32:44 <pboyHB> Therefore, making netinstall the preferred method, is another solution here
17:34:10 <Eighth_Doctor> the DVD media does not preclude making smaller installs possible
17:35:02 <jwhimpel> I personally would not object to just enough packages to bring up the server with the standard server modifications, configure the internet, and dnf.  Everything else could could be added via dnf.
17:35:36 <pboyHB> Eighth_Doctor: Of course not. Smaller images are a plus
17:36:00 <Eighth_Doctor> I basically never use the netinstall ISO and pretty much use the DVD media
17:36:11 <Eighth_Doctor> it's faster and reproducible
17:36:39 <Eighth_Doctor> the netinstall exists for people who have more extreme bandwidth requirements
17:36:59 <Eighth_Doctor> another option that we could add is a way to use the Fedora Cloud images to make a Fedora Server
17:37:17 <Eighth_Doctor> we've never really had that before, but nothing technically stops that from being a workable solution
17:37:27 <pboyHB> Eighth_Doctor: then we should either drop the DVD image size or drop some of the additional optionsß
17:37:35 <Eighth_Doctor> no
17:37:40 <Eighth_Doctor> I'm saying we should not touch the DVD media
17:37:55 <Eighth_Doctor> because it doesn't actually solve the problem you're trying to solve
17:38:22 <Eighth_Doctor> you have not stated an actual problem you are solving by doing this
17:39:13 <Eighth_Doctor> we even promote both the regular DVD ISO and the netinstall ISO on the download page
17:39:25 <pboyHB> Eighth_Doctor: What#s your solution how we find such issues as the Cockpit installation case?
17:39:46 <Eighth_Doctor> fix the pungi bug?
17:39:54 <Eighth_Doctor> like, the issue is known, someone just has to fix it
17:40:21 <Eighth_Doctor> DVD media should be including weak deps in the repo generation, but they're not
17:40:29 <Eighth_Doctor> that's a bug that should be fixed
17:40:51 <pboyHB> It was no pungi bug. It was the decision not to include recommended packages
17:41:18 <Eighth_Doctor> then reverse that decision
17:41:25 <Eighth_Doctor> inclusion of packages != installation of packages
17:41:40 <Southern_Gentlem> i see no reason that the server dvd has to be container to 2G or less as long as its less than the 4.7G space of a DVD
17:41:43 <pboyHB> Eighth_Doctor:  @DVD media: than we have to accept, that the DVD images doesn't fit onto a DCD anymore. II'm ok with that.
17:41:43 <Eighth_Doctor> the whole point of weak deps is to be able to split those two parts of the decision tree
17:42:10 <Eighth_Doctor> DCD?
17:42:17 <pboyHB> sorry DVD
17:42:38 <jwhimpel> Was the DVD size issue just for Desktop DVD's or is there a size issue for Server DVD's also.
17:43:21 <Eighth_Doctor> we still have ~2GB of wiggle room
17:43:28 <Eighth_Doctor> (if we're counting single-layer DVDs)
17:43:35 <Southern_Gentlem> live have been limited to 2Gish, but i dont think anyone would complain about a 4G server iso
17:43:44 <Eighth_Doctor> and ~6GB of wiggle room for double-layer DVDs
17:43:54 <Eighth_Doctor> fwiw, RHEL DVDs are 8GB
17:43:57 <Southern_Gentlem> Eighth_Doctor,  single layer 4.7G
17:44:33 <pboyHB> We should ask sgallagh. He saw the need to limit the size of the full install image.
17:44:36 <Eighth_Doctor> one of the reasons for the limits for the live ISOs was so we can stuff them all into an omnibus DVD image
17:44:51 <Eighth_Doctor> that practice stopped a very long time ago, and we never included Server in that anyway
17:45:16 <jwhimpel> Anyone have a pointer to the discussion where the decision was made, so I can better understand their rationale?
17:45:22 <pboyHB> Southern_Gentlem: You are right. I dn't know at the moment, why there is a limit of 2 gb.
17:45:46 <sgallagh> That limit was based on the availability of cheap thumb drives
17:45:46 <Southern_Gentlem> well that and at one time usbkeys where expensive where now you can get a 32GB for cheaper than 2G used to be
17:45:54 <Eighth_Doctor> indeed
17:46:06 <pboyHB> We should just include even recommended packages and accept an image size up to 4 gb.
17:46:09 <Eighth_Doctor> 4GB USB sticks are starting to die out in favor of 8GB ones at that price point
17:46:25 <Southern_Gentlem> Eighth_Doctor, want to try 16-32G
17:46:31 <Eighth_Doctor> hehe
17:46:41 <Eighth_Doctor> I'm thinking of Asia where things are bit slower on the uptake
17:46:42 <pboyHB> Eighth_Doctor: That another question. Who is using DVDs today?
17:46:44 <sgallagh> However, keeping the size down is still advantageous for folks in countries with poor broadband (like much of the USA)
17:46:48 <Southern_Gentlem> i am buying 64G at walmart for $12 each
17:47:18 <Southern_Gentlem> sgallagh, but all other server isos have been 4G for years
17:47:28 <Eighth_Doctor> pboyHB: I suspect a lot of folks like myself who have to deploy in places with less than ideal bandwidth prefer the DVD ISO
17:47:51 <Southern_Gentlem> or people setting up pxeboot
17:48:09 <pboyHB> Eighth_Doctor: 'Yes, but do you really use a DVD nowadays?
17:48:11 <sgallagh> I’m open to increasing the maximum, but not to using that as a justification to grow the size too much.
17:48:21 <Eighth_Doctor> pboyHB: not the physical DVD no, mostly on USB sticks
17:48:30 <pboyHB> sgallagh: +1 !
17:48:42 <Eighth_Doctor> sgallagh: I'm saying we should just go from 2GB to 4GB for now
17:49:05 <Eighth_Doctor> and see if we can get what we need to fit in there
17:49:51 <sgallagh> Yeah, I'm fine with setting that as the maximum, but ideally I think we still want to *try* to stay smaller.
17:50:00 <sgallagh> A small server image is a valid selling point
17:50:09 <pboyHB> Do we know how big the image will be when we include recommended packages?
17:50:57 <sgallagh> No
17:50:58 <Eighth_Doctor> not yet
17:51:07 <Southern_Gentlem> lets find that out
17:51:37 <pboyHB> I think it would be good if net install and full install lead to the same result. They do not now.
17:51:46 <Eighth_Doctor> yup
17:51:51 <jwhimpel> +1
17:51:59 <Eighth_Doctor> fixing how the DVD iso repo is populated should fix that
17:52:11 <pboyHB> How can we find out the size?
17:52:57 <Eighth_Doctor> good question
17:53:15 <Eighth_Doctor> it's been a long time since I've messed with the install media creation process, and I'm pretty sure it's been rewritten a couple of times since then
17:53:37 <jwhimpel> Perhaps a ticket to "Release Mgmt"?
17:54:41 <Eighth_Doctor> yeah likely a releng ticket to help figure that out
17:54:53 <pboyHB> Eighth_Doctor: Could you organize how to find out?
17:55:01 <Eighth_Doctor> sure
17:55:38 <pboyHB> #agreed: Eighth_Doctor checks the size of a install image including all recommends.
17:55:51 <pboyHB> #action: ighth_Doctor checks the size of a install image including all recommends.
17:56:05 <pboyHB> #topic Planing for next Fedora release
17:56:18 <pboyHB> We have commited to a number of goals in the new PRD. What of these should be tackled?
17:56:46 <pboyHB> But we are running out of time now. So we should delay this.
17:56:48 <x3mboy> To know that we need to actually finish the PRD
17:56:58 <Southern_Gentlem> most likely we will have to look at the server dvd ks
17:57:23 <pboyHB> x3mboy: wee decided: final discussion and voting May 12
17:57:36 <pboyHB> #topic Open Floor
17:57:45 <pboyHB> Next chair?
17:58:10 <pboyHB> Eighth_Doctor>? Can you do it?
17:59:47 <pboyHB> I have done it 3 times in a row now.
18:00:17 <Eighth_Doctor> pboyHB: I can't, I have too many meeting conflicts around this time
18:00:29 <pboyHB> OK. I see, it's me again.
18:00:33 <Eighth_Doctor> sorry :(
18:00:40 <pboyHB> Thanks anyway.
18:00:55 <pboyHB> OK, time is up.
18:01:09 <pboyHB> Thanks to anybody for coming.
18:01:16 <pboyHB> See you again next week.
18:01:30 <pboyHB> #endmeeting