fedora-qa
LOGS
15:01:17 <adamw> #startmeeting Fedora QA meeting
15:01:17 <zodbot> Meeting started Mon Apr 12 15:01:17 2021 UTC.
15:01:17 <zodbot> This meeting is logged and archived in a public location.
15:01:17 <zodbot> The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:17 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:17 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:01:22 <adamw> #meetingname fedora-qa
15:01:22 <zodbot> The meeting name has been set to 'fedora-qa'
15:01:25 <adamw> #topic Roll Call
15:01:32 <adamw> morning folks, sorry again for the late notice
15:01:37 <adamw> did anyone make it? :D
15:01:48 <bcotton> .hello2
15:01:52 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
15:02:57 <frantisekz> .hello2
15:02:57 <zodbot> frantisekz: frantisekz 'František Zatloukal' <fzatlouk@redhat.com>
15:04:40 <coremodule> .hello2
15:04:40 <zodbot> coremodule: coremodule 'Geoffrey Marr' <gmarr@redhat.com>
15:04:55 <lruzicka[m]> .hello lruzicka
15:04:56 <zodbot> lruzicka[m]: lruzicka 'Lukáš Růžička' <lruzicka@redhat.com>
15:05:22 <adamw> well ben lives here, of course
15:05:22 * kparal lurks
15:07:29 <adamw> hi kparal
15:07:50 <bcotton> you only adopted the #fedora-meeting. i was born into it
15:09:06 <adamw> hehe
15:09:08 <adamw> alrighty
15:09:10 <adamw> #topic Previous meeting follow-up
15:09:42 <adamw> #info no action items
15:09:56 <adamw> #info we'll follow up test day stuffl ater
15:10:13 <adamw> #topic Fedora 34 Final status and validation
15:10:43 <adamw> #info we're currently in Final freeze, with 6 accepted blockers and several proposed, blocker review meeting is coming up right after this meeting
15:11:09 <adamw> so I'm a bit concerned about the bootloader stuff
15:12:03 <adamw> #info on https://bugzilla.redhat.com/show_bug.cgi?id=1938630 (re-signed bootloader bug): we got a new shim build last week, but cmurf and I have each found a significant bug in it so far
15:12:27 <adamw> and pjones is apparently going to take some time off soon, which won't help
15:12:42 <kparal> what significant bug?
15:13:07 <adamw> the bug I found breaks boot on dell sputnik laptops with default configuration
15:13:30 <adamw> the bug cmurf found, i believe, breaks boot on older macs - ones with the original "EFI" (not UEFI) implementation
15:13:38 <kparal> good to know that even laptops get vaccinated these days
15:13:54 <adamw> heh
15:14:12 <adamw> sputnik = 'developer edition', the ones with ubuntu preloaded (they are popular among fedora users too)
15:14:51 <adamw> i believe for cmurf's case we can potentially work around it in anaconda without having to redo shim, but we need to look into that, and thinking about it, that approach wouldn't help upgrades
15:15:38 <adamw> Ben Cotton: do you have any further insight here? into scheudles or anything?
15:15:56 <bcotton> i wish! i get all of my information second-hand :/
15:17:13 <bcotton> i'd fly to boston and sit on peter's desk, but the office is closed
15:18:26 <adamw> curses
15:18:38 <adamw> alright, well, that's where we're at as far as I know.
15:23:37 <adamw> aside from that, we're getting candidates for validation and they're testing out okay aside from the known blockers
15:23:39 <adamw> so please help fill out those matrices
15:27:05 <adamw> any other notes on current f34?
15:28:23 <adamw> #topic Outstanding proposals
15:28:54 <adamw> by which i mean "ones we haven't sorted yet", not "really good ones" :D
15:29:48 <adamw> #info lruzicka proposed a criterion for multiple displays - https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/message/K7OED5BXPTGCYHH7QHHVOUHA4R7EG5BV/ - which got a lot of feedback
15:30:08 <cmurf> What, no awards ceremony?
15:30:27 <adamw> sadly no
15:30:32 <lruzicka[m]> No, it seems that it is difficult to get the interest
15:30:57 <adamw> so i think the status here is that you're taking feedback for a second draft, right lukas?
15:31:17 <lruzicka[m]> there will be a second draft, for sure, based on the premise that we:
15:31:33 <lruzicka[m]> want to test ONE CARD with TWO MONITORS max.
15:32:04 <lruzicka[m]> this is what I have understood so far ... anything else get too complicated and unclear
15:32:27 <bcotton> +1 to that
15:32:59 <lruzicka[m]> so, I believe it is two monitors for a desktop and one external monitor for a laptop
15:33:11 <cmurf> sounds reasonable
15:33:11 <adamw> yeah, that seemed to be the consensus
15:34:38 <lruzicka[m]> ok, then I will repost the draft tomorrow probably
15:34:41 <frantisekz> lruzicka, just beware that plenty of laptops have two gpus and need both of them to drive the external display
15:35:08 <lruzicka[m]> frantisekz: so what would you suggest in this case? block on them or not?
15:35:47 <frantisekz> huh, I'd suggest not to block, at this moment, stuff gets really complicated when intel and nvidia gpus need to work together... each display on different port
15:36:04 <frantisekz> *each display on different gpu
15:36:25 <lruzicka[m]> frantisekz: this is exactly what I was talking about being unclear ... when I write **one card** then someone complains about above laptops, when I skip the word one, someone complains about complexity.
15:36:36 <frantisekz> :D :D
15:37:11 <frantisekz> I think you should explicitly say one card, no matter what will be blocking for now
15:37:14 <frantisekz> we can expand later
15:37:24 <lruzicka[m]> so, I think let's stick to ONE CARD, if there are two cards which work in cooperation, that's a bonus?
15:37:54 <lruzicka[m]> frantisekz: got you :D
15:37:59 <frantisekz> yeah, for now, some laptops use only the igpu for it, some both graphics cards, let's stay with one now
15:38:14 <frantisekz> we can explore this area and expand the blocking later down the road
15:38:16 <frantisekz> :D
15:38:25 <cmurf> i guess i wouldn't get into the hardware specificstoo much; one or two cards, or discrete versus integrated gpu
15:40:36 <frantisekz> we can decide per bug basis... I am even not sure how to find out if the external display is driven by the dGPU or iGPU
15:41:26 <adamw> it does feel tricky to formulate
15:41:35 <adamw> like we sort of have an idea what we want but it's hard to get into words
15:42:17 <adamw> i wonder if it's one we might want to get wider input on?
15:42:28 <cmurf> i think we want to cover wide spread bugs that affect a lot of a particular configuration, e.g. anyone using two displays can't login because bug
15:42:33 <adamw> maybe from the gfx devs about what's plausible, and from devel@ or users@ about what the user expectations are
15:43:16 <cmurf> whereas if it's a bug pertaining to a particular gpu or combination of gpus, more likely it's a conditional blocker
15:46:39 <adamw> welp, i guess we can leave the ideas with lukas to think about :)
15:47:07 <adamw> the other outstanding proposal is ben's:
15:47:08 <adamw> "Basic criterion proposal: g-i-s shouldn't take 2 minutes to launch"
15:47:14 <adamw> that never got settled, did it ben?
15:47:27 <bcotton> i was just re-reading the thread
15:47:39 <bcotton> it doesn't seem like anyone wanted substantive changes
15:47:53 <cmurf> it probably shouldn't take 30 seconds
15:48:17 <cmurf> first time i encountered the delay i started reaching for the power button
15:48:47 <bcotton> there was the one comment about "displayed without error" but as you pointed out we could cover that with the "no selinux denial and no crashes"
15:49:01 <bcotton> i agree that 30 seconds is probably too long
15:50:08 <bcotton> but i wanted to be conservative in the initial pass
15:50:56 <adamw> yeah, and some systems are slow
15:51:02 <frantisekz> how would we formally measure the time? eg. I can imagine a hw config that just takes 2 minutes to load g-i-s...
15:51:25 <adamw> #info the other outstanding proposal is "Basic criterion proposal: g-i-s shouldn't take 2 minutes to launch" - https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/message/OSN4LTQ2BSUJQL7KIB67YNIDHSLD7I5B/
15:51:35 <frantisekz> what about using OpenQA? It *should* perform similarly over time, shouldn't it adamw?
15:51:38 <adamw> #info this proposal seems to have solid consensus and could be moved forward
15:52:15 <adamw> #action bcotton to move forward with implementing this proposal
15:52:39 <adamw> frantisekz: eh, it can depend on how many things run at once. and rawhide with debugging enabled is slower. and actually figuring out how long things take in openqa isn't the easiest thing
15:53:18 <frantisekz> mhm, okay, we'll need to figure out something else then
15:53:22 <lruzicka[m]> hehe openqa isn't the easiest thing ... carve it into a stone
15:54:52 <adamw> we might be able to figure something, though.
15:54:55 <adamw> okay, let's move on
15:55:04 <adamw> #topic Test Day / community event status
15:55:17 <adamw> sumantro, are you around?
15:56:06 <frantisekz> (a bit of ot, I've fixed testdays displaying internal server error in 404 cases for test events)
15:57:03 <adamw> thanks frantisekz!
15:57:29 <adamw> welp, i'll do it then
15:57:52 <adamw> #info today is grub and shim test day - very important, so please, after blocker meeting head to #fedora-test-day to help out: https://fedoraproject.org/wiki/Test_Day:2021-04-12_Grub_and_Shim_Test_Day
15:58:13 <adamw> it will be really useful to have feedback for the new bootloader updates from as many systems as posskbe
15:58:36 <coremodule> today also marks the start of the IoT test week: https://fedoraproject.org/wiki/Test_Day:2021-04-12_Fedora_34_IoT_Edition
15:58:44 <adamw> indeedy doodly
15:58:47 <adamw> that one's in #fedora-iot
15:59:16 <adamw> #info tomorrow (04-13) will be virtualization test day: https://fedoraproject.org/wiki/Test_Day:2021-04-13_Virtualization
15:59:25 <adamw> so please help out with all of those if possible
16:00:34 <adamw> also just a note, we have an outreachy project this cycle: https://www.outreachy.org/apply/project-selection/ ("Improve Fedora QA Dashboard"), so we have folks showing up in IRC and other places who are interested in that
16:01:06 <adamw> please be welcoming :D you can direct them to lbrabec or jskladan for specific info on the outreachy project
16:01:18 <adamw> ok, so quickly:
16:01:21 <adamw> #topic Open floor
16:01:24 <adamw> any urgent business?
16:01:27 <frantisekz> just one thing, this looks pretty ugly, I am yet to find time to test that, but anybody else is very welcome to do so: https://www.reddit.com/r/Fedora/comments/mojn18/fedora_34_beta_upgrade_freezes_entire_system/ ; https://bugzilla.redhat.com/show_bug.cgi?id=1948197
16:03:41 <cmurf> btw on shim test day, adamw made a couple ISO images, all you need to do to test is make a usb stick (or whatever) and try to boot from it
16:04:06 <cmurf> so it's kind of a risk free way of testing
16:04:19 <adamw> openqa made them, i just copied them :D
16:04:29 <adamw> sorry i didn't do one with the later build yet, didn't actually realize it was needed for today
16:05:58 <cmurf> well they are referenced in the test day page
16:06:03 <cmurf> and the UEFI test case
16:06:30 <cmurf> later build? of?
16:10:42 <cmurf> adamw maybe end this meeting? :D
16:13:02 <adamw> #endmeeting