fedora-server
LOGS
17:00:12 <copperi> #startmeeting fedora-server
17:00:12 <zodbot> Meeting started Wed Mar 24 17:00:12 2021 UTC.
17:00:12 <zodbot> This meeting is logged and archived in a public location.
17:00:12 <zodbot> The chair is copperi. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:12 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:12 <zodbot> The meeting name has been set to 'fedora-server'
17:00:26 <copperi> #chair michel_slm pboyHB
17:00:26 <zodbot> Current chairs: copperi michel_slm pboyHB
17:00:38 <copperi> #topic Roll Call
17:01:00 <michel_slm> .hello salimma
17:01:01 <zodbot> michel_slm: salimma 'Michel Alexandre Salim' <michel@michel-slm.name>
17:01:24 <dcavalca> .hello2
17:01:25 <zodbot> dcavalca: dcavalca 'Davide Cavalca' <dcavalca@fb.com>
17:03:30 <copperi> Peter should come shortly
17:03:35 <copperi> #topic Introductions
17:03:47 * nirik can try and watch, but also busy with the account system stuff.
17:04:12 <copperi> Anyone new who want to introduce themselves ?
17:04:31 * michel_slm have a work organizational presentation but can lurk
17:05:34 <dcavalca> I've missed a bunch of these previously due to conflicts, but will try to attend more regularly going forward
17:05:47 <dcavalca> I work with michel_slm at Facebook and maintain our CentOS Stream deployment there
17:06:49 <copperi> Welcome dcavalca
17:07:17 <dcavalca> thanks
17:07:28 <copperi> #topic Documentation update
17:07:41 <copperi> #info Fedora Server Update Proposal https://hackmd.io/@x3mboy/By5OkH71O
17:07:52 <copperi> #info Fedora Server Documentation https://docs.fedoraproject.org/en-US/fedora-server/
17:08:39 <x3mboy> .hello
17:08:39 <zodbot> x3mboy: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
17:08:46 <x3mboy> .hi
17:08:47 <zodbot> x3mboy: x3mboy 'Eduard Lucena' <eduardlucena@gmail.com>
17:09:52 * michel_slm didn't know there's hi - is that the same as hello2
17:10:09 <pboyHB> .hello. pboy
17:10:37 <copperi> you have an extra dot there
17:10:39 <pboyHB> .hello pboy
17:10:40 <zodbot> pboyHB: pboy 'Peter Boy' <pboy@uni-bremen.de>
17:10:43 <michel_slm> for the PRD, this one item seems like it should not specifically mention EL8 - "For the people who were using it as servers, it was split between getting ready for the next RHEL/CentOS they would be deploying, they needed packages which were not in EPEL, or things like python/nodejs/etc was new enough for what they needed to run but wasn’t in EL8."
17:11:38 <pboyHB> :copperi: thanks that's ai :-)
17:12:36 <dcavalca> I really like the "server of the future" framing in the PRD
17:14:05 <pboyHB> Sorry for beeing late. What section we are dicussing?
17:14:33 <copperi> pboyHB: I just gave links, have not gone over it yet
17:14:49 <dcavalca> the bit that michel_slm mentioned is in 4.1
17:14:57 <michel_slm> yeah, I just jumped to the first issue I noticed, it's in 4.1
17:15:02 <michel_slm> added a comment in the doc
17:15:11 <pboyHB> thanks
17:15:49 <michel_slm> do we need to refresh this a bit to mention Stream? having a clear segmentation between when to use Stream and when to use Server could be useful
17:16:20 <michel_slm> (also please let me know if I rehash something that's been discussed previously, I missed a few meetings due to parental leave)
17:16:46 <dcavalca> referencing back the mission, I think you could say that CentOS (both Linux and Stream) is the "server of the present", while Fedora is the "server of the future"
17:17:01 <pboyHB> michel_slm: That's the uneditid collection. It should not go into the PRD that way. Next section i tried to summerize.I think I don't explizity mentiopn EL8 there.
17:17:43 <michel_slm> pboyHB: ah, got it
17:19:30 <x3mboy> I think we shouldn't mention any other project beyond our project
17:19:31 <dcavalca> "Very easy (quasi rolling) updates with shorter, less disruptive release jumps" -- I'd suggest saying "faster release cycle aligned with other Fedora editions" or something like that
17:19:47 <dcavalca> Server isn't a rolling distro, and mentioning rolling could cause confusion
17:20:01 <pboyHB> dcavalca: Should we really mention any other distribution when we try to argue for Fedora? Shouldn't concentrate on our own ?
17:20:16 <dcavalca> pboyHB: oh I agree, this should be focused on Fedora
17:21:04 <pboyHB> dcavalca: To mention alternatives could be part of marketing considerations, I guess.
17:21:31 <dcavalca> yeah, either there or in a separate FAQ document of some kind
17:22:43 <pboyHB> dcavalca: I agree, we should not mention "rolling", but one of your alternatives
17:24:32 <dcavalca> left a comment on the doc
17:25:19 <x3mboy> I never saw it as rolling, it's just "quickly updated"
17:25:23 <pboyHB> Did you already agree upon section 3 (Mission) and 4 (market opportunity)?
17:25:52 <pboyHB> x2mboy: +
17:26:16 <pboyHB> x3mboy, of course
17:26:58 <x3mboy> I have a question
17:27:11 <x3mboy> Why are we still using the side-by-side version?
17:27:30 <pboyHB> x3mboy: There are nearly all of the comments.
17:27:54 <x3mboy> Ok
17:28:25 <x3mboy> It will be extremely easier to update the only- new version
17:28:30 <pboyHB> After goining through this version, we (or better you?) create an updated version, than full page, i would suggest.
17:28:45 <x3mboy> Ok
17:28:55 <x3mboy> I already have one
17:28:56 <x3mboy> https://hackmd.io/xv-iMBzsTQ-KMvnDNV7VIA
17:29:04 <x3mboy> Without all the comments
17:29:26 <x3mboy> I think I will work over that one, when we start to have written on stone decisions
17:29:33 <pboyHB> x3mboy: Yes, i linkt both versions on our Wiki page.
17:29:45 <x3mboy> (Y)
17:29:49 <x3mboy> 👍️
17:29:52 <copperi> #info updated Product Requirement Document
17:30:07 <copperi> #link https://hackmd.io/xv-iMBzsTQ-KMvnDNV7VIA
17:31:47 <copperi> x3mboy: I made couple changes to old version, you want to update them to new one ?
17:32:10 <copperi> 4.1 title and 4.1.2 wording
17:32:21 <x3mboy> Sure
17:32:28 <x3mboy> Action me
17:33:32 <copperi> #action x3mboy to update new version as proposed on the old one
17:37:03 <pboyHB> If we are still discussing 4.1: The question is, does the "Another Numbering " section includes all the relevant arguments of the items 1-13 or is there missing one?
17:37:59 <pboyHB> Questen (b) is there something which shouldnt be there?
17:41:07 <dcavalca> the content in "Another Numbering" lgtm, modulo the rolling comment I mentioned previously
17:42:35 <pboyHB> OK, so we do agree upon 4.1 Another numbering including the rolling release modification.
17:42:46 <pboyHB> last chance to object. :-)
17:44:03 <michel_slm> +1
17:45:02 <pboyHB> #agree: section 4.1 Another numvbering including modification rolling release
17:46:20 <copperi> pboy: do you have anything else on the agenda today ?
17:46:30 <pboyHB> OF course, we may have a "second reading" and make addtional modifications
17:47:05 <pboyHB> copperi: The next auestion is documentation.
17:48:45 <pboyHB> As an info: I contacted docs group leader about contribution to the Fedora installation Guide and Sys Admin Guide. It chould be possible, but no detailed planning yet.
17:49:37 <copperi> #info pboyHB contacted docs group leader about contribution to the Fedora installation Guide and Sys Admin Guide. It chould be possible, but no detailed planning yet.
17:49:50 <pboyHB> I'm considering to wrtie some text to our own guide so we will have some info. And discuss later, if we transfer it to Fedora docs.
17:50:28 <copperi> Final location is minor issue, writing docs should come first
17:50:59 <copperi> we can take a look at it next time.
17:51:03 <pboyHB> Yes, but the content is partly dependent on the context.
17:51:45 <copperi> ok
17:52:24 <copperi> #topic Housekeeping (next meeting and chair)
17:52:49 <copperi> Who wants to chair next meeting ?
17:54:34 <pboyHB> If there is no one else, I coiuld take it.
17:54:55 <copperi> #action pboy chairs next meeting
17:55:16 <copperi> next wednesday same time ?
17:55:34 <michel_slm> it's a fixed schedule now, right?
17:56:04 <copperi> #info next meeting 31.3.2021 17.00 UTC
17:56:21 <copperi> michel_slm: yes, just to make safe
17:56:29 <michel_slm> copperi++ for hosting
17:56:29 <zodbot> michel_slm: Karma for copperi changed to 8 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:56:35 <copperi> #topic Open Floor
17:56:57 <copperi> anyone have any last minute items ?
17:57:18 <michel_slm> are there server oriented packages we should keep a close eye on when they break?
17:57:38 <michel_slm> e.g. nextcloud server is currently uninstallable because of a missing PHP dependency
17:58:11 <pboyHB> idea is: everyone should check packages which are most important for him.
17:58:46 <pboyHB> And of course inform about issues, as with nextcloud
18:00:12 <copperi> We can look at it more next time
18:00:17 <copperi> #endmeeting