fedora-server
LOGS
18:04:43 <smooge> #startmeeting fedora-server
18:04:44 <zodbot> Meeting started Wed Mar  3 18:04:43 2021 UTC.
18:04:44 <zodbot> This meeting is logged and archived in a public location.
18:04:44 <zodbot> The chair is smooge. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:04:44 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:04:44 <zodbot> The meeting name has been set to 'fedora-server'
18:05:03 <smooge> #chair pboyHB copperi adamw
18:05:03 <zodbot> Current chairs: adamw copperi pboyHB smooge
18:05:06 <nirik> hello (he says and then runs to get a cup of coffee)
18:05:32 <smooge> #topic Introduction, Quick Hello
18:05:33 <Southern_Gentlem> .hello jbwillia
18:05:34 <zodbot> Southern_Gentlem: jbwillia 'Ben Williams' <vaioof@gmail.com>
18:05:40 <pboyHB> .hello pboy
18:05:40 <dustymabe> .hello2
18:05:40 <zodbot> pboyHB: pboy 'Peter Boy' <pboy@uni-bremen.de>
18:05:41 <adamw> .hello adamwill
18:05:44 <zodbot> dustymabe: dustymabe 'Dusty Mabe' <dusty@dustymabe.com>
18:05:47 <zodbot> adamw: adamwill 'Adam Williamson' <awilliam@redhat.com>
18:05:50 <copperi> .hello2
18:05:51 <zodbot> copperi: copperi 'Jan Kuparinen' <copper_fin@hotmail.com>
18:05:57 <jwhimpel> .helo jwhimpel
18:06:02 <ab> .hello abbra
18:06:03 <zodbot> ab: abbra 'None' <abokovoy@redhat.com>
18:06:27 <smooge> #topic Agenda
18:06:47 <smooge> #info Currently Ongoing Work Projects
18:07:20 <jwhimpel> .hello
18:07:20 <zodbot> jwhimpel: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
18:07:24 <smooge> #info  Introduce Dusty Mabe from Cloud Group
18:07:38 <smooge> #info Work needed for Fedora 34 beta
18:07:55 <smooge> #info PRD Update 1.5 round of discussion
18:08:13 <smooge> #Info Status Reboot Server Working Group
18:08:22 <smooge> #info Status Reboot Server Working Group
18:08:29 <smooge> ok first topic
18:08:42 <adamw> have you tried turning it off and on again
18:08:45 <smooge> #topic  Currently Ongoing Work Projects (pboyHB)
18:09:00 <pboyHB> Probablysome info from me
18:09:13 <pboyHB> I contact the "old"members
18:09:20 <pboyHB> mwolf, could not contact via email, so taken off list
18:09:30 <pboyHB> mhayden, informed me we would like to contribute, but unfortunately is currently too busy with other tasks, so he is not able to.
18:09:38 <pboyHB> The other two (dperpeet, jds2001) didn’t answer. I suggest to no longer include either of them in our list of members for the time being.
18:09:55 <nirik> +1
18:10:11 <smooge> agreed
18:10:21 <pboyHB> Interested members to be According to my accounting:
18:10:33 <pboyHB> @defolos,
18:10:33 <pboyHB> @mhoungbo,
18:10:34 <pboyHB> @fsaez
18:10:34 <pboyHB> @fcami
18:10:36 <pboyHB> @copperi
18:10:57 <pboyHB> Oh, I'm too fast
18:11:08 <dustymabe> 🏎️
18:11:27 <nirik> just ignore it. @ is the 'attention' command for fedbot... it tried to look up those as commands.
18:11:38 <adamw> yeah, we don't need it for the meeting
18:11:49 <copperi> not for zodbot
18:11:52 <pboyHB> OK. Sugestion: I create a ticket and we vote on them
18:12:08 <pboyHB> They had all participated the last meetings, as I remember
18:14:36 <pboyHB> I mean, I create a ticket after the IRC meeting,
18:14:55 <pboyHB> Or someone else who is better in working with that system?
18:15:24 <nirik> I'm all for everyone interested joining...
18:15:42 <pboyHB> nirik: +1
18:15:53 <adamw> sure
18:16:20 <ab> yes,  makes sense
18:16:21 <pboyHB> Or we add them without explizic voting? we are three +, which is the minimum. Agreed?
18:17:08 <nirik> I think we can just add them here
18:17:08 <smooge> Agreed
18:17:23 <pboyHB> OK, I'll add them later.
18:18:10 <Southern_Gentlem> ok add me as well
18:18:20 <nb> hi
18:18:39 <copperi> +1
18:18:43 <nb> +1 to add them
18:18:59 <pboyHB> Southern_Gentlem: OK, obviously no objection
18:19:33 <smooge> I am ok with Southern_Gentlem also
18:19:39 <smooge> anything else on this?
18:19:44 <nb> I thought Southern_Gentlem was already in the original list?
18:19:54 <nb> the list that mattdm originally proposed?
18:20:03 <Southern_Gentlem> nb not that i knew of
18:20:26 <nb> https://pagure.io/fedora-server/issue/6
18:20:30 <nb> Southern_Gentlem you are listed on there
18:20:34 <Southern_Gentlem> ok
18:20:51 <pboyHB> Oh, I missed him in my accounting, sorry
18:21:20 <smooge> ok are there any objections from previous members? if not I am marking this as + in 2 minutes
18:21:22 * linuxmodder lurking
18:22:12 <linuxmodder> what is the current vote for ? came in late?
18:22:40 <smooge> #agreed defolos mhoungbo fsaez fcami pboyHB copperi Southern_Gentlem are added as SIG members
18:23:01 <linuxmodder> smooge, I'd be interested in being added as well if its not to late
18:23:01 <smooge> #topic  Introduce Dusty Mabe from Cloud Group
18:23:15 <Southern_Gentlem> +1 linuxmodder
18:23:20 <dustymabe> 👋
18:23:36 <copperi> +1
18:23:44 <adamw> +1
18:23:45 <smooge> linuxmodder, I understand.. can you ask on the mailing list in reply to things so I can keep the meeting moving
18:24:10 <linuxmodder> smooge,  done
18:24:17 <smooge> I don't have any objections but we have a very full schedule and I need to keep this moving
18:24:30 <smooge> Hi this is dustymabe who does many things at Red Hat. Many things
18:24:34 <linuxmodder> onwards
18:25:02 <smooge> dustymabe deals with the CLoud Sig, Atomic/CoreOS, and probably a bunch of things I can't remember because I am old
18:25:30 <linuxmodder> he's also in cockpit stuff alot too
18:25:32 <dustymabe> 🙂
18:25:38 <smooge> we invited him to this meeting so we could discuss joining the cloud sig and server sig formally
18:26:05 <dustymabe> Hi everyone
18:26:15 <pboyHB> dustymabe: Welcome again. I'm interested to propagate Cloud (Base) Images as recommended way to create VMs within Fedora Server even if it runs „autonomously“ (i.e. is not part of a cloud system, but not necessarily standalone).
18:26:45 <pboyHB> But there are some issues to resolve ,e.g. missing firewall.
18:26:59 <pboyHB> Welll, and missing documentation
18:28:16 <dustymabe> Anything else?
18:29:13 <pboyHB> Relating to me, there may be more topics I don't know yet.
18:29:50 <pboyHB> But perhaps the broader topic fist: joining both groups
18:29:51 <ab> pboyHB: may be a way to proceed would be to file issues against cloud base images and resolve them?
18:30:12 <smooge> mine is just what would help get the groups 'together'
18:30:14 <copperi> Cloud sig meetings have not had any participants for several weeks, so dustymabe is the only active there ?
18:30:43 <dustymabe> copperi: the meetings are a bit more regular when I'm fully available - had a baby in January so I've been away for some time
18:30:52 <dustymabe> will be back 100% at the end of March
18:30:56 <pboyHB> ab: there are alternative ways to resolve it. So some discussion would be fine.
18:31:02 <copperi> dustymabe: ok
18:31:18 <dustymabe> others tend to join the cloud WG meetings when I start them up. we do have a few active members
18:31:41 <smooge> yeah. I think it is 'dusty is here. lets do a meeting :)'
18:32:06 <dustymabe> so let me run a bit with a train of thought
18:32:18 <dustymabe> there have been several discussions about joining server/cloud in the past
18:32:45 <dustymabe> i think the cloud WG members aren't opposed, but also don't see much need to change the cloud deliverable significantly from what it is today
18:33:05 <pboyHB> I heard something about "killing" one or the other, Not what I like
18:33:07 <dustymabe> so, is there anyone with a concrete view of what bringing the two groups together would achieve?
18:34:02 <pboyHB> Yes, e.g. documentation and presentation on fedoras project pages.
18:35:03 <pboyHB> We tend to create a "Server Box" on docs.fedoraproject. It could be "Server & Cloud" and could get filled faster.
18:35:03 <dustymabe> That's one benefit. What about the actual deliverable artifacts?
18:35:12 <nirik> cloud image might be easier to find/see/use if it was just part of server deliverables...
18:35:51 <dustymabe> +1
18:35:53 <pboyHB> The artifact may be basically the same, I suppose.
18:36:06 <copperi> that would be logical place to search for it
18:36:08 <copperi> +1
18:36:16 <dustymabe> pboyHB: sounds reasonable
18:36:21 <linuxmodder> most VPSes I see now use cloud as their server image so that would make that easier
18:36:24 <pboyHB> May be, we should adjust the Base image.
18:36:29 <linuxmodder> +1
18:37:39 <dustymabe> assuming we aren't proposing the change the cloud deliverable significantly from what it is today I'm supportive.
18:38:01 <smooge> if anything.. I think we are talking about the opposite
18:38:15 <dustymabe> oh, maybe I misunderstand
18:38:20 <pboyHB> smooge: +1
18:38:40 <nirik> it might be nice if it was also more useful as a qcow2 image, but thats just a random thought... not sure how much that matters
18:38:50 <smooge> well if Cloud is being used in VPS more than Server.. then we would want to make sure that our images matched what was used more
18:39:26 <dustymabe> nirik: "more useful as a qcow2 image" - can you explain?
18:39:34 <linuxmodder> I know linode and 1and1 and DO all use a cloud instance for Fedora Server
18:40:03 <smooge> ok we have 10 minutes left in this meeting
18:40:06 <linuxmodder> almost same constraints as fic instances
18:40:28 <nirik> dustymabe: ie, as a small thing to install and manage as a vm with libvirt, etc... for that it would need an easy cloud-init configure thing (which libvirt can do), so not sure what all (if anything) would need to change.
18:40:59 <dustymabe> yeah `virt-install` now has an easy option for setting password and such using cloud-init
18:41:05 <pboyHB> nirik: I'm working on a dos about htat
18:41:20 <adamw> i don't have a strong opinion either way on this
18:41:22 <pboyHB> working on a doc to that
18:41:45 <nirik> pboyHB: oh yeah? cool!
18:41:56 <dustymabe> smooge: so I think I misunderstood earlier, I thought the proposal was to leave the actual bits of the cloud image mostly unchanged but change how it was presented on website/downloads/documentation?
18:42:15 <dustymabe> pboyHB: ^^ - can you help clear things up?
18:42:19 <smooge> yes that is what I thought I was saying
18:42:39 <dustymabe> smooge: ahh ok when you said "if anything.. I think we are talking about the opposite" I got confused
18:42:48 <dustymabe> ok so we are on the same page then?
18:42:56 <smooge> I am talking about we may change the server bits to match the cloud bits
18:43:10 <dustymabe> ahh, I see
18:43:11 <pboyHB> dustynabe: I'm already working on an article about virt-install version 3 and cloud-init
18:43:18 <dustymabe> pboyHB: nice
18:43:20 <linuxmodder> and then  merge docs? smooge
18:43:26 <smooge> does that make sense?
18:43:32 <copperi> yes
18:43:46 <linuxmodder> yeah makes sense to me
18:43:50 <dustymabe> smooge: maybe, I'm not super familar with exactly what makes up "server" today. Other than that you use and installer ISO
18:43:59 <smooge> ok we have 5 minutes left in this meeting. I think this needs to be in the next meeting AND the other items need to be dealt with on the list
18:44:12 <dustymabe> smooge: real quick before we move on
18:44:16 <smooge> understood
18:44:19 <dustymabe> what is the timeline for changes here?
18:44:27 <dustymabe> I'm back 100% at the end of March
18:44:36 <dustymabe> can I take it to the cloud WG then to discuss?
18:44:47 <dustymabe> and we make subsequent changes in April and later?
18:44:48 <smooge> I do not see us getting these 'changes' done by F34 release so this would be F35?
18:44:56 <dustymabe> ok, that works for me then
18:45:23 * dustymabe yields meeting floor
18:45:24 <smooge> however.. <as I realize I am way over bounds> I am just the person who runs this meeting. pboyHB actually is more of the group chair
18:46:06 <pboyHB> smooge:  (blushing)
18:46:35 <pboyHB> How we proceed now?
18:46:40 <smooge> but I think that an F35 change-proposal etc would be the point
18:46:47 <smooge> I think for this meeting we go to open floor
18:46:53 <pboyHB> +1
18:47:16 <smooge> for the item, it needs a general proposal on a mailing list that dusty and eveyrone can read.. then it can go to the groups and get voted on.
18:47:29 <smooge> then we call a preacher, some shotguns and have us a little shindig
18:47:44 <smooge> #topic open floor
18:48:03 <pboyHB> Question 1: How can I close a ticket?
18:48:14 <pboyHB> We have a lot of old open tickets
18:48:21 <smooge> #info the following items are not discussed in this meeting: Fedora 34 beta, PRD, Documentaiton updates
18:48:39 <smooge> ah infra needs to make you an admin on that
18:48:59 <pboyHB> OK, who do I have to ask?
18:49:12 <smooge> nirik, that is something infra does or can it be someone else?
18:50:07 <smooge> ok I am going to say pboyHB could you open a fedora infra ticket so I can track the work and we can do it after the meeting?
18:50:34 <pboyHB> OK.  Question 2: What about ticket 10 cloud-init DNS settings ?
18:50:55 <nirik> I can do it. :)
18:50:58 <smooge> Oh next meeting is 2021/3/17
18:50:59 <nirik> sorry, got sidetracked
18:51:14 <smooge> pboyHB, can you share a link to it?
18:51:31 <pboyHB> https://pagure.io/fedora-server/issue/10
18:52:19 <pboyHB> I suppose, we are not the right address
18:52:48 <nirik> pboyHB: added you. you should be able to close tickets now...
18:53:00 <pboyHB> nirik: Thanks!
18:53:01 <nirik> who is running the next meeting?
18:53:02 <smooge> pboyHB, that is a cloud item. dustymabe may be able to help us on that
18:53:24 <smooge> as in 'go talk to foo until I get back from parent time off'
18:53:40 <pboyHB> OK., so I'll close and transfer to dusty / cloud
18:53:41 <dustymabe> yeah I haven't had a chance to dig into that issue yet
18:53:53 <dustymabe> we might have an open ticket for it too - let me check
18:54:14 <dustymabe> no I don't see one
18:54:18 <dustymabe> https://pagure.io/cloud-sig/issues
18:54:40 <dustymabe> looks like there is a linked ML thread
18:55:06 <dustymabe> and it's long
18:55:08 <dustymabe> :)
18:55:35 <smooge> yes very long.. and lots of 'you broke my stuff'
18:56:01 <linuxmodder> ^^
18:56:03 <smooge> so I think pboyHB we say we are tracking the issue in the list and will try to work something out afterwords
18:56:06 <linuxmodder> that is insanely long
18:56:27 <pboyHB> smooge: OK
18:56:30 <smooge> we are 6 minutes over what I timeboxed. I would like to close this and have conversation move to #fedora-server
18:56:51 <pboyHB> OK, Do we have a chair for next meeting?
18:56:53 <smooge> I will do next meeting as I forgot to ask at the beginning of the meeting
18:57:06 <smooge> if someone wants to take it for the next instead we can do so later
18:57:06 <pboyHB> smooge: +1
18:57:12 <smooge> #endmeeting