fedora_prioritized_bugs_and_issues
LOGS
15:01:09 <bcotton_> #startmeeting Prioritized bugs and issues
15:01:09 <zodbot> Meeting started Wed Oct 21 15:01:09 2020 UTC.
15:01:09 <zodbot> This meeting is logged and archived in a public location.
15:01:09 <zodbot> The chair is bcotton_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:09 <zodbot> The meeting name has been set to 'prioritized_bugs_and_issues'
15:01:10 <bcotton_> #meetingname Fedora Prioritized bugs and issues
15:01:10 <zodbot> The meeting name has been set to 'fedora_prioritized_bugs_and_issues'
15:01:21 <bcotton_> #topic Purpose of this meeting
15:01:22 <bcotton_> #info The purpose of this process is to help with processing backlog of bugs and issues found during the development, verification and use of Fedora distribution.
15:01:24 <bcotton_> #info The main goal is to raise visibility of bugs and issues to help  contributors focus on the most important issues.
15:01:25 <bcotton_> #link https://docs.fedoraproject.org/en-US/program_management/prioritized_bugs/#_process_description
15:01:28 <bcotton_> #topic Roll Call
15:01:51 * cyberpear listens in
15:02:07 <bcotton_> welcome, cyberpear!
15:05:44 * bcotton_ nudges mattdm
15:05:58 <mattdm> bcotton_ I'm busy talking to you in another channel!
15:06:28 <bcotton_> if we're not talking in at least three separate conversations, are we even talking?
15:06:38 <bcotton_> #topic Nominated bugs
15:06:40 <bcotton_> #info 2 nominated bugs
15:06:41 <bcotton_> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&f1=flagtypes.name&f2=OP&list_id=10871664&o1=substring&query_format=advanced&v1=fedora_prioritized_bug%3F
15:06:46 <bcotton_> #topic glibc: Back out glibc-rhbz1869030-faccessat2-eperm.patch workaround for systemd UAPI breakage
15:06:48 <bcotton_> #link https://bugzilla.redhat.com/show_bug.cgi?id=1869030
15:07:53 <bcotton_> mhroncok: you nominated this one
15:08:00 <mattdm> does this even need our attention? looks like it's moving forward
15:08:11 <mattdm> or do we just want to highlight it as important?
15:08:14 <mattdm> it does seem important
15:08:20 <mhroncok> bcotton_: have I?
15:08:39 <bcotton_> mhroncok: so says bugzilla
15:08:42 * mhroncok is on the fesco meeting at the same time, sorry
15:09:09 * bcotton_ understands :-)
15:09:11 <mhroncok> bcotton_: Error 500 - Internal Server Error
15:09:18 <mhroncok> bcotton_: so says bugzilla
15:09:22 <bcotton_> no bugs, everyone go home!
15:10:33 <mattdm> I'm already home!
15:11:20 <bcotton_> so if i understand it correctly, we're carrying a patch in glibc that needs to be backed out, but we can't yet because it breaks copr and mock if we do?
15:12:13 <mhroncok> bugzilla loaded
15:12:20 * mhroncok reads
15:13:03 <mattdm> so, let's accept this as prioritized, and then if the copr people don't see that thread in a couple of days nudge them?
15:13:03 <bcotton_> oh!
15:13:15 <bcotton_> also this was proposed as a prioritized bug before it was fixed
15:13:20 <bcotton_> basically the bug got repurposed
15:13:39 <mattdm> oh that's cheating :)
15:13:47 <bcotton_> -1 from me
15:14:07 <mhroncok> thsi was fixed in fedora
15:14:12 <mhroncok> it was reopened for rhel purposes
15:14:17 <mhroncok> no longer rioritized for fedora
15:14:24 <mhroncok> *prioritized
15:14:47 <mhroncok> my flag was just a leftover
15:15:05 <mattdm> yeah -1 on that now
15:15:28 <mhroncok> technically, I'd like to simply withdraw my proposal :)
15:15:41 <mattdm> sure :)
15:15:41 <mhroncok> but bugzilla won't let me apparently.
15:15:46 <bcotton_> #info mhroncok withdraws the prioritized proposal since the behavior was fixed
15:15:49 <bcotton_> easy enough!
15:16:04 <bcotton_> (i can clear the flag on it)
15:16:07 <bcotton_> #topic [Rawhide/Fedora33] gcc crashes at brew during Firefox build
15:16:08 <bcotton_> #link https://bugzilla.redhat.com/show_bug.cgi?id=1886399
15:16:34 <bcotton_> note that this is apparently not the same gcc/Firefox bug(s?) as we've discussed in the past
15:16:50 <mhroncok> this is fixed
15:16:55 <mhroncok> updates pending
15:17:51 <mattdm> ok, so we can accept it for an easy win on our stats? :)
15:18:16 <bcotton_> i'm okay with that. it's always the possible the fix didn't actually fix :-)
15:19:16 <mhroncok> sure
15:19:25 <mattdm> +1 then :)
15:19:25 <mhroncok> +1 to prioritize this
15:19:34 <bcotton_> proposed #agreed 1886399 - Accepted as a prioritized bug in case the pending fix is insufficient. Building Firefox is important.
15:20:56 <bcotton_> that's a yes, okay
15:20:57 <mhroncok> ack
15:21:00 <bcotton_> #agreed 1886399 - Accepted as a prioritized bug in case the pending fix is insufficient. Building Firefox is important.
15:21:18 <bcotton_> #topic Accepted bugs
15:21:20 <bcotton_> #info 0 accepted bugs
15:21:21 <bcotton_> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&f1=flagtypes.name&f2=OP&list_id=10871665&o1=substring&query_format=advanced&v1=fedora_prioritized_bug%2B
15:21:24 <bcotton_> technically no longer correct, but whatever :-)
15:21:29 <mattdm> heh
15:21:37 <bcotton_> #topic Prioritized bugs fixed from last meeting
15:21:39 <bcotton_> Just a quick review to remind ourself that this process works sometimes
15:21:40 <bcotton_> #info [Fedora Media Writer] Does not work on macOS Catalina - https://bugzilla.redhat.com/show_bug.cgi?id=1840663
15:21:42 <bcotton_> #info [Rawhide] gcc crashes at brew during Firefox build - https://bugzilla.redhat.com/show_bug.cgi?id=1862029
15:21:48 <bcotton_> yay fixed bugs!
15:21:59 <bcotton_> #topic Next meeting
15:22:00 <bcotton_> #info We will meet again on 4 November at 1500 UTC in #fedora-meeting
15:22:11 <mhroncok> bcotton_ I have a metatopic
15:22:26 <bcotton_> #topic open floor
15:22:29 <bcotton_> mhroncok: metatopic away!
15:22:40 <mhroncok> so, we have this FTBFS policy in Fedora
15:22:50 <mhroncok> #link https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
15:23:28 <mhroncok> I know there are some packages that will be affected by point 8 in couple months
15:23:40 <mhroncok> "Cca a week before the Fedora N mass branching, packages that weren’t successfully rebuilt at least in Fedora N-2 will be retired"
15:24:10 <mhroncok> #link https://github.com/hroncok/fedora-report-ftbfs-retirements/blob/master/ftbfs-retirements.ipynb
15:24:39 <mhroncok> is it applicable to mark a FTBFS bug prioritized when I know that the retirement would negatively impact Fedora?
15:25:15 <bcotton_> i'd say yes.
15:25:33 <mhroncok> as an example, https://bugzilla.redhat.com/show_bug.cgi?id=1863143
15:25:58 <bcotton_> there might not be anything that can be done about it, but at least it could help find new maintainers to fix it
15:26:32 <mhroncok> for example, when I attempted to prioritize shim FTBFS, it was rejected IIRC
15:27:03 <mhroncok> shim got a policy exception instead... to avoid retirement
15:27:26 <bcotton_> that sounds right and i think the reasoning was "it's not actually a problem, it's just a policy edge case"
15:28:02 <bcotton_> this one is more on the "it's a problem" end of the spectrum, even though xen is no longer a blocking test case, iirc
15:28:22 <bcotton_> but in general, nominating a bug is free, so i'd err on the side of nominating
15:28:30 <mhroncok> ok, let me propose it
15:29:09 <bcotton_> do you want us to come back around and consider it right now, or take care of it in 2 weeks like normal?
15:29:11 <mhroncok> and we can go right away voting or wait for the next meeting, whatever works for you. it's important, but not urgent (yet)
15:29:17 <mhroncok> :D
15:29:28 <bcotton_> okay, i'll go with the "let's wait until next time"
15:29:33 <mhroncok> ack
15:29:42 <bcotton_> that gives a chance for the maintainer to respond to the proposal, etc
15:30:24 <bcotton_> anything else for this time around?
15:30:32 <mhroncok> not from me
15:30:38 <mattdm> thanks bcotton_!
15:30:42 <mattdm> and mhroncok
15:30:45 <mhroncok> bcotton++
15:31:07 <bcotton_> Great! Thanks everyone, and I'll see you all in two weeks
15:31:10 <bcotton_> #endmeeting