fedora_iot_working_group_meeting
LOGS
14:04:57 <pwhalen> #startmeeting Fedora IoT Working Group Meeting
14:04:57 <zodbot> Meeting started Wed Oct  7 14:04:57 2020 UTC.
14:04:57 <zodbot> This meeting is logged and archived in a public location.
14:04:57 <zodbot> The chair is pwhalen. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:57 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:04:57 <zodbot> The meeting name has been set to 'fedora_iot_working_group_meeting'
14:04:57 <pwhalen> #chair pwhalen pbrobinson bcotton tdawson puiterwijk
14:04:57 <zodbot> Current chairs: bcotton pbrobinson puiterwijk pwhalen tdawson
14:04:57 <pwhalen> #topic roll call
14:05:18 <pwhalen> Sorry for the late start, who's here today?
14:05:23 <bcotton> .hello2
14:05:24 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
14:05:28 <pwhalen> howdy bcotton
14:05:40 <bcotton> helloooooo pwhalen
14:06:05 * pbrobinson o/
14:07:39 <pwhalen> ok, lets get started
14:07:42 <pwhalen> #topic 1) ==== Working Group process and admin  ====
14:07:43 <pwhalen> #link https://docs.fedoraproject.org/en-US/iot/
14:07:57 * bcotton has updates again
14:08:07 <pwhalen> All yours
14:08:28 <bcotton> #info Design has provided images for IoT page
14:08:43 <bcotton> #action bcotton to add new imates to IoT page on getfedora
14:09:12 <bcotton> #action bcotton to post on the mailing list to check if any existing iot.fp.o needs to be pulled before we change it to redirect to getfedora
14:09:18 <bcotton> (i'm 95% sure I never did that last week)
14:09:29 <pbrobinson> bcotton: I didn't do my read through either
14:09:39 <pbrobinson> although I did check it had docs and bits
14:09:46 <pwhalen> Do we plan on having that theme in anaconda? Like server looks different during installs
14:10:02 <bcotton> #info IoT WG badge is pushed, working to get granting privs assigned to bcotton, pbrobinson, pwhalen (automated awards based on group membership may be broken at the moment?)
14:10:18 <bcotton> #link https://badges.fedoraproject.org/badge/fedora-iot-wg
14:10:24 <pbrobinson> bcotton: OK, let me know when to test
14:10:57 <bcotton> pwhalen: ooh, that's a good idea. it's probably too late for F33 (but I don't know how much is involved in that, so maybe it can be done quickly and given an FE?)
14:11:20 <pwhalen> yea, I have no idea either.
14:11:58 <pwhalen> Perhaps an F34 consideration
14:12:02 <bcotton> i can create a taiga card and look at it for 34
14:12:12 <pwhalen> sounds good
14:12:19 <pbrobinson> +1
14:13:11 <bcotton> done!
14:13:20 <bcotton> anyway, that's the end of my update
14:13:30 <pwhalen> thanks bcotton
14:13:40 <pwhalen> Anything else for admin?
14:13:49 <bcotton> ooh, me!
14:13:50 <bcotton> :-)
14:13:53 <pwhalen> heh
14:14:07 <pbrobinson> LOL
14:14:12 <bcotton> Do we want to have epics in Taiga for each release?
14:14:30 <pbrobinson> not really
14:14:34 <pbrobinson> oh
14:14:35 <pbrobinson> maybe
14:14:39 <bcotton> We have some for bigger features, but it might be helpful to have one per-release for status checking
14:14:43 <pbrobinson> I thought was a question if we did
14:14:47 <bcotton> Cards can be assigned to multiple epics
14:15:08 <pbrobinson> that would assume there's an army working on this stuff
14:15:16 <pbrobinson> although there will be more in the F-34 cyle
14:15:21 <pbrobinson> cycle
14:15:25 <bcotton> I don't have strong feelings about this since I'm not doing much of the work, but I just noticed it's not there, so i figured i'd check
14:16:09 <bcotton> happy to let this sit for a bit and/or send something to the list
14:16:12 <pbrobinson> I think we should review soon
14:17:14 <pbrobinson> one other thing for this section
14:17:34 <pbrobinson> bcotton: is there anything else we should be doing to close out editions pieces
14:18:13 <bcotton> we should probably start working on a fedora magazine article
14:18:27 <bcotton> i'm happy to write a first draft for you to edit
14:19:04 <pbrobinson> yes, I figured we may end up with a few
14:19:17 <pbrobinson> but not all at once
14:20:09 <pbrobinson> I fixed ARMv7 UEFI builds this week which should give us ARMv7 too for GA which should also start to attract groups like Beagle
14:20:23 <pwhalen> w00t! Moar to test for me!
14:20:33 <bcotton> yeah. i'd like to at least have a high-level "hey, we're at the big kid table now" article ready to go for shortly after the release. and then we can do more focused stuff as we have time in the coming weeks/months/eternities
14:20:59 <pbrobinson> sounds good to me
14:21:19 <pwhalen> Ok, moving on
14:21:24 <bcotton> okay, that's it from me for now. for real this time
14:21:29 <pwhalen> #topic 2) ==== Fedora 32 status ====
14:22:10 <pwhalen> Not aware of any new issues in F32. Upgrades should be working
14:22:19 <pbrobinson> I think the new update that went out seems OK
14:23:01 <pbrobinson> I plan on provisioning a bunch of stuff once I get this U-Boot build closed out and submitted
14:23:37 <pwhalen> Sounds good. Anything else to mention? Will F32 armhfp images pop up in new composes?
14:24:03 <pbrobinson> no
14:24:19 <pbrobinson> I don't intend on enabling them there, it's fine for F-33+ IMO
14:24:57 <pwhalen> No complaints here.
14:25:05 <pwhalen> #topic 3) ==== Fedora 33 status ====
14:25:41 <pwhalen> #info OpenQA testing - https://openqa.fedoraproject.org/tests/overview?distri=fedora&version=33&build=Fedora-IoT-33-20201006.0&groupid=1
14:26:38 <pbrobinson> I feel we're reasonable here, I need to do a bunch more testing basically
14:27:32 <pwhalen> We also had a test day - https://testdays.fedorainfracloud.org/events/95
14:27:38 <pwhalen> No new issues reported.
14:27:53 <pbrobinson> do we know how many participated?
14:29:11 <pwhalen> Looks like about 9 people
14:29:34 <pwhalen> however, tdawson did the work of many. Lots of testing!
14:29:45 <pwhalen> Thanks again tdawson
14:29:52 <pbrobinson> tdawson++
14:30:27 <pbrobinson> tdawson: BTW I think we might be able to use the eMMC on the Rock960 properly
14:30:50 <pwhalen> We also have the aarch64 openqa back online, so results will be available there too.
14:31:13 <pwhalen> tdawson: cool
14:31:51 <pwhalen> The merge of release criteria is mostly complete, I saw some mail this morning but not reviewed.
14:32:04 <pwhalen> Thanks coremodule!
14:32:30 <pwhalen> Anything else for F33? Concerns?
14:33:10 <pbrobinson> nothing/none from me ATM
14:34:17 <pwhalen> #topic 4) ==== Fedora Rawhide status ====
14:34:42 <pwhalen> OpenQA looks good - https://openqa.fedoraproject.org/tests/overview?distri=fedora&version=34&build=Fedora-IoT-34-20201005.0&groupid=1
14:34:50 <pwhalen> Not really done any testing there
14:35:28 <pwhalen> Any plans for f34? Changes to consider?
14:37:22 <pbrobinson> yes, a few
14:37:28 <pbrobinson> IMA policy
14:38:15 <pbrobinson> should hopefully be able to have working container build pipeline so various apps to run in containers on aarch64/x86
14:38:31 <pbrobinson> maybe a toolbox container
14:38:46 <pwhalen> that would be great, right now not available on aarch64
14:38:57 <pbrobinson> no, it's in CPEs pipeline though
14:39:07 <pwhalen> cool
14:39:45 <pwhalen> Anything else for rawhide?
14:40:08 <pwhalen> #topic 5) ==== Open Floor ====
14:41:06 <pwhalen> That's all I had for today. I'll leave it open for a couple of minutes
14:41:13 <pbrobinson> nothing more from me
14:42:30 <pwhalen> #endmeeting