i18n
LOGS
05:30:06 <vishal_vvr> #startmeeting i18n
05:30:07 <zodbot> Meeting started Tue Oct  6 05:30:06 2020 UTC.
05:30:07 <zodbot> This meeting is logged and archived in a public location.
05:30:07 <zodbot> The chair is vishal_vvr. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:30:07 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
05:30:07 <zodbot> The meeting name has been set to 'i18n'
05:30:15 <vishal_vvr> #meetingname i18n
05:30:15 <zodbot> The meeting name has been set to 'i18n'
05:30:21 <vishal_vvr> #topic agenda and roll call
05:30:27 <vishal_vvr> #link https://fedoraproject.org/wiki/I18N/Meetings/2020-10-06
05:31:36 <petersen> hello
05:31:40 <priyamgupta_> Hi
05:32:33 <vishal_vvr> #chair petersen priyamgupta_
05:32:33 <zodbot> Current chairs: petersen priyamgupta_ vishal_vvr
05:33:27 <vishal_vvr> we will wait for few minutes, while others join
05:33:37 <tagoh> hi
05:34:07 <vishal_vvr> #chair tagoh
05:34:07 <zodbot> Current chairs: petersen priyamgupta_ tagoh vishal_vvr
05:37:16 <vishal_vvr> Let's start with today's agenda
05:37:24 <pravins> hi all :)
05:37:32 <vishal_vvr> #chair pravins
05:37:32 <zodbot> Current chairs: petersen pravins priyamgupta_ tagoh vishal_vvr
05:37:51 <vishal_vvr> #topic Upcoming schedule
05:38:50 <vishal_vvr> does anyone has any Upcoming schedule announcements
05:39:22 <petersen> Final freeze for F33 starts today
05:39:41 <petersen> Current Final Target date 	Tue 2020-10-20
05:40:21 <petersen> also https://fedorapeople.org/groups/schedule/f-34/f-34-key-tasks.html :)
05:41:26 <vishal_vvr> Thank you petersen
05:41:50 <petersen> https://qa.fedoraproject.org/blockerbugs/milestone/33/final/buglist
05:42:17 <pravins> Not very far, looking forward for F33 GA :)
05:42:56 <vishal_vvr> anything to discuss here?
05:42:58 <petersen> .bug 1816547
05:43:02 <zodbot> petersen: 1816547 – Firefox not using langpacks for localization - https://bugzilla.redhat.com/1816547
05:43:28 <petersen> .bug  	1884467
05:43:32 <zodbot> petersen: 1884467 – gnome-tour shortcut keys not working - https://bugzilla.redhat.com/1884467
05:43:48 <petersen> Seems the firefox langpacks issue still there?
05:44:20 <petersen> I heard the team has been busy with version updates
05:45:12 <petersen> Actually it might be fixed??
05:45:14 <suanand> (hi, sorry)
05:45:22 <petersen> I just saw the latest comment in the bug
05:45:26 <vishal_vvr> #chair suanand
05:45:26 <zodbot> Current chairs: petersen pravins priyamgupta_ suanand tagoh vishal_vvr
05:45:38 <petersen> priyamgupta_: can you retest f33 firefox?
05:46:05 <priyamgupta_> okay,sure
05:46:13 <petersen> thanks
05:47:36 <petersen> Not sure what is wrong with gnome-tour... something particular about Alt-N it seems
05:48:02 <petersen> (I reported that one last week)
05:49:14 <vishal_vvr> if nothing more to discuss here let's move on the next topic
05:49:34 <vishal_vvr> #topic Outstanding issue
05:49:42 <vishal_vvr> #info #120 Fedora 31 Bug triaging
05:49:47 <vishal_vvr> #info https://pagure.io/i18n/issue/120
05:50:50 <vishal_vvr> #link https://pagure.io/i18n/issue/120
05:51:03 <vishal_vvr> priyamgupta_, any update on this ticket
05:51:26 <priyamgupta_> As of today 14 bugs present.I will continue with my bug triage activity.
05:52:36 <vishal_vvr> Thanks, good work keep working on it :)
05:52:45 <pravins> priyamgupta_: any bug to discuss in this meeting?
05:53:37 <priyamgupta_> No as of now.
05:54:02 <pravins> .bug 1753295
05:54:04 <zodbot> pravins: 1753295 – Pango has dropped support for non-Opentype bitmap fonts - https://bugzilla.redhat.com/1753295
05:54:39 <pravins> with 115 comments :)
05:54:59 <pravins> Recent comment from -  Jan Pazdziora 2020-09-23
05:55:23 <tagoh> We need an update on fonttosfnt
05:56:21 <pravins> .whoowns fonttosfnt
05:56:22 <zodbot> pravins: Package fonttosfnt not found.
05:56:51 <pravins> .whoowns xorg-x11-font-utils
05:56:52 <zodbot> pravins: owner: xgl-maint; commit: airlied, ajax, alexl, caillon, caolanm, glisse, johnp, mbarnes, rhughes, rstrode, slaanesh, ssp, whot
05:57:03 <tagoh> pravins, that is xorg-x11-font-utils where it is assigning...
05:57:14 <pravins> looks desktop team.
05:57:55 <petersen> Good that the bug finally got assigned to a correct component ;-(
05:58:00 <petersen> Oh dear
05:58:08 <pravins> i think safe to move for next release, i hope they will fix it.
05:58:37 <pravins> i mean, change Version :)
05:59:00 <pravins> petersen: yeah, agree
05:59:28 <pravins> i dont know whether this kind of bugs gets discussed in WG meeting.
05:59:41 <pravins> but if someone attending, good to bring into notification.
06:01:06 <pravins> Thanks petersen tagoh for the inputs
06:01:16 <petersen> I changed to 32
06:01:25 <pravins> petersen++
06:01:25 <zodbot> pravins: Karma for petersen changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
06:01:37 <petersen> Should we assign it to epico maybe
06:02:03 <petersen> tagoh: If all that is needed is a backport?
06:02:05 <pravins> i was thinking same, since its assigned to group. It might get missed.
06:02:27 <petersen> whot is kind if the de facto maintainer, but yeah
06:03:48 <tagoh> petersen, yes, backport would be great. and then we may need to rebuild bitmap fonts with it.
06:04:21 <petersen> Let's talk to epico when he is on that - I wish we had already done it...
06:04:32 <petersen> s/on that/back/
06:04:43 <petersen> tagoh: unless you want to :)
06:05:03 <petersen> pinging whot would be a good first step probably
06:05:30 <petersen> I guess it is needed for all fedora releases?
06:06:07 <pravins> true, but we can ignore EOL F31.
06:06:43 <pravins> it this is getting fixed before F31 EOL, then its definitely good.
06:06:54 <tagoh> petersen, hmm, getting confused. right, epico updated bitmap-fonts.spec to use fonttosfnt but we need a fix in fonttosfnt right.
06:07:33 <petersen> Yeah I think so, it might not be merged yet?  So it is only in his copr perhaps
06:07:57 <tagoh> petersen, it is. see https://src.fedoraproject.org/rpms/bitmap-fonts/c/2c4fec66edc8179d5784014d49a137a6bd8015f3?branch=master
06:08:34 <petersen> I mean the latest fonttosfnt changes
06:09:02 <tagoh> Right
06:09:26 <tagoh> -35 isn't yet even built in rawhide but in ELN.
06:09:35 <petersen> Oh
06:10:30 <tagoh> We need to bump up a release to avoid a conflict between rawhide and eln.
06:10:51 <petersen> Well there just hasn't been a f34 build yet, right?
06:11:16 <tagoh> right
06:11:20 <petersen> Anyway  this is a good kind of thing to track also in pagure or under Fonts component
06:12:37 <petersen> We better move on, sorry
06:12:42 <pravins> +1 to track. !!
06:12:58 <pravins> yeah, but happy with this detailed discussion.
06:13:29 <vishal_vvr> okay, if nothing more to discuss here let's move on the next topic
06:13:33 <petersen> Yes, good to discuss some bugs after a while
06:13:44 <vishal_vvr> +1 petersen
06:13:52 <petersen> pravins: thanks a lot for raising that one
06:14:06 <vishal_vvr> #topic issues
06:14:14 <vishal_vvr> #info #124 need for a generic fonts component in Fedora bugzilla
06:14:18 <pravins> petersen: welcome :)
06:14:21 <vishal_vvr> #link https://pagure.io/i18n/issue/124
06:15:17 <vishal_vvr> this ticket is created by petersen, anything to discuss on this ?
06:15:57 <petersen> Yes
06:16:39 <petersen> So panemade raised https://pagure.io/fedora-infrastructure/issue/9368
06:16:58 <petersen> paragan I mean
06:17:16 <petersen> So I think we need some discussion it now... since the ball is already rolling
06:17:44 <petersen> My naive suggestion is maybe just to assign Fonts to i18n-bugs
06:17:55 <petersen> tagoh: did you see?
06:18:02 <petersen> Any thoughts
06:18:41 <tagoh> Yes, i18n-bugs would be good as PoC.
06:19:30 <pravins> Just for understanding - This component will be use only for common bugs across fonts, right?
06:20:01 <petersen> pravins: that's right
06:20:37 <pravins> i think, then this is safe. I dont see, there will be huge bugs will be reported against it. Except packaging or one like non-bitmap-fonts support etc
06:20:41 <petersen> (the other alternative would be the fonts-sig..... but that really needs to be revamped first
06:20:43 <petersen> )
06:20:57 <tagoh> it might be also used for requesting new packaging for a font. but the main purpose may be a generic entry point for bugs which reporters isn't sure where to assign.
06:21:25 <petersen> pravins: well it is quite common actually - new fonts rfe's etc  rendering issues which have not been triaged yet etc
06:21:37 <petersen> tagoh: exactly
06:22:30 <petersen> at the moment those kind of bugs end up in "random" components like that one above
06:22:48 <pravins> i18n-bugs looks good in that case and also triaging them once in this meeting is also important
06:23:01 <petersen> bcotton asked about examples so we should paste some into our ticket
06:23:11 <pravins> like triage after 3 meetings
06:23:26 <petersen> Right we should/have to triage them
06:23:33 <tagoh> nod
06:23:35 <petersen> some rfe take time though
06:23:55 <petersen> We can use FutureFeature etc
06:24:31 <tagoh> could also be asked for some volunteers on the list perhaps.
06:26:25 <petersen> Yeah
06:26:38 <petersen> We could have fonts-sig in auto CC
06:26:43 <tagoh> One concern on this idea is that it can be similar to i18n we already have.
06:27:01 <petersen> ah we have i18n component?
06:27:17 <tagoh> yep
06:27:47 <petersen> Well i18n is more contained within our team, whereas fonts has many people involved
06:28:06 <petersen> Do we have any i18n bugs?
06:28:45 <petersen> hmm 17 Closed
06:28:59 <petersen> Well I admit I had forgotten about the i18n component
06:29:06 <tagoh> Right. well, we just need to advertise it to get more opportunities
06:29:13 <petersen> Yes
06:29:26 <petersen> moving NEW bugs there is one way anyway
06:30:05 <petersen> Can you help to come up with some example bugs?
06:30:12 <petersen> list
06:30:23 <tagoh> Sure. let me figure out
06:30:28 <petersen> Thank you
06:32:03 <vishal_vvr> okay lets move onto the next point in this topic
06:32:11 <vishal_vvr> #info #122: Docs Beats for Fedora 33
06:32:16 <vishal_vvr> #link https://pagure.io/i18n/issue/122
06:32:41 <vishal_vvr> This is a tracker ticket to add i18n changes information in docs beats for Fedora 33 release.
06:33:34 <vishal_vvr> one link for ibus is already added into it https://pagure.io/fedora-docs/release-notes/issue/532
06:34:09 <petersen> I pinged fujiwara to remind him on this
06:34:38 <petersen> Not sure if there are any other relnotes needed?
06:34:54 <petersen> If not I think we can move on
06:35:52 <vishal_vvr> okay
06:35:54 <vishal_vvr> #info 119: Tracker for Fedora 33 Changes
06:36:00 <vishal_vvr> #link https://pagure.io/i18n/issue/119
06:36:45 <petersen> I think we are good here too
06:37:04 <vishal_vvr> okay, lets move onto the next point in this topic
06:37:08 <petersen> 1.5.23 landed in Fedora last week
06:38:15 <vishal_vvr> #info #114: rotate chairperson?
06:38:20 <vishal_vvr> #link https://pagure.io/i18n/issue/114
06:38:57 <petersen> vishal_vvr, you did a great job moderating the discussions today
06:39:02 <vishal_vvr> This ticket is open from long time, any update or suggestion on this ticket
06:39:20 <vishal_vvr> thank petersen
06:39:35 <petersen> What do people want?
06:39:38 <vishal_vvr> s/thank/Thank you
06:40:47 <petersen> if vishal_vvr and/or priyamgupta_ want to continue running the meeting that would be fine I think personally
06:41:06 <vishal_vvr> There was one more suggestion to move this meeting to video conference
06:41:34 <petersen> (personally I am not a fan for frequently changing the chair but certainly good to change after a long while)
06:42:05 <petersen> Right that could also be interesting - recently we have so few irc/chat meetings
06:44:28 <vishal_vvr> petersen, third option by merging two suggestions in ticket
06:44:33 <vishal_vvr> rotate every meeting on volunteer basis through all regular attendees :P
06:44:36 <priyamgupta_> vishal vvr : +1
06:45:01 <petersen> I would rather do that on release basis say
06:45:16 <petersen> So we would have one chair for F34 say, etc
06:45:19 <priyamgupta_> petersen : I can chair the meeting :)
06:45:50 <vishal_vvr> release basis +1 petersen
06:45:56 <priyamgupta_> vishal vvr :that +1 for video conference.
06:46:36 <priyamgupta_> petersen : yeah. Release basis +1
06:47:30 <vishal_vvr> video conference i feel it is better but we need to rely on some opensource platform like jitsi meet
06:47:47 <vishal_vvr> so other community members could also join
06:47:55 <petersen> How about vishal_vvr chairs for f34 and then priyamgupta_ can take over for f35 if you wish ?
06:48:22 <vishal_vvr> petersen, yes i am good on that
06:48:40 <vishal_vvr> priyamgupta_, or you wish to continue for f34 ?
06:48:43 <petersen> What do other feel about video meeting?
06:50:11 <priyamgupta_> Petersen : I am okay with any option,can chair for f34 or f35.
06:50:13 <petersen> I actually feel irc meeting is somewhat refreshing because I attend so many video calls... or maybe we could alternate or do a monthly video call or vice versa
06:51:00 <vishal_vvr> petersen, +1 monthly video call
06:51:22 <petersen> Maybe we should take a vote if we want to change from irc to video, or discuss more next time?
06:51:29 <petersen> Okay
06:51:49 <petersen> Less people today too
06:52:24 <petersen> priyamgupta_: certainly good for you to try some time - good learning experience
06:53:52 <priyamgupta_> petersen : Yeah. Sure i will chair :)
06:54:54 <vishal_vvr> petersen, me and priyamgupta_ will continue chairing meetings according once availability
06:55:01 <petersen> okay
06:55:13 <petersen> good
06:55:59 <priyamgupta_> vishal vvr : i will chair next meeting :)
06:56:38 <vishal_vvr> okay thank you priyamgupta_
06:58:09 <vishal_vvr> #agreed priyamgupta_ will chair the next meeting
06:58:44 <vishal_vvr> okay moving onto next topic
06:58:53 <vishal_vvr> #topic Open Floor
06:58:57 <petersen> I put a summary in the ticket - feel free to add anything I missed
06:59:38 <vishal_vvr> anything to discuss here?
07:01:07 <vishal_vvr> okay it seem there isn't much to discuss here, we already had good discuss in previous topics
07:01:34 <vishal_vvr> if nothing more then let's close the meeting
07:02:12 <vishal_vvr> Thank you everyone for joining
07:02:24 <vishal_vvr> #endmeeting