fedora-qa
LOGS
15:00:15 <adamw> #startmeeting Fedora QA Meeting
15:00:15 <zodbot> Meeting started Mon Oct  5 15:00:15 2020 UTC.
15:00:15 <zodbot> This meeting is logged and archived in a public location.
15:00:15 <zodbot> The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:15 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:00:25 <adamw> #meetingname fedora-qa
15:00:25 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:30 <adamw> #topic Roll call
15:00:34 <adamw> morning morning
15:00:38 <adamw> how's everyone doing?
15:00:42 <frantisekz> .hello2
15:00:43 <zodbot> frantisekz: frantisekz 'František Zatloukal' <fzatlouk@redhat.com>
15:01:41 <coremodule> .hello2
15:01:42 <zodbot> coremodule: coremodule 'Geoffrey Marr' <gmarr@redhat.com>
15:01:58 <coremodule> good morning adamw! doing well here, how are you?
15:02:29 <bcotton> .hello2
15:02:30 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
15:02:42 <adamw> doing good, thanks
15:02:49 <bcotton> Good to see you, adamw
15:02:54 * kparal is here
15:03:16 * sumantro is here
15:03:58 * pwhalen is here
15:04:23 <adamw> well that's a lot of people
15:04:30 <adamw> now i feel like this meeting isn't going to be exciting enough
15:04:39 <pwhalen> welcome back adamw!
15:04:44 <adamw> maybe someone can run out and buy some fireworks...
15:04:47 <adamw> thanks pwhalen
15:05:34 <adamw> #topic Previous meeting follow-up
15:05:55 <adamw> "coremodule and pwhalen to work on reconciling IoT and main release criteria"
15:06:03 <adamw> i believe that's ongoing, and we have a topic for it coming up...
15:06:11 <adamw> right?
15:06:16 <coremodule> we can talk about it now or later...
15:06:25 <coremodule> but yes, we have criteria
15:06:58 <adamw> roger
15:07:10 <adamw> #info "coremodule and pwhalen to work on reconciling IoT and main release criteria" - this is ongoing, and there's a topic for it later where we'll get more detail
15:07:50 <adamw> #info "adamw to ask mcatanzaro to put the first boot experience criterion proposal into production" - this got done, by kparal in the end: https://fedoraproject.org/w/index.php?title=Fedora_33_Final_Release_Criteria&diff=588238&oldid=579377
15:08:02 <adamw> that's all the action items, any other followup from last time?
15:08:31 <kparal> nothing here
15:09:13 <adamw> alllrighty
15:09:30 <adamw> #topic Fedora 33 status
15:09:43 <adamw> soooo, i believe some kind of a Beta got released while i was off
15:09:46 <adamw> i'm sure it's terrible
15:09:51 <coremodule> duh
15:10:02 <coremodule> it is
15:10:05 <coremodule> awful, relaly
15:10:11 <frantisekz> :D
15:10:16 <coremodule> you'd be so disappointed
15:11:28 <adamw> =)
15:12:09 <adamw> it looks like things are mostly OK, openQA tests are passing
15:12:18 <adamw> we still have that awkward KDE blocker but at least there's an idea of what to do there
15:12:18 <bcotton> i made sure we put in extra bugs, just for you
15:12:28 <adamw> gee, thanks
15:12:38 <jsmith> adamw: <tease>You're going to have to try harder to stop a beta next time</tease>
15:12:56 <pwhalen> adamw: speaking of openqa, do we have an eta for aarch64 and power being readded?
15:12:58 <jsmith> adamw: That being said, we're all thrilled that you're back :-)
15:13:24 <adamw> pwhalen: i don't have an eta exactly, i've talked about it with smooge and nirik a couple times but can't quite remember where we're at
15:13:35 <adamw> pwhalen: we could talk about it again in #fedora-admin
15:13:49 * pwhalen joins there
15:14:27 <pwhalen> it would be great to have it for final, its a lot of testing
15:14:34 <adamw> anyone have any other notes on f33 stuff? awkward issues or anything?
15:16:12 <adamw> #info Fedora 33 is moving along well at present, we got the Beta release done and current nightlies seem to be working well
15:17:16 <adamw> Final freeze is scheduled in about 23 hours, at least according to https://fedorapeople.org/groups/schedule/f-33/f-33-all-tasks.html - is that right, bcotton?
15:18:34 <Southern_Gentlem> adamw, what bcotton said last week
15:18:50 <kalev> adamw: hey, welcome back! :)
15:18:56 <adamw> hi kalev, thanks
15:19:04 <kalev> adamw: I made some noise about the schedule last week and it turns out to be correct, see https://pagure.io/fesco/issue/2477
15:19:33 <adamw> indeed
15:19:33 <Southern_Gentlem> also statedin the go/nogo
15:19:45 <adamw> #info Final freeze is scheduled in about 23 hours
15:20:13 <adamw> #topic IoT release criteria status
15:20:24 <adamw> so, where are we with this? i believe there's a draft up for review?
15:20:28 <coremodule> https://pagure.io/fedora-qa/issue/622
15:20:51 <adamw> for anyone not familiar - this is about merging the IoT release criteria, which are currently in the IoT docs space, into the main release criteria on the wiki
15:21:38 <coremodule> you can find the drafts on this ticket, i have made *almost* all of the changes kparal suggested (no time to update the ticket, that will happen later today). the suggestion of kparal's that i didnt change was moving the rpm-ostree criterion into the beta criteria list from basic.
15:22:18 <coremodule> pwhalen and I talked while I was drafting this up and he said that the IoT team's intention was that rpm-ostree related stuff must work in basic
15:22:59 <kparal> coremodule: I suggested moving two of them, so you're talking about both?
15:23:38 <adamw> #info this is being actively worked on in https://pagure.io/fedora-qa/issue/622 , coremodule has posted a draft and is revising it in response to feedback
15:24:00 <adamw> so it'd be great if anyone else interested can check the ticket and review the draft too
15:24:24 <coremodule> kparal, both you suggested look to be contained under the same rpm-ostree criterion
15:24:52 <kparal> adamw: could you help me understand the exact different between Basic and Beta milestone, these days?
15:25:11 <coremodule> adamw, if people would like to review and post their feedback, I'd like to have this published sometime this week (really in schedule with the freeze)
15:25:12 <kparal> is the idea that everything Basic automatically fails CI tests?
15:25:45 <adamw> kparal: that was sort of it, yeah
15:25:59 <kparal> but is that implemented somewhere?
15:26:04 <adamw> basic is meant to be stuff that works all the time, and the idea was that we would gate composes on things in Basic
15:26:05 <kparal> or just the glorious future plan?
15:26:38 <adamw> it's more or less implemented from our side - there's a greenwave profile for 'should we ship this rawhide compose' and i even wired it into check-compose
15:26:53 <adamw> that's how the compose check reports say "this compose would have failed" or "would have passed" rawhide gating
15:27:16 <kparal> coremodule: just to reply back, I suggested moving 2 sentences out of 4, not the whole criterion. I'm not sure if that was clear
15:27:17 <adamw> but releng hasn't ever gone ahead and actually made compose sync dependent on the result of that check
15:27:30 <adamw> so for practical purposes right now, basic and beta do the same thing
15:27:39 <kparal> ok, so for now the difference is almost zero
15:27:45 <adamw> yeah
15:28:42 <kparal> ok, then I guess ¯\_(ツ)_/¯ to this particular point, coremodule
15:28:46 <adamw> =)
15:29:32 <coremodule> adamw, a mail went out to the list regarding the feedback on this
15:29:33 <coremodule> https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/thread/KLG45B434REWXT6NXN5BSWGFOQIGGPNM/
15:29:46 <coremodule> and only kparal responded, so it is my intention to have this published this week
15:30:16 <adamw> sounds good to me
15:30:42 <adamw> #action coremodule to finalize the IoT criteria merge, taking into account any further feedback, and put it into 'production'
15:33:29 <coremodule> ack
15:35:05 <adamw> alrighty
15:35:06 <adamw> moving along
15:35:23 <adamw> #topic Test Day / community event status
15:35:38 <sumantro> Last week we had the IoT Test Day which was successful https://testdays.fedorainfracloud.org/events/95
15:36:12 <sumantro> *TODAY* we are hosting a cloud test day  http://fedoraproject.org/wiki/Test_Day:2020-10-05_Fedora_33_Cloud_Testday
15:36:31 <adamw> everyone get cloudy!
15:36:38 <adamw> did upgrade test day happen yet? i'm losing track
15:36:49 <sumantro> adamw yes it did
15:36:55 <adamw> ah, okay.
15:37:15 <adamw> i was gonna ask if we could check some things relating to systemd-resolved on upgrade, but i guess i can do that myself :P
15:37:15 <sumantro> Upgrade test day was successful too; https://testdays.fedorainfracloud.org/events/94
15:38:55 <sumantro> adamw, I could check if something specific around systemd-resolved is needed
15:39:02 <pwhalen> No new bugs for IoT. Thanks for all your help, sumantro!
15:39:05 <pwhalen> sumantro++
15:39:05 <zodbot> pwhalen: Karma for sumantro changed to 9 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:39:15 <sumantro> pwhalen, thanks for all the help!
15:39:47 <lig> sumantro: regarding cloud test, AFAIR there were plans to extend GCP images availability. Is it worth it to check GCP regions for the Cloud Image availability?
15:40:19 <sumantro> dustymabe, ^^
15:40:51 <coremodule> I think (don't quote me), that only CoreOS images are available on GCP
15:41:19 <sumantro> lig, dustymabe can have some idea around that, in the past FCOS images are on GCP last I can recall..
15:42:27 <sumantro> Anyway, A FCOS test week, a virtualization test day and a storage test day are on the cards
15:43:29 <adamw> awesome
15:43:38 <lig> sumantro: My point is that I can check on GCP and I can even try to run an app on Fedora Cloud image on GCP. But it only make sense if GCP is officially supported.
15:43:41 <adamw> #info IoT test day went off well last week
15:43:54 <adamw> #info Today is Cloud Test Day, so join in over at #fedora-test-day if you can
15:44:06 <adamw> #info FCOS test week, virt test day and storage test day are coming
15:44:06 <sumantro> adamw, in F34 we have a Changeset and I was wondering if it will be a nice idea to run a KDE test day as well?
15:44:07 <sumantro> https://fedoraproject.org/wiki/Changes/WaylandByDefaultForPlasma
15:44:19 <adamw> sumantro: definitely a test day for that would be a great idea
15:44:31 <adamw> you could coordinate with rdieter
15:47:08 <adamw> looks like we're done
15:47:13 <adamw> #topic Open floor
15:47:15 <adamw> any other business, folks?
15:47:54 <adamw> remember, blocker review coming up in 13 mins in #fedora-blocker-review
15:48:22 <bcotton> hashtag blocktober
15:48:44 <lig> Well, I would like to raise a question about Parental Controls;)
15:49:44 <lig> It's kinda the thing I'm interested in and would like to test. AFAIU it is not on an official Change Set as a stand-alone feature right?
15:50:40 <adamw> sorry, not sure what this is - do you have a link?
15:51:09 <lig> there is this one https://pagure.io/fedora-workstation/issue/186
15:52:03 <lig> Basically, Gnome depends on malcontent lib and it was packaged for f34 only
15:52:10 <lig> but I see now https://bodhi.fedoraproject.org/updates/FEDORA-2020-7dc46fca0b
15:52:24 <lig> Looks like it has gotten f33 build
15:52:59 <lig> So, the question is, should this one take place in some test plan?
15:53:18 <adamw> aha, thanks
15:53:36 <adamw> well, as it's being added to gnome-initial-setup it seems, that would fall under the 'first boot experience' criterion we recently added
15:53:46 <lig> I don't see the functionality available in F33 Beta, freshly installed
15:53:54 <adamw> so testing that the settings in g-i-s works would definitely be a thing to do
15:54:14 <adamw> the update is still in testing, so that adds up
15:54:32 <adamw> as well as the update going stable, it would need to be added to the default package set somehow to show up by default, i guess
15:54:41 <adamw> if they do that, nightly builds should start showing it
15:54:57 <lig> do you have a link to the criterion? sorry, I'm kinda new and still learning my way around
15:55:24 <adamw> oh, reading through the ticket, it seems they decided to package it up and make it available, but not include it by default yet
15:55:38 <adamw> "decision was to see if we can make parental controls available to install, without showing them by default"
15:56:06 <adamw> so that makes it less important, but testing of it would still be welcome of course - best place for feedback would be in the update on bodhi, or bugzilla if you find a bug after it's stable
15:57:55 <lig> adamw: thanks a lot for the guidance. Will try to provide feedback on bodhi update then
15:58:34 <adamw> thanks for bringing it up :)
15:58:49 <adamw> any other issues, folks?
16:00:13 <adamw> ok, thanks for coming everyone!
16:00:14 <adamw> #endmeeting