fedora_prioritized_bugs_and_issues
LOGS
15:00:59 <bcotton> #startmeeting Prioritized bugs and issues
15:00:59 <zodbot> Meeting started Wed Sep  9 15:00:59 2020 UTC.
15:00:59 <zodbot> This meeting is logged and archived in a public location.
15:00:59 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:59 <zodbot> The meeting name has been set to 'prioritized_bugs_and_issues'
15:01:00 <bcotton> #meetingname Fedora Prioritized bugs and issues
15:01:00 <zodbot> The meeting name has been set to 'fedora_prioritized_bugs_and_issues'
15:01:11 <bcotton> #topic Purpose of this meeting
15:01:12 <mattdm> look i'm here
15:01:13 <bcotton> #info The purpose of this process is to help with processing backlog of bugs and issues found during the development, verification and use of Fedora distribution.
15:01:14 <bcotton> #info The main goal is to raise visibility of bugs and issues to help  contributors focus on the most important issues.
15:01:16 <bcotton> #link https://docs.fedoraproject.org/en-US/program_management/prioritized_bugs/#_process_description
15:01:21 <bcotton> #topic Roll Call
15:01:26 <bcotton> mattdm++
15:01:27 <mattdm> good morning
15:01:42 <bcotton> good morning to you, too
15:03:17 <bcotton> looks like it's just the two of us
15:03:28 <bcotton> #topic Nominated bugs
15:03:29 <mhroncok> bcotton: you wish :)
15:03:29 <bcotton> #info 1 nominated bugs
15:03:30 <bcotton> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&f1=flagtypes.name&f2=OP&list_id=10871664&o1=substring&query_format=advanced&v1=fedora_prioritized_bug%3F
15:03:35 <bcotton> mhroncok: sneaky!
15:03:44 <bcotton> #topic gcc crashes during PGO Firefox build
15:03:45 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1849165
15:04:19 <bcotton> <TV voiceover voice>last time on "Prioritized Bugs Meeting", we decided to wait until this meeting because the reproducibility is unclear
15:05:06 <bcotton> since then, there have been no updates
15:05:10 <mhroncok> needinfo the reporter?
15:05:27 * mattdm reads
15:05:34 <bcotton> yeah, i think that's the approach. if it's still unclear in 2 weeks, we shrug and reject
15:06:51 <mattdm> yeah.
15:07:05 <bcotton> #action bcotton to needinfo the reporter
15:07:41 <bcotton> #topic Accepted bugs
15:07:43 <bcotton> #info 2 accepted bugs
15:07:44 <bcotton> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&f1=flagtypes.name&f2=OP&list_id=10871665&o1=substring&query_format=advanced&v1=fedora_prioritized_bug%2B
15:07:55 <bcotton> #topic [Fedora Media Writer] Does not work on macOS Catalina
15:07:56 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1840663
15:07:58 <bcotton> #link https://pagure.io/releng/issue/9577
15:08:10 <bcotton> so progress is being made on signing
15:08:24 <bcotton> not as fast as we'd like, but it's not clear that anything can be done to speed it up
15:10:33 <mattdm> so.. check back in two weeks?
15:10:38 <mattdm> is there anything we can do?
15:11:02 <bcotton> other than me testing the signed installer that kevin produced yesterday
15:11:07 <bcotton> , no
15:11:55 <mhroncok> I can test this as well in virtualbox
15:12:33 <bcotton> okay, so let's test and hope that by the next meeting this one is moved to the "successes" topic
15:12:50 <bcotton> #topic [Rawhide] gcc crashes at brew during Firefox build
15:12:51 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1862029
15:13:26 <bcotton> #info A fix for this bug was submitted, but it introduced a new error
15:13:42 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1862029#c11
15:14:14 <mattdm> from what i see in koji, there have not been successful builds since
15:14:24 <mattdm> soooo that's pretty bad.
15:14:40 <bcotton> who needs a web browser when you have curl?
15:15:51 <bcotton> the new issue was just reported on friday, but this is kind of a big deal
15:16:23 <mattdm> hmmm. newer builds are failing because of missing build deps so might be unrelated?
15:17:07 <mattdm> specifically something around openh264-devel
15:17:09 <mhroncok> No matching package to install: 'openh264-devel'
15:17:17 <mhroncok> * Mon Sep 07 2020 Martin Stransky <stransky@redhat.com> - 80.0.1-3
15:17:17 <mhroncok> - Build with Openh264 support (mozbz#1057646)
15:17:33 <mattdm> yeah :-/
15:17:50 <mattdm> so I think the next step is to check with martin for an update?
15:17:56 <mhroncok> agreed
15:18:12 <bcotton> agreed
15:18:18 <mhroncok> make it so!
15:18:53 <bcotton> #info latest build failures are due to openh264-devel dependency missing
15:18:54 <bcotton> #action bcotton to check with Martin for an update
15:18:59 <mattdm> bcotton++
15:19:16 <bcotton> #topic Next meeting
15:19:17 <bcotton> #info We will meet again on 23 September at 1500 UTC in #fedora-meeting
15:19:23 <bcotton> that's the end of the list. anything else?
15:19:48 * mhroncok wonders...
15:20:02 <mhroncok> are others nominating prioritized bugs?
15:20:34 <bcotton> it's been a while
15:20:35 <mhroncok> for example, I find it rather sad that firefox maintainers would rather approach fesco to switch o clang than to escallate the gcc bugzillas
15:20:44 <bcotton> it might be good to remind folks that this process exists again
15:21:36 <bcotton> apart from cc'ing devel with the agenda the day before the meeting (which i've been meaning to do anyway), any suggestions for how to keep this in the back of people's minds
15:21:36 <mhroncok> bcotton: devel  + devel-announce?
15:21:50 <mhroncok> bcotton: I mean do a one time reminder that this exists now
15:22:03 <mhroncok> no idea how to make it more permanently known
15:22:48 <bcotton> yeah, i've been thinking about a "here's a reminder of all the things i think you should know about" email
15:22:56 <mattdm> heh. toooo muchhhh
15:23:12 <mattdm> no more than three things i should know in one mail :)
15:23:50 <mhroncok> bcotton: maybe send somehting like the blocker bugs status?
15:23:56 <mhroncok> but with prioritized?
15:24:06 <bcotton> good, because i just came up with 3 :-)
15:24:09 <bcotton> ooh, that's a good idea
15:24:47 <mattdm> or... what about adding it to the blocker bugs app?
15:24:52 <mattdm> Did we discuss this before?
15:25:11 <bcotton> maybe do it the week between meetings. doing it weekly might be too spammy
15:25:16 <mhroncok> sounds reasonable, that could drive some attention to it
15:25:28 <mattdm> +1 to mail the week between meetings
15:25:32 <mhroncok> (adding it to https://qa.fedoraproject.org/blockerbugs )
15:25:56 <bcotton> mattdm: we did. or at least copying the code and running it separately
15:26:16 <mattdm> bcotton: huh, i've forgotten that. why don't we use it in this meeting? :)
15:26:34 <bcotton> there's some process change that would have to happen for it to work, but that's doable
15:26:37 <mattdm> also, QA has shiny new code.
15:27:00 <bcotton> i'd have to talk to adam et al about how they'd feel about it, but in theory it should be pretty easy to add
15:27:39 <bcotton> #action bcotton to talk to QA about adding prioritized bugs to the blockerbugs app
15:27:40 <mhroncok> the BZ process might need to be adapted to use blockers and whiteboard to make it work in the same way
15:28:15 <mattdm> I think it _probably_ works best if this is a milestone, but the other alternative would be for it to be a status next to blocker and fe
15:28:43 <bcotton> maybe. i'd rather write the code to make it use the flag
15:28:58 <bcotton> yeah, i was thinking a milestone that doesn't change. since prioritized bugs are not release specific
15:29:18 <mattdm> and then we'd have blockers and FEs for that milestone?
15:29:33 <bcotton> ?
15:29:46 <mattdm> well, look at https://qa.fedoraproject.org/blockerbugs/propose_bug
15:30:02 <mattdm> you'd pick the "prioritized" milestone, and then check which box?
15:30:14 <bcotton> ideally, neither
15:30:31 <bcotton> if you checked the prioritzied milestone, it would disable those boxes
15:30:51 <mattdm> if it can do that, yeah :)
15:31:01 <bcotton> we're getting pretty far ahead of ourselves though :-)
15:31:36 <mhroncok> :)
15:31:47 <mattdm> I think that's a good thing to ask for
15:31:56 <mattdm> looks like kparal is the main dev recently?
15:32:10 <mattdm> also lbrabec
15:32:18 <bcotton> yeah. the implementation shouldn't be too difficult, if everyone's on board
15:32:45 <mattdm> I'm on board, so that's one of us :)
15:33:28 <bcotton> and you're the pope, so...
15:33:35 <mhroncok> I like the idea but I won't b able to help implementation wise
15:34:00 <mhroncok> I be this is written in Python and I don't know any of that
15:34:04 <mhroncok> *I bet
15:34:04 <bcotton> lol
15:34:26 <mattdm> lol
15:34:36 <mattdm> https://pagure.io/fedora-qa/blockerbugs/tree/develop
15:34:43 <mattdm> it's all java! you're in luck!
15:34:56 <bcotton> okay, so i think we can go ahead and end this meeting so that mhroncok can go learn python ;-)
15:35:13 <mattdm> seconded
15:35:25 <mhroncok> thirded
15:35:26 <bcotton> thanks, mattdm and mhroncok!
15:35:30 <bcotton> #endmeeting