fedora_prioritized_bugs_and_issues
LOGS
15:11:40 <bcotton> #startmeeting Prioritized bugs and issues
15:11:40 <zodbot> Meeting started Wed Jun  3 15:11:40 2020 UTC.
15:11:40 <zodbot> This meeting is logged and archived in a public location.
15:11:40 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:11:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:11:40 <zodbot> The meeting name has been set to 'prioritized_bugs_and_issues'
15:11:41 <bcotton> #meetingname Fedora Prioritized bugs and issues
15:11:41 <zodbot> The meeting name has been set to 'fedora_prioritized_bugs_and_issues'
15:11:49 <bcotton> #info bcotton apologies for the late start
15:12:15 <mattdm> OH HI
15:12:18 <bcotton> for some reason i didn't have a notification on the calendar
15:12:24 <mattdm> me either. also late :)
15:12:28 <mattdm> it's perfect!
15:12:29 <bcotton> #topic Purpose of this meeting
15:12:30 <bcotton> #info The purpose of this process is to help with processing backlog of bugs and issues found during the development, verification and use of Fedora distribution.
15:12:32 <bcotton> #info The main goal is to raise visibility of bugs and issues to help  contributors focus on the most important issues.
15:12:33 <bcotton> #link https://docs.fedoraproject.org/en-US/program_management/prioritized_bugs/#_process_description
15:12:36 <bcotton> #topic Roll Call
15:12:45 <mattdm> i am here
15:12:49 <bcotton> mbriza++ for pinging me, or i would have forgotten entirely
15:12:49 <zodbot> bcotton: Karma for mbriza changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:12:55 <mbriza> o/
15:13:10 <mbriza> i wasn't really sure if i got the timezone right
15:13:28 <bcotton> you did :-)
15:13:37 <bcotton> #topic Nominated bugs
15:13:38 <bcotton> #info 1 nominated bugs
15:13:40 <bcotton> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&f1=flagtypes.name&f2=OP&list_id=10871664&o1=substring&query_format=advanced&v1=fedora_prioritized_bug%3F
15:13:43 <mbriza> yeah, yeah, i pinged you after double-triple checking it :)
15:13:45 <bcotton> #topic [Fedora Media Writer] Does not work on macOS Catalina
15:13:46 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1840663
15:13:53 <bcotton> #info Bug open upstream and is a WIP
15:13:55 <bcotton> #link https://github.com/FedoraQt/MediaWriter/issues/217
15:13:57 <bcotton> so!
15:14:22 <mbriza> well, sicne we're here basically just because of me, i'll summarize the status
15:15:02 <mbriza> developing for macOS seems like to be trying to chase a moving target and doing privileged authorization properly is really hard to do properly, so a few years ago I decided to use a hack
15:15:12 <mbriza> that hack stopped to work in Catalina but I found another hack
15:15:39 <mbriza> rpi-imager is using it but that project is Apache 2.0 licensed, meanwhile FMW is GPL2
15:16:07 <mbriza> from what I was able to determine from reading articles on licensing, I can't just use that piece of code so I need to reimplement the same thing they're doing
15:16:33 <bcotton> my understanding as not-a-lawyer, is that you can use apache-licensed code in GPL software, but not the other way around
15:17:06 <mbriza> the code in question is not that complex though:
15:17:09 <bcotton> but it's been a while since i've looked at either of those licenses
15:17:15 <mattdm> there is some dispute
15:17:24 <mbriza> it boils down to starting /usr/libexec/authopen which is a binary that shows an authentication dialog and then lets you use either stdin/stdout to manipulate the file, or do some magic tricks with pipes or sockets and then do it through them
15:18:23 <mbriza> so i basically know how to fix it, i just haven't managed to actually pull it off completely because testing the code is insanely time consuming
15:18:25 <bcotton> if FMW uses GPLv3, it's a solved problem https://www.apache.org/licenses/GPL-compatibility.html
15:18:29 <mattdm> (in short, apache considers their 2.0 version to be compatible with all gpl versions, but fsf says it's only compatible with 3.0)
15:18:41 <mbriza> bcotton: it doesn't and relicensing seemed like an overkill
15:19:08 <bcotton> right. the question is "does relicensing require less effort than writing new code and testing it"
15:19:25 <mattdm> mbriza: we can probably find you some help with the testing
15:19:29 <bcotton> (with an implied question of "is there a particular reason to stay on gplv2?"
15:19:52 <bcotton> yeah, now's a good time in the cycle to throw work at the QA team :-)
15:19:57 <mattdm> (well, if anything else he's using is not "GPL 2 or later", that's hard)
15:20:02 <mbriza> mattdm: yeah, once i have something that seems to work to me, i'll ask
15:20:15 <mbriza> now it's just changing a line of code here and there and writing an entire sugar on a stick image
15:20:27 <mbriza> (because it's the smallest one)
15:20:41 <mbriza> bcotton: tbh the main reason is i don't really know how to do that
15:20:46 <mbriza> there's multiple contributors
15:21:17 <mbriza> overall i guess just writing the same thing from scratch will be easier
15:21:58 <bcotton> if https://github.com/FedoraQt/MediaWriter/graphs/contributors is the full list of contributors, you'd need to get their permission to relicense
15:22:03 <mattdm> What can we do to help you?
15:22:23 <bcotton> but it can be time consuming (as we found when we converted docs from the GFDL to CC BY-whatever-we-use-now)
15:22:34 <mbriza> bcotton: yeah, then it's probably not worth the effort
15:22:51 <mbriza> mattdm: except writing the code yourselves, not much, really
15:24:04 <mbriza> sorry to be so blunt :)
15:24:43 <bcotton> so i propose we accept this as a prioritized bug and let mbriza come ask when there's something we can do to help
15:24:46 <mbriza> anyway as i outlined previously, the eventual patch will be really simple, i just need to figure out the right order of all calls so it works reliably
15:24:56 <mattdm> mbriza: no, that's fair :)
15:25:12 <mattdm> can we send you $BEVERAGES ?
15:25:25 <mattdm> bcotton +1 to prioritizing
15:25:27 <mbriza> that's always welcome :)
15:25:41 <bcotton> mbriza: you might consider asking for help on devel, there may be some folks with enough catalina experience that can help solve this more quickly
15:25:55 <bcotton> (or maybe you did already and i forgot)
15:26:24 <mbriza> nah, i didn't
15:27:00 <mbriza> i probably have this evening free so i'm going to look at it once more while watching tv or something and then if i don't figure it out, i'll come and ask
15:27:33 <bcotton> sounds good
15:27:47 <mbriza> it really shouldn't be that hard to start an executable and paste the whole image ot its stdin... but it doesn't work in the way i'm doing it
15:28:18 <mbriza> my backup plan is to rewrite the same thing from chromium, they have it in MIT I think
15:28:22 <bcotton> #agreed BZ 1840663 is accepted as a prioritized bug
15:28:31 <bcotton> something something Just Works[tm] :-)
15:28:32 <mbriza> or GPL, i don't know, it's compatible for sure
15:31:27 <bcotton> thanks for the udpate, mbriza, and please be sure to let us know if there's anything we can do to help get this fixed
15:32:35 <bcotton> #topic Accepted bugs
15:32:36 <bcotton> #info 0 accepted bugs
15:32:38 <bcotton> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&f1=flagtypes.name&f2=OP&list_id=10871665&o1=substring&query_format=advanced&v1=fedora_prioritized_bug%2B
15:32:39 <bcotton> yay!
15:32:47 <bcotton> #topic Prioritized bugs fixed from last meeting
15:32:48 <bcotton> Just a quick review to remind ourself that this process works sometimes
15:32:53 <mbriza> bcotton: i will, thank you
15:32:55 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1715900
15:32:56 <bcotton> #info Closed as agreed in the last meeting
15:33:02 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1811800
15:33:03 <bcotton> #info Closed with provenpackager intervention
15:33:11 <bcotton> #topic Next meeting
15:33:12 <bcotton> #info We will meet again on 17 June at 1500 UTC in #fedora-meeting
15:33:29 <bcotton> anything else we need to cover?
15:34:39 <mattdm> Nope!
15:34:42 <mattdm> No troubles!
15:34:45 <mattdm> Everything is fine!
15:34:48 <mattdm> Nothing to see here.
15:34:50 <mattdm> Move along.
15:35:10 <mattdm> https://www.youtube.com/watch?v=3bjEpLoL0ls
15:36:55 <bcotton> okay, thanks mattdm and mbriza!
15:37:01 * bcotton changes name to mbcotton to fit in
15:37:04 <bcotton> #endmeeting