fedora_prioritized_bugs_and_issues
LOGS
15:00:02 <bcotton> #startmeeting Prioritized bugs and issues
15:00:02 <zodbot> Meeting started Wed Mar 11 15:00:02 2020 UTC.
15:00:02 <zodbot> This meeting is logged and archived in a public location.
15:00:02 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:02 <zodbot> The meeting name has been set to 'prioritized_bugs_and_issues'
15:00:04 <bcotton> #meetingname Fedora Prioritized bugs and issues
15:00:04 <zodbot> The meeting name has been set to 'fedora_prioritized_bugs_and_issues'
15:00:13 <bcotton> #topic Purpose of this meeting
15:00:14 <bcotton> #info The purpose of this process is to help with processing backlog of bugs and issues found during the development, verification and use of Fedora distribution.
15:00:21 <bcotton> #info The main goal is to raise visibility of bugs and issues to help  contributors focus on the most important issues.
15:00:22 <bcotton> #link https://docs.fedoraproject.org/en-US/program_management/prioritized_bugs/#_process_description
15:00:37 <bcotton> #topic Roll Call
15:00:40 <mhroncok> o/
15:01:37 <bcotton> hello, mhroncok!
15:01:49 <mhroncok> hello bcotton
15:03:03 * bcotton waits patiently for mattdm
15:03:14 <olem> Hello bcotton
15:03:19 <bcotton> welcome, olem
15:05:05 <bcotton> okay, well we'll get started without mattdm :-)
15:05:19 <bcotton> #topic Nominated bugs
15:05:20 <bcotton> #info 4 nominated bugs
15:05:22 <bcotton> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&f1=flagtypes.name&f2=OP&list_id=10871664&o1=substring&query_format=advanced&v1=fedora_prioritized_bug%3F
15:05:26 <bcotton> #topic Install alsa-sof-firmware package by default
15:05:28 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1811914
15:05:29 <bcotton> #info Also proposed as an F32 Beta Freeze Exception
15:06:08 <bcotton> this is ON_QA, so i'm not sure we need to give it much thought at this point
15:06:55 * mhroncok gave +1 Freeze exception in bugzilla
15:07:40 <bcotton> any objections to rejecting this as a prioritized bug since it's already in the works and seems likely to get a Freeze Exception?
15:07:51 <mhroncok> ack, no need to prioritize at this point
15:08:25 <mhroncok> also, seesm liek the person reported it to themselves and marked as prioritied, so they know this needs to be done
15:08:32 <mhroncok> *seems like
15:08:47 <bcotton> #agreed BZ 1811914 is rejected as a prioritized bug since it's already ON_QA
15:09:05 <bcotton> #topic Display corruption on aarch64 virtual machines
15:09:06 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1807661
15:09:16 <bcotton> #info This is an accepted F32 Beta Blocker
15:09:28 <bcotton> given that, there's no reason to make it a prioritized bug
15:09:50 <bcotton> release blocking is as high of a priority as we can give a bug
15:10:05 <bcotton> #agreed BZ 1807661 is rejected as a Prioritized Bug because it is an accepted Beta Blocker
15:10:12 <bcotton> #topic Multiple packages have broken dependencies due to PostgreSQL 12
15:10:14 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1811800
15:10:16 <bcotton> #info Also proposed as an F32 Beta Blocker
15:10:29 <bcotton> this one seems unlikely to be accepted as a blocker (or even an FE) since it doesn't violate any criteria
15:10:34 <bcotton> so i'm +1 to prioritizing it
15:10:46 <mhroncok> +1 as well (I've proposed it)
15:11:13 <mhroncok> note that in fact this is a Fedora 32 change that wasn't finished but the tracking bug was CLOSED
15:11:27 <mhroncok> hence I wanted to block on it: eithe rthis should be done, or the postgres upgrade should be reverted
15:11:54 <bcotton> yeah, that's a thing for me to watch better next time. change tracking bugs shouldn't be closed until the release
15:12:03 <bcotton> but i'd argue reverting is a FESCo decision
15:12:21 <mhroncok> bcotton: I agree, and I'd very much ike to ge tthis fixed
15:12:32 <bcotton> so for our purposes...
15:12:42 * mhroncok however I'm unsure the change owner takes this seriously enough :(
15:12:51 <bcotton> #agreed BZ 1811800 is accepted as a prioritized bug
15:12:56 <mhroncok> \o/
15:13:22 <bcotton> i'll follow up with them after the meeting to give some gentle encouragement
15:13:25 <bcotton> #topic No checkbox to install updates in the shutdown dialog
15:13:27 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1805265
15:13:57 <bcotton> #info We previously deferred until the Workstation WG weighed in. They did and consider it a bug
15:14:02 <bcotton> #link https://pagure.io/fedora-workstation/issue/133
15:14:11 <bcotton> i'm of two minds on this. on the one hand, it's important
15:14:18 <bcotton> on the other hand, it seems like an issue for upstream
15:14:35 <bcotton> so i don't know if us calling it prioritized means much
15:14:39 <mhroncok> I'm +1 to make it prioritized
15:14:56 <mhroncok> we have red hat employees who can fix this upstream
15:15:11 <bcotton> #link https://gitlab.gnome.org/GNOME/gnome-shell/issues/2276
15:15:20 <bcotton> mhroncok: that's a convincing argument
15:15:24 <bcotton> +1 from me too, then
15:15:27 <mhroncok> (as a side note, I'd like to tlak to bcotton about how do we encourage prioritized bugz to be fixed)
15:15:36 <mhroncok> *talk
15:15:38 <mhroncok> omg
15:15:40 <mhroncok> talk
15:15:52 <bcotton> mhroncok: ack, let's do that after we wrap up here
15:16:15 <bcotton> #agreed BZ 1085265 is accepted as a prioritized bug
15:16:30 <bcotton> #topic Accepted bugs
15:16:31 <bcotton> #info 4 accepted bugs
15:16:33 <bcotton> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&f1=flagtypes.name&f2=OP&list_id=10871665&o1=substring&query_format=advanced&v1=fedora_prioritized_bug%2B
15:16:37 <bcotton> #topic Migrate Fedora 31 users back to nonmodular content overridden by the eclipse module
15:16:38 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1780827
15:16:40 <bcotton> #info Accepted as a Prioritized Bug on 2019-12-18
15:16:55 <mhroncok> so I wrote a fixer there
15:17:00 <mhroncok> it's pretty brutal
15:17:08 <bcotton> yeah, i saw that :-/
15:17:35 <bcotton> mhroncok: is your intent that the packagers will do this or that you'll do it as a (i assume you're a) provenpackager?
15:17:49 <bcotton> or something else
15:17:51 <mhroncok> at this point we can either: say this is only fixed on upgrading to f32. or migrate all users away from those modules (once)
15:18:26 <mhroncok> honestly, both is quite horrible. maybe this needs a FESCo vote?
15:18:39 <bcotton> yeah, i think this is a good decision for FESCo
15:18:59 <mhroncok> #action mhroncok to file a FESCo ticket
15:19:00 <bcotton> i'm not sure which of those two choices i like less
15:19:08 <bcotton> mhroncok++
15:19:30 <bcotton> #topic Modules make eclipse non-installable
15:19:31 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1800528
15:19:33 <bcotton> #info Accepted as a Prioritized Bug on 2020-02-12
15:19:39 <bcotton> can be solved by not having default modules https://bugzilla.redhat.com/show_bug.cgi?id=1800528#c4
15:19:41 <bcotton> FESCo banned default modules in 32+ https://pagure.io/fesco/issue/2341#comment-628267
15:20:22 <mhroncok> this needs to be solved in Fedora 31 modular content somehow
15:20:51 <bcotton> the "somehow" seems to be the sticking point
15:21:54 <mhroncok> well it seems from the bug that the maintainer of the maven module is not keen to fix the content and we cannot fix the delivery mechnaism
15:22:25 <mhroncok> as a prioritized bug I think we need to "force" the content fix
15:22:51 <mhroncok> however, the "prioritized bug" is now assigned to "orphan"
15:23:00 <mhroncok> hence nobody is really fixing this mess :(
15:23:06 <mattdm> oH hi SoRRy I gOt DisTracTeD!!1
15:23:26 <bcotton> welcome, mattdm. you got here just in time for the Hard Part[tm]
15:23:34 * mattdm runs back away
15:23:43 <mhroncok> mattdm: good bye :P
15:23:47 <bcotton> is the maven module itself the place to fix it, though?
15:24:05 <mhroncok> bcotton: honestly? no, the modularity thing is broken
15:24:21 <mhroncok> bcotton: but with the situation we are in, maven module is the only tplace to hack it away
15:24:53 <mhroncok> maven module maintainer: "I'm not going to add packages unrelated to Maven to maven module."
15:25:04 <mhroncok> dnf miantainer: "I hope that you will provide an alternative solution in reasonable time."
15:25:11 <mhroncok> nobody: "yes, here it is"
15:25:27 <bcotton> lol
15:26:15 <mattdm> lolsigh
15:26:35 <mattdm> ok, so, I guess the question is: is there a lever we can push on, and which way does it push?
15:27:50 <mhroncok> I am not sure if this is entirely correct but as far I I understand the problem, this can be reasonably fixed in the maven module
15:28:13 <mhroncok> the maven module maintainer should IMHO be encouraged to do that
15:28:24 <mhroncok> (trough his manager if needed, that is)
15:30:40 <bcotton> i'm happy to have mattdm do that :-)
15:30:58 <mattdm> yeah it's kinda my job :)
15:31:43 <bcotton> #action mattdm to encourage maven module maintainer to implement a fix for F31
15:31:53 <mhroncok> thanks
15:32:09 <mattdm> Let me make sure I 100% understand, though
15:32:31 <mattdm> 1. Does this affect F32 at all?
15:32:55 <mattdm> 2. In F31, if one enables a non-default eclipse stream, does that work?
15:33:09 <mattdm> 2a. And if they do that, what happens up upgrade to F32?
15:33:30 <mhroncok> 1. not at all, f32 is fixed by disabling the default modular streams
15:33:56 <mhroncok> 2. most likely that installs eclipse, but may break other things, like protobuf
15:34:32 <mhroncok> 2a. everything is unicorns and rainbows when they upgrade to F32 assuming they do it via dnf system-upgrade
15:34:53 <mattdm> see, 1 + 2a makes me relucatant to lean hard on someone's manager
15:35:11 <mattdm> because the problem will basically correct itself :-/
15:35:24 <mattdm> I like to save leaning on managers for when there's _really_ a need
15:36:08 * mhroncok is not very happy to say: in order to install eclipse, upgrade to Fedora 32 which has not yet reached beta
15:36:37 <mhroncok> the maven module is breaking the rules (https://bugzilla.redhat.com/show_bug.cgi?id=1800528#c12)
15:36:58 <mhroncok> surely, there must be something that can be done instead of waiting for Fedora 32
15:37:29 <bcotton> hm, since it's breaking the rules, i suppose if the gentle pressure from mattdm doesn't get the maintainer to act, a provenpackager can step in?
15:37:49 <sgallagh> I'll volunteer to step in if that's the case.
15:37:54 <mhroncok> sgallagh++
15:38:01 <mhroncok> sgallagh: and hello
15:38:13 <mattdm> and the packager in question is Mikolaj Izdebski?
15:38:16 * sgallagh has been following the discussion intermittently while in another meeting
15:38:42 <mhroncok> mattdm: correct https://src.fedoraproject.org/modules/maven
15:38:44 <bcotton> sgallagh++
15:38:53 <sgallagh> I do have to ask: has anyone considered Flatpak as a solution to the Eclipse Problem?
15:39:27 <mhroncok> sgallagh: as far as I recall, mbooth said it is a different can of worms
15:39:37 <mhroncok> (not in those exact words)
15:39:42 <sgallagh> Fair enough
15:40:47 <bcotton> so in summary, mattdm will contact Mikolaj and if nothing happens, sgallagh will provide a fix as a provenpackager?
15:40:59 <mhroncok> ack
15:41:12 <mattdm> writing email now
15:41:18 <mattdm> ben I'm ccing you but no managers
15:41:18 <bcotton> mattdm++
15:41:21 <bcotton> ack
15:41:26 <mattdm> we'll see how that goes :)
15:41:35 <bcotton> i say we wait a week before we turn sgallagh loose?
15:42:03 * sgallagh likes the sound of that
15:42:49 <bcotton> #agreed mattdm will contact the maven module maintainer (previously #action'ed) and if there's no fix within a week, sgallagh will step in as a provenpackager
15:43:51 <bcotton> shall we move on?
15:44:30 <bcotton> let's!
15:44:34 <bcotton> #topic moby-engine does not obsolete proper version of docker, upgrading to Fedora 32 is blocked
15:44:35 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1804305
15:44:37 <bcotton> #info Accepted as a Prioritized Bug on 2020-02-26
15:44:38 <bcotton> #info moby-engine-19.03.7-2.ce.git7141c19.fc31 (update FEDORA-2020-aa8bed5ad6) should fix this
15:45:26 <bcotton> so from https://bugzilla.redhat.com/show_bug.cgi?id=1804305#c19 it looks like this is fixed on 32, but we need a different fix for 31
15:46:16 <olem> Or do we need a fix for f31 @mhroncok ?
15:46:29 <olem> Or do we need a fix for f31 mhroncok ?
15:49:14 * mhroncok is back
15:49:23 <bcotton> welcome back, mhroncok
15:49:36 <bcotton> mhroncok: in case you didn't see, olem is asking "do we need a fix for f31?"
15:49:46 <mhroncok> runnign this Fedora thing, it is not very reliable
15:49:54 <bcotton> :-)
15:50:12 <mhroncok> olem: there is no way to fix this on f31 that isn't disturbing to our users
15:50:42 <mhroncok> olem: other than unretiring docker in there and updating it (in case fedora 30 version of docker was updates since the f31 retirement)
15:50:49 <mhroncok> *was updated
15:51:34 <olem> Ok. I'll unpush my update https://bodhi.fedoraproject.org/updates/FEDORA-2020-aa8bed5ad6 on f31.
15:52:09 <bcotton> would just having that in f32 fix the upgrade issue?
15:52:15 <mhroncok> olem: as a "almost good" solution, I suppose the docker obsoletes should be repalced by conflicts on f31 (in case the package do conflict)
15:52:48 <mhroncok> bcotton: yes, that's where the upgrade issue manifested itself, upgrading to f31 is ok-ish (docker from f30 stays)
15:53:39 <olem> mhrocnok There's already this Conflicts: docker on f31.
15:54:06 <bcotton> okay, so it sounds like unpushing the f31 update leaves us in a state where this problem is fixed?
15:54:25 <olem> I guess so
15:54:26 <mhroncok> olem: than just removing the obsoletes (as they are not doing anything with the missing epoch, but might be confusing) -- that is however just a cosmetic issue
15:54:32 <mhroncok> bcotton: yes
15:54:38 <bcotton> hooray!
15:54:54 <bcotton> #action olem to unpush FEDORA-2020-aa8bed5ad6
15:55:21 <bcotton> #topic Next meeting
15:55:23 <bcotton> bcotton is on PTO during our next meeting
15:55:24 <bcotton> #info We will meet again on 8 April at 1600 UTC in #fedora-meeting
15:56:17 <bcotton> mhroncok: i didn't expect us to take the full hour but we did. i may be indisposed for the next hour (depending on if people show up to that meeting or not), so we can discuss the "enforcement" of prioritized bugs later, if that works for you?
15:57:38 <bcotton> #undo
15:57:38 <zodbot> Removing item from minutes: INFO by bcotton at 15:55:24 : We will meet again on 8 April at 1600 UTC in #fedora-meeting
15:57:39 <mhroncok> bcotton: sure, just ping me once available
15:57:49 <bcotton> #info We will meet again on 8 April at 1500 UTC in #fedora-meeting
15:58:05 <bcotton> (forgot to adjust my doc for DST)
15:58:07 <bcotton> mhroncok: ack
15:58:12 <bcotton> okay, thanks everyone!
15:58:17 <bcotton> olem++ thanks for your contributions
15:58:18 <zodbot> bcotton: Karma for olem changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:58:22 <bcotton> #endmeeting