fedora-qa
LOGS
16:01:05 <adamw> #startmeeting Fedora QA Meeting
16:01:05 <zodbot> Meeting started Mon Feb 17 16:01:05 2020 UTC.
16:01:05 <zodbot> This meeting is logged and archived in a public location.
16:01:05 <zodbot> The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:01:05 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
16:01:10 <adamw> #meetingname fedora-qa
16:01:10 <zodbot> The meeting name has been set to 'fedora-qa'
16:01:13 <adamw> #topic Roll call
16:01:25 <tablepc> .hello2
16:01:26 <zodbot> tablepc: tablepc 'Pat Kelly' <pmkellly@frontier.com>
16:01:29 * kparal is here
16:01:32 <coremodule> .hello2
16:01:33 <zodbot> coremodule: coremodule 'Geoffrey Marr' <gmarr@redhat.com>
16:02:37 <bcotton> .hello2
16:02:38 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
16:05:01 * sumantro is here
16:06:18 <adamw> morning morning
16:06:21 <adamw> how's everyone doing?
16:06:25 <cmurf> .hello chrismurphy
16:06:26 <zodbot> cmurf: chrismurphy 'Chris Murphy' <bugzilla@colorremedies.com>
16:07:07 * bcotton has a case of the mondays
16:07:24 <cmurf> Good but for some reason I can't find my clown shoes...
16:09:06 * adamw plays sad trombone
16:09:10 <adamw> alrighty, let's get rolling
16:09:14 <adamw> #topic Previous meeting follow-up
16:09:36 <adamw> "kparal and pwhalen to work on pushing forward desktop validation change proposals (switch ARM blocking desktop to be Workstation aarch64, and KDE or all-desktops app coverage reduction)"
16:09:47 <adamw> so, i think bcotton stuck his head up and threw some bureaucracy at us? :)
16:09:55 <bcotton> that's what they pay me for :-)
16:10:07 <bcotton> #info FESCo approved change to ARM blocking desktop
16:10:28 <bcotton> like 35 minutes ago :-)
16:10:33 <kparal> awesome
16:10:49 <kparal> ftr, the ticket is here: https://pagure.io/fesco/issue/2339
16:11:45 <kparal> and my proposal for desktop coverage reduction is here: https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/thread/QEYDNIJQYPXZTXDMSMLF2JQLLZMZMCTM/
16:11:57 <adamw> wahay, bureaucracy resolved
16:12:12 <adamw> bcotton: the cause of and solution to all of fedora's bureaucracy
16:13:46 <cmurf> pretty sure that predates bcotton
16:14:00 <bcotton> cmurf: let me have my moment!
16:14:31 <adamw> #info proposal was posted to test@, arm@ and xfce@ . our noble fpm suggested it go through FESCo, so kparal filed a ticket: https://pagure.io/fesco/issue/2339 . that was recently resolved and the change has been approved. we will move forward with making it
16:14:33 <adamw> that OK?
16:14:59 <cmurf> pretty sure the magnificence of buraucracy has become more substantial since bcotton
16:15:19 <cmurf> but cmurf can't spell while making coffee so...
16:15:26 <kparal> adamw: pwhalen filed it but whatever
16:15:43 <bcotton> cmurf++
16:15:43 <zodbot> bcotton: Karma for chrismurphy changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:16:00 <adamw> #undo
16:16:00 <zodbot> Removing item from minutes: INFO by adamw at 16:14:31 : proposal was posted to test@, arm@ and xfce@ . our noble fpm suggested it go through FESCo, so kparal filed a ticket: https://pagure.io/fesco/issue/2339 . that was recently resolved and the change has been approved. we will move forward with making it
16:16:11 <adamw> #info proposal was posted to test@, arm@ and xfce@ . our noble fpm suggested it go through FESCo, so pwhalen filed a ticket: https://pagure.io/fesco/issue/2339 . that was recently resolved and the change has been approved. we will move forward with making it
16:16:29 <adamw> thanks to both of you for pushing that forward
16:16:46 <adamw> "tablepc to draft up his proposed changes to https://fedoraproject.org/wiki/QA:Testcase_package_install_remove and send them to the list"
16:17:00 <adamw> i think the way this turned out was we decided changing that test case wasn't quite what we wanted, right?
16:17:37 <tablepc> Right, Kparal and I have been discussing it.
16:17:54 <kparal> I'm having troubles understanding the motivation
16:18:22 <kparal> but yes, some of that was misunderstanding I think
16:18:47 <tablepc> The initial plan has been abandon and we are now discussing another, but related test case.
16:18:59 <kparal> tablepc: and I still don't understand it, sorry :/
16:19:54 <adamw> sigh, i'm bad today. just a sec
16:19:55 <adamw> #undo
16:19:55 <zodbot> Removing item from minutes: INFO by adamw at 16:16:11 : proposal was posted to test@, arm@ and xfce@ . our noble fpm suggested it go through FESCo, so pwhalen filed a ticket: https://pagure.io/fesco/issue/2339 . that was recently resolved and the change has been approved. we will move forward with making it
16:20:01 <tablepc> You convinced me that chagning the install remove was a bad idea
16:20:18 <adamw> #info "kparal and pwhalen to work on pushing forward desktop validation change proposals" - proposal was posted to test@, arm@ and xfce@ . our noble fpm suggested it go through FESCo, so pwhalen filed a ticket: https://pagure.io/fesco/issue/2339 . that was recently resolved and the change has been approved. we will move forward with making it
16:20:38 <tablepc> We have been discussing the Menu test case.
16:21:13 <adamw> #info "tablepc to draft up his proposed changes to https://fedoraproject.org/wiki/QA:Testcase_package_install_remove and send them to the list" - on further discussion it became clear that changing this test case wasn't really what we wanted to do. further discussion is currently happening to decide exactly how we should proceed with tablepc's ideas
16:22:25 <adamw> any other follow up?
16:22:49 <kparal> should we discuss my desktop testing proposal now or later?
16:23:18 <tablepc> Now now now
16:23:39 <adamw> er
16:23:42 <kparal> I sent it out 2 hours ago so I presume everybody already studied that instead of sleeping or whatnot
16:23:44 <adamw> next topic i think is proposals
16:23:46 <adamw> =)
16:23:46 <tablepc> I sent you an e'mail this morning with some feedback
16:23:52 <adamw> of course, i have a special Kparal Proposal Alarm
16:23:56 <adamw> it rings throughout the AdamCaev
16:23:58 <adamw> ...cave
16:24:13 <adamw> oh okay, third topic
16:24:16 <adamw> so let's get through the second!
16:24:20 <adamw> #topic Fedora 32 status
16:24:24 <adamw> sooo....still bad!
16:24:27 <adamw> okay, next topic
16:24:28 <adamw> :P
16:24:29 <coremodule> lol
16:25:25 <tablepc> I didn't get it. Is it on the list?
16:26:15 <adamw> #info the optical disc boot bug is resolved - https://bugzilla.redhat.com/show_bug.cgi?id=1801353
16:26:38 <cmurf> haha
16:26:46 <adamw> #info the glib / selinux issue has been worked around for now (by fixing the glib fallback path) - https://bugzilla.redhat.com/show_bug.cgi?id=1795524
16:26:50 <tablepc> As for F32 from what I can see Anaconda is very ill.
16:27:11 <cmurf> well at least we're getting to anaconda now...
16:27:27 <adamw> #info now we have some new bugs causing havoc:
16:27:41 <adamw> #info https://bugzilla.redhat.com/show_bug.cgi?id=1803293 (plymouth keeps starting up and blocking TTYs)
16:28:11 <adamw> what problem are you seeing with anaconda?
16:28:34 <tablepc> Won't configure a disk so the install can proceed
16:28:46 <tablepc> There already seems to be a bug report
16:29:10 <cmurf> is it the accepted blocker?
16:29:29 <cmurf> 1797274  anaconda  MODIFIED  AttributeError: can't set attribute
16:29:42 <tablepc> 179 yes, 8792
16:29:48 <tablepc> Hows that for bad
16:30:15 <adamw> that one looks fixed to me
16:30:22 <adamw> (7274)
16:30:34 <tablepc> last saw it on 0214 drop
16:31:11 <adamw> tablepc: are you sure that's the same bug you're seeing?
16:31:21 <adamw> that one's quite specific - you have to have an existing software RAID set
16:31:56 <tablepc> Might be wrong just going from description. Haven't had any luck chasing it down myself
16:32:07 <tablepc> Don't have a raid
16:32:35 <adamw> tablepc: if anaconda shows a traceback, you can report it as a bug by following the prompts
16:32:51 <tablepc> The install starts says it's configuring the disk and quits
16:33:32 <tablepc> When it quits I can't get a terminal or anything
16:34:09 <cmurf> hmm
16:34:24 <adamw> doesn't sound like the same bug, then
16:34:31 <cmurf> there's a test case and criterion for anaconda built-in bug reporter, that should work
16:34:31 <adamw> but you'd have to look at the logs in /tmp to see what's going on...
16:34:35 <tablepc> When I reload F31 everything works fine so it's not the hardware
16:35:17 <tablepc> Okay I'l ask How can I look at the logs when I can't get a terminal
16:35:25 <cmurf> yeah the -tb file in /tmp should be enough to figure out if it's a dup or not
16:35:35 <cmurf> if one is produced
16:36:04 <cmurf> this is a Live? not a dvd/netinstall?
16:36:24 <tablepc> This is live from a thumb drive
16:37:04 <tablepc> The checksum passed
16:37:11 <adamw> okay, let's move this to #fedora-qa
16:37:15 <adamw> we need to move along with the meetin
16:37:50 <adamw> any other notes on f32 current status?
16:38:22 <adamw> i suppose the other note is:
16:38:33 <adamw> #info most recent F32 compose failed, issue is being worked on in https://pagure.io/releng/failed-composes/issue/1010
16:40:50 <adamw> #topic Proposals, IoT, CoreOS...
16:41:04 <adamw> so, this is kind of a grab-bag Stuff We've Got Goin' On topic :P
16:41:20 <kparal> https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/thread/QEYDNIJQYPXZTXDMSMLF2JQLLZMZMCTM/
16:42:07 <adamw> #info kparal has proposed a reduction in coverage for the default application functionality criterion: https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/thread/QEYDNIJQYPXZTXDMSMLF2JQLLZMZMCTM/
16:42:28 <kparal> do you have some initial thoughts?
16:43:18 <coremodule> per your proposal kparal, I think the key is "...people using
16:43:18 <coremodule> alternative desktops and architectures are usually far from beginners..."
16:43:19 <adamw> well, my initial thought is the most obvious one: drawing a quality line between Workstation and 'everything else' is a new and fairly significant thing
16:43:38 <tablepc> Narrowing scope and doing it better seems good to me
16:44:01 <kparal> adamw: well, we've been doing it unofficially for years
16:44:13 <kparal> this makes the line visible and defined
16:44:23 <adamw> hmm. maybe you have? i've always tried hard not ot
16:44:28 <cmurf> haha
16:44:42 <adamw> i've always tried to honor the idea that gnome and kde are equivalently release-blocking
16:44:56 <kparal> alright, I can admit that I had to try very hard to make KDE and XFCE pass the desktop test
16:45:04 <kparal> otherwise we would have never released
16:45:31 <adamw> heh
16:45:44 <adamw> anyway
16:45:47 <adamw> we don't need to dwell on it
16:45:49 <tablepc> The versions to test are growing faster than the test team. That's not tenable long term.
16:45:55 <adamw> just felt it was worth noting
16:46:29 <adamw> i would also say the proposal really needs to go to at least workstation and kde lists
16:46:30 <kparal> it is worth noting. But this is not just about KDE, though
16:46:37 <tablepc> Does RHEL use both Gnome and KDE?
16:46:40 <adamw> though if you just wanted to discuss it among ourselves first that's fine
16:46:52 <adamw> tablepc: afaik, KDE was in RHEL up to 7, it is not in 8.
16:47:33 <cmurf> Skimming it, the main issue seems to be getting to an agreement someone soon since it's intended to apply to the F32 cycle
16:48:33 <kparal> I highlighted the idea to the workstation WG in this ticket, but no one responded to it exactly (but to other topics): https://pagure.io/fedora-workstation/issue/128
16:48:39 <cmurf> also Workstation WG has wanted to clarify+enhance the basic functionality test, as in 'raise the bar'
16:48:42 <tablepc> Seems to me like "management has some hard decisions to make. Unless there is budget for hiring.
16:48:51 <kparal> I can send it out to desktop and kde lists
16:49:16 <adamw> thanks
16:49:33 <kparal> I'll wait for a few responses in the test list first
16:50:20 <kparal> cmurf: how would you want to raise the bar?
16:51:30 <cmurf> WG is willing to block on bugs where basic function is met, but a more stringent usefulness metric is not
16:51:49 <kparal> adamw: if we wanted equal criteria for everyone, we can use the lower bar for everyone. But that's not going to be liked by Workstation WG I guess
16:51:52 <adamw> i mean, broadly i feel like we need to do *something* like this, at least. we can argue the details
16:52:00 <adamw> kparal: yeah, that's one question i was gonna ask
16:52:02 <cmurf> i.e. included apps need to more than just launch and have some menus appear to work
16:53:56 <kparal> there are 2 approaches what to do with limited resources - guarantee higher quality only for higher-profile product (this proposal), or keep the standards the same, but spend more time on higher-profile product (e.g. QA would mainly test Workstation and other would be best effort). The latter is going to lead to last minute blockers which is not a good situation to be in
16:54:11 <tablepc> Seems like stuff I've been duscussing with kparal
16:54:24 <tablepc> more testing on apps
16:55:18 <cmurf> WG doesn't suggest a change in QA strategy, just that Workstation would have a higher quality bar should such bugs be discovered
16:55:20 <kparal> cmurf: it was never the case that the app just started. We really test basic functionality, e.g. working with files in nautilus
16:55:43 <adamw> so, we're short on time now, folks
16:56:30 <adamw> i guess we can pick up discussion on coreos, iot and other topics next week
16:57:29 <adamw> #info please post your thoughts on kparal's proposal to the list, everyone
16:57:36 <adamw> #action kparal to forward proposal to desktop and kde lists
16:57:44 <kparal> ok
16:57:47 <adamw> #topic Open floor
16:57:52 <adamw> any other urgent business we didn't cover yet?
16:58:05 <sumantro> A couple of test day notes
16:58:12 <sumantro> Kernel 5.5 Test Week is about to end in a few hours. About 60+ testers, results on http://testdays.fedorainfracloud.org/events/75
16:58:44 <kparal> :tada:
16:58:48 <sumantro> Gnome test 2020-02-20
16:58:59 <sumantro> and IoT on 2020-02-26
16:59:16 <sumantro> Fedora i18n on 2020-03-10
16:59:21 <sumantro> That's all
17:00:17 <adamw> thanks sumantro!
17:00:35 <adamw> #info GNOME Test Day is on 2020-02-20, IoT Test Day on 2020-02-26, i18n Test Day on 2020-03-10
17:00:42 <adamw> thanks for coming everyone!
17:00:46 <adamw> #endmeeting