fedora_prioritized_bugs_and_issues
LOGS
16:00:04 <bcotton> #startmeeting Prioritized bugs and issues
16:00:04 <zodbot> Meeting started Wed Feb 12 16:00:04 2020 UTC.
16:00:04 <zodbot> This meeting is logged and archived in a public location.
16:00:04 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:04 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:04 <zodbot> The meeting name has been set to 'prioritized_bugs_and_issues'
16:00:05 <bcotton> #meetingname Fedora Prioritized bugs and issues
16:00:05 <zodbot> The meeting name has been set to 'fedora_prioritized_bugs_and_issues'
16:00:15 <bcotton> #topic Purpose of this meeting
16:00:17 <bcotton> #info The purpose of this process is to help with processing backlog of bugs and issues found during the development, verification and use of Fedora distribution.
16:00:19 <bcotton> #info The main goal is to raise visibility of bugs and issues to help  contributors focus on the most important issues.
16:00:20 <bcotton> #link https://docs.fedoraproject.org/en-US/program_management/prioritized_bugs/#_process_description
16:00:33 <bcotton> #topic Roll Call
16:00:55 <mhroncok> hey. I'm here, summoned by an e-mail
16:01:05 <mattdm> i am here!
16:01:18 <mattdm> i did not know e-mail had that power.
16:01:35 <bcotton> hello. mhroncok! I figured it would be good to cc reporters and assignees to talk about the bugs :-)
16:01:36 <mhroncok> it was a nice e-mail :)
16:01:43 <bcotton> mattdm: maybe *your* emails don't have that power...
16:02:07 <mattdm> haha. yes.
16:02:22 <bcotton> i'll wait a moment to see if my emails lure anyone else to the meeting
16:02:44 * zbyszek was lured successfully
16:02:55 <bcotton> welcome zbyszek!
16:03:09 <mattdm> wow, this new plan is amazing
16:03:27 <mhroncok> hopefully not only the reportes will come :)
16:03:42 <mattdm> well, that's a start :)
16:04:08 <bcotton> speaking of starting, let's!
16:04:15 <bcotton> #topic Nominated bugs
16:04:16 <bcotton> #info 1 nominated bugs
16:04:18 <bcotton> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&f1=flagtypes.name&f2=OP&o1=substring&product=Fedora&query_format=advanced&v1=fedora_prioritized_bug%3F
16:04:43 <bcotton> so the email yesterday had two, i'll just note that one for the record real quick
16:04:50 <bcotton> #topic turns Wi-Fi on without asking or telling me
16:04:52 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1792650
16:04:55 <bcotton> #info CLOSED->NOTABUG
16:05:19 <mattdm> yeah I 100% agree with that assessment
16:05:21 <bcotton> now for the real deal
16:05:28 <bcotton> #topic Authentication dialog for samba printer provides no input fields
16:05:30 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1715900
16:06:20 <mattdm> this seems like it's an upstream samba problem?
16:06:47 <mattdm> It does seem relatively important if it affects all printing to windows computers
16:06:54 <bcotton> yeah, although it's possible we could carry the reversions until upstream fixes it
16:07:24 <bcotton> and it's a regression that's causing at least one person to stay on an EOL fedora
16:08:02 <mattdm> i'm concerned that just blindly reverting will cause other problems
16:08:10 <mattdm> e.g. one of the commits says it fixes https://bugzilla.samba.org/show_bug.cgi?id=13832
16:08:16 <mattdm> which is "Printing via smbspool backend with kerberos auth fails"
16:08:23 <bcotton> yeah, theres that
16:08:36 <mattdm> oh, maybe all of the commits are for that
16:09:01 <mattdm> it looks like one of the reviewres of those commits is a red hatter
16:10:06 <bcotton> my inclination is to grant the prioritized status and defer to the maintainer's decision on how to best address it
16:10:15 <mattdm> Okay, works for me
16:10:27 <mattdm> We don't have a long prioritized list so we can handle this I think
16:10:34 <bcotton> mhroncok, zbyszek, anyone else: opinions?
16:10:42 <mattdm> if we were juggling fifteen or something, it would fall down my priority list
16:11:14 <mhroncok> no opinion, wasn't really paying attention to this one, sorry
16:11:21 <bcotton> #agreed BZ 1715900 is accepted as a prioritized bug
16:11:24 * mhroncok will try to do better now
16:11:30 <bcotton> mhroncok: no worries :-)
16:11:38 <zbyszek> What bcotton says sounds reasonable.
16:11:38 <bcotton> #topic Accepted bugs
16:11:40 <bcotton> #info 1 accepted bugs
16:11:42 <bcotton> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&f1=flagtypes.name&f2=OP&&o1=substring&product=Fedora&query_format=advanced&v1=fedora_prioritized_bug%2B
16:11:51 <bcotton> zbyszek: wow, i don't hear that very often ;-)
16:11:56 <bcotton> #topic Migrate Fedora 31 users back to nonmodular content overridden by the eclipse module
16:11:58 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1780827
16:12:19 <mattdm> I assume this is the one we have special guests for :)
16:12:34 <bcotton> it would seem to be
16:12:43 <mhroncok> I work closely with the dnf team, they understand that this is top prio
16:12:56 <bcotton> #info this is a top priority for the dnf team
16:13:11 <mhroncok> OTOHO unlike the F32 blocking ones, this has no deadlines, so it can easily slip
16:13:15 <mhroncok> *OTOH
16:13:27 <bcotton> #info this is not an F32 blocker, so it may slip
16:13:38 <mattdm> soooo, top priority after blockers?
16:13:46 <mhroncok> this shoukld coem first
16:13:48 <mhroncok> *come
16:14:01 <mhroncok> the only reason it's not a blocker is that it affects already released fedora only
16:14:13 <mhroncok> we cannot block F32 on F31 bugs
16:14:16 <bcotton> what's the impact on upgrade?
16:14:24 <mhroncok> bcotton: good question
16:14:42 <mhroncok> bcotton: I have no idea
16:15:00 <mattdm> mhroncok: We can block F32 on "can't upgrade from F31" bugs even if the bug is in F31. But I don't *want* to
16:15:07 <bcotton> because we do have a concept of "Previous Release" blockers if it us an upgrade-related problem
16:15:13 <mattdm> bcotton: well the headline says "Cannot upgrade"
16:15:17 <bcotton> yes, that
16:15:36 <mattdm> that seems like a fairly sigificant upgrade-related problem
16:15:46 <mhroncok> are we on the same BZ?
16:16:01 <mattdm> oh, no, wait, i am ahead of myself :)
16:16:02 <bcotton> mattdm: i think you're looking at a different bug
16:16:14 <mattdm> "Cannot upgrade to Fedora 32: Modules blocking the upgrade path" *IS* a blocker
16:16:18 <mhroncok> .bug 1780827
16:16:19 <zodbot> mhroncok: 1780827 – Migrate Fedora 31 users back to nonmodular content overridden by the eclipse module - https://bugzilla.redhat.com/1780827
16:16:24 <mattdm> yeah sorry.
16:17:23 <mattdm> so anyway bcotton's question stands then
16:17:24 <mhroncok> as much as I hate this bug, I think it won't block upgrades, users affected by this will still be affected by this after upgrading to F32
16:17:39 <bcotton> i mean, i suppose it doesn't matter for the purposes of this discussion. if it does block upgrades, then it should be nominated as a blocker
16:17:50 <bcotton> but it's definitely something we want fixed as soon as possible
16:17:50 <mhroncok> only if the eclipse module goes away, they would be affected, but that's covered by the second one
16:17:50 <mattdm> ok, so, it has to be after the blocker in priority I think.
16:17:56 <mattdm> hopefully both can get done
16:18:15 <mhroncok> hopefully
16:18:35 <mhroncok> I don't think there needs to be any poking into this at this moment
16:18:46 <mhroncok> it was ignored for quite a while, but now it's handled by somebody else
16:18:46 <bcotton> it sounds like the team understands the priority, so i don't know if there's much else for us to do at this point except keep an eye on it
16:19:02 <mhroncok> right
16:19:21 <zbyszek> The bug isn't particularly hard to fix: just drop the modular content, add another hack of "dnf module reset" to dnf.
16:19:35 <zbyszek> In fact, that's probably the only solution that will work in time for F32.
16:20:00 <mhroncok> zbyszek: I was thinking, maybe consult dnf history to see if the module was enabled during regular "dnf upgrade" and reset it if true
16:20:20 <zbyszek> mhroncok: too complicated. I'd just od it unconditionally.
16:20:32 <mattdm> let's not solve this here :)
16:20:43 <mhroncok> zbyszek: that's breaking users who opted in for eclipse module, which is still the only way to install eclipse
16:20:55 <zbyszek> The more general solution of "modularity fixed" that the dns team wants to work on is nice, but currently it's a pie in the sky.
16:20:57 <mhroncok> mattdm: sorry, so easy to go deeper
16:21:22 <zbyszek> Right, some of the eclispe stuff needs to be rebuilt in Fedora properly too.
16:21:29 <mhroncok> zbyszek: it is... wait...
16:21:52 <mhroncok> .bug 1800528
16:21:53 <zodbot> mhroncok: 1800528 – Modules make eclipse non-installable - https://bugzilla.redhat.com/1800528
16:22:39 <mhroncok> this woudl also be a candidate for prioritized bug, but since Dan marked it as high prio, I didn't do that
16:23:04 <bcotton> mhroncok: is it sufficiently different from 1780827?
16:23:14 <mhroncok> bcotton: totally different
16:23:31 <zbyszek> Yes, it's a different facet, merits its own bug.
16:23:38 <mhroncok> bcotton: 1780827: users were forced to broken modular packages
16:23:47 <bcotton> i'm fine with slapping the prioritized label on it, too, then
16:23:58 <mhroncok> bcotton: 1800528: users cannot install nonmodular eclipse due to modular packages
16:24:22 <bcotton> it's as much for the sake of matthew and i being aware of stuff as it is for the maintainers
16:24:39 <mhroncok> bcotton: I am not familiar with the process. do we mark bugs prioritized even if we see people are actively trying to fix them? if so, please do
16:25:45 <bcotton> #topic (late nominee) Modules make eclipse non-installable
16:25:51 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1800528
16:26:32 <bcotton> so yeah, we can certainly flag it. if people are actively working on it, we either see if we can help get them what they need or just stay out of their way and keep an eye on it
16:26:48 <bcotton> i'm +1 on this one
16:27:11 <mhroncok> I'm +1 to mark it prioritized given the above
16:27:18 <zbyszek> I'm +1 too.
16:27:29 <mattdm> yep +1
16:27:41 <bcotton> #agreed 1800528 is accepted as a prioritized bug
16:27:45 <mattdm> that's 4 out of 1 required vote :)
16:27:57 <bcotton> #topic Next meeting
16:27:58 <zbyszek> Not sure if that changes anything, since those bugs being prioritized clearly doesn't have much effect..., but OK.
16:27:59 <bcotton> #info We will meet again on 26 February at 1600 UTC in #fedora-meeting
16:28:48 <bcotton> zbyszek: sometimes the process helps, sometimes it just lets me play with Bugzilla for a few minutes :/
16:29:00 <zbyszek> What about #1801353?
16:29:06 <zbyszek> .bug 1801353
16:29:11 <zodbot> zbyszek: Error: That URL raised <('The read operation timed out',)>
16:29:34 <bcotton> not a bug, i guess ;-)
16:29:50 <mhroncok> that's an accepted blocker
16:30:00 <mhroncok> https://bugzilla.redhat.com/show_bug.cgi?id=1801353 Mounting root from installation media fails since kernel-5.6.0-0.rc0.git5.1.fc32
16:30:55 <zbyszek> It's currently assigned to the kernel, but there's so many moving parts that it's hard to say for certain what the issue is.
16:31:08 <bcotton> yep. if it becomes not a blocker (fixed "enough", i guess?) but still an issue, we can consider it for prioritized bugs. but adding the prioritized flag to a blocker is just me playing in bugzilla
16:31:21 <mattdm> yes.
16:31:31 * zbyszek shuts up.
16:31:39 <mattdm> lol no no it's fine :)
16:31:44 <mattdm> glad to have you here :)
16:32:02 <bcotton> yes, it's so nice to have someone to talk these through with besides matthew
16:32:21 * mattdm ignores that
16:32:36 <bcotton> i mean i like you an all, but.... :-)
16:32:46 <bcotton> okay, anything else for this meeting?
16:32:55 <mattdm> We should probably explictly call out in the process doc that we consider blocker bugs already prioritized automatically
16:33:09 <bcotton> mattdm: ack
16:33:10 <mattdm> and therefore don't need this process
16:33:42 <bcotton> #action bcotton to update the process doc to make explicit that blocker bugs are prioritized and don't need this process
16:34:23 <bcotton> okay, last call
16:35:20 <bcotton> thanks, everyone!
16:35:24 <bcotton> mhroncok++
16:35:27 <bcotton> zbyszek++
16:35:27 <zodbot> bcotton: Karma for zbyszek changed to 5 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:35:28 <bcotton> #endmeeting