fedora_prioritized_bugs_and_issues
LOGS
16:00:18 <bcotton> #startmeeting Prioritized bugs and issues
16:00:18 <zodbot> Meeting started Wed Jan 15 16:00:18 2020 UTC.
16:00:18 <zodbot> This meeting is logged and archived in a public location.
16:00:18 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:18 <zodbot> The meeting name has been set to 'prioritized_bugs_and_issues'
16:00:19 <bcotton> #meetingname Fedora Prioritized bugs and issues
16:00:19 <zodbot> The meeting name has been set to 'fedora_prioritized_bugs_and_issues'
16:00:33 <bcotton> #topic Purpose of this meeting
16:00:35 <bcotton> #info The purpose of this process is to help with processing backlog of bugs and issues found during the development, verification and use of Fedora distribution.
16:00:37 <bcotton> #info The main goal is to raise visibility of bugs and issues to help  contributors focus on the most important issues.
16:00:38 <bcotton> #link https://docs.fedoraproject.org/en-US/program_management/prioritized_bugs/#_process_description
16:00:45 <bcotton> #topic Roll Call
16:01:32 * jsmith is lurking
16:02:37 <bcotton> hello, jsmith!
16:02:41 <mattdm> hi!
16:02:47 <bcotton> hello mattdm!
16:03:03 <mattdm> I am on The Document Foundation advisory board call as well
16:03:03 <jsmith> Hello!
16:03:10 <mattdm> so half attention
16:03:20 <bcotton> okay, i'll only count your vote for half then
16:03:32 <bcotton> #topic Nominated bugs
16:03:34 <bcotton> #info 1 nominated bugs
16:03:35 <bcotton> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&f1=flagtypes.name&f2=OP&o1=substring&product=Fedora&query_format=advanced&v1=fedora_prioritized_bug%3F
16:03:37 <mattdm> fair
16:03:40 <bcotton> #topic shim-unsigned-x64: FTBFS in Fedora, hasn't been rebuilt since Fedora 28
16:03:41 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1780827
16:03:55 <bcotton> so the maintainer says this is Not An Issue
16:04:31 <bcotton> it doesn't matter that the shim hasn't rebuilt, so long as we don't drop this package
16:04:38 <mattdm> right. let's not drop shim
16:04:46 <bcotton> basically its an edge case in the FTBFS policy
16:05:16 <mattdm> yeah.
16:06:02 <pjones> that's my position, yes
16:06:21 <pjones> (also keep in mind it is not GPL code, and we don't have strong requirements in that regard)
16:07:43 <bcotton> proposed #agreed BZ 1780827 is rejected as a prioritized bug since it is not a bug, but an edge case in policy. The package should be excepted from the long-term FTBFS cleanup
16:07:52 <bcotton> pjones++
16:07:52 <zodbot> bcotton: Karma for pjones changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:09:37 <pjones> bcotton: and by "the package" we mean shim, shim-unsigned-x64, and shim-unsigned-aarch64
16:09:43 <bcotton> pjones: ack
16:10:12 <bcotton> updated proposed #agreed BZ 1780827 is rejected as a prioritized bug since it is not a bug, but an edge case in policy. shim, shim-unsigned-x64, and shim-unsigned-aarch64 should be excepted from the long-term FTBFS cleanup
16:11:34 <pjones> In the past we had excluded them from mass rebuilds as well, though that seems to have stopped happening at some point, so instead they just fail every time,
16:11:46 <pjones> which is how they came to be noticed as FTBFS in the first place.
16:12:08 <bcotton> ah. i assume you told releng about this?
16:12:32 <pjones> I don't know what mechanism we used to exclude them; my suspicion is that I thought they were on a list somewhere that tools knew about, but actually they were in someone in releng's head somewhere and that person stopped being the person doing the rebuilds.
16:13:04 <pjones> bcotton: I have shouted into several voids about this in the past, but I'm really not sure where the correct place to follow through on this is.
16:13:27 <bcotton> pjones: okay, i'll follow up with releng about this
16:13:32 <pjones> (the fact that the mass rebuilds are completely opaque, with a non-person listed in the change log, doesn't help.)
16:13:47 <bcotton> #action bcotton to check with releng about excluding shim packages from mass rebuild, as they used to be
16:15:01 <bcotton> i'm not hearing any complaints about the proposed agreed so i'll just let zodbot have it
16:15:10 <bcotton> #agreed BZ 1780827 is rejected as a prioritized bug since it is not a bug, but an edge case in policy. shim, shim-unsigned-x64, and shim-unsigned-aarch64 should be excepted from the long-term FTBFS cleanup
16:15:30 <bcotton> anything else on this bug before we move on to the accepted bugs?
16:17:23 <bcotton> that's a no!
16:17:26 <bcotton> #topic Accepted bugs
16:17:27 <bcotton> #info 1 accepted bugs
16:17:29 <bcotton> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=__open__&f1=flagtypes.name&f2=OP&&o1=substring&product=Fedora&query_format=advanced&v1=fedora_prioritized_bug%2B
16:17:34 <bcotton> #topic Migrate Fedora 31 users back to nonmodular content overridden by the eclipse module
16:17:36 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1780827
16:18:10 <bcotton> so we accepted this, but i'm not sure we quite know what to do about it other than to say "yep, this should be fixed"
16:18:37 <bcotton> mattdm: do you know if this is an issue for the eclipse module maintainer or someone else?
16:25:10 <bcotton> okay, i guess we'll leave this for later then
16:25:36 <bcotton> #topic Next meeting
16:25:38 <bcotton> #info The 29 January meeting is canceled. We will meet again on 15 February at 1600 UTC in #fedora-meeting
16:25:52 <bcotton> #undo
16:25:52 <zodbot> Removing item from minutes: INFO by bcotton at 16:25:38 : The 29 January meeting is canceled. We will meet again on 15 February at 1600 UTC in #fedora-meeting
16:26:11 <bcotton> #info The 29 January meeting is canceled. We will meet again on 12 February at 1600 UTC in #fedora-meeting
16:26:38 <bcotton> #endmeeting