magazine
LOGS
13:00:15 <asamalik> #startmeeting Magazine editorial board
13:00:15 <zodbot> Meeting started Wed Dec  4 13:00:15 2019 UTC.
13:00:15 <zodbot> This meeting is logged and archived in a public location.
13:00:15 <zodbot> The chair is asamalik. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
13:00:15 <zodbot> The meeting name has been set to 'magazine_editorial_board'
13:00:15 <asamalik> #meetingname magazine
13:00:15 <zodbot> The meeting name has been set to 'magazine'
13:00:15 <asamalik> #topic Roll call
13:00:15 <asamalik> #chair stickster ryanlerch cverna asamalik sub_pop gregbartholomew bcotton misc rwaltr
13:00:15 <zodbot> Current chairs: asamalik bcotton cverna gregbartholomew misc rwaltr ryanlerch stickster sub_pop
13:00:23 <cverna> good morning all
13:00:28 <bcotton> .hello2
13:00:29 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
13:00:48 <asamalik> good morning, good afternoon, good evening, good night, good all the times!
13:01:28 <stickster> o/
13:01:30 <stickster> .hello pfrields
13:01:31 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
13:02:14 <asamalik> #topic Agenda
13:02:31 <asamalik> #link https://docs.fedoraproject.org/en-US/fedora-magazine/workflow/
13:02:31 <asamalik> #info -- 1/ Last week's stats --
13:02:31 <asamalik> #info -- 2/ In progress followup --
13:02:31 <asamalik> #info -- 3/ Finished articles to review --
13:02:31 <asamalik> #info -- 4/ Articles to edit --
13:02:32 <asamalik> #info -- 5/ Publishing schedule --
13:02:32 <asamalik> #info -- 6/ Article proposals to clarify / approve --
13:02:33 <asamalik> #info -- 7/ Open floor --
13:03:18 <asamalik> I'd like to go through those quickly, so we can talk about the holiday schedule
13:03:46 <cverna> +1
13:03:49 <stickster> go for it
13:03:55 <asamalik> #topic 1/ Last week's stats
13:03:58 <asamalik> #info Week of Nov 25: 69.1K pageviews -- Slightly down from the previous week, but still slightly higher than the average before the last release.
13:04:28 <stickster> Yeah, not terrible
13:05:08 <asamalik> #topic 2/ In progress followup
13:05:12 <asamalik> #info Looking at the 'in progress' column, is there something that's been finished? Anything to follow up on with its author?
13:05:12 <asamalik> #link Board: https://teams.fedoraproject.org/project/asamalik-fedora-magazine/kanban
13:05:27 <asamalik> #info #93Setting up and configuring the sway window manager
13:05:31 <asamalik> #link https://teams.fedoraproject.org/project/asamalik-fedora-magazine/us/93?kanban-status=191
13:05:46 <asamalik> This was ready, but I asked the author to provide some more details
13:06:11 <asamalik> they were suggesting to install some arbitrary set of packages without explaining why
13:06:40 <asamalik> #info #46How to get a complete virtualization system on Fedora Workstation 30
13:06:45 <stickster> Yeah, I saw that one
13:06:52 <asamalik> #link https://teams.fedoraproject.org/project/asamalik-fedora-magazine/us/46?kanban-status=191
13:07:36 <asamalik> just added the preview URL
13:07:36 <asamalik> https://fedoramagazine.org/?p=29700&preview=true
13:07:44 <asamalik> still in progress
13:08:10 <stickster> #82 and #104 are definitely ready for edit/image
13:09:01 <asamalik> stickster: yes! I've moved those two in the morning today and tagged them with a date for publishing
13:09:05 <stickster> Cool
13:09:07 <asamalik> #info #108 Fedora - The Origins
13:09:12 <asamalik> #link https://teams.fedoraproject.org/project/asamalik-fedora-magazine/us/108?kanban-status=191
13:09:44 <asamalik> this one will be probably in progress for some time, it's about the history of Fedora (still discussed in the pagure ticket)
13:09:46 <asamalik> I'll find the link
13:09:59 <stickster> https://fedoramagazine.org/?p=29794&preview
13:10:00 <asamalik> https://pagure.io/fedora-magazine-proposals/issue/34
13:10:04 <stickster> ^ yeah, that too
13:10:21 <stickster> This article will need some work, it's mainly a very big transcription of an interview at the moment
13:10:24 <asamalik> stickster: thanks
13:10:50 <asamalik> yeah
13:11:07 <asamalik> I like the idea, though
13:11:18 <asamalik> let's see how it goes
13:11:25 <asamalik> and we can always help in the process
13:12:02 <asamalik> #info #106Using the screen utility
13:12:08 <asamalik> #link https://teams.fedoraproject.org/project/asamalik-fedora-magazine/us/106?kanban-status=191
13:12:31 <stickster> Wow, that's a detailed proposal!
13:12:38 <asamalik> yep!
13:13:14 <stickster> +1 from me, although I switched to tmux several years ago
13:13:37 <asamalik> ha me too
13:13:40 <asamalik> but yeah, still in progress
13:13:52 <asamalik> that's all here!
13:14:07 <asamalik> #topic 3/ Finished articles to review
13:14:11 <asamalik> #info Looking at the 'review' column, let's decide which articles are good to go. Move each either to the 'to edit' (finished) or to the 'in progress' (needs more work) and provide feedback.
13:14:11 <asamalik> #link Board: https://teams.fedoraproject.org/project/asamalik-fedora-magazine/kanban
13:14:25 <asamalik> so...
13:14:28 <asamalik> #info #101Build your own cloud with Fedora 30 and nextcloud
13:14:33 <asamalik> #link https://teams.fedoraproject.org/project/asamalik-fedora-magazine/us/101?kanban-status=196
13:14:45 <asamalik> there was a discussion on the list about this one
13:14:53 <asamalik> I commented on the card this morning
13:15:21 <stickster> Is owncloud the same as nextcloud?
13:15:48 <asamalik> stickster: I believe it's similar to openoffice vs. libreoffice
13:16:26 <asamalik> or what I meant was: they have the same origin, but are now distinct projects
13:16:56 <asamalik> https://lists.fedoraproject.org/archives/list/magazine@lists.fedoraproject.org/message/VG4M7VZ276NI73OCE6CRI6SXYHMYKBXK/
13:17:01 <asamalik> ^^ that's basically the main point
13:17:20 <stickster> Yeah, this looks a little hinky at the moment
13:18:02 <stickster> I *do* think it's OK for us to have upstream installation instructions. Not everything can be packaged, and if we make a habit of not covering anything outside the repos, it locks out a lot of useful things that help promote using Fedora.
13:18:18 <asamalik> stickster: that's a good point, yes!
13:18:20 <stickster> If the author fixes to use the right installation instructions from upstream, I think this should be OK.
13:18:24 <stickster> Just my opinion
13:18:46 <asamalik> no I completely agree.. for some unknown reason that didn't struck my mind as an option this morning
13:19:10 <bcotton> agreed
13:19:13 <asamalik> ok let me update the card
13:21:25 <asamalik> done
13:21:29 <stickster> neat
13:21:44 <asamalik> #topic 4/ Articles to edit
13:21:47 <asamalik> #info Looking at the 'to edit' column, assign an editor and a cover image creator.
13:21:47 <asamalik> #link Board: https://teams.fedoraproject.org/project/asamalik-fedora-magazine/kanban
13:22:17 <asamalik> #info #82[3-5] cool terminal pagers
13:22:22 <asamalik> #link https://teams.fedoraproject.org/project/asamalik-fedora-magazine/us/82?kanban-status=192
13:22:26 <stickster> Hit me for this one
13:22:32 <asamalik> stickster++
13:22:38 <stickster> #action stickster edit and image for terminal pagers article
13:23:02 <asamalik> #info #104 Organizing all those 1s and 0s
13:23:11 <asamalik> #link https://teams.fedoraproject.org/project/asamalik-fedora-magazine/us/104?kanban-status=192
13:23:29 <asamalik> https://fedoramagazine.org/?p=29728
13:23:36 <asamalik> this URL works — I have updated it in the card
13:23:42 <asamalik> I can do this one
13:23:58 <asamalik> ... those memories of learning this!
13:24:13 <asamalik> #action asamalik edit and image #104 Organizing all those 1s and 0s
13:24:21 <stickster> disco
13:24:27 <asamalik> #topic 5/ Publishing schedule
13:24:34 <asamalik> #info Looking at the 'queued' and 'to edit' columns, decide the publishing schedule for the next week period.
13:24:34 <asamalik> #info If there is not enough content, we might also need to look at the 'in progress' or even the 'article spec' columns come up with additional content.
13:24:34 <asamalik> #link Board: https://teams.fedoraproject.org/project/asamalik-fedora-magazine/kanban
13:24:51 <asamalik> so, running my magical container we get the following:
13:24:53 <asamalik> Fri 06 Dec 2019: #82 [3-5] cool terminal pagers
13:24:53 <asamalik> Mon 09 Dec 2019: #104 Organizing all those 1s and 0s
13:25:03 <asamalik> so we need one more for next Wednesday
13:25:14 <stickster> asamalik: what about the rebasing Silverblue article?
13:25:30 <asamalik> stickster: so about that one... it still doesn't work in gnome software
13:25:38 <stickster> Oh I see
13:25:42 <asamalik> so I was wondering if we should just go for the terminal and send it out?
13:26:05 <stickster> Yeah
13:26:13 <asamalik> because at this point we might either do that, or wait, but then we might end up publishing it months after the release....
13:26:13 <stickster> I'll get it done tonight
13:26:19 <asamalik> woot
13:26:25 <stickster> Oh  sorry, I was referring to the wrong thing
13:26:54 * asamalik was talking about #105
13:26:56 <stickster> I agree we should go for the terminal method.
13:27:03 <cverna> +1 to do only from the terminal
13:27:18 <asamalik> ok so that's agreed
13:27:33 <stickster> Yeah, it would be OK to note the bug in GNOME Software for refernece.
13:27:37 <stickster> *reference.
13:27:39 <cverna> users of silverblue shouldn't be too scared of using the terminal :)
13:27:39 <asamalik> right
13:27:47 <stickster> cverna++
13:28:16 <asamalik> haha right!
13:28:19 <asamalik> ok card updated
13:28:29 <asamalik> do we want to shift everything and get it out Friday?
13:28:53 <asamalik> or do those few days matter at this point?
13:29:19 * cverna don't have a strong opinion there
13:29:29 <cverna> doesn't* :P
13:30:02 <asamalik> yeah... you know what, let's just keep it as it is and go for next wednesday, that's fine
13:30:10 <asamalik> and maybe we can make the author to do the update :P
13:31:29 <asamalik> and it already has an image
13:31:31 <asamalik> and I can edit
13:31:33 <stickster> Yeah. And if not one of us can certainly find time.
13:31:43 <asamalik> yep I could do that if necessary
13:32:20 <asamalik> #proposed #agreed PUBLISHING SCHEDULE: Fri 06 Dec 2019: #82 [3-5] cool terminal pagers (stickster edit + image) -- Mon 09 Dec 2019: #104 Organizing all those 1s and 0s (asamalik edit + image) -- Wed 11 Dec 2019: #105 How to rebase to Fedora 31 on Silverblue (asamalik edit)
13:32:26 <stickster> +1 lgtm
13:33:13 <asamalik> #agreed PUBLISHING SCHEDULE: Fri 06 Dec 2019: #82 [3-5] cool terminal pagers (stickster edit + image) -- Mon 09 Dec 2019: #104 Organizing all those 1s and 0s (asamalik edit + image) -- Wed 11 Dec 2019: #105 How to rebase to Fedora 31 on Silverblue (asamalik edit)
13:33:36 <cverna> +1
13:33:40 <asamalik> let's skip proposals right now, I encourage everyone to comment on those async :)
13:33:58 <asamalik> #topic 7/ Open floor
13:34:16 <asamalik> that gives us ~25 mins to talk about other stuff — like the holiday publishing schedule for example
13:34:36 <stickster> agreed
13:35:34 <stickster> #info Last year of stats: https://fedoramagazine.org/wp-admin/admin.php?page=stats&view=postviews&summarize&numdays=365
13:35:48 <cverna> 🎅🎅🎅
13:36:32 <stickster> We could start sorting these into buckets: https://hackmd.io/7j1TOmKNTlKnpaHYlB3sjQ?edit
13:36:42 <asamalik> so I liked bcotton's proposal:
13:36:43 <asamalik> 1. Best developer articles (5 articles)
13:36:43 <asamalik> 2. Best sysadmin articles (5 articles)
13:36:43 <asamalik> 3. Best user tools articles (5 articles)
13:36:44 <asamalik> 4. Most-read articles (10? most-read, perhaps adjusted for calendar)
13:36:44 <asamalik> 5. Editors' choice (5 articles that the editors loved, perhaps with a
13:36:44 <asamalik> focus on highlighting first-time writers)
13:37:24 <asamalik> stickster: oh you're one (big) step ahead of me!
13:37:31 <stickster> Just trying to save you time :-)
13:37:46 <asamalik> that is very much appreciated, thanks :)
13:38:11 <asamalik> of course i3 is the #1
13:43:48 <cverna> do we just take the top 5, or we can adapt a little :P
13:44:06 <cverna> in developer category we have a lot of VS code
13:45:03 <asamalik> nice!
13:45:41 <stickster> asamalik: cverna: One thing we need to do is verify all the listed articles are 2019
13:45:47 <stickster> I think they are, though.
13:46:00 <asamalik> yep! that's a good point
13:46:07 <asamalik> the #1 i3 is not I believe
13:46:10 <asamalik> but we could update it
13:47:12 <asamalik> or do we want to use the "Most read" for popular ones not from 2019?
13:47:31 <stickster> asamalik: I like that idea, so we're not scraping bottom of the barrel here
13:47:41 <asamalik> yep
13:47:43 <stickster> #info all time stats: https://fedoramagazine.org/wp-admin/admin.php?page=stats&view=postviews&summarize&numdays=-1
13:48:06 <stickster> Ha, STILL i3!!!
13:48:11 <bcotton> i'd like to keep it to 2019 if we can, that way we can do the same every year. the hard part is that an article from january will be more popular than one from november
13:48:28 <bcotton> but i also think it's okay for an article to appear in most read and one of the other lists
13:49:06 <asamalik> bcotton: yeah that's a good point... we should have a way to approximate popularity for the newer one what it would be in a year so it's fair...
13:49:23 <bcotton> one way would be to sort by average views per week or something
13:49:46 <stickster> We may want to scale back to top 4 in each category.
13:49:48 <asamalik> yeah
13:49:48 <bcotton> that'll weight toward more recent articles, but it's a start
13:50:03 <asamalik> oh actually, to give value to the non-2019 — we should update all of those to work on f31
13:50:13 <bcotton> +1 to top 4. four foundations, four articles :-)
13:50:29 <bcotton> asamalik: maybe if we had more time :-D
13:50:33 <bcotton> i do like that idea though
13:50:58 <asamalik> bcotton: so let's keep it as an idea for times with time and no ideas :D
13:53:09 <cverna> ok I think I have the for developers ready with 2019 articles
13:53:09 <asamalik> nice! so I think we have a good list there
13:53:29 <asamalik> so let's just grab it and send it to the list?
13:54:16 <cverna> +1
13:54:31 <stickster> asamalik: OK, looks good!
13:54:43 <asamalik> cool! taking it and sending it
13:54:58 <stickster> \o/
13:55:08 <asamalik> cookies for everyone!
13:55:17 <asamalik> sent
13:55:25 <asamalik> ok, anything else for today?
13:55:38 <asamalik> I'll leave it on the list for ~2 days and then create cards for those
13:57:34 <asamalik> all right, thanks all for coming, we did some useful stuff today!
13:57:58 <asamalik> #endmeeting