i18n
LOGS
05:31:02 <paragan> #startmeeting i18n
05:31:02 <zodbot> Meeting started Tue Nov  5 05:31:02 2019 UTC.
05:31:02 <zodbot> This meeting is logged and archived in a public location.
05:31:02 <zodbot> The chair is paragan. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:31:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
05:31:02 <zodbot> The meeting name has been set to 'i18n'
05:31:02 <paragan> #meetingname i18n
05:31:02 <zodbot> The meeting name has been set to 'i18n'
05:31:02 <paragan> #topic agenda and roll call
05:31:11 <paragan> #link https://fedoraproject.org/wiki/I18N/Meetings/2019-11-05
05:31:17 <mfabian>05:31:27 <suanand> .hello2
05:31:28 <zodbot> suanand: suanand 'Sundeep Anand' <suanand@redhat.com>
05:31:34 <pyadav> hi
05:31:35 <vishal_vvr> hi
05:32:22 <petersen> hi
05:32:55 <paragan> Hi all
05:33:02 <paragan> last week we saw Fedora 31 released
05:33:51 <paragan> Good to see few of Changes got included in that release :)
05:34:41 <paragan> we are monitoring any feedback for this release
05:34:52 <epico> hi
05:35:22 <paragan> hopefully soon many will be seen as using Fedora 31 release :)
05:35:58 <mfabian> It works  mostly fine for me.
05:36:02 <petersen> Yeah - I need to upgrade!
05:36:29 <paragan> sure
05:36:44 <paragan> thanks mfabian for your feedback
05:36:57 <paragan> yes for me also F31 release working fine
05:37:20 * suanand for me also
05:37:29 <paragan> cool
05:38:28 <vishal_vvr> works fine for me aswell, only hexchat text is rendering broken at times
05:38:55 <paragan> Individuals can go through their assigned bugs for F31 and try to fix them soon :)
05:39:15 <paragan> vishal_vvr, you are using non-English locale?
05:39:38 <mfabian> vishal_vvr: Is there a bug?
05:39:39 <vishal_vvr> paragan, i am using en_US
05:39:50 <petersen> vishal_vvr: oh
05:40:07 <paragan> okay, good to report it in bug with all available details
05:40:16 <vishal_vvr> ahh it was a font issue, changed to liberation it worked :P
05:40:56 <paragan> hmm
05:41:26 <mfabian> I could not yet figure  out how to  check  whether dhcp  is working  correctly or not.  Previously dhclient was  used and  there was a /var/run/dhclient*.pid file when it was running. Now it is somehow done by network manager. After the update I first had no IP at all and did run dhclient manually. Now I get an IP after a reboot, maybe some update has fixed the problem ...
05:41:45 <pravins> hi
05:42:05 <pravins> i also have to update
05:42:59 <mfabian> Apparently I cannot update the zanata-client packages to f31 versions, but as  we move to weblate this probably doesn't matter.
05:43:41 <paragan> okay
05:44:02 <suanand> we have https://docs.weblate.org/en/latest/wlc.html
05:44:22 <petersen> I was just trying to test ibus with the KDE Live image
05:44:51 <mfabian> wlc is not yet working for me, I hope I can figure that out soon.
05:45:00 <petersen> mfabian: zanata-python-client too
05:46:04 <paragan> #chair mfabian suanand pyadav vishal_vvr petersen epico pravins
05:46:04 <zodbot> Current chairs: epico mfabian paragan petersen pravins pyadav suanand vishal_vvr
05:46:13 <paragan> any other feedback anyone want to share?
05:47:05 <suanand> mfabian, okay (probably we can tweak)
05:48:24 <paragan> Thanks all for this feedback
05:48:52 <paragan> now lets use this feedback to improve required things in next Fedora 32 release :)
05:49:21 <paragan> Please note now Fedora Program Manager has stopped regular wiki page schedule page creation
05:49:50 <paragan> it will be now
05:49:53 <paragan> #info https://fedorapeople.org/groups/schedule/f-32/f-32-key-tasks.html
05:50:39 <petersen> I noticed - is that officially announced?
05:50:46 <petersen> How to enable ibus in KDE?
05:51:45 <paragan> petersen, I am not sure if its officially announced but Ben has confirmed me that in some ticket discussion I remember
05:51:53 <mfabian> petersen: I think I tried it in a vm and it worked for  me.
05:52:52 <petersen> aha
05:53:21 <petersen> So the CVE fix doesn't affect f31?
05:54:16 <petersen> I wrote a short section on Pango Bitmap fonts in the F31 Common Bugs page
05:54:32 <epico> petersen: thanks!
05:54:43 <petersen> https://fedoraproject.org/wiki/Common_F31_bugs#Pango_no_longer_supports_bitmap_format_fonts
05:54:49 <petersen> Please correct my mistakes
05:55:13 <petersen> Those two things are my main concern right now
05:57:59 <paragan> petersen++
05:57:59 <zodbot> paragan: Karma for petersen changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
05:58:24 <paragan> Sure we will try to resolve those things soon
05:58:30 <paragan> #topic Upcoming schedule
05:59:38 <epico> petersen++
05:59:38 <zodbot> epico: Karma for petersen changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
05:59:43 <paragan> #info 2019-12-25 Change Checkpoint: Proposal submission deadline (Changes requiring infrastructure changes)
06:00:17 <paragan> #info 2019-12-31 Change Checkpoint: Proposal submission deadline (Changes requiring mass rebuild)
06:00:18 <paragan> #info 2019-12-31 Change Checkpoint: Proposal submission deadline (System Wide Changes)
06:00:45 <paragan> so request all members to think and see if they can submit any Changes this time also
06:01:25 <petersen> Ah no ibus IMEs in KDE Live
06:02:05 <petersen> Anyone got any Changes in mind or in the pipeline yet?
06:03:20 <mfabian> I still would like to try again to make ibus-typing-booster the default for Indian languages  ...
06:05:53 <pravins> lets bring and debate of some crazy ideas :)
06:06:00 <pravins> Cloud IME :)
06:07:03 * suanand thinks pravins you mean IME-as-a-service ? or IME for cloud-apps?
06:07:34 <pravins> IME as a Service sounds much better.
06:08:23 <suanand> use-case?
06:08:57 <pravins> Cloud Apps
06:09:29 <pravins> not sure as of now, but i would like to see some crazy, out of the box ideas from community members
06:10:09 <paragan> lets think on any ideas
06:10:12 <paragan> let's move
06:10:22 <paragan> #topic No assignee issues
06:10:22 <paragan> #info #114: rotate chairperson? (petersen)
06:10:22 <paragan> #link https://pagure.io/i18n/issue/114
06:10:42 <suanand> (pulling i18n components to microservice arch is a good  idea .. but should be backed with strong know-how and use-cases)
06:10:45 <paragan> are people fine with rotating chairperson?
06:10:58 <petersen> Okay this one pretty crazy, hehe :)
06:10:59 <paragan> anyone want to chair next meeting :)
06:12:07 <petersen> The idea behind this is to increase engagement in this meeting
06:12:31 * suanand shall I? from Dec?
06:13:02 <suanand> (I mean I may not be available in next meeting)
06:13:24 <vishal_vvr> paragan, i can chair next meeting
06:14:13 <paragan> Okay let vishal_vvr chair next meeting :)
06:14:36 <paragan> do contact me if you need any help for creating agenda page
06:14:37 <pravins> vishal_vvr: ++
06:14:46 <paragan> suanand, can go next time :)
06:14:53 <vishal_vvr> paragan, sure :)
06:15:00 <suanand> petersen++ mfabian++ paragan++ vishal_vvr++
06:15:01 <zodbot> suanand: Karma for petersen changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
06:15:04 <zodbot> suanand: Karma for pnemade changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
06:15:07 <zodbot> suanand: Karma for vishalvvr changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
06:15:27 <petersen> Gosh so much karma :)
06:15:52 <paragan> :)
06:16:26 <paragan> #action Vishal will chair meeting on 19th Nov
06:16:36 <paragan> moving to next ticket
06:16:50 <paragan> #info #112: Docs Beats for Fedora 31 (pnemade)
06:16:50 <paragan> #link https://pagure.io/i18n/issue/112
06:17:03 <paragan> This was not properly reviewed
06:17:34 <paragan> individuals reviewed their text but I think we missed its appearance in release-notes
06:18:10 <paragan> we got 3 changes and all should have been added under https://pagure.io/fedora-docs/release-notes/blob/f31/f/modules/release-notes/pages/desktop/I18n.adoc
06:18:15 <paragan> but only ibus got
06:18:20 <petersen> Ah
06:18:33 <paragan> langpacks got added in https://pagure.io/fedora-docs/release-notes/blob/f31/f/modules/release-notes/pages/sysadmin/Distribution.adoc
06:18:35 <petersen> The other went.. where?
06:18:45 <paragan> and noto fonts in https://pagure.io/fedora-docs/release-notes/blob/f31/f/modules/release-notes/pages/desktop/Desktop.adoc
06:19:13 <paragan> I will report to move other 2 change notes under i18n page
06:22:02 <paragan> moving on
06:22:10 <petersen> https://docs.fedoraproject.org/en-US/fedora/f31/release-notes/
06:24:10 <paragan> #info #110: Fedora 29 Bug triaging (pnemade)
06:24:10 <paragan> #link https://pagure.io/i18n/issue/110
06:25:37 <paragan> the current 18 bug list is likely to get auto-closed as EOL bugs
06:28:59 <paragan> if anyone still want to look and fix or triage please do so
06:29:03 <paragan> #topic Open Floor
06:29:08 <paragan> anything to discuss here?
06:31:05 <mfabian> Did anybody try weblate?
06:31:17 <mfabian> I could not figure out how to upload screenshots.
06:31:39 <mfabian> https://translate.stg.fedoraproject.org/screenshots/ibus-typing-booster/app/
06:32:09 <mfabian> I have no idea how uploading screenshots is supposed to work.
06:32:21 <petersen> Please ask :-)
06:32:32 <petersen> How did it work?
06:32:51 <mfabian> How did weblate work?
06:33:37 <petersen> I have no context
06:34:09 <petersen> These are screenshots for projects on Weblate?
06:34:13 <mfabian> We have a test instance  of weblate and ibus-typing-booster is there as a test project: https://translate.stg.fedoraproject.org/projects/ibus-typing-booster/app/
06:34:19 <suanand> spathare did some testing (w.r.t Zanata)
06:34:24 <petersen> Nod - great thanks
06:35:05 <mfabian> Apparently one can upload screenshots to help the translators, so I could upload screenshots if ibus-typing-booster which the translators can see so they can see the strings in their graphical context.
06:35:14 <petersen> I see
06:35:18 <mfabian> But I couldn't figure out how.
06:35:25 <mfabian> Translating works fine.
06:35:49 <mfabian> One can just go to https://translate.stg.fedoraproject.org/projects/ibus-typing-booster/app/ and if one has a Fedora account, start translating.
06:36:00 <petersen> Great
06:36:35 <mfabian> If the language one wants to translate is not there yet, one can click on the ̈Start new translation" button at the bottom of the page and add it.
06:37:12 <mfabian> I got several new translations so far: Odia, Hungarian, Arabic, Hebrew, Swahili, Portuguese
06:37:41 <suanand> mfabian, perhaps you might have already seen: https://docs.weblate.org/en/latest/admin/translating.html#additional-info-on-source-strings
06:38:16 <mfabian> suanand: Thank you, I did not see that yet!
06:38:40 <petersen> Slightly amusing how the stats are full width :)
06:39:45 <petersen> mfabian: looks like yours is the first software
06:40:25 <mfabian> petersen: Yes, Jean-Baptiste asked me if I would like ibus-typing-booster there as a first test case ☺
06:40:34 <petersen> I saw
06:41:24 <paragan> mfabian++ Good you are using weblate
06:41:24 <zodbot> paragan: Karma for mfabian changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
06:43:35 <paragan> I think we are overtime now :)
06:43:45 <paragan> Thank you all who joined this meeting
06:43:58 <paragan> please continue discussion in our irc channel
06:44:05 <paragan> #endmeeting