fedora_iot_working_group_meeting
LOGS
14:02:41 <pwhalen> #startmeeting Fedora IoT Working Group Meeting
14:02:41 <zodbot> Meeting started Wed Jul 24 14:02:41 2019 UTC.
14:02:41 <zodbot> This meeting is logged and archived in a public location.
14:02:41 <zodbot> The chair is pwhalen. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:41 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:02:41 <zodbot> The meeting name has been set to 'fedora_iot_working_group_meeting'
14:02:41 <pwhalen> #chair pwhalen pbrobinson bcotton tdawson
14:02:41 <pwhalen> #topic roll call
14:02:41 <zodbot> Current chairs: bcotton pbrobinson pwhalen tdawson
14:03:03 * pwhalen is here
14:03:11 <bcotton> .hello2
14:03:14 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
14:05:03 <pbrobinson> #topic 1) ==== Working Group process and admin  ====
14:05:20 <pbrobinson> I don't have too much to offer for this one
14:05:41 <pbrobinson> #link https://docs.fedoraproject.org/en-US/iot/edition-promotion/
14:06:07 <pbrobinson> #info I'm working through the edition promotion pieces, feedback is still welcome
14:06:23 <pbrobinson> bcotton: do you have anything to add here? Or anyone else?
14:07:04 <bcotton> yes
14:07:33 <pbrobinson> bcotton: go!!
14:07:35 <bcotton> #info bcotton has nudged badges team on an IoT badge. We're waiting for design resources
14:08:28 * pbrobinson would also love a hex sticker, would we base that on the same design as the badge or the logoy thing that's been referenced elsewhere?
14:08:56 <pbrobinson> like the 9 squares on https://getfedora.org/
14:09:13 <bcotton> i'd think a logoy thing would work better. probably be less graphically involved than the badge
14:11:04 * laubersm lurks
14:11:13 <pbrobinson> hey laubersm how goes?
14:11:27 <bcotton> oh, i have one other thing
14:11:33 <pbrobinson> bcotton: go!
14:11:42 <laubersm> been teaching a lot again.  Students are on a lab atm.
14:11:52 <bcotton> i started a thread about "let's have a single place for bugs" that i recall has some responses but i need to...
14:12:05 <bcotton> #action bcotton to follow up on bug-filing mailing list thread
14:12:31 <pbrobinson> yes, I need to reply, I explicitly was waiting to let others venture their opinions first
14:14:21 <pbrobinson> anything more?
14:14:35 <laubersm> I don't know all the current tooling options but I from what I saw in the thread I would think bugzilla is still the best option. I can visualize reports coming in that overlap with other fedora components so the option to transfer, duplicate, and reference would be required.
14:15:03 <bcotton> nothing more from me
14:15:12 <bcotton> laubersm: agreed
14:15:42 <pbrobinson> yes. that was basically my thoughts as well
14:15:45 * pwhalen also likes bugzilla
14:16:48 <pbrobinson> #topic 2) ==== Fedora 31 ====
14:17:11 <pbrobinson> so we've got mostly regular builds on rawhide
14:17:42 <pbrobinson> I need to work out why the nightly cron jon isn't running, but I'm going to rebuild the compose host to F-30 so if it still doesn't work then I'll dig
14:18:02 <pbrobinson> #info regular rawhide IoT composes
14:18:12 <pbrobinson> #info mass rebuild for F-31 kicks off today
14:19:48 <pwhalen> has anyone hit any issues with f31?
14:20:35 <pbrobinson> has anyone tested F-31?
14:23:07 * pwhalen has tested f31
14:23:46 <pwhalen> looking now, I'm seeing an error 'error: Unrecognized archive format' when I try to do an upgrade
14:24:11 * jsmith has not tested with F-31 yet :-(
14:24:24 <pwhalen> I'll do some more testing, file a bug if needed
14:24:40 <pbrobinson> pwhalen: I wonder if that is due to the switch to zstd for compression in rpm? Do you have rpms opverlaid out of interest?
14:25:14 <pwhalen> I do.. this was an upgrade from an older compose
14:26:01 <pwhalen> https://paste.fedoraproject.org/paste/y-CPEhdL6jJA2VR8BZcH4A
14:26:25 <pwhalen> so that sounds right
14:27:14 <pbrobinson> pwhalen: so I suspect we need to file a bug with rpm-ostree, can you do that
14:27:37 <nirik> https://github.com/projectatomic/rpm-ostree/pull/1866
14:28:06 <nirik> https://discussion.fedoraproject.org/t/not-able-to-update-silverblue-31/2023/13
14:28:08 <pbrobinson> nirik: awesome, happen to know if there's RHBZ
14:28:12 <pwhalen> thanks nirik
14:28:18 <nirik> not sure...
14:28:31 <pwhalen> if not, I can file one
14:29:21 <nirik> the zstd thing just kind of appeared/landed without much notice I'm afraid. ;(
14:29:39 <pbrobinson> yes, pity, nor much discussion
14:29:49 <pbrobinson> oh well
14:33:00 <pbrobinson> #topic 3) ==== Fedora 30 ====
14:33:13 <pbrobinson> #info F-30 has moved to stable branch
14:33:47 <pbrobinson> #info F-29 users will move to F-30
14:33:49 <pbrobinson> it seems to have been a fine transition on a number of devices for me
14:34:01 <pwhalen> upgrade worked for me without issue
14:34:44 <pbrobinson> #info F-30 users will need to do a "rpm-ostree rebase -b fedora/stable/<ARCH>/iot" as per the docs
14:37:46 <pbrobinson> anyone with any testing or queries or such?
14:39:27 <pbrobinson> #topic 4) ==== Open Floor ====
14:39:37 <pbrobinson> anyone have anything for open floor?
14:39:45 * pwhalen has nothing to add
14:40:18 <bcotton> nothing here
14:40:45 <pbrobinson> I'll leave it open for a few mins, if anyone has anything feel free to just jump right in
14:45:37 <pbrobinson> https://github.com/latchset/clevis/issues/109
14:45:42 <pbrobinson> bah
14:45:48 <pbrobinson> thank you all
14:45:48 <pbrobinson> #endmeeting