fedora_iot_working_group_meeting
LOGS
14:00:31 <pbrobinson> #startmeeting Fedora IoT Working Group Meeting
14:00:31 <zodbot> Meeting started Wed Jun  5 14:00:31 2019 UTC.
14:00:31 <zodbot> This meeting is logged and archived in a public location.
14:00:31 <zodbot> The chair is pbrobinson. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:31 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:31 <zodbot> The meeting name has been set to 'fedora_iot_working_group_meeting'
14:00:31 <pbrobinson> #chair pwhalen pbrobinson bcotton
14:00:31 <pbrobinson> #topic roll call
14:00:31 <zodbot> Current chairs: bcotton pbrobinson pwhalen
14:01:15 * pwhalen is here
14:01:18 <pbrobinson> who do we have around?
14:01:21 <pwhalen> good morning folks
14:02:09 <bcotton> .hello2
14:02:10 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
14:02:20 <tdawson> Hello
14:02:30 <dressedfez> hi
14:02:52 <pbrobinson> #topic 1) ==== Working Group process and admin  ====
14:03:02 <pbrobinson> I don't have anything of note here
14:03:08 <bcotton> o/
14:03:15 <pbrobinson> bcotton: go!
14:03:26 <pbrobinson> I was literally about to ask you ;)
14:04:20 <bcotton> so dressedfez discovered that our Taiga board isn't very open to newcomers. Taiga doesn't, as far as we can tell, have the ability for people to self-add to projects. but we can edit the permissions on various things to make it easier for non-members to interact
14:05:04 <bcotton> the "unauthenticated user" role, AFAICT, is not as described, so we can open permissions up on that to let people create/comment/edit whatever
14:06:01 <pbrobinson> bcotton: is "unauthenticated user" literally that? How does it deal with spam and people doing things we don't want?
14:06:14 <bcotton> not something to decide this minute, but let's think about how we want to enable folks to interact without having to be added to the project (and what sort of requirements we might put on being added to the project, ranging from "they asked to be added" to "they did X things"...and then who should have the ability to add users)
14:07:01 <bcotton> pbrobinson: from my testing, it still requires being logged in. i'm working on getting more confirmation of that, but with an incognito logged-out browser, i haven't been able to abuse it much. that may be an artifact of how the FAS authentication works?
14:07:09 <pbrobinson> bcotton: that makes sense, it sounds like something we should consider for the entire teams.fp.o instance?
14:08:09 <bcotton> pbrobinson: it's not a instance-wide config, afaict. i was hoping infra would give us some docs as promised, but that hasn't materialized yet. so i may sit down with asamalik and work on making some docs for folks so that i'm not manually telling people about this :-)
14:08:50 <asamalik> bcotton: let's do this! :)
14:08:57 <pbrobinson> bcotton: maybe taiga could change the "defaults" across the instance
14:09:17 <bcotton> but i think we need to have the "how do we want IoT interactions to work?" conversation, and then we can try to figure out the right settings to implement that policy
14:09:22 <pbrobinson> how would the docs be different to upstream?
14:09:30 <pbrobinson> bcotton: sure
14:09:35 <bcotton> pbrobinson: mostly about how to *use* it in fedora
14:09:53 <bcotton> pbrobinson: e.g. https://docs.fedoraproject.org/en-US/taiga-docs/taiga/
14:09:57 <bcotton> #link https://docs.fedoraproject.org/en-US/taiga-docs/taiga/
14:10:45 <pbrobinson> bcotton: you happy to have the action to lead this?
14:11:42 <bcotton> pbrobinson: action away!
14:12:28 <pbrobinson> #action: bcotton to investigate and suggest ways to adjust the iot taiga instance settings to make it easy for contributors to get involved
14:12:39 <x3mboy> Hi!
14:12:45 <pbrobinson> anything else for WG bits?
14:12:47 <x3mboy> .hello2
14:12:48 <zodbot> x3mboy: x3mboy 'Eduard Lucena' <eduardlucena@gmail.com>
14:14:24 <pbrobinson> #topic 2) ==== Fedora 30 ====
14:14:55 <pbrobinson> i plan to change the streams over next week with our next release
14:15:22 <pbrobinson> this will move all f29 users to f30, I need to look at a few bits how we keep the f30 users on the stable train here
14:16:46 <bcotton> pbrobinson: can you get a magazine article written about this? (or fill in a skeleteon that "somebody" starts for you?)
14:16:51 <pbrobinson> #info plan to change over ostree repos for f30 next week, this will move f29 users to f30
14:17:07 <pwhalen> When is the next f30 release planned?
14:17:17 <pbrobinson> bcotton: can do, there's probably already one somewhere for atomic
14:17:23 <bcotton> this is a good opportunity to showcase how Fedora IoT means you're not stuck with outdated IoT devices forever and ever
14:17:45 <pbrobinson> pwhalen: "mid June", depends a bit on how I recover
14:18:04 <pbrobinson> my brain has been quite a bit of mush this week so it's mostly been "light duties"
14:18:08 <bcotton> pbrobinson: ideally we'd have it published before you do the move, but if that's not reasonable, that's okay. i can start a draft for you today or tomorrow, if that works?
14:18:20 <pwhalen> pbrobinson, sounds good (not the illness)
14:18:38 <pbrobinson> bcotton: mostly makes sense, or we can sync up early next week?
14:18:49 <bcotton> pbrobinson: sounds good
14:19:07 <bcotton> #action bcotton to start draft of Fedora Magazine article about F29->F30 move
14:19:27 <bcotton> (see? this is why i don't usually say much in these meetings. i end up with #action)
14:19:36 <pbrobinson> bcotton: :-P
14:19:39 <pwhalen> heh
14:19:47 <tdawson> :)
14:23:13 <pbrobinson> #topic 3) ==== Fedora 31 planning ====
14:23:33 <pbrobinson> I've not done much here except thinking. I need to get those thoughts into taiga
14:25:00 <pwhalen> anything you want to share now?
14:25:27 <pbrobinson> a bunch around security
14:25:44 <pbrobinson> a toolbox container so we can slim down the base image
14:26:01 <pbrobinson> a bunch else that doesn't currently come to my mind
14:27:07 <pwhalen> I started to look at the existing fedora-toolbox, perhaps we could add tools to that, or create a new one
14:27:40 <pbrobinson> yes, that was going to be one starting point
14:28:07 <pbrobinson> I think they actually package and ship the container, I'm not sure that's something we necessarily want to do
14:28:38 <pbrobinson> we also need a status update from CPE team on the status of arm containers in the container build pipeline
14:28:48 <pwhalen> right, it is a container. and currently x86_64 only
14:28:54 <pbrobinson> that's only been promised since f28
14:30:12 <cverna> we don't have enough hardware for that
14:30:39 <cverna> we have an aarch64 cluster one 1 box in stg and prod
14:30:51 <bcotton> pbrobinson: do you have a ticket handy for that? i can bring it up in the next biweekly meeting with jim and leigh
14:31:41 <pbrobinson> bcotton: I don't remember if there was a ticket or just an open promise, I got them the HW for the aarch64 side of things
14:31:52 <pbrobinson> I'll take a look and see what I can find
14:32:07 <pbrobinson> they were suppose to add all arches for like years
14:32:11 <bcotton> okay, great. let me know. my next meeting is the 14th os there's time
14:33:37 <cverna> I had this issue that I created --> https://pagure.io/cpe-planning/issue/7
14:33:39 <pbrobinson> bcotton: will do
14:33:48 <pbrobinson> cverna++ thanks
14:33:48 <zodbot> pbrobinson: Karma for cverna changed to 10 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:34:13 <bcotton> cverna++
14:34:13 <zodbot> bcotton: Karma for cverna changed to 11 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
14:34:21 <cverna> but as I said it mostly works except that we don't have enough hardware
14:35:05 <pbrobinson> cverna: there was 2 thunderX2 servers for it, were they moved to something else? How much hardware is actually needed, they're pretty decent boxes
14:35:55 <cverna> what I was given is one vm in stg and one vm in prod that was taken off the koji builders
14:36:00 <cverna> more details --> https://pagure.io/fedora-infrastructure/issue/7184
14:36:47 <cverna> anyway I think it is good to bring that up to jim and leigh because it is currently not in our priorities
14:37:07 <pbrobinson> cverna: right, so is there a prod ticket to match that one for stage? Smooge or Kevin should know the details of the ThunderX2 boxes
14:37:39 <pbrobinson> cverna: are these priorities published somewhere?
14:37:51 <pbrobinson> bcotton: is that enough for you to go with?
14:37:54 <cverna> here is the prod ticket --> https://pagure.io/fedora-infrastructure/issue/7411
14:38:14 <bcotton> pbrobinson: yep, this is a good starting point
14:38:33 <pbrobinson> bcotton: just ping if you need more info from me
14:38:36 <smooge> thunderx boxes were built
14:38:40 <cverna> pbrobinson: we have not yet published the priorities, we are working on how we will work with taiga
14:38:52 <bcotton> pbrobinson: ack
14:39:23 <pbrobinson> smooge: yea, I thought they had been, will take this offline, something has got lost somewhere
14:39:49 <pbrobinson> #topic 4) ==== Flock IoT planning ====
14:41:37 <pbrobinson> so I've not yet, but I'm planning on putting in 2 talks and a iot hackfest.
14:41:51 <pbrobinson> meant todo that sat but I never made it out of bed
14:42:56 <pbrobinson> anyone else planning anything?
14:46:40 <pbrobinson> #topic 5) ==== Open Floor ====
14:46:52 <pbrobinson> anyone got anything for open floor
14:47:09 * tdawson will be updating mozilla-iot-gateway to fix two bugs
14:47:20 <tdawson> It will still be at 8.1
14:48:38 <pbrobinson> tdawson: cool, overall how's it working?
14:48:39 <tdawson> It should fix dressedfez's container problem, as well as the IoT user not being properly added problem.
14:49:42 <tdawson> Well, I like the 8.1 interface ... but I've noticed that our IoT release needs a few more things installed to get all the functionality.
14:50:12 <tdawson> With a standard fedora server installed, I get zigbee support, but not with an iot install.
14:50:16 <pbrobinson> tdawson: in the base image, or container?
14:50:21 <tdawson> So .... I guess that's three bugs I'm working on  :)
14:50:37 <tdawson> base image
14:50:46 <tdawson> dressedfez has been working on the container
14:51:32 <pbrobinson> so is it a package difference or some other difference like permissions?
14:51:52 <dressedfez> The Dockerfile needs still some modifcations and we need the fix from upstream as I have with tdawson
14:51:54 <tdawson> That's what I'm not sure about ...
14:52:30 <tdawson> Yep.  I feel bad about saying the fix was in my last package, when it really wasn't.  Wasted alot of time there. :(
14:52:52 <pbrobinson> tdawson: oops, it's a learning experience
14:53:33 <x3mboy> HI
14:53:48 <x3mboy> I think I write to the list, but not sure
14:54:10 <dressedfez> I will discuss with some local people. I would be interested after this iot-gateway is done to package home assistant.
14:54:52 <tdawson> x3mboy: Oh yes, about the marketing campain
14:55:01 <pbrobinson> dressedfez: please engage with the HA people over that, it's fast moving and I think that will be better done a different way
14:55:13 <dressedfez> I would need some guidance for this since I have never done something like this.
14:55:17 <x3mboy> I, on behalf of the Marketing team, have created a set of tickets to launch a campaign, that consist in some inforgraphics to let people know about the awesome things we do
14:55:24 <x3mboy> And of course, you're part of it
14:55:29 <pbrobinson> x3mboy: you did, I've been ill and on minimal stuff so I've not replied yet
14:55:56 <x3mboy> pbrobinson: no problem
14:55:59 <pbrobinson> dressedfez: happy to help there, and know one of the HA people
14:56:13 <x3mboy> I will just put the link here, so any can take a look and comment
14:56:14 <x3mboy> https://pagure.io/design/issue/645
14:56:44 <x3mboy> pbrobinson: also, hope you the best and a quick recovery
14:57:04 <dressedfez> pbrobinson: then you can connect me and we will stay in contact concerning the packaging. I have here somebody who knows more so I can maybe ask him as well.
14:57:07 <pbrobinson> x3mboy: thanks, me too
14:57:19 <bcotton> #link https://pagure.io/design/issue/645
14:57:27 <dressedfez> pbrobinson: fast recovery from me too
14:58:30 <pbrobinson> #info link to to launch a campaign, that consist in some inforgraphics to let people know about the awesome things we do including IoT
14:59:02 <pbrobinson> anyone else have anything in the last 2 mins?
14:59:30 <pbrobinson> thank you all
14:59:30 <pbrobinson> #endmeeting