fedora_iot_working_group_meeting
LOGS
14:00:46 <pbrobinson> #startmeeting Fedora IoT Working Group Meeting
14:00:46 <zodbot> Meeting started Wed May  1 14:00:46 2019 UTC.
14:00:46 <zodbot> This meeting is logged and archived in a public location.
14:00:46 <zodbot> The chair is pbrobinson. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:46 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:46 <zodbot> The meeting name has been set to 'fedora_iot_working_group_meeting'
14:00:46 <pbrobinson> #chair pwhalen pbrobinson bcotton
14:00:46 <zodbot> Current chairs: bcotton pbrobinson pwhalen
14:00:46 <pbrobinson> #topic roll call
14:00:46 <pbrobinson> who is here?
14:01:04 <pbrobinson> who do we have here today?
14:01:12 * pwhalen is here
14:01:19 <bcotton> .hello2
14:01:20 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
14:01:42 <lauber> laubersm is here
14:01:49 * lauber is laubersm
14:03:59 <pbrobinson> #topic 1) ==== Working Group process and admin  ====
14:04:18 <pbrobinson> first up it probably makes sense to cancel next week's meeting
14:04:42 <pwhalen> likely a good idea, +1
14:04:55 <lauber> I haven't picked a session for that time slot yet. we could meet in person
14:04:57 * lauber ducks
14:05:19 * lauber votes cancel (for all that she is here anyway)
14:05:22 <bcotton> +1 cancel
14:05:22 <pbrobinson> lauber: I'll likely be at the Fedora booth
14:05:26 <bcotton> lauber-- :-)
14:05:48 <pbrobinson> #info next week's (8th May 2019) meeting is cancelled
14:05:56 * jsmith is here, late...
14:06:09 <pbrobinson> jsmith: welcome, we're just getting started
14:06:26 <pbrobinson> anyone else have anything for admin/WG bits?
14:08:57 * pbrobinson notes he should work with bcotton to get better IoT artwork and stickers too
14:09:18 <pbrobinson> #action pbrobinson to work out what's needed to close artwork and stickers bits out
14:09:20 <pbrobinson> #topic 2) ==== Fedora 30 ====
14:09:59 <pbrobinson> we're done but I relised I don't know what I need to do to get that flipped from f29 to f30 releases
14:10:12 <pbrobinson> #action pbrobinson to get the iot.fedoraproject.org site updated
14:10:17 * pbrobinson failed there :-/
14:10:40 <pbrobinson> anyone done any testing for IoT on F-30?
14:11:20 <lauber> nothing beyond the test days weeks ago.
14:11:48 <pwhalen> testing the compose from the 28th, which I think includes all the GA bits
14:12:11 <pwhalen> looks ok so far. Small cosmetic issue with the date being wrong again.
14:12:43 <pwhalen> hit an issue with inital-setup hanging on the fitlet, investigating now but couldnt reproduce in a vm
14:13:01 <pwhalen> otherwise, looking good
14:15:29 <pbrobinson> I think F-30 looks fine, we'll be moving to a much more defined monthly release cycle
14:15:33 <bcotton> pwhalen: related to other initial-setup bugs we fixed just before release or something new?
14:16:07 <pwhalen> bcotton, I dont think so, this would be new.
14:16:34 <pbrobinson> initial-setup seems to be whack-a-mole stype
14:16:36 <pbrobinson> style
14:16:38 <pwhalen> so I created a user in anaconda, so when they system booted it only presented the network spoke. When I tried to continue it just hung
14:17:01 <pwhalen> on a vm, it worked ok.
14:17:12 <bcotton> good times :/
14:17:26 <pwhalen> I am convinced the fitlet2 doesnt like me
14:18:09 <pbrobinson> well that will only affect people using the installer, pre-canned images for the RPI and related won't be affected so we can document it in common bugs
14:18:20 <pwhalen> agreed
14:18:38 <pbrobinson> and likely if they're using a kickstart for the installer they will/can disable the initial-setup service there
14:18:58 <pbrobinson> so it's luckily workable
14:19:29 <pwhalen> right, I'll test some more and file a bz with the details
14:20:36 <pbrobinson> #action pwhalen to further test the initial-setup and file bugs as necessary
14:20:49 <pbrobinson> we can target for the late may/early june release
14:21:39 <pbrobinson> anyone else have anything for F-30?
14:22:20 <pbrobinson> #info next f-30 release aimed for late may/early june
14:22:24 * pwhalen has nothing else
14:23:24 <pbrobinson> #topic 3) ==== Fedora 29 release 2 status ====
14:24:03 <pbrobinson> I have a few bits to do here, I've done a couple of RCs and seems fine
14:24:52 <pbrobinson> it will be the last f29 release
14:25:05 <pbrobinson> anyone have anything there?
14:25:05 <pwhalen> I should just test the latest compose there?
14:25:23 <pbrobinson> I've done at least upgrade testing and all seems fine
14:25:43 <pwhalen> ok, will do some more too. need to test upgrades to f30 as well
14:26:01 <pbrobinson> If some one has some cycles to test f29 -> f30 rebases that would be also useful
14:26:34 <pbrobinson> #info please test f29 -> f30 rebases and report any issues
14:27:14 <pbrobinson> #info if anyone sees any updates needed for docs also file a bug/PR here https://pagure.io/fedora-iot/iot-docs/issues
14:27:52 <pwhalen> will do
14:28:00 <pbrobinson> anyone anything for upgrades or f29?
14:28:27 <lauber> there is a PR opened a month ago for updates to reference platforms
14:28:35 <lauber> in docs
14:28:48 <lauber> and not by me.
14:29:11 <pbrobinson> lauber: thanks, not sure how I missed that
14:29:39 <pbrobinson> merged
14:29:54 <pbrobinson> #topic 4) ==== Fedora 31 planning ====
14:31:09 <pbrobinson> so from a f31 planning PoV I'm intending on doing as much as possible in kanban
14:31:23 <pbrobinson> #info f31 planning for IoT will go in https://teams.fedoraproject.org/project/fedora-iot/kanban
14:32:15 <tdawson> I've updated mozilla-iot-gateway* to 0.8 in rawhide/F31
14:32:29 <tdawson> 0.8 has logging, so I wanted to get that in.
14:32:58 <pwhalen> howdy tdawson, logging is good :)
14:33:02 <pbrobinson> my rough list is as follows: security improvements, toolbox container, investigate ignition for provisioning, EBBR support for SBCs on ARMv7/aarch64 and investigate cockpit as a possible management API
14:33:21 <pbrobinson> tdawson: awesome, I hope to get an instance up for testing soon
14:33:36 <pwhalen> same, now that f30 is out the door
14:33:39 <tdawson> cockpit does have rpm-ostree support
14:34:12 <tdawson> I haven't tested the cockpit support, but I noticed it ... I just haven't had a chance to play with it.
14:34:16 <pbrobinson> yes, and there's a new cockpit-podman module
14:34:51 <tdawson> Cool ... that should be nice.
14:35:01 <pbrobinson> and it gives third parties an integration point that's consistent with other Fedora derivatives
14:35:18 <bcotton> i've never used cockpit, but i do like the idea of consistency :-)
14:35:42 <pbrobinson> yes, less work for me \o/
14:36:58 <lauber> bcotton, I am sure you can learn cockpit next week. It is a key change in management of RHEL8 :)
14:37:36 <pbrobinson> anyone else got anything for F31 planning?
14:39:16 <tdawson> nothing else from me
14:39:18 <pbrobinson> #topic 5) ==== Open Floor ====
14:40:04 <lauber> I'll be in Boston next week. Would love to put face to names.
14:40:56 <lauber> Also get help picking (suggestions for) a board for a home project I have.
14:40:56 * tdawson won't be able to make it to Summit.
14:41:43 <pbrobinson> lauber: happy to chat about it
14:42:28 <bcotton> lauber: see you there!
14:42:50 <lauber> tdawson, shucks
14:43:30 * lauber notes she already knows the faces of pbrobinson and bcotton but will be good to see them again.
14:44:00 * pwhalen will not be at summit either
14:48:47 <pbrobinson> anything else?
14:52:13 <tdawson> Not from me
14:53:04 <pwhalen> Nor I
14:53:10 <pbrobinson> thank you all
14:53:13 <pbrobinson> #endmeeting