fedora-qa
LOGS
16:00:05 <adamw> #startmeeting Fedora QA Meeting
16:00:05 <zodbot> Meeting started Mon Dec 10 16:00:05 2018 UTC.
16:00:05 <zodbot> This meeting is logged and archived in a public location.
16:00:05 <zodbot> The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:05 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
16:00:10 <adamw> #meetingname fedora-qa
16:00:10 <zodbot> The meeting name has been set to 'fedora-qa'
16:00:14 <adamw> #topic Roll call
16:00:39 * satellit listening
16:00:40 <frantisekz_> .hello2
16:00:41 <zodbot> frantisekz_: Sorry, but you don't exist
16:00:43 <adamw> morning folks!
16:00:45 <adamw> how's life?
16:00:50 <frantisekz> .hello2
16:00:51 <zodbot> frantisekz: frantisekz 'František Zatloukal' <fzatlouk@redhat.com>
16:00:58 <adamw> hey, we don't approve of non-existent people here
16:01:04 <frantisekz> :D hi
16:01:53 <nabooengineer> hi
16:02:05 <lruzicka> .hello2
16:02:06 <zodbot> lruzicka: lruzicka 'Lukáš Růžička' <lruzicka@redhat.com>
16:02:09 <frantisekz> adamw, pretty fine so far, everyone is getting ready for xmas :D
16:02:16 * coremodule is here! Good morning!
16:02:27 <Lailah> Hello
16:02:29 <lruzicka> yeah, life seems to be alrighty here
16:02:38 <Lailah> .fas lailah
16:02:39 <zodbot> Lailah: lailah 'Sylvia Sánchez' <BHKohane@gmail.com>
16:02:47 <adamw> woohoo xmas! that sacred time of year where no-one thinks you're weird if you bake ginger cookies every day of the week
16:02:51 <lruzicka> adamw, are you covered in snow?
16:03:00 <adamw> only rain, sadly
16:03:03 <Lailah> adamw: LOL
16:03:26 <lruzicka> global warming seems to be the issuie
16:03:37 <Lailah> I prefer Spekulatius
16:03:48 <adamw> wait a second, i have to check if BC is exporting large amounts of fossil fuels today
16:03:50 <adamw> *reads news*
16:03:52 <adamw> oh hey, we are!
16:03:53 <Lailah> Yeah, I didn't see any snows yet
16:04:03 <adamw> so in that case, of course not, silly, global warming is a big fraud made up by china and, uh, aliens.
16:04:13 <coremodule> adamw, Is that to say you have been baking ginger cookies?
16:04:15 <Lailah> LMAO
16:05:54 <adamw> coremodule: i.....may have been.
16:05:55 <Lailah> Eh, share some adamw
16:05:55 <coremodule> ...^^^ what Lailah said!
16:05:56 <adamw> no! they're all for me.
16:05:56 <Lailah> You know, Christmas spirit and so...  we should share with each other
16:05:56 <adamw> that's the spirit of xmas, right?
16:05:56 <Lailah> Doh...
16:05:56 <adamw> pretty sure i read that somewhere.
16:05:56 * kparal joins late
16:05:56 <adamw> i think it was a book by charles dickens.
16:05:56 <adamw> i...may not have read to the end, but i'm sure i got the gist of it.
16:05:56 <Lailah> LOL
16:06:01 <Lailah> adamw:  I think you missed a few points in that book
16:06:02 <adamw> i just hope none of you have sick kids, because to be honest, it's not looking good for them either. :P
16:06:14 * kparal will be here for about 20 minutes, then needs to leave
16:06:20 <adamw> ok, let's keep making jokes then
16:06:22 <Lailah> adamw:  no, thankfully, no kids here
16:06:32 <coremodule> lol
16:06:44 <adamw> allllrighty then
16:06:50 <adamw> #topic Previous meeting follow-up
16:06:50 <lruzicka> the first christmas spirit is one of the past - kparal
16:07:20 <jlanda> heya
16:07:27 <adamw> so we just had one action item, for you, lruzicka
16:07:40 <adamw> "lruzicka to draft up a mail summarizing our concerns and ideas around revising desktop application testing, and send it to the desktop SIGs for their comments"
16:07:43 <adamw> did you get anywhere with that?
16:07:44 <adamw> hi jlanda
16:08:33 * Lailah raises a hand
16:08:40 <adamw> ayup?
16:08:49 <lruzicka> adamw, Yeah, I wrote a draft and sent it to kparal for a review and then I lost a track of it ..
16:09:00 <Lailah> I have a couple of bugs here in KDE Spin, but first finish what you started.
16:09:03 <adamw> let's call it "in progress" then :P
16:09:08 * jlanda just watches, I've been totally afk during my PTO :D
16:09:09 <kparal> I followed up with some clarification about workstation testcases on the list
16:09:15 <adamw> Lailah: thanks, we can put it under one of the next topics
16:09:39 <lruzicka> and I cant remember whether I was supposed to send it then, or if you did, kparal ?
16:09:49 <adamw> #info lruzicka and kparal are busily and actively revising the draft of the mail and definitely didn't lose it down the back of their desk or anything
16:09:55 <kparal> I mostly complained that https://fedoraproject.org/wiki/QA:Testcase_workstation_core_applications is confusing
16:10:06 <kparal> not sure if we resolved that fully, will need to check the emails
16:10:15 <Lailah> LOL
16:10:20 <kparal> either way, I want to remove " Ideally, the applications should all launch successfully (though note that this part of the test is effectively a subset of QA:Testcase_desktop_menus)" from the test case
16:10:24 <adamw> yeah, you had a point there.
16:10:37 <lruzicka> kparal, I have a very distant memory that we wanted to draw Adam into it and ask him, why the testcases are as they are?
16:11:00 <kparal> right, that email thread was a part of that
16:11:11 <Lailah> Iruzicka: Which Adam?
16:11:14 <adamw> i don't recall precisely why we put that in, but i'm ok with taking it out. it *may* have been that one of the desktop team said "why doesn't the test ask you to launch the app?" or something like that
16:11:22 <lruzicka> the divine Adamw
16:11:25 <adamw> haha
16:11:25 <Lailah> Ah
16:11:31 <Lailah> LOL
16:11:32 <Lailah> Okay
16:11:33 <kparal> now I remember. we don't have a criterion for it, but it's marked Beta
16:11:40 <kparal> and I think you didn't reply to that, adamw
16:11:47 <adamw> kparal: i thought i did
16:12:02 <adamw> and said it's because of the workstation tech spec, but we need to make that link clearer...
16:12:10 <adamw> confusion reigns!
16:12:37 <kparal> you said that, but we still don't have any criteria about workstation tech spec
16:12:51 <Lailah> Good grief....
16:13:03 <kparal> I found the thread, you didn't reply :)
16:13:14 <Lailah> That settles in then, adamw
16:13:16 <lruzicka> and we there is actually no difference in how we want to test desktop apps in Workstation
16:13:20 <kparal> the important question is "If say Boxes dropped out of the compose (but still was listed on the wiki page), would we block the release? And on what grounds?"
16:13:28 <Lailah> You're guilty of not reply
16:13:35 <jlanda> m, I wanna remember that I read a mail about that concerns about workstation core applications from kparal on test@
16:13:41 <jlanda> or did I dream it?
16:13:43 <lruzicka> so to divide into core apps and some other apps does not make much sense, just creates confusion
16:14:06 <adamw> lruzicka: the key point is that the core apps are required to be *present*
16:14:13 <Lailah> What should be the definition of  "core apps" ?
16:14:16 <adamw> the other criterion is about testing whatever apps happen to be present
16:14:20 <adamw> Lailah: they're in the workstation techs pec
16:14:22 <lruzicka> originally, I lived with an idea that we might give the core applications harder time testing, but kparal thinks we should do with all apps.
16:14:27 <Lailah> Ah, okay
16:14:28 <adamw> https://fedoraproject.org/wiki/Workstation/Technical_Specification#Core_Applications
16:14:45 <Lailah> Ah, thanks
16:15:11 <lruzicka> and in that case, we do not need to have a special test case for them, right?
16:15:12 <kparal> so, can somebody find a criterion that links to the spec above?
16:15:21 <adamw> it's part of the whole idea that was floating around at fedora.next time that the editions provide guarantees of certain things being there - sort of 'apis'
16:15:30 <adamw> like with server edition you *always* get Cockpit ootb
16:15:44 <adamw> kparal: no. i'm sure we had this covered somehow, but maybe we actually didn't, or it got lost.
16:15:55 <lruzicka> yeah, I would support this approach, but it is nowhere defined.
16:15:58 <kparal> adamw: ok, that would answer my question :)
16:16:07 <adamw> might be worth looking back at the proposal of the criterion
16:16:21 <adamw> if i was being my usual bureaucratic self it should have mentioned something about that
16:16:38 <kparal> adamw: which criterion you're now talking about?
16:16:43 <adamw> oh yeah. d'oh. :P
16:16:46 <Lailah> What happened to your usual bureaucratic self, adamw ?
16:16:49 <kparal> :D
16:16:53 <adamw> we'd have to just look at all the mails around fedora.next
16:16:57 <adamw> or perhaps the wiki history
16:17:01 <adamw> Lailah: he must've been on an off day :P
16:17:07 <Lailah> Doh...
16:17:14 <adamw> see, people make fun of me for being all nerdy about how these things all have to link up
16:17:19 <adamw> then when they don't, people complain :P
16:17:25 <Lailah> LEL
16:17:31 <Lailah> We want the nerdy back!
16:17:52 <adamw> sigh, the page history just says "create test case to check Workstation core application availability"
16:17:53 <kparal> ok. for now I'm fine with just the intention. I just needed to clarify the criterion confusion. 'we forget about it' is a good enough answer for me. of course we should fix that
16:18:06 <kparal> *forgot
16:18:09 <adamw> kparal: i'd just like to make sure we actually *did* just forget it, so we don't duplicate anything
16:18:22 <adamw> but if i can't find anything, let's go ahead and add a criterion or something.
16:18:47 <kparal> ok
16:18:50 <Lailah> Should we wait or just go ahead and add a criterion?
16:19:39 <adamw> gimme like today to see if i can find anything.
16:19:46 <Lailah> Okay
16:20:32 <kparal> I believe I can now continue with lruzicka to fine tune the proposal
16:20:59 <lruzicka> sure
16:21:23 <adamw> alrighty
16:21:41 <adamw> #info lruzicka and kparal to continue work on this email and related criteria proposal etc
16:21:43 <adamw> er
16:21:46 <adamw> #action lruzicka and kparal to continue work on this email and related criteria proposal etc
16:22:46 <adamw> #topic Fedora 30 status
16:23:01 <adamw> Lailah: was the problem you're having in Rawhide? or an earlier release?
16:23:24 <Lailah> I'm on F29 with Testing repos
16:23:32 <Lailah> It's KDE Spin
16:23:54 <Lailah> It's not a tragedy but they're both weird and slightly annoying
16:24:20 <adamw> ah, okay. we can cover it under open floor later then
16:24:23 <adamw> i'll make sure tehre's time
16:24:30 <Lailah> Okay
16:24:43 <adamw> #info Rawhide is mostly working at present
16:25:06 <adamw> #info the dbus-broker and boot loader specification Changes have landed, so please test those out (particularly on upgrade from previous releases)
16:25:25 <adamw> one thing to note on the BLS change - that's https://fedoraproject.org/wiki/Changes/BootLoaderSpecByDefault - it is being *applied on upgrade*
16:25:32 <Lailah> Okay
16:25:42 <adamw> that is, when you upgrade to Rawhide (later F30), a script runs and converts your bootloader config. hopefully, correctly!
16:25:54 <adamw> so, please be aware of that, and file bugs if it goes sideways
16:26:05 <jlanda> arm too? or arm continues with uboot yet?
16:26:10 <adamw> i have concerns about how well that's going to handle cases where people are not just using a straightforward ootb default bootloader setup
16:26:16 <adamw> jlanda: 32-bit ARM is still on uboot
16:26:45 <adamw> there's a Change to switch to UEFI, but I don't know if it's landing in F30, and even if it is, the Change page for that one says it would *not* be applied on upgrade, only fresh installs.
16:26:54 <jlanda> ok, so no testing on rbpi 2 yet :D
16:29:26 <adamw> alrighty, any other notes on f30?
16:29:52 <Lailah> Not from me. I'm still updating myself after a long absence
16:30:00 <Lailah> Or whatever it is written
16:30:07 <Lailah> You know what I mean
16:31:07 <adamw> =)
16:31:17 <adamw> i know what you mean, but i don't know what would be the best word, heh
16:31:34 <adamw> sumantrom[m]: are you around?
16:31:46 <Lailah> Apparently absence is the most fitting.
16:31:52 <Lailah> According to Google Translate
16:32:22 <Lailah> Non-attendance would be fitting too, but sounds awkward
16:33:31 <adamw> absence works, sure
16:33:42 <adamw> hmm, if sumantro's not around, we'd best skip the community update topic, as that was for him
16:34:14 <coremodule> just pinged him...
16:34:23 <Lailah> I thought he was....
16:34:33 <Lailah> I might have dreamed it...
16:35:55 <adamw> hehe
16:35:59 <adamw> no problems, we can do it next week
16:36:02 <adamw> i was just padding the agenda :P
16:36:05 <adamw> #topic Open floor
16:36:28 <lruzicka> I have one thing to ask you.
16:36:37 <adamw> ask away!
16:36:51 <frantisekz> Just noting I want to revive the discussion around my multilib testing proposal :) , probably tomorrow
16:37:26 <lruzicka> I would like to work on some tests for desktop applications in Fedora, perhaps in cooperation with Petr Schindler
16:37:33 <adamw> as in, automated tests?
16:37:34 <lruzicka> who is now in RH Desktop QA
16:38:03 <lruzicka> yes, adamw, automated tests ... and I would like to get some tips on what is basic functionality, that we would wish to test for
16:38:39 <adamw> interesting question
16:38:41 <lruzicka> so if anyone has an idea, please drop me an email or two :)
16:38:56 <adamw> perhaps start a thread on test@ and desktop@ asking for ideas, and draw up a list from that?
16:39:05 <lruzicka> can do
16:39:14 <Lailah> I'm interested to know as well
16:39:23 <adamw> #info lruzicka is looking for suggestions of basic desktop functionality to test, look out for a mailing list thread soon
16:39:58 <adamw> Lailah: what was your KDE issue?
16:41:44 <Lailah> Okay, there are two. I'll explain first the dumbest one.
16:42:39 <Lailah> For some reason, when I install Kate  (it doesn't come by default) it added itself to favourites in menu. I deleted it and on every restart it's there again.
16:42:45 <Lailah> It's silly but annoying
16:42:54 <Lailah> The second one is related to networks
16:43:33 <Lailah> If I put my laptop to sleep the wifi connection is cut, which is expected.  But when I wake it up, it doesn't reconnect.  It doesn't even try.
16:43:50 <Lailah> It just sits there offline until I go and connect it
16:44:15 <Lailah> Again, it's not a tragedy but it shouldn't do that, and it's kinda annoying.
16:44:17 <adamw> the first one sounds like just a straightforward bug to file, i guess. i never know which is the right kde component to file against so i just guess one :)
16:44:24 <adamw> the second...it'd be interesting to know if it's KDE-specific
16:44:33 <adamw> can you test it with another desktop, maybe with a live image?
16:45:11 <Lailah> I might have a live ISO with another desktop yes.
16:45:25 <Lailah> I need to check if it's F28 or F29
16:45:34 <Lailah> This didn't happen on F28 BTW
16:45:43 <Lailah> It's totally news to me
16:46:33 <Lailah> I searched on RH Bugzilla for the Kate/Plasma issue, but didn't find anything.
16:46:51 <lruzicka> Lailah, maybe it is a strategy ... maybe KDE disconnects the connection before going to sleep
16:47:15 <Lailah> I don't know the component against which I should file the bug...  Plasma maybe?
16:47:26 <lruzicka> Lailah, I have never seen it anywhere else, but I am not using KDE
16:47:31 <Lailah> Yeah, it doesn't reconnect
16:47:45 <adamw> it's normal for the connection to be dropped on suspend, but of course it should be restored on resume, yes
16:47:52 <jlanda> m, but that's a de job or nm one?
16:47:58 <adamw> it's mostly NetworkManager that takes care of that, though, which is why i'd want to check it with another desktop
16:48:18 <jlanda> I had some similar issues in the past, but almost always the problem was on kernel side
16:48:50 <jlanda> Crappy wifi drivers, usb bus that didn't power as it should after coming from sleep...
16:49:00 <Lailah> Right now, I'm on a metered connection, but I can try installing another desktop as soon as I get a better internet.
16:49:16 <Lailah> Meanwhile, I can see if I have a recent live ISO with another desktop
16:49:25 <jlanda> It could be interesting to know the wifi chipset,
16:49:43 <Lailah> jlanda:  That's interesting, I didn't think of kernel
16:49:46 <Lailah> It could be
16:50:11 <jlanda> Anyway, I'll install kde on my laptop asap, i certainly know that my wifi chip works properly after coming from sleep on gnome
16:50:27 <Lailah> It's definitely a new issue, it didn't happen in my previous versions, and I have been using KDE Spin for a while now
16:50:28 <adamw> so yeah, it sure sounds like there's a bug, but it'd be good to get some idea of where the bug is before filing it
16:50:29 <jlanda> I'm almost sure that it will work on plasma, but I'll try asap
16:50:39 <adamw> if you see the same thing with another desktop, it means the bug is not in KDE
16:50:46 <adamw> but more likely in NM or the kernel, as jlanda says
16:50:58 <Lailah> Yeah, I agree
16:51:08 <adamw> so narrow it down as much as you can, then go ahead and file a bug :)
16:51:20 <Lailah> Okay
16:51:45 <Lailah> I'll do that and report back next meeting.
16:52:36 <jlanda> I'll post to test@ with my result after install u-t
16:52:52 <jlanda> Ar, after installing plasma
16:52:58 <adamw> rgr
16:53:00 <Lailah> Got it
16:53:01 <adamw> ok, anyone have anything else?
16:53:24 <Lailah> Not that I can remember
16:53:30 <Lailah> Oh, yeah, I have
16:53:38 <Lailah> But it's rather a question
16:53:55 <jlanda> not on my side, i have tons of mail to read before reporting anyting :D
16:54:05 <Lailah> LOL
16:54:25 <lruzicka> not on my side
16:54:38 * satellit none here
16:56:08 <adamw> Lailah: ask away :)
16:56:46 <Lailah> Is it normal that Chrome/Chromium repos get silently disabled on update?
16:57:23 <Lailah> It happened to me and a couple of days ago, someone complained of the same issue in Fedora International (Telegram)
16:57:35 <adamw> well, it depends where the repo definition comes from, i guess? if the repo definition itself is in a package, then updates to that package can potentially change the config
16:57:43 <jlanda> Lailah: there was an error o wks release package
16:57:43 <jlanda> It's not normal, but a known bug
16:57:53 <jlanda> But it should be fixed nowadayd
16:57:53 <adamw> ah, you know about this, jlanda?
16:58:31 <jlanda> stephen wrote some days earlier to fc29 release informing about that
16:58:55 <jlanda> The wks-releade paclage was rewritting the repo list
16:59:06 <jlanda> Instead of maintaining your settings
16:59:43 <jlanda> So it used to put all the optionals ones to disabled=1 sile tly
16:59:44 <jlanda> Ar, my crappy tunnels again
16:59:47 <Lailah> But I don't have Workstation...
16:59:54 <Lailah> It's the kDE Spin
17:00:09 <jlanda> And some days ago, so that's a new bug
17:00:18 <Lailah> I don't remember that person who complained...  I think it was XFCE, but I can ask
17:00:18 <jlanda> Not the one that I remember :S
17:00:21 <adamw> fedora-repos package, maybe?
17:00:31 <adamw> do you remember what list this mail was on?
17:00:39 <jlanda> test@ for sure
17:01:18 <jlanda> Could be during your pto adamw
17:01:31 <Lailah> pto?
17:01:51 <Lailah> Damn, a few meetings away and I already feel so off....
17:01:56 <adamw> ok
17:01:56 <lruzicka> pto = paid time off - vacation
17:02:00 <Lailah> Ah
17:02:12 <adamw> alrighty, anyway, look out for that mail, lailah :)
17:02:20 <jlanda> 10/35
17:02:23 <adamw> we're over time, now, so thanks for coming, everyone
17:02:29 <jlanda> ar, 10/35
17:02:30 <Lailah> In  @test  adamw ?
17:02:37 <jlanda> Omg, 10/25
17:02:41 <jlanda> He wrote to test@
17:02:47 <Lailah> Okay
17:02:59 <Lailah> 10/25 ?
17:03:18 <jlanda> I can check the mail on the cellphone but can't find the url, my train connectivity is sooo slow
17:03:23 <jlanda> October 25th Lailah
17:03:29 <Lailah> Ah
17:03:39 <jlanda> https://bugzilla.redhat.com/show_bug.cgi?id=1640626
17:03:46 <Lailah> Ah, okay, thank you
17:03:49 <jlanda> This is what I remember
17:04:36 <Lailah> Okay, I'll comment there that it happened in KDE Spin as well.
17:04:49 <Lailah> Yes, that looks like the issue I mentioned
17:05:02 * adamw sets fuse
17:08:58 * Lailah wonders what happened to the fuse...
17:09:13 <lruzicka> it still has not set off
17:09:21 <lruzicka> :)
17:09:25 <Lailah> Ah
17:10:54 <jlanda> adamw is cooking ginger cookies for all of us before #endmeeting :D
17:11:05 <Lailah> Aawwww
17:11:05 <coremodule> COOKIES!
17:11:12 <Lailah> That's so cute adamw !
17:11:27 <Lailah> Coo-kies! Coo-kies!
17:11:59 <jlanda> We should federate the cooking process, coremodule's ones will be delivered on time but ours on europe... We could receive them on february :D
17:12:07 <lruzicka> I have a nature-is-calling moment .... so I probably will have to leave you, guys.
17:12:30 <coremodule> haha, maybe adamw can make cookies in advance for you
17:12:31 <jlanda> cya lruzicka
17:12:38 <Lailah> See ya  coremodule!
17:12:41 <Lailah> Have a nice day
17:12:44 <lruzicka> bye, have a nice time
17:12:46 <coremodule> bye lruzicka
17:12:50 <Lailah> Ah, dang it
17:12:55 <coremodule> bye Lailah!
17:12:57 <Lailah> I greeted the wrong person
17:12:58 <Lailah> LOL
17:13:10 <jlanda> Or he ate too many adamw's cookies and that's the reason for his hurry to the toilet
17:13:18 <Lailah> LMAO
17:13:28 <Lailah> Eh, he had too many and we had none
17:13:31 <Lailah> That's unfair
17:15:53 <lruzicka> I am back, it was not that complicated :d
17:16:07 <Lailah> Good
17:16:20 <Lailah> But adamw is nowhere to be seen
17:16:26 <lruzicka> it was all the coffee :D
17:16:31 <Lailah> Ah
17:17:29 <jlanda> You came in time for adamw's ginger cookies party :D
17:17:47 <Lailah> Cookies! Cookies!
17:18:08 <Lailah> We need something to drink to accompany the cookies....
17:19:05 <jlanda> He uses to #chair coremodule but today that he disappeared he forgot it :D
17:19:39 <Lailah> Maybe he has been kidnapped by aliens!
17:20:20 <jlanda> He talked too much about them and global heating...
17:20:37 <Lailah> Yeah...
17:21:00 <Lailah> Meh...  we won't get ginger cookies...
17:28:05 <lruzicka> :) I think I will have to wait when I get home, some cookies might be there.
17:28:33 <Lailah> I'm already at home, no cookies  :'(
17:48:49 <kparal> #chair
17:49:16 <kparal> adamw: you forgot to end the meeting
18:40:09 <smooge> zodbot: #endmeeting
18:41:49 <jlanda> I asked for support on #fedora-ops
18:42:58 <jlanda> Southern_Gentlem: are you around?
18:43:05 <nirik> I can do it
18:43:21 <jlanda> ;)
18:43:36 <nirik> #endmeeting