fedora-qa
LOGS
16:00:07 <adamw> #startmeeting Fedora QA Meeting
16:00:07 <zodbot> Meeting started Mon Nov 12 16:00:07 2018 UTC.
16:00:07 <zodbot> This meeting is logged and archived in a public location.
16:00:07 <zodbot> The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:07 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:07 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
16:00:14 <adamw> #meetingname fedora-qa
16:00:14 <zodbot> The meeting name has been set to 'fedora-qa'
16:00:20 <adamw> #topic Roll call
16:00:26 <adamw> morning, folks, who's around for the qa meeting?
16:00:50 <bcotton> .hello2
16:00:51 <zodbot> bcotton: bcotton 'Ben Cotton' <bcotton@redhat.com>
16:01:00 <kk4ewt> .hello jbwillia
16:01:01 <zodbot> kk4ewt: jbwillia 'Ben Williams' <vaioof@gmail.com>
16:01:21 * cmurf checking in from a train to Vancouver
16:02:02 * coremodule is here.
16:04:08 <adamw> hmm, not a lot of folks
16:04:21 * adamw never sure how many places remembrance day is a holiday in. :P
16:05:28 <cmurf> Commonwealth countries add up :-D
16:05:49 <jlanda> heya
16:06:00 <adamw> well, the big thing for the agenda today was the proposed test changes, but seems like none of the brno folks are around...
16:06:10 * sumantro is here
16:06:15 <bcotton> so that means we can decide without them, yeah? :-)
16:06:19 <adamw> =)
16:06:20 <adamw> hi sumantro
16:06:25 <sumantro> hi adamw :)
16:06:33 <jlanda> kamil wrote that they had a team dinner, so they'll not appear today :D
16:07:17 <cmurf> haha team dinner in Brno means about 5 liters each
16:07:50 <jlanda> they started to dinner for 5pm, so probably more than 5 liters each :D
16:08:14 <adamw> ah, missed that
16:08:29 <adamw> they're very big on team building exercises in brno
16:08:43 <cmurf> True they are the ones keeping the median around, what is it, 8 liters per man woman and child?
16:09:00 <adamw> https://www.google.ca/maps/place/Lok%C3%A1l+U+Caipla/@49.1985291,16.5963979,15z/data=!4m8!1m2!2m1!1slokal+near+Brno,+Czechia!3m4!1s0x47129450aa5814b9:0x5e1a73c439270ee2!8m2!3d49.1959028!4d16.6094465 <---- prime team-building exercise location
16:09:46 <adamw> welp, let's go ahead anyway, but i guess we won't make any hard decisions today
16:09:50 <adamw> #topic Previous meeting follow-up
16:10:02 <cmurf> (Puget Sound in the morning by train while having WiFi for a Fedora meeting is a really nice way to start the week, BTW.)
16:10:35 <adamw> cmurf: still better: a nice fluffy dressing gown and a desk fifteen feet from your bed
16:10:56 <adamw> #info "adamw to try and move along outstanding criteria proposals towards resolution" - still didn't do this as I still suck (aka spent all week trying to fix rawhide)
16:11:07 <adamw> #action adamw to try and move along outstanding criteria proposals towards resolution
16:11:09 <adamw> this week for sure!
16:11:24 <adamw> "frantisekz to sort through the remaining f28 common bugs to see which still apply" - anyone happen to know his status on that?
16:11:53 <kk4ewt> adamw,  so what was the items that came up that were blockers but really werenot in the f29 time frame
16:12:03 <coremodule> Methinks he completed this from his status report, but I'm not 100% sure.
16:12:07 <cmurf> adamw: yeah I gave up my desk 5 feet from my bed when I moved from NYC, but I kept the gown, pry that thing from my cold dead hands!
16:14:48 <adamw> kk4ewt: can we do one thing at a time? :)
16:16:15 <adamw> #info "frantisekz to sort through the remaining f28 common bugs to see which still apply" - from his rh team status report, we believe this was completed
16:18:15 <bpabon> .hello bpabon
16:18:15 <zodbot> bpabon: Sorry, but you don't exist
16:18:34 <adamw> buu buuuuuuu
16:18:44 <bpabon> .hello bpabon
16:18:45 <zodbot> bpabon: Sorry, but you don't exist
16:18:49 <cmurf> haha
16:18:55 <adamw> #topic Lukas' desktop testing proposals
16:19:11 <adamw> #info as lukas and the other brno folks aren't around we won't take any decisions today, but let's talk about the ideas a bit
16:19:24 <bpabon> ROFLMAO how embarrassing
16:20:01 <cmurf> bpabon: happens to me too my fas name is real and my irc nick is a nick, but i love the assertion that I personally do not exist
16:20:28 <adamw> i.e., try it with your fas name
16:20:32 <adamw> .hello
16:20:32 <zodbot> adamw: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
16:20:36 <adamw> .hello adamwill
16:20:36 <zodbot> adamw: adamwill 'Adam Williamson' <awilliam@redhat.com>
16:20:42 <bpabon> Ok
16:21:05 <bpabon> .hello blaise
16:21:06 <zodbot> bpabon: blaise 'Blaise R Pabon' <blaise@gmail.com>
16:21:08 <adamw> there is a sophisticated verification system in place, so don't be alarmed if a drone appears when you do that
16:21:25 <adamw> just lie back and let it do its work, you'll barely feel the injection
16:21:26 <adamw> :P
16:21:59 <bpabon> No worries, I m using riot and getting confused by the multiple gateways
16:22:25 <bpabon> Thank you all for your patience
16:23:21 <adamw> so, the proposals in question here are the ones lukas posted to test@: "Lukas' desktop testing proposals" and "Proposal to redefine core applications"
16:23:22 <jlanda> about lukas' propossal, I like the idea of making life easier for qa team, but I'm not sure if the proposal would achieve that goal :D
16:23:40 <adamw> yeah, i think there's basically a good idea at the core of each proposal, maybe we need to tweak the details a bit
16:23:58 <adamw> having openqa do at least some desktop app testing would be useful, if we can make the tests not too much work to maintain
16:24:34 <adamw> and having some sort of definition of key desktop apps probably isn't a bad idea, but we have to be careful not to have it mean we're blocking releases on Cinnamon or something
16:24:36 <jlanda> yeah, but we were talking about making core applicationt ests with spins.. and is there any installation test on openqa with spins?
16:24:48 <adamw> at present, only GNOME and KDE
16:24:58 <adamw> but the tests are written to at least in theory make it 'easy' to add other desktops
16:24:59 <jlanda> we should start from there, otherwise would be like building from the roof to bottom :D
16:25:56 <RNM> .hello robbinespu
16:25:59 <zodbot> RNM: robbinespu 'Robbi Nespu' <robbinespu@gmail.com>
16:26:16 * jlanda had planned to setup local openqa instance this weekend, but sick child didn't help so it continues being a plan :D
16:27:43 <bpabon> Fwiw, I see the silver blue team finding random issues related to Wayland, so desktop testing seems like a good idea to do early and often.
16:28:40 <adamw> oh yeah, it certainly is
16:30:16 <adamw> hi roshi
16:30:18 <adamw> =)
16:30:50 <jlanda> and there is a huge bug on wayland+nvidia too, wks included, saddly I found it after release, I was working with a radeon while last testings  :(
16:31:57 <adamw> i think that's known about and is why workstation defaults to xorg if you use nvidia?
16:31:58 <adamw> but imbw.
16:32:22 <jlanda> adamw: but is not working properly on fc29+> nvidia serie 10
16:32:37 <jlanda> it's unusable right now on a 1060 without some grub tweaking
16:32:49 <adamw> fun
16:33:09 <jlanda> nouveau sucks on this serie due to lack of firmware, gdm stucks when trying to go xorg with nvidia closed drivers due to 'rghb' option on kernel
16:33:31 <jlanda> so combine them and boom, unusable desktop for nvidia >= 10XX on fc29
16:33:31 <adamw> alright, welp, anyone got any more thoughts on the proposals, or shall we move on?
16:34:11 <jlanda> move on for me, we can discuss deeper next week with brno team present
16:34:49 <adamw> #info we agreed that both proposals contain good ideas but may need a bit of tweaking, we will discuss further next time
16:34:55 <adamw> #topic Fedora 30 status
16:35:43 <adamw> so, I can give a bit of an update here, there were various 'fun' bugs in rawhide last week related to package install ordering and the new boot loader specification stuff that got enabled in anaconda, they should mostly be cleared up with the next compose
16:36:31 <adamw> we're still early in the cycle, change proposals are open till january, so it's a bit early to start planning events and reviewing changes
16:36:53 <adamw> #info F30 status: early in cycle, currently Rawhide is mostly usable if you start with a minimal or live install
16:37:03 <adamw> any other notes / questions on f30 at this point?
16:38:05 <coremodule> will f30 be Apple II compatible?
16:38:46 <sumantro> should we call for test days in next 24 hrs? we can start with FreeIPA which has been on the to-do list for long
16:39:03 <adamw> yeah, sure, it's never a bad idea
16:39:07 <adamw> coremodule: ..........no.
16:39:15 <adamw> sumantro: we can always send another one later too :)
16:39:22 <coremodule> daaaang it
16:39:51 <sumantro> adamw we start tonight then! :)
16:40:23 <adamw> ayup
16:40:30 <adamw> #action sumantro to send out initial call for F30 Test Days
16:40:58 <adamw> #topic IBM, Your New Best Friend
16:41:02 <adamw> sooo, any questions? :)
16:41:17 <roshi> lol
16:41:20 <adamw> i figured i'd put this on here in case anyone wanted to ask or comment
16:41:26 <sumantro> hahaha
16:41:29 <jlanda> will we have free ppc64 boxes?
16:41:29 <roshi> adamw++ for topic wording
16:41:29 <zodbot> roshi: Karma for adamwill changed to 4 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:41:46 <adamw> jlanda: funnily enough, we actually already got two...
16:42:04 <adamw> we've been working with a couple of folks from IBM on ppc64 testing in openQA for a couple of years already
16:42:06 <jlanda> lol, I didn't know :D
16:42:17 <adamw> https://openqa.stg.fedoraproject.org/group_overview/3
16:42:22 <adamw> the boxes that those tests run on were donated by IBM
16:42:28 <RNM> Now the topic i waiting to hear :)
16:42:30 <jlanda> cool
16:42:36 <RNM> cool
16:42:41 <adamw> i am hoping this gets us lots of brownie points with our new corporate overlords. :P
16:43:31 <cmurf> Dear IBM we will solve all your problems in the glorious shiny future just keep on not using that 10 foot pole.
16:43:36 <adamw> so, anyway, yeah, if anyone has any questions, fire away
16:44:27 <adamw> so far all i really know is that nothing much is supposed to change for fedora for at least the short to medium term, long term who knows - but then that was just as true under independent rh
16:44:54 <bpabon> Are red hat people worried about their jobs?
16:45:13 <adamw> #info in case you've been living under a rock, the story here is that IBM has agreed to buy Red Hat for a very large amount of money
16:46:14 <adamw> bpabon: in a sort of vague generalized way, maybe a bit? in a specific way, not really
16:46:51 <adamw> so far it doesn't sound like this is one of those buyouts where they immediately fire half the company or anything
16:47:01 <cmurf> FWIW the acquisition won't complete for about 9-12 months (2nd half 2019).
16:47:12 <bpabon> I imagine the rh sales people will be... Reallocated.
16:47:34 <adamw> i don't know anything about that
16:47:39 <adamw> but to speculate i'd say probably not at least at first
16:47:54 <adamw> large-scale enterprise software sales is a pretty complex job, believe it or not
16:48:11 <adamw> and both IBM and RH are smart enough to know it's not just like you can take A Sales Person and have them Sell Anything
16:48:19 <cmurf> I expect RH autonomy for a couple of years.
16:48:57 <adamw> probably in the long term they're gonna want to unify some teams, otherwise what's the point of owning the company? but it probably wouldn't just be 'all the RH people are out now', because it would be a bit silly to just jettison all that product knowledge
16:49:06 <cmurf> Also, this is by far the biggest aquisition IBM has ever done, so comparison to IBM acquisition history is probably not indicated.
16:49:38 <jlanda> and no sense on buying rh to fire its human power
16:49:48 <adamw> but anyway, so far as any impact on fedora qa goes, our best guess is 'we don't know for sure, but probably nothing immediate or drastic'
16:49:54 <cmurf> Well in the announcment, IBM expects to immediately add profit to their own bottom line haha. So that's a big reason to buy RH. It's a golden egg laying goose.
16:50:41 <RNM> IBM will be getting money on their business after acquisition.
16:50:47 <adamw> cmurf: well, i mean, buying RH clearly does add profit. we make a profit. now that profit goes onto IBM's books. qed. 34 billion dollars is a lot of money to pay for, what, $700m in annual profits or something? but hey. :P
16:51:00 * jlanda starts the train trip, I'll go offline for minutes
16:51:41 <cmurf> It is interesting they are paying this much of a premium. Basically they wanna make sure the shareholders don't say no. Shareholders still have to approve it.
16:52:11 <cmurf> (OK I've got a something if we can get to open floor before the hour is up)
16:52:11 <adamw> this shareholder's bank account votes HELL YEAH
16:52:23 <adamw> and yeah, we should do that, as i think kk4ewt had something
16:52:40 <adamw> so, that's the IBM story: we're all gonna see what happens together :P
16:53:11 <adamw> #info we really don't know for sure what the impact of the IBM deal will be on Fedora or Fedora QA in the long term, in the medium term it likely won't be anything major
16:53:16 <adamw> #topic Open floor
16:53:23 <adamw> so, anything for open floor?
16:53:49 <cmurf> :D
16:53:52 <cmurf> https://fedoraproject.org/wiki/Changes/BootLoaderSpecByDefault
16:54:30 <cmurf> I volunteer myself and then adamw to get the change owners to drop this onto Rawhide ASAP.
16:54:51 <cmurf> It's a big change that will need early awareness, and documentation changes.
16:55:12 <bcotton> cmurf++
16:55:12 <zodbot> bcotton: Karma for chrismurphy changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:55:15 <cmurf> Even if nothing breaks, it's going to be confusing.
16:55:29 <bcotton> cmurf: do you know what's holding it back from being submitted?
16:55:34 <bcotton> the change proposal, that is
16:55:48 <adamw> cmurf: it's already in rawhide.
16:55:56 <cmurf> pjones is never not incredibly busy and lives in a time vortex as a result?
16:55:58 <sumantro> cmurf++
16:55:58 <zodbot> sumantro: Karma for chrismurphy changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:55:59 <adamw> that's one of the things that broke rawhide last week.
16:56:06 <cmurf> LOL
16:56:09 <bcotton> ugh
16:56:11 <cmurf> that's awesome
16:56:16 <adamw> it's all fixed now though!
16:56:25 <jlanda> till tomorrow
16:56:29 * bcotton goes to get the "get your change approved before you put it in rawhide" stick
16:56:34 <adamw> jlanda: right. :P
16:56:49 <adamw> bcotton: well, iirc, it was approved for f29
16:56:52 <jlanda> then you'll have another breaking dbus, grub, kernel, uefi or something :D
16:56:56 <cmurf> it was pushed from 29 to 30
16:56:57 <cmurf> https://pagure.io/fesco/issue/1985
16:56:57 <adamw> then we kicked it out of f29 for landing too late
16:57:00 <cmurf> so it's approved
16:57:05 <adamw> so it'd be a bit mean to then yell at them for landing it in f30 too early
16:57:22 <adamw> cmurf: anyway, yeah, since anaconda 30.10-1, bls is on by default
16:57:31 <adamw> and since 30.10-2 it works for live installs. :P
16:57:32 <bcotton> ehh. my understanding is that it should still get resubmitted, but it's definitely a squishy area :-)
16:57:45 <cmurf> that is marvelous
16:58:07 <cmurf> let's move on then
16:58:42 <adamw> kk4ewt: what was it you wanted to ask?
16:59:17 <adamw> #info cmurf asked about https://fedoraproject.org/wiki/Changes/BootLoaderSpecByDefault , adamw reported that it landed with anaconda-30.10-1, BLS is default in all composes since then
17:00:54 <jlanda> related with kk4ewt question before, I'm a bit concerned about lack of criteria to block broken crond or sshd on server flavour, the non working /etc/cron.d thing for example, we were almost all in favour of blocking but there was not a clearly violated criteria
17:01:42 <jlanda> we should fix that, with a specific criteria or some sort of core application collection for server, dunno what's the best approach
17:01:58 <adamw> i thought ssh was already blocking...
17:02:03 <adamw> did this come up while i was away?
17:02:11 <cmurf> maybe
17:02:37 <jlanda> m, I thi i you were here yet, the broken /etc/cron.d
17:02:46 <jlanda> I think*
17:02:49 <adamw> the cron thing, yeah
17:02:54 <adamw> that's different from ssh, though...
17:03:02 <jlanda> yeah sure
17:03:20 <adamw> huh, i actually can't immediately see a criterion that clearly covers default ssh. hrm
17:03:26 <jlanda> the sshd one actually didn't happend, I extended my concern :D
17:03:54 <cmurf> I'm not sure to what degree systemd timers and chrond have overlapping functionality but the criterion should apply to both
17:04:00 <adamw> anyway, yeah, basically if something like this concerns you, please draft up a criteria proposal and send it to test@
17:04:10 <adamw> it doesn't have to be the most polished thing in the world, it just has to kickstart a discussion
17:04:15 <cmurf> a generic, whatever is responsible on an installed system for scheduling tasks, must work
17:04:27 <cmurf> not *too* generic of course
17:04:39 <adamw> yeah, i actually think this is one that should be more specific than generic
17:04:44 <jlanda> oki, I'll try to make some time to start the discussion
17:04:50 <adamw> thanks
17:05:24 <adamw> #info jlanda brought up the case for adding criteria to cover cron and ssh functionality on server, he will try to find time to propose wording
17:05:28 <adamw> anything else, folks?
17:05:33 <RNM> i have
17:05:48 <jlanda> yep, shoule be specific, 'the current cronlike service must work properly for root, users and /etc/cron.d' or something :D
17:06:06 <adamw> RNM: go ahead
17:06:08 <RNM> Do Fedora QA mail list will be close and move to use Discourse?
17:06:18 <adamw> i don't think we were planning anything like that
17:06:24 <RNM> good
17:06:39 <RNM> I happy to hear that :)
17:06:44 <adamw> ok :)
17:06:53 <adamw> it hadn't come up at all, so far as i know.
17:06:58 <cmurf> AFAIK Discourse is a test and there's no actual decision on expanding the test let alone switching.
17:08:12 <adamw> #info rnm asked if there was any plan to migrate the qa team from a mailing list to discourse, so far as we know the answer is no.
17:10:15 <adamw> alrighty, thanks for coming, everyone
17:10:17 <adamw> see you next time
17:10:23 <adamw> #endmeeting