fedora_prioritized_bugs_and_issues
LOGS
15:02:37 <bcotton> #startmeeting Prioritized bugs and issues
15:02:37 <zodbot> Meeting started Wed Oct 10 15:02:37 2018 UTC.
15:02:37 <zodbot> This meeting is logged and archived in a public location.
15:02:37 <zodbot> The chair is bcotton. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:37 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:02:37 <zodbot> The meeting name has been set to 'prioritized_bugs_and_issues'
15:02:38 <bcotton> #meetingname Fedora Prioritized bugs and issues
15:02:38 <zodbot> The meeting name has been set to 'fedora_prioritized_bugs_and_issues'
15:02:46 <bcotton> (sorry for the delay, i was just so excited about expense reports)
15:02:55 <bcotton> #topic Purpose of this meeting
15:02:57 <bcotton> #info The purpose of this process is to help with processing backlog of bugs and issues found during the development, verification and use of Fedora distribution.
15:03:03 <bcotton> #info The main goal is to raise visibility of bugs and issues to help  contributors focus on the most important issues.
15:03:05 <bcotton> #link https://fedoraproject.org/wiki/Fedora_Program_Management/Prioritized_bugs_and_issues_-_the_process
15:03:10 <bcotton> #topic Roll Call
15:06:00 <bcotton> mattdm?
15:06:02 <bcotton> anyone?
15:08:15 * orc_fedo looks at bcotton , wonders if he will be at Ohio LF this weekend
15:08:49 <bcotton> orc_fedo: i will not, unfortunately
15:08:54 <orc_fedo> ;(
15:10:05 <bcotton> orc_fedo: are you here for the Prioritized Bugs and Issues meeting?
15:10:36 <orc_fedo> bcotton yeah .. sort of -- I had one in there I think actually
15:10:48 <orc_fedo> what is the BZ magic URL again please?
15:10:48 <bcotton> cool, i guess it's just the two of us
15:11:02 <bcotton> but that's enough to proceed with
15:11:12 <bcotton> #topic Nominated bugs
15:11:14 <bcotton> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&bug_status=POST&bug_status=MODIFIED&bug_status=ON_DEV&bug_status=ON_QA&bug_status=VERIFIED&bug_status=RELEASE_PENDING&classification=Fedora&keywords=Triaged&keywords_type=nowords&list_id=9195844&product=Fedora&query_format=advanced&status_whiteboard=PrioritizedBug&status_whiteboard_type=allwords
15:11:15 <bcotton> #info 3 nominated bugs
15:11:41 <bcotton> #topic In Gnome Wayland, forward-key-event does not work well, breaks space key completely
15:11:43 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1625142
15:11:45 <bcotton> #info Bug is ON_QA
15:11:48 <orc_fedo> yeah -- mine is gone now it seems
15:12:01 <bcotton> i'm not sure it really matters if we vote to accept it or not. it seems like it's already fixed?
15:13:25 <bcotton> i guess we can accept it in case someone says "no, this isn't acutally fixed"
15:13:34 <orc_fedo> nod
15:13:46 <bcotton> proposed #agreed BZ 1625142 is accepted as a PrioritizedBug
15:15:55 <bcotton> orc_fedo: objections?
15:16:51 <mattdm> bcotton: SORRY got distracted with $DISTRACTINGSTUFF
15:17:16 <bcotton> welcome, mattdm. i hope you were distracted by my expense report so i don't have to do it :p
15:17:29 <bcotton> we're still on our first nominee
15:17:32 <mattdm> um, no, but I also have to do my expense reports so THANKS
15:17:42 <mattdm> lit looks like there's a fix already for this?
15:18:13 <mattdm> therefore accepting it will increase our success percentage!
15:18:32 <bcotton> that sounds like a +1
15:18:40 <bcotton> #agreed BZ 1625142 is accepted as a PrioritizedBug
15:18:51 <bcotton> #topic Plymouth doesn't echo LUKS keypresses or show boot progress with amdgpu+LUKS
15:18:53 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1490490
15:19:38 <bcotton> this seems like a hardware-specific issue
15:19:48 * mattdm is getting an amd gpu system on friday
15:19:57 <mattdm> I may suddenly care about this one personally :)
15:20:03 <bcotton> haha
15:20:17 <bcotton> it does seem like a pretty obnoxious bug
15:20:52 <mattdm> yeah +1
15:21:00 <bcotton> and it's had literally no input from the assignee since it was opened
15:21:06 <bcotton> i, too am +1
15:21:21 <bcotton> i guess that settles it
15:21:31 <bcotton> #agreed BZ 1490490 is accepted as a PrioritizedBug
15:21:45 <bcotton> #topic selinux prevents loading of anything inside /etc/cron.d
15:21:46 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1625645
15:21:48 <bcotton> #info Rejected as a blocker due to a lack of applicable criteria
15:21:53 <bcotton> speaking of obnoxious bugs
15:22:08 <bcotton> the blocker review meeting wanted to call this one a blocker, but couldn't find a good excuse
15:22:18 <mattdm> ait just a quick note on the previous one -- i will email hardware enablement and plymouth dev @ rh and see if i can get a response
15:22:35 <bcotton> cool
15:22:44 <bcotton> #undo
15:22:44 <zodbot> Removing item from minutes: INFO by bcotton at 15:21:48 : Rejected as a blocker due to a lack of applicable criteria
15:22:46 <bcotton> #undo
15:22:46 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x7ff79039a350>
15:22:49 <bcotton> #undo
15:22:49 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x7ff7721cc450>
15:23:08 <bcotton> #action mattdm to email hardware enablement and plymouth dev @ Red Hat
15:23:14 <mattdm> thanks :)
15:23:18 <bcotton> we good now?
15:23:24 <mattdm> yes. email sent, even
15:23:26 <mattdm> #info email sent :)
15:23:31 <bcotton> excellent!
15:23:34 <bcotton> #topic selinux prevents loading of anything inside /etc/cron.d
15:23:36 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1625645
15:23:38 <bcotton> #info Rejected as a blocker due to a lack of applicable criteria
15:24:11 <bcotton> #info BZ 1625645 accepted as a F29 Freeze Exception
15:24:40 <bcotton> not being able to use `/etc/cron.d/` seems pretty ungreat
15:24:47 <bcotton> i am +1 for prioritizing this
15:25:29 <mattdm> +1
15:25:48 <bcotton> #agreed BZ 1625645 is accepted as a PrioritizedBug
15:25:48 <mattdm> how is this not a blocker?
15:26:05 <bcotton> on a technicality, i think. no criteria specifically apply
15:26:13 <bcotton> i wasn't at that meeting, though
15:26:18 <mattdm> isn't there some "basic functionality" for server?
15:26:33 <mattdm> i can see the argument that it might not be basic desktop functionality, but, otherwise....
15:27:23 <bcotton> i think because cron still works generally, it doesn't count. but it does seem like a bug in the blocker criteria
15:27:24 <mattdm> i mean, I guess it could be fixed with a zero day?
15:28:07 <bcotton> https://fedoraproject.org/wiki/Fedora_29_Final_Release_Criteria#System_services specifically says "All system services present after installation with one of the release-blocking package sets must start properly, unless they require hardware which is not present."
15:28:21 <mattdm> that's pretty loose
15:28:45 <mattdm> okay, let's accept it as a prioritized bugs, but I might suggest something for the release criteria in the future
15:28:56 <bcotton> agreed
15:29:06 <bcotton> moving on
15:29:17 <bcotton> oh, hey, that was the last candidate
15:29:27 <bcotton> #topic Accepted bugs
15:29:28 <bcotton> #link https://bugzilla.redhat.com/buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&bug_status=POST&bug_status=MODIFIED&bug_status=ON_DEV&bug_status=ON_QA&bug_status=VERIFIED&bug_status=RELEASE_PENDING&classification=Fedora&keywords=Triaged&keywords_type=allwords&list_id=9195442&product=Fedora&query_format=advanced&status_whiteboard=PrioritizedBug&status_whiteboard_type=allwords
15:29:30 <bcotton> #info 6 accepted bugs
15:29:37 <bcotton> #topic Require all other updates to be installed before allowing to start system upgrade
15:29:37 * mattdm notes that dnf-automatic uses systemd timers instead of cron, so... okay
15:29:38 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1336435
15:29:40 <bcotton> #info BZ 13364535 was accepted on 2017-08-02
15:29:46 <mattdm> I emailed richard again this morning
15:29:48 <bcotton> #info assignee has made no comments since needinfo flag was set on 2017-09-27
15:29:49 <bcotton> #info Upstream bug has had no activity in the last year
15:30:11 <bcotton> #link https://gitlab.gnome.org/GNOME/gnome-software/issues/116
15:30:12 <bcotton> #info mattdm has followed up with Richard Hughes to update
15:30:20 <mattdm> #info software dev has some solid reasons to push back on this, but they're just in a private email to me, and we need that conversation to happen with QA
15:30:33 <mattdm> #info like, in the bug, or on the devel or test mailing lists
15:31:44 <bcotton> i guess that's about all we can say for this one right now
15:32:14 <mattdm> yeah :(
15:32:47 <bcotton> #topic Dracut exhibits numerous AVC denied errors during cleanup, takes long time to power off
15:32:48 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1385432
15:32:50 <bcotton> #info BZ 1385432 was accepted on 2017-05-25
15:32:56 <bcotton> #info assignee has made no comments since needinfo flag was set on 2018-08-02
15:32:58 <bcotton> #info Comments reporting it is fixed in F28
15:33:26 <bcotton> #undo
15:33:26 <zodbot> Removing item from minutes: INFO by bcotton at 15:32:58 : Comments reporting it is fixed in F28
15:33:27 <bcotton> #undo
15:33:27 <zodbot> Removing item from minutes: INFO by bcotton at 15:32:56 : assignee has made no comments since needinfo flag was set on 2018-08-02
15:33:33 <bcotton> #info Comments reporting it is fixed in F28
15:34:06 <bcotton> so the BZ is still in the "ASSIGNED" state, but it sounds like for our purposes we can call it fixed
15:35:14 <bcotton> i'm guessing a fix was pushed without a BZ in the update
15:35:14 <mattdm> \o/
15:35:29 <bcotton> #action bcotton to follow up with assignee to update bug status
15:35:50 <bcotton> proposed #agreed BZ 1385432 is considered fixed for the purposes of the PrioritizedBugs process
15:38:43 <mattdm> +1
15:38:45 <mattdm> sorry
15:38:48 <mattdm> distracted again
15:38:51 <mattdm> squirrels
15:38:55 <bcotton> #agreed BZ 1385432 is considered fixed for the purposes of the PrioritizedBugs process
15:39:07 <bcotton> #topic  PackageKit accumulate over 18GBytes of RPM packages in /var/cache/PackageKit/metadata and fill my root filesystem with unused RPM files
15:39:09 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1306992
15:39:10 <bcotton> #info BZ 1306992 was accepted on 2018-08-29
15:40:27 <bcotton> nothing new on this since the last time, really
15:41:05 <mattdm> yeah I don't think any background work either
15:41:24 <mattdm> i will talk to richard again
15:41:40 <bcotton> #action mattdm to follow up with Richard Hughes again
15:41:48 <bcotton> anything else?
15:42:51 <bcotton> okay, last one
15:42:54 <bcotton> #topic get_best_query().filter(latest=True) is returning incorrect results
15:42:55 <bcotton> #link https://bugzilla.redhat.com/show_bug.cgi?id=1548586
15:42:57 <bcotton> #info BZ 1548586 was accepted on 2018-06-11
15:43:01 <bcotton> #info fixed version in dnf 3.0 COPR, but not available in Fedora yet
15:43:03 <bcotton> #info we wanted the fix backported, but that may be too challenging
15:43:22 <bcotton> sigh, gotta update my notes better between meetings
15:43:38 <bcotton> #undo
15:43:38 <zodbot> Removing item from minutes: INFO by bcotton at 15:43:03 : we wanted the fix backported, but that may be too challenging
15:43:40 <bcotton> #undo
15:43:40 <zodbot> Removing item from minutes: INFO by bcotton at 15:43:01 : fixed version in dnf 3.0 COPR, but not available in Fedora yet
15:43:46 <bcotton> #info we wanted the fix backported, but that may be too challenging
15:43:57 <bcotton> so i think this may be another "fixed for our purposes" bug?
15:45:19 * mattdm looks
15:45:48 <mattdm> yeah, and it looks like the dnf team is working with brian to address the lorax issue
15:45:54 <mattdm> (i was cc'd on some mail)
15:46:16 <bcotton> proposed #agreed BZ 1548586 is considered fixed for the purposes of the PrioritizedBug process
15:46:50 <mattdm> +1
15:47:10 <bcotton> #agreed BZ 1548586 is considered fixed for the purposes of the PrioritizedBug process
15:47:31 <bcotton> okay, then we're all done here
15:47:38 <bcotton> #topic Next meeting
15:47:40 <bcotton> #info The 24 October meeting is canceled
15:47:46 <bcotton> #info The next meeting is 7 November at 1600 UTC in #fedora-meeting (note the change in UTC time due to the end of Daylight Saving Time in the US)
15:47:56 <mattdm> thanks ben!
15:48:03 <bcotton> #endmeeting