magazine
LOGS
20:00:05 <stickster> #startmeeting Magazine editorial board
20:00:05 <zodbot> Meeting started Wed Sep 12 20:00:05 2018 UTC.
20:00:05 <zodbot> This meeting is logged and archived in a public location.
20:00:05 <zodbot> The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:05 <zodbot> The meeting name has been set to 'magazine_editorial_board'
20:00:07 <stickster> #meetingname magazine
20:00:07 <zodbot> The meeting name has been set to 'magazine'
20:00:08 <stickster> #topic Roll call
20:00:10 <stickster> .hello pfrields
20:00:11 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
20:00:25 <stickster> #chair ryanlerch sub_pop cverna
20:00:25 <zodbot> Current chairs: cverna ryanlerch stickster sub_pop
20:01:05 * stickster pulls up stats and a chair
20:02:48 <ryanlerch> .hello ryanlerch
20:02:49 <zodbot> ryanlerch: ryanlerch 'Ryan Lerch' <rlerch@redhat.com>
20:02:54 <ryanlerch> morning stickster!
20:03:13 <stickster> morning Ryan, got your java?
20:03:43 <ryanlerch> stickster: yes! sorry!
20:03:51 <ryanlerch> that is why i was 2 mins late :D
20:03:58 <asamalik> .hello2
20:03:59 <sub_pop> .hello linkdupont
20:04:00 <zodbot> asamalik: asamalik 'Adam Samalik' <asamalik@redhat.com>
20:04:03 <zodbot> sub_pop: linkdupont 'Link Dupont' <link@sub-pop.net>
20:04:17 <stickster> #chair asamalik
20:04:17 <zodbot> Current chairs: asamalik cverna ryanlerch stickster sub_pop
20:04:45 <stickster> #topic Last week's stats
20:04:51 <ryanlerch> morning all!
20:05:31 <stickster> #info Week of Sep 3: ~69.5K page views, up from previous week and a very nice way to start what's often a "down" month
20:06:04 <stickster> We're already on our way to be the best September (YoY) ever
20:06:25 <asamalik> good morning evening and afternoon!
20:06:40 <ryanlerch> some good meaty articles have been helpig that IMHO!
20:06:47 <asamalik> \o/
20:07:01 <stickster> Indeed!
20:07:56 <sub_pop> Also an article on the ever-controversial GNOME
20:08:28 <ryanlerch> sub_pop: :)
20:08:41 <stickster> sub_pop: Did we get a lot of controversial comments? I'm not sure I saw all the incoming, given the timing
20:09:12 <stickster> There was that one about trying to run it on an underpowered machine
20:09:25 <ryanlerch> nothing more than people doing that "shampoo is better" scene from billy madison... :D
20:09:35 <sub_pop> It was quite civil, considering the wrath with which other sites seem to talk about GNOME. But I suspect that's because there's a strong correlation between Fedora users and GNOME users.
20:10:54 <stickster> ryanlerch: lol. sub_pop: could be? I'll never understand why bashing other people's thing is a way anyone wants to spend their time
20:11:35 <sub_pop> Neither can any of us in the GNOME community
20:11:39 <stickster> ^ bashing other people's bashing of other people's things apparently is exempt :-D
20:11:47 <sub_pop> rofl
20:11:53 <ryanlerch> :D
20:11:58 <stickster> Anyhoo
20:12:09 <stickster> Excellent that we're off to a great start.
20:12:31 <stickster> Nothing in Pending Review :-\ so...
20:12:35 <stickster> #topic Drafts to review
20:12:40 <stickster> #link https://fedoramagazine.org/wp-admin/edit.php?post_status=draft&post_type=post
20:13:19 <stickster> sub_pop: OK, it's probably about time we figure out what to do with the 15 year post. That's only ~7 weeks off IIRC
20:13:44 <sub_pop> Yes!
20:13:45 <stickster> #info --- Figuring out the 15 year anniversary story ---
20:13:53 <stickster> #link https://fedoramagazine.org/?p=21118&preview=1&_ppp=68464f6db6
20:13:53 <sub_pop> It's nagging in the back of my mind.
20:14:04 <sub_pop> I fleshed it out some, IIRC
20:14:26 <ryanlerch> wallpapers over the years might be a good side post / part of this post
20:14:34 <stickster> Yes indeed! I almost feel like this could be a couple stories. Why not one about the tech, one about the art, and another about the people?
20:14:54 <sub_pop> Ah cool yea
20:15:05 <sub_pop> The draft I wrote seems mostly "the tech" one?
20:15:23 <ryanlerch> fwiw, i have them back to 8 here:
20:15:25 <ryanlerch> https://fedoramagazine.org/installing-extra-wallpaper-packs-to-fedora-workstation/
20:15:35 <stickster> I wonder if I could convince mizmo[m] to write us an article highlighting some art and wallpapers across the 15 years of Fedora. She's been working on it pretty much that entire time
20:15:36 <ryanlerch> that was kinda the limit of ones in the repos
20:15:40 <stickster> ryanlerch: ^ agreed!
20:15:56 <stickster> oh wait, I thought you said "link back to them," my apologies
20:16:03 <stickster> although yeah, we could of course do that
20:16:47 <stickster> #action stickster email mizmo[m] to see if she could put something together in the next 2-3 weeks
20:17:01 <stickster> We could make this a set of anniversary posts to run across the whole week
20:17:16 <sub_pop> What kind of content are you imagining for people?
20:17:40 <stickster> sub_pop: What about some interviews with people who've been around for most of that time?
20:18:07 <stickster> not full length for each person -- rather, ask a set of questions of everyone, then weave them together into a retro piece
20:18:08 <ryanlerch> a video of someone installing fc1, then upgrading one by one to fedora 29?
20:18:19 <sub_pop> ryanlerch: =-O
20:18:20 <stickster> ryanlerch: only if we speed it up like 100x!
20:18:32 <sub_pop> I do have a FC1 qcow2 image that works in GNOME Boxes
20:18:35 <stickster> actually, would need to be more like 250x probably!
20:19:00 <stickster> ISTR we didn't really have upgrade at all until... what, fedup?
20:19:13 <sub_pop> Who are some people who have been around?
20:21:17 <stickster> sub_pop: hmmm. those we can still reach easily, and might afford us the time? me, quaid, mizmo, notting, mattdm, dcantrell(?), jforbes, spot, maybe kfenzi?
20:21:38 <stickster> oh and gregdek
20:22:18 * sub_pop waits for the summons
20:22:20 <stickster> There are *TONS* of others who came in during the years after FC1/FC2, but I think all those were around then
20:22:45 <stickster> There are, similarly, lots of participants who were there at the start but now off doing other things
20:22:58 * jforbes reads backscroll
20:22:59 <sub_pop> Yea
20:23:20 <stickster> sub_pop: How about as a first action, draft a set of questions that would be interesting to ask. Start a thread on list and we can collab it there
20:23:46 <sub_pop> Alright.
20:24:00 <stickster> Like, how'd you hear about it/get involved, what was the most fun thing you've done in Fedora, are you still involved and what do you do now, ...
20:24:05 <stickster> just some thoughts
20:24:05 <mattdm> stickster no we totally did. anaconda did it.
20:24:25 <mattdm> fedup was a quick "oh no! we forgot to put upgrade in the anaconda rewrite plans" fix
20:24:41 <stickster> OK, my memory's notoriously doubleplusungood.
20:25:05 <mattdm> I don't think it's actually possible to upgrade from some releases, though. FC4 was bonkers.
20:25:27 <stickster> #action sub_pop start thread on interview questions, with goal to send out requests maybe by this Friday
20:26:05 <stickster> We can give people 2-3 weeks to answer, and it shouldn't take more than a couple more to pull together the piece
20:26:22 <ryanlerch> stickster: sounds like a good plan!
20:26:23 <stickster> Ideally we want to have everything ready a couple weeks ahead, since the Fedora 29 GA is happening between then and our target date
20:26:45 <jforbes> Happy to take some time to answer questions.
20:27:00 * stickster pokes mattdm to remind him about articles for F29 release (announcements etc.) so we don't do a last-minute fire drill
20:27:09 <stickster> jforbes: that would be awesome, thanks!
20:27:18 <stickster> expect to hear from Link or someone shortly :-)
20:28:06 <stickster> sub_pop: Do you want to take the action of meanwhile turning your tech article outline into prose?
20:28:14 * mattdm hides
20:28:17 <sub_pop> Yes
20:28:53 <sub_pop> Archive.org to the rescue! (My old FC1 RPM repo) https://web.archive.org/web/20040606090718/http://rpms.subpop.net:80/
20:31:09 <stickster> mattdm: I poke only because there is a good chance I won't be around during that 1-2 weeks to answer a klaxon.
20:31:29 <stickster> Well, not only because of that. Primarily because fire drills are bad. But also that.
20:31:57 <sub_pop> On that, are there FC29 Talking points that we can start drafting into the What's New Workstation article?
20:32:03 <stickster> #action sub_pop Turn 15-year tech outline into something more prosey
20:32:12 <sub_pop> Oh my. F29*
20:32:16 <sub_pop> 👴
20:32:19 <stickster> hahaha
20:32:36 * stickster points further marketingy stuff to #fedora-mktg for the moment so we can get to the bottom of a schedule
20:33:21 <stickster> #info --- Python 3.7 ---
20:33:23 <stickster> #link https://fedoramagazine.org/?p=22568&preview=1&_ppp=402d05db88
20:33:30 <sub_pop> #action sub_pop to probe #fedora-mktg for Talking Points for the What's New in Fedora 29 Workstation
20:33:54 <ryanlerch> +1 on the python article
20:33:56 <stickster> I actually retitled this (from "null") so we'd know what it is -- it's still really just a pitch. But seems very in keeping with our "We ❤️  Python" stance
20:34:11 <ryanlerch> we have done similar ones to this befoer, and they have always done well
20:34:13 <stickster> +1 here, too
20:35:04 <sub_pop> +1 if this is a pitch
20:35:19 <sub_pop> Oh, there, /me rereads
20:35:26 <stickster> #agreed Python 3.7 article is approved
20:35:28 <stickster> #action stickster email mcyprian to have him complete the article
20:35:45 <stickster> #info --- battery saving ---
20:36:01 <stickster> #link https://fedoramagazine.org/?p=22301&preview=1&_ppp=3aa68a5ef9
20:36:41 <sub_pop> Didn't this come up before?
20:37:54 <stickster> Yeah
20:38:05 <stickster> I believe I emailed the author already
20:38:24 <stickster> There was no response :-(
20:38:45 <sub_pop> That's too bad. This is a nice pitch.
20:38:57 <sub_pop> .fasinfo pams1234
20:38:58 <zodbot> sub_pop: User: pams1234, Name: Pamir Sujan, email: pamstheartist@gmail.com, Creation: 2016-09-08, IRC Nick: None, Timezone: UTC, Locale: C, GPG key ID: None, Status: active
20:39:01 <zodbot> sub_pop: Approved Groups: cla_done cla_fpca
20:39:33 <stickster> #action stickster ping Pamir again (DONE)
20:39:48 <stickster> #info --- git repos ---
20:40:00 <stickster> #link https://fedoramagazine.org/?p=21705&preview=1&_ppp=38d2a62181
20:40:12 <stickster> #info stickster pinged sundaram on this with no response
20:40:44 <stickster> Does anyone out there want to take this over?
20:41:19 <ryanlerch> is this for "running your own git forge"?
20:41:26 <ryanlerch> or what you should use?
20:41:41 <stickster> it's options for running a FOSS git forge, yes
20:41:58 <sub_pop> :( This would be great too
20:42:12 <stickster> I'm guessing in this case it's things like Gitlab CE, Pagure, Kallithea
20:42:27 <sub_pop> perhaps between cverna and I we could get through this series?
20:42:45 <ryanlerch> yeah, i can help out whit this one too
20:43:01 <stickster> Yeah, depends on how heavy the install/config sections are -- I'm guessing you'd need an article per
20:43:01 <ryanlerch> but the "running a server" part is where i willbe useless :)
20:43:22 <sub_pop> I can see it being an article per project
20:43:24 <stickster> This seems like something not likely to hit in the next week :-)
20:43:30 <sub_pop> And a docker image or vagrant box for each.
20:43:46 <sub_pop> That's pretty low-barrier-to-entry/trial for people
20:44:08 <sub_pop> Be cool if we could demo it in openshift too
20:44:08 <stickster> That's how all the kids want to do it. Preferably it should at least help them get started, then point them at the official docs for how to run in production
20:44:24 <stickster> Like "here's how you can take it for a test drive"
20:44:27 <sub_pop> Yea
20:44:49 <sub_pop> Or maybe we can do buildah/podman versions
20:44:51 <stickster> ryanlerch: sub_pop: cverna: Maybe you guys can discuss amongst yourselves which to do first, how to tackle/divide up work
20:45:00 <stickster> If we could get one next week that would ROCK
20:45:00 <ryanlerch> stickster: +1
20:45:08 <sub_pop> Phew, yea. My todo list is getting longer and longer
20:45:18 <stickster> sub_pop: haha. see what happens when you show up?
20:45:30 <stickster> asamalik: ^^ you too!
20:45:33 <bowlofeggs> there's also redmine and gerrit ☺
20:45:38 <stickster> oh yeah
20:45:40 <sub_pop> lol gerrit
20:45:53 <stickster> bowlofeggs: congrats, you just volunteered to write one of those.
20:45:55 <sub_pop> or "How to tear your hair out without even trying"
20:45:57 <bowlofeggs> lol
20:45:59 <sub_pop> rofl
20:46:08 <stickster> YOU SEE WHAT HAPPENS LARRY
20:46:10 <sub_pop> we could summon the army with "emacs"
20:46:16 <bowlofeggs> i did actually deploy and admin a redmine years and years ago (probably ~2010?)
20:46:27 <bowlofeggs> haven't since though (though i have used one since)
20:46:33 <stickster> OK, getting serious though, we still have nothing on deck for our Fri/Mon/Wed schedule. And I have to leave in 15 min
20:46:59 <asamalik> omg did I just say .hello and then got awfully distracted? :/ sorry
20:47:06 <ryanlerch> stickster: was thinking cos its a lean week, i could refresh that wallpaper article, and report
20:47:08 <sub_pop> #action sub_pop, cverna, ryanlerch, bowlofeggs discuss git-forge article series
20:47:09 <ryanlerch> repost
20:47:28 <ryanlerch> https://fedoramagazine.org/installing-extra-wallpaper-packs-to-fedora-workstation/
20:48:02 <stickster> ryanlerch: Yeah, we may need to do that!
20:48:10 <stickster> Could we try it for Friday?
20:48:13 <sub_pop> Or "unveil" the F29 background?
20:48:26 * stickster has time to whip something up for Monday -- both his weekend gigs were canceled due to expected weather
20:48:37 <stickster> sub_pop: not sure we have that totally finished yet
20:48:39 <stickster> or is it?
20:48:41 <sub_pop> Oh yea. Stay dry!
20:48:49 <ryanlerch> there is a silverblue testday pitch too
20:49:02 <sub_pop>20:49:40 <stickster> ryanlerch: OH!! that would be great
20:49:51 <stickster> #topic Pitches to review
20:50:19 <ryanlerch> it needs a few intro paragraphs into just what is silverblue (and why it exists)
20:50:22 <asamalik> I really liked the wallpapers article, didn't know we have those in packages
20:50:47 <stickster> asamalik: indeed!
20:50:52 <ryanlerch> hopefully somthing a bit more that "atomic workstation" since it still confuses me a little bit
20:51:01 * asamalik loves Silverblue!
20:51:18 <stickster> ryanlerch: What if we run that on Friday?
20:51:27 * stickster is running it on his old laptop now
20:51:32 <ryanlerch> asamalik: would you be able to help me expand the intro to that test day article?
20:51:44 * ryanlerch is  still a little confused by it all
20:52:00 <asamalik> ryanlerch: sure!
20:52:18 <ryanlerch> these test day articles on magazine are more like "look at this awesome new feature coming"
20:52:30 <ryanlerch> oh, and we are having a test day for it
20:52:48 <ryanlerch> stickster: okies put asamalik and me on the hook for frifay
20:52:50 <stickster> asamalik: ryanlerch: It would be good if that article also had a few more details on the actual date, too (which is on the wiki page)
20:52:54 <asamalik> quick summary: fearless upgrades, os vs. app separation, runs Civilization V :D
20:52:59 <stickster> it's coming up next week, so Friday is perfect to run the article
20:53:08 <stickster> we have older test day articles to rely on for that
20:53:12 <stickster> asamalik: :-D
20:53:30 <stickster> #action ryanlerch and asamalik finish Silverblue Test Day article for publication on Fri 2018-09-14
20:53:55 <stickster> All the other pitches are pre-existing. cverna has two in that list that he was going to work on
20:54:25 <stickster> ryanlerch: If you do the wallpaper update article for Monday, I'll whip something up this weekend for Wednesday
20:54:32 <stickster> sub_pop has a lot to do already :-D
20:54:32 <asamalik> ryanlerch: let's do that tomorrow morning.. ehhh.. later today? 😧
20:54:39 <ryanlerch> stickster: sounds like a plan
20:54:47 <sub_pop> Yea I'm not volunteering for anything else this week :P
20:54:50 <stickster> #topic Publishing schedule (cutting to the chase)
20:54:54 <ryanlerch> asamalik: for sure, i'll be around your morning / my ebening
20:55:10 * asamalik sets an alarm clock
20:55:23 <ryanlerch> asamalik: haha, not that early
20:55:31 * asamalik lied
20:56:00 <stickster> proposal: #agreed SCHEDULE: Fri 2018-09-14, Silverblue Test Day (asamalik/ryanlerch) -- Mon 2018-09-17, Easy wallpaper retro update (ryanlerch) -- Wed 2018-09-19 TBA (stickster)
20:56:10 <ryanlerch> +1
20:56:12 <asamalik> +1
20:56:40 <sub_pop> +1
20:57:08 <stickster> #agreed SCHEDULE: Fri 2018-09-14, Silverblue Test Day (asamalik/ryanlerch) -- Mon 2018-09-17, Easy wallpaper retro update (ryanlerch) -- Wed 2018-09-19 TBA (stickster)
20:57:13 <stickster> OK, anything else?
20:57:17 <stickster> #topic Open floor
20:57:54 <sub_pop> 🦗
20:58:28 <asamalik> 🦑
20:58:34 <stickster> :-)
20:58:38 <ryanlerch> 
20:58:40 <stickster> OK, thanks for coming everyone!
20:58:51 <ryanlerch> thanks for chairing stickster
20:58:54 <ryanlerch> stay safe
20:59:06 <stickster> 🎂
20:59:14 <asamalik> thanks all and sorry for not being there too much in the start
20:59:14 <stickster> #endmeeting