magazine
LOGS
20:00:43 <stickster> #startmeeting Magazine editorial board
20:00:43 <zodbot> Meeting started Wed Aug  1 20:00:43 2018 UTC.
20:00:43 <zodbot> This meeting is logged and archived in a public location.
20:00:43 <zodbot> The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:43 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:43 <zodbot> The meeting name has been set to 'magazine_editorial_board'
20:00:46 <stickster> #meetingname magazine
20:00:46 <zodbot> The meeting name has been set to 'magazine'
20:00:49 <stickster> #topic Roll call
20:00:52 <stickster> .hello pfrields
20:00:53 <zodbot> stickster: pfrields 'Paul W. Frields' <stickster@gmail.com>
20:01:03 <cverna> hi everyone :)
20:01:05 <stickster> #chair ryanlerch x3mboy sub_pop[m] cverna
20:01:05 <zodbot> Current chairs: cverna ryanlerch stickster sub_pop[m] x3mboy
20:01:12 <ryanlerch> .hello ryanlerch
20:01:13 <zodbot> ryanlerch: ryanlerch 'Ryan Lerch' <rlerch@redhat.com>
20:01:19 <stickster> Hi Clément, Ryan... thanks for being here!
20:02:20 <stickster> Hmm, just us chickens so far?
20:02:36 <stickster> ryanlerch: Oh my goodness, did you realize we past 10M views this month?
20:02:46 <stickster> passed*  <-- nice writing, Paul
20:03:01 <cverna> nice :)
20:03:09 <stickster> that's all-time, but still!
20:03:12 <sdgathman> I have an idea for an article, but I can't work on it until after Aug 11 (presentation)
20:03:19 <cverna> I think we passed the 2M for this year
20:03:39 <ryanlerch> 10M OMG!
20:03:45 <stickster> cverna: We did indeed!
20:03:50 <ryanlerch> wow!
20:04:05 <stickster> sdgathman: We'd love to hear about it. We can put you up in a moment if you can't stick around long
20:04:10 <stickster> #topic Last week's stats
20:04:28 <sdgathman> stickster: I'm working on a package, but will keep this open
20:04:35 <stickster> #info Last week: just shy of 66.5K pageviews -- up again from previous week which is great
20:05:32 <stickster> #info For July 2018: 272,852 pageviews -- that is down from July 2017 but *only* because that was a release month!  Up over 75% from July 2016!
20:06:04 <stickster> #info This month we also passed *2 million* page views for the year, and *10 million* page views all-time!
20:06:08 <cverna> 3 best month of the year so far :)
20:06:36 <stickster> indeed
20:06:38 <cverna> without spectre/meltdown and release it would be our best month
20:06:44 <stickster> *nod
20:07:04 <stickster> cverna: your VS Code article was *INCREDIBLY* popular
20:07:13 <ryanlerch> so we hope for a high-profile security issue?
20:07:14 <stickster> over 13.4K views on Friday alone
20:07:23 <stickster> ryanlerch: hahahahaha yeah. NO. I mean NO.
20:07:25 <ryanlerch> cverna++ nice work on that one!
20:07:39 <stickster> cverna++++++++++++++++++++
20:07:41 <cverna> yeah it did bring it fair share of comments too :)
20:09:01 <cverna> I probably do another one on the VS Code live share plugin that allow to share the editor with multiple people
20:09:08 <cverna> but that will be after flock :)
20:10:27 <stickster> cverna: It did. I find the uninformed and rude comments about freedom to be completely irrational and evidence that some people are always looking to grind an axe.
20:10:34 <ryanlerch> yeah those comments arent unexpected though :(
20:10:46 <stickster> SORRY GUYS, IT'S AS FREE AS ANYTHING YOU RUN. Stop whining.
20:11:01 <stickster> *pant pant* sorry
20:11:06 <sdgathman> "Can anything good come out of Microsoft?"
20:11:21 <stickster> sdgathman: apparently, that's been asked and answered ;-)
20:11:35 <ryanlerch> cverna: i loved the response that we are a contributor org, feel free to write about your favourite editor
20:11:41 <stickster> me too!
20:11:42 <ryanlerch> then *crickets*
20:11:57 <cverna> :) that's the best answer we can do :P
20:12:02 <stickster> oh well. Anyway, it was a fantastic article cverna, and you can be proud of it!
20:12:13 * stickster is going to switch to vs code just to try it out more
20:12:46 <stickster> #topic Quick pitch moment with sdgathman
20:12:54 <stickster> sdgathman: OK, tell us about your idea!
20:13:14 <sdgathman> My idea is to present how to use common apps in full decentralized mode.
20:13:42 <sdgathman> E.g. a simple smtpd on a laptop listening on cjdns IP, and linphone on a cjdns IP.
20:14:04 <sdgathman> It's not a new idea, but new to Fedora magazine.
20:14:17 <sdgathman> I'm doing a presentation for LUG on Aug 11.
20:14:25 <sdgathman> That's it.
20:14:40 <sdgathman> Oh
20:14:45 <stickster> sdgathman: Sounds intriguing -- but I'm not familiar with cjdns, can you describe what problem/use case this solution solves?
20:14:46 <sdgathman> Full dex because no dns.
20:15:17 * cverna was looking at that https://github.com/cjdelisle/cjdns/blob/master/doc/Whitepaper.md
20:15:22 <stickster> i.e. title of the article is "How to...[what?]"
20:15:26 <sdgathman> No DNS, no IANA, no central authority, no telco, but direct phone calls.
20:15:54 <sdgathman> How to make phone calls with no server.
20:16:00 <stickster> there you go!
20:16:08 <cverna> I think that sounds like a cool idea
20:16:17 <sdgathman> Normally, in NAT jail, you have to use a central server like linphone.org to make SIP calls.
20:16:24 <stickster> So you don't have to pay for a service or connect to a server, but here you go... I think that sounds fascinating
20:16:40 <sdgathman> linphone.org is free (beer), but ....
20:17:33 * stickster is +1 on pitch
20:17:35 <cverna> I am +1
20:17:42 <ryanlerch> +1 from me!
20:17:50 * jsmith uses cjdns from time to time himself
20:18:03 <sdgathman> cjdns is in Fedora
20:18:09 <stickster> #agreed sdgathman pitch for "How to make phone calls without a server" is approved, can be drafted at any time
20:18:52 <stickster> #topic Pending review posts
20:18:56 <stickster> #link https://fedoramagazine.org/wp-admin/edit.php?post_status=pending&post_type=post
20:19:05 <stickster> #info --- set up your own router ---
20:19:13 <stickster> #link https://fedoramagazine.org/?p=21941&preview=1&_ppp=50d91eddb2
20:19:35 <stickster> Oops, I think this was the one you were going to try to put out yesterday/today, is that right ryanlerch?
20:19:39 <ryanlerch> this ome was for today, but bounced it for the docs one
20:20:01 <ryanlerch> still a bit of work to do on it, but can get it ready for friday if needs be
20:20:52 <stickster> I had an idea for one, and I was doing tech work for it over the weekend but failed to complete
20:21:54 <sdgathman> "How to run your own <centralized service of some sort>" is always helpful to avoid full centralization.
20:22:14 <sdgathman> We need more of those.
20:22:19 <stickster> ryanlerch: I might be able to finish my article for this Friday but I'm not sure tbh
20:22:37 <stickster> I can *definitely* get it ready for Monday. I'm looking back at my notes/progress and it looks like I'm almost there.
20:22:39 <ryanlerch> stickster: i can get the router one done for friday
20:22:48 <stickster> OK. If we miss Wed this week, so be it
20:22:48 <cverna> we still have the docs one to push through too
20:22:52 <stickster> Ah yes!
20:22:58 <stickster> We also need to figure out what to do about Flock
20:23:15 <ryanlerch> yeah, docs is just waiting for the site to go live, then the docs one
20:23:21 <stickster> Several of us will be there all next week -- I expect I won't have time to write anything though I might be able to edit a less "challenging" article
20:23:41 <ryanlerch> i canhold down the fort
20:23:44 <ryanlerch> :)
20:23:54 <stickster> ryanlerch: HEY! cprofitt sent us a HDYF!
20:23:55 <ryanlerch> maybe another listicle artile too
20:24:07 <stickster> Oh wait, it's not done. But coming, I think
20:24:10 <ryanlerch> stickster: AFAICT, it is just a wireframe
20:24:58 <ryanlerch> stickster: that will take the pressure off a bit
20:25:02 <stickster> ryanlerch: OK, I will write up mine tonight (right after I finish the rest of my podcast mix/post) so you have it available
20:25:14 <cverna> we had a few 5 apps for ... that could be done for the Flock week
20:25:20 <ryanlerch> stickster: awesome
20:25:25 <stickster> Ah, indeed cverna! It's like we planned for this :-D
20:25:58 <cverna> I might be able to do one over the weekend or during the travel to flock on Tuesday
20:25:59 <stickster> So ryanlerch, is the docs site expected to go live tonight/tomorrow, or is that more undecided?
20:26:16 <stickster> #info router article is more challenging and needs work
20:26:26 <ryanlerch> stickster: according to bexelbie on the list, thursday for the live / post
20:26:30 <stickster> #action ryanlerch will get to it when time allows, we may have other articles closer to going out
20:26:51 <stickster> #info article on new docs site is imminent with the go-live happening Thursday 2018-08-02
20:27:20 <stickster> Is that something you have in hand now?
20:27:27 <ryanlerch> i did a feature image for docs last night too
20:27:34 <stickster> Sounds like it is, then -- coolio!
20:28:01 <ryanlerch> stickster: +1
20:28:17 <stickster> #action ryanlerch will push out docs site article Thu 2018-08-02 with the go-live
20:28:23 <cverna> atolstoy sent some pitches too on the mailing list
20:28:43 <stickster> 🤯
20:28:55 <cverna> https://lists.fedoraproject.org/archives/list/magazine@lists.fedoraproject.org/thread/ZCDSKZK2PT5FM2VHQRCR4CEFFCKLM45C/
20:28:57 <stickster> embarrassment of riches!
20:29:05 <cverna> ha ha :)
20:30:54 <stickster> Oh, I just realized I was on the wrong page and that's why I couldn't find the docs post :-D
20:31:07 <stickster> #topic Pitches to review
20:31:23 <stickster> #info --- transform Linux fs ---
20:31:31 <stickster> #link https://fedoramagazine.org/?p=22143&preview=1&_ppp=6ceba59b72
20:32:02 <stickster> Once again, 🤯
20:32:06 <ryanlerch> +1 from me -- is it in Fedora do we know?
20:32:14 <cverna> +1 too
20:32:39 <cverna> https://apps.fedoraproject.org/packages/fstransform
20:32:41 <stickster> cverna: it is!
20:32:43 <cverna> it looks like
20:32:56 <cverna> :)
20:32:57 <stickster> It's like magic
20:32:58 <stickster> +100
20:33:06 <stickster> #agreed fstransform pitch is approved
20:33:18 <stickster> #action stickster email list + atolstoy so he can draft when ready
20:34:20 <ryanlerch> awesome!
20:34:52 <stickster> #info --- upscale bitmaps ---
20:34:58 <stickster> #link https://fedoramagazine.org/?p=22145&preview=1&_ppp=2dbbf27c92
20:35:38 <ryanlerch> never heard of these too, but sound interesting!
20:35:56 <ryanlerch> looking forward to some side-byside comparisons!
20:35:57 <stickster> This is great. I would like to see it get a better title, like "Upscale small icons with better results" or something a little less jargon
20:36:05 <ryanlerch> +1 from me
20:36:20 <ryanlerch> i can be on the hook for editing this one when the time comes too
20:36:22 <stickster> ryanlerch: Check out https://github.com/nagadomi/waifu2x
20:36:30 <stickster> there's examples in the readme
20:36:53 <stickster> ryanlerch: you're on
20:37:04 <stickster> big +1 here, this looks cool
20:37:05 <cverna> +1 too
20:37:16 <stickster> #agreed upscaling bitmaps article approved
20:37:24 <stickster> #action stickster email list + atolstoy so he can draft when ready
20:37:30 <ryanlerch> atolstoy++
20:37:31 <zodbot> ryanlerch: Karma for atolstoy changed to 1 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
20:37:39 <cverna> atolstoy++
20:37:39 <zodbot> cverna: Karma for atolstoy changed to 2 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
20:37:47 <cverna> cookies are back :)
20:38:09 <stickster> atolstoy+++++++++++++
20:38:17 <stickster> aw man zodbot you're no fun
20:38:20 <stickster> atolstoy++
20:38:22 <zodbot> stickster: Karma for atolstoy changed to 3 (for the current release cycle):  https://badges.fedoraproject.org/tags/cookie/any
20:38:23 <stickster> *sigh
20:40:00 <stickster> OK, so that is basically it for everything new.
20:40:05 <stickster> #topic Publishing schedule
20:40:09 <stickster> So I think so far we have:
20:40:13 <stickster> Thu 2018-08-02 -- docs
20:40:30 <stickster> Fri 2018-08-03 -- mmmmmmmaybe router, or something else?
20:40:41 <stickster> Mon 2018-08-06 -- my article should be ready
20:41:34 <stickster> Wed 2018-08-08 -- listicle?
20:41:38 <stickster> Fri 2018-08-10 -- listicle?
20:41:45 <stickster> Mon 2018-08-13 -- ?
20:42:10 <stickster> I'm hoping that a HDYF and/or one of atolstoy's articles will be ready for the 10th and 13th
20:42:31 <ryanlerch> sounds like a plan
20:42:44 <cverna> oh I have a pitch replace jquery with vanilla javascript, learn how to use modern javascript instead of relying on a library
20:42:57 <stickster> haha cverna, I was just talking to mizmo[m] about that today
20:43:03 <ryanlerch> will try to do some more newsy stuff, and on-the fly stuff if needs be
20:43:09 <cverna> I have been playing with vanilla js today :)
20:43:17 <cverna> stickster: ah cool :)
20:43:36 <stickster> Now "PureJS" or vanilla is somehow sweeping the nation...  "no framework is the new framework"
20:43:42 <stickster> *nations
20:43:59 <cverna> stickster: http://vanilla-js.com/
20:44:14 <stickster> everyone is trying to out-cool each other, so "the old ways are best" is now hip
20:44:46 <stickster> cverna: I can't wait until we go back to telephones with cords, being nice to strangers, and people looking in each others' eyes at dinner
20:44:52 <cverna> stickster: the wheel always comes back to the starting point
20:45:29 <cverna> stickster: telephones with cords ??? what are you talking about :P
20:45:42 <stickster> cverna: 😡
20:45:56 <stickster> don't make me feel so old! :-D
20:46:01 <sdgathman> stickster: walking and biking places, you get to bow/nod to those you pass, and sometimes stop to talk.
20:46:34 <cverna> stickster: oops :-D
20:47:51 <stickster> #proposed #agreed Thu 2018-08-02, docs (ryanlerch) -- Fri 2018-08-03, router or alternative (ryanlerch?) -- Mon 2018-08-06, CD rip/burn part 2 (stickster) -- Wed 2018-08-08 / Fri 2018-08-10 / Mon 2018-08-13, TBA ryanlerch heroism
20:48:38 <stickster> atolstoy: we would love to fit one of your articles into the "TBA" schedule above ^^
20:48:42 <ryanlerch> +1
20:48:58 * stickster not happy about leaving ryanlerch with "heroism" duties but that's basically what it is
20:49:09 * stickster will try to do something extra to give him more to work with :-)
20:49:16 <ryanlerch> i may be too busy at flock down under
20:49:23 <stickster> ha!
20:49:34 <stickster> I want to go there next year, please
20:49:45 <ryanlerch> the oneperson flock in my basement
20:49:48 <stickster> Next year will be 10 years since I was in APAC, I think I'm due
20:50:17 <stickster> #agreed Thu 2018-08-02, docs (ryanlerch) -- Fri 2018-08-03, router or alternative (ryanlerch?) -- Mon 2018-08-06, CD rip/burn part 2 (stickster) -- Wed 2018-08-08 / Fri 2018-08-10 / Mon 2018-08-13, TBA ryanlerch heroism
20:50:27 <stickster> #topic Open floor, all other business
20:51:08 <stickster> Anything else to discuss this week?
20:51:10 <ryanlerch> nothing from me
20:51:19 <cverna> nothing here
20:52:44 <stickster> Okey dokey
20:52:51 <stickster> Thanks for being here, everyone!
20:52:53 <stickster> #endmeeting