fedora-qa
LOGS
15:00:49 <adamw> #startmeeting Fedora QA Meeting
15:00:49 <zodbot> Meeting started Mon Jul  2 15:00:49 2018 UTC.
15:00:49 <zodbot> This meeting is logged and archived in a public location.
15:00:49 <zodbot> The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:49 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:49 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:00:54 <adamw> #meetingname fedora-qa
15:00:54 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:56 <adamw> #topic Roll call
15:01:00 <adamw> who's around for QA fun?
15:01:05 * sumantro is here
15:01:21 * coremodule is here!
15:02:04 <jlanda> hello
15:02:20 <sumantro> jlanda, hey!
15:02:53 * kparal is here
15:03:30 <frantisekz> .hello2
15:03:31 <zodbot> frantisekz: frantisekz 'František Zatloukal' <fzatlouk@redhat.com>
15:05:11 <pac23> hi
15:05:20 <adamw> morning folks
15:05:23 <adamw> how's everyone doing?
15:06:07 <kparal> monday-y
15:06:44 <adamw> hah, i know, right.
15:06:49 <adamw> it's a holiday here, too :/
15:06:49 <kparal> but this week has only 3 working days over here, so it's not so bad :)
15:07:16 <adamw> #topic Previous meeting follow-up
15:07:18 <sumantro> kparal, india has the whole working week :D
15:07:27 <jlanda> here too
15:07:34 <kparal> somebody needs to do the job when we're slacking :)
15:08:02 <sumantro> kparal, I am all game :)
15:08:18 <adamw> kparal: we don't really notice any difference ;)
15:09:04 * kparal scratches his head
15:09:07 <adamw> #info "adamw to implement removal of kickstart package criterion" - this was done, except the criterion is replaced by one requiring only a git tag: https://fedoraproject.org/wiki/Fedora_29_Final_Release_Criteria#Kickstarts
15:10:02 <adamw> #info "adamw to file ticket for writing permanent modularity test cases, adding them to the validation matrix, tag sumantrom, sgallagh and langdon" - also done, https://pagure.io/fedora-qa/issue/555
15:10:08 <adamw> note there hasn't been any movement there...
15:10:26 <sumantro> adamw I am waiting for sgallagh for reverting back
15:11:06 <kparal> lruzicka complained that his proposed modularity test case went unreviewed by server sig. not sure if it changed
15:11:13 <sgallagh> sumantro: Apologies, but I'm not going to have time to deal with that until the 16th at the earliest
15:11:27 <sgallagh> kparal: I swear we approved that...
15:11:52 <kparal> ok, that was last week, maybe that changed
15:11:58 <sumantro> sgallagh, copied!
15:12:03 <kparal> he's on PTO this week anyway
15:12:28 <adamw> yeah, i thought i saw a mail approving it too
15:12:41 <sgallagh> kparal: Would you mind sending a reminder message to server@? I'll dig through the archives.
15:12:57 <sgallagh> But I feel like we discussed and approved it at a previous meeting, though I may have forgotten to report it back
15:13:06 <adamw> that might be it.
15:14:42 <kparal> what I found seems approved. I'll talk to lruzicka when he gets back
15:17:32 <adamw> #kparal to follow up with lruzicka on modularity test case
15:17:35 <adamw> ....d'oh
15:17:38 <adamw> #action kparal to follow up with lruzicka on modularity test case
15:17:46 <adamw> move along?
15:19:13 <kparal> sure
15:20:29 <adamw> #topic Fedora 29 status
15:21:04 <adamw> so, things are quite 'exciting' in F29 right now
15:21:15 <adamw> #info DNF 3 landed in F29 last week
15:21:40 <adamw> #info Python 3.7 is pending soon
15:23:18 <adamw> obviously, we need to be testing all package management-related bits with DNF 3
15:23:37 <adamw> it can affect pretty much anything, as libdnf was also bumped and packagekit needed a rebuild
15:24:06 <sumantro> DNF 3.0 Test Days are in order then adamw say what?
15:24:20 <adamw> can't hurt
15:24:42 <adamw> #action sumantro to look into organizing DNF 3.0 test day(s)
15:24:44 * sumantro got another one in bucket!
15:27:34 <adamw> for python we should be on the lookout for breakage in the installer obviously, and in major tooling including our own
15:28:10 <sumantro> adamw anaconda test day ? :)
15:29:12 <adamw> well, again running test days never hurts, but we do test the installer pretty hard just through openqa and validation testing
15:29:19 <adamw> so, i'll say that's up to you, bearing in mind schedule issues etc etc
15:29:33 <sumantro> adamw, sure sure :)
15:30:40 <coremodule> Not exactly a test day, but an ansible 101/102 session is planned for later this week on July 5th... Details to come.
15:30:47 <adamw> alrighty
15:33:28 <adamw> any other notes on f29?
15:33:52 <coremodule> Why won’t it run on my hardware??
15:33:55 <coremodule> https://ibb.co/gyuRNJ
15:35:20 <adamw> because god hates you
15:35:26 <adamw> hehe
15:35:34 <adamw> man, i used to have one of those.
15:35:44 <adamw> complete with 5.25" floppy drives.
15:36:08 <adamw> #topic Test Day / Onboarding status
15:36:12 <adamw> so, what's goin' on, sumantro?
15:36:17 <sumantro> Upcoming Test Day: https://fedoraproject.org/wiki/Test_Day:2018-07-12_Fedora_Media_Writer
15:37:30 <sumantro> Thanks to coremodule , we had a Onboarding session which was interactive and we had couple of introduction emails coming in..so /me is happy
15:38:01 <coremodule> :D ‘twas fun, let’s do it again!
15:38:10 <adamw> #chair sumantro
15:38:10 <zodbot> Current chairs: adamw sumantro
15:38:29 <adamw> did we get good attendance at the onboarding? and have you guys been following up on the group membership requests?
15:39:02 <jlanda> I would like to attend, but I was busy ;)
15:39:13 <sumantro> adamw we got around ~15ish people. I need to follow up on the membership req.
15:39:22 <adamw> ok, please be careful to do that
15:39:33 <adamw> #action sumantro to check on qa group membership request backlog
15:39:56 <sumantro> I have also raised a bunch of tickets for test days
15:40:37 <sumantro> and contacted the maintainers.. so this season , we should have about 15 Test Days in total (if everything goes right)
15:40:51 <adamw> excellent
15:41:01 <adamw> #info onboarding event went well with ~15 attendees
15:41:13 <adamw> #info around 15 test days are in the works for F29 cycle
15:41:28 <adamw> good job, sumantro and coremodule
15:42:03 <sumantro> thanks adamw et all QA contributors for showering so much testing love! :)
15:42:29 <coremodule> Thanks adamw, glad to help!
15:42:50 <adamw> anything else on this topic?
15:43:12 <Southern_Gentlem> wiki page showing those somewhere?
15:43:35 <sumantro> Southern_Gentlem, which one , the test day topics?
15:43:39 <Southern_Gentlem> yes
15:43:52 <sumantro> I am glad you asked, a rough draft is here https://fedoraproject.org/wiki/QA/Test_Days/Fedora_Test_Days
15:44:03 <adamw> though also look at the fedora-qa tracker and the calendar
15:44:31 <Southern_Gentlem> when on that page would be good as well
15:44:42 <sumantro> Southern_Gentlem, right now
15:44:44 <jlanda> after talking to jskladan, I proposed an fedora-bootstrap restyling for the testdays-web to be coherent with the rest of the fedora-apps
15:45:08 <jlanda> so luckily it wilm be ready for those test days ;)
15:45:17 <Southern_Gentlem> sumantro, nm i didnt see the date under status
15:45:18 <jlanda> s/wilm/will
15:45:52 <sumantro> Southern_Gentlem, as and when the maintainers start giving me a GO , I will go ahead and schedule, I will say to tune in every week once :)
15:48:17 <adamw> #topic Open floor
15:48:22 <adamw> so, anything else to note, folks?
15:48:43 <kparal> nothing here
15:48:56 <jlanda> Hi! I would like to introduce myself. I'm julen, 35 years old and Free software fan since late 90s. I like to contribute to the community when I have some spare time and this time I ended here ;)
15:49:15 <kparal> welcome jlanda
15:49:22 <kparal> thanks for all the patches
15:49:30 <jlanda> np
15:50:12 <jlanda> I don't have time for big projects but I like to contribute as I can
15:50:40 <adamw> hi jlanda, welcome!
15:52:46 <jlanda> thanks
15:54:03 <adamw> welp, if that's everything, let's get 6 minutes back :)
15:54:05 <adamw> thanks for coming out, folks
15:54:11 <adamw> #endmeeting