fedora-qa
LOGS
15:00:03 <adamw> #startmeeting Fedora QA Meeting
15:00:03 <zodbot> Meeting started Mon Jun 11 15:00:03 2018 UTC.
15:00:03 <zodbot> This meeting is logged and archived in a public location.
15:00:03 <zodbot> The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:03 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:00:07 <adamw> #meetingname fedora-qa
15:00:07 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:12 <adamw> #topic Roll call
15:00:18 <adamw> morning folks! who's around for meet-y fun?
15:00:25 <lruzicka> .hello2
15:00:26 <zodbot> lruzicka: lruzicka 'Lukáš Růžička' <lruzicka@redhat.com>
15:00:32 <reher> .hello
15:00:32 <zodbot> reher: (hello <an alias, 1 argument>) -- Alias for "hellomynameis $1".
15:00:40 <x3mboy> .hello2
15:00:41 <zodbot> x3mboy: x3mboy 'Eduard Lucena' <eduardlucena@gmail.com>
15:00:48 * coremodule is ready for meet-y fun!
15:01:08 <frantisekz> .hello2
15:01:08 <zodbot> frantisekz: frantisekz 'František Zatloukal' <fzatlouk@redhat.com>
15:01:08 <tflink> .hello2
15:01:11 <zodbot> tflink: tflink 'Tim Flink' <tflink@redhat.com>
15:01:18 <adamw> mmm, meet-y
15:01:30 <adamw> sgallagh: any chance you can join us?
15:01:30 * sumantrom[m] is here
15:01:47 <sgallagh> adamw: For 30 minutes, yes
15:01:51 <sgallagh> Then I have another meeting
15:02:09 <adamw> alright, i'll try and get to that topic quick
15:02:29 <adamw> #topic Previous meeting follow-up
15:03:02 <adamw> #info "adamw to follow up on crypto and grub Change proposals with concerns about 'how to test' sections" - I did that, there's been some follow-up discussion on devel@
15:03:27 <adamw> #info "adamw to draft proposal to drop the kickstart criterion" - I also did that, and the proposal was generally +1ed, I will likely go ahead and make the change this week
15:03:35 <adamw> #action adamw to implement removal of kickstart package criterion
15:03:41 <adamw> any other follow-up from last week?
15:03:50 <adamw> further thoughts on the changes or anything?
15:05:52 <sgallagh> I suspect it'll tie into the future discussion, but I plan to submit another module-related Change today
15:06:02 <sgallagh> Which will, of course, have QA impact
15:06:29 <adamw> can we get a sneak preview?
15:06:32 <sgallagh> https://fedoraproject.org/wiki/Changes/ModulesForEveryone
15:06:54 <sgallagh> (that's a draft; it may need cleaning up)
15:08:27 <adamw> look under your seat! you get a module! and you get a module!
15:08:37 <sgallagh> Basically, yes
15:08:39 <adamw> alrighty, so yeah, let's go ahead and segue into...
15:08:45 <adamw> #topic Modularity testing coverage
15:09:33 <adamw> so basically i just wanted to pull in sgallagh and make sure we've got a good plan for setting up ongoing modularity testing
15:09:43 <sgallagh> The most noteworthy thing I think you probably want to take away from that link is that we expressly treat non-default module streams as non-blocking for any purpose aside from proving that module streams can be switched at all
15:09:44 <adamw> sumantro, are you still holding the ball for writing modularity test cases?
15:10:37 <Sumantrom> Yes!
15:10:49 <adamw> ok
15:10:56 <adamw> hum, i thought we had a ticket for it, but i don't see it
15:11:26 <adamw> have you talked with sgallagh about what specifically we need to be covering? do you have a plan for what test cases to write?
15:12:47 <Sumantrom> I have a brief word with sgallagh and he will get back to me, I will ping him tomorrow for more details and I am aware of libdnf changes and cockpit test cases which are to be written
15:13:05 <adamw> okay
15:13:30 <sgallagh> Right now my view is that we want to block on the functionality working *at all*, but not for any specific alternative module streams being available
15:13:44 <sgallagh> And by "functionality" I mean:
15:13:51 <adamw> sgallagh: yeah, i'm focusing on the functionality of the system - but there's enough complexity there in itself
15:14:19 <adamw> basically we need to decide exactly what needs to be 'functional' and ensure we write test cases to cover it all, and they're in the validation pages
15:14:27 <adamw> so i think the best thing to do here is to have a ticket we can use to track progress, make sure everything that needs to be covered is covered, and make sure it's done by beta
15:14:32 <sgallagh> * The set of stuff we blocked on in F28
15:14:32 <sgallagh> * That updates must work via all supported package managers and honor the selected module streams
15:14:32 <adamw> does that sound reasonable?
15:14:44 <sgallagh> Sounds right to me
15:14:57 <Sumantrom> Sounds good to me as well
15:16:06 <adamw> ok, so i'll file a ticket and make sure you're both @ on it
15:16:23 <adamw> of course, anyone who wants to help with that work, please join the ticket too
15:16:42 <adamw> #action adamw to file ticket for writing permanent modularity test cases, adding them to the validation matrix, tag sumantrom and sgallagh
15:16:47 <lruzicka> ack
15:16:51 <sgallagh> ack
15:16:52 <adamw> any other thoughts on this?
15:17:01 <sgallagh> adamw: Please keep langdon on that CC as well
15:17:34 <adamw> roger
15:17:35 <Sumantrom_> Adamw sure, thanks :)
15:17:37 <adamw> #undo
15:17:37 <zodbot> Removing item from minutes: ACTION by adamw at 15:16:42 : adamw to file ticket for writing permanent modularity test cases, adding them to the validation matrix, tag sumantrom and sgallagh
15:17:46 <adamw> #action adamw to file ticket for writing permanent modularity test cases, adding them to the validation matrix, tag sumantrom, sgallagh and langdon
15:17:48 <sgallagh> (He's the Objective Lead... I'm just the muscle :) )
15:20:31 <adamw> alrightly, thanks a lot sgallagh
15:20:32 <adamw> moving along!
15:20:42 <sgallagh> Any time
15:20:45 <adamw> #topic Onboarding status
15:20:58 <adamw> just wanted a quick update from sumantro on where we are with the next onboarding meeting, for anyone who wants to join
15:21:57 <Sumantrom_> So the probable date is 2018-06-19 I had a affirmative from fedora classroom team too for a larger audience.
15:22:21 <Sumantrom_> Timing is yet to be decided but we should have it in next 24 hrs
15:22:23 * langdon muttes
15:22:29 * langdon mutters rather
15:22:55 <Sumantrom_> I will send out invites and social media posts shortly
15:23:05 * adamw sends langdon back to the room with the rubber walls
15:23:17 <lruzicka> :)
15:23:28 <adamw> Sumantrom_: awesome, thanks - everyone pencil in 2018-06-19 on your calendars....
15:23:30 <Sumantrom_> @coremodulw and @frantizek if possible :)
15:24:00 <adamw> #info onboarding meeting is pencilled in for 2018-06-19, please come along if you would find it helpful or you want to help onboard some new members!
15:24:39 <coremodule> Sumantrom_, you got it! I'm ready and excited!
15:25:03 <Sumantrom_> Thanks coremodule! :)
15:25:55 <adamw> #topic Open floor
15:26:02 <adamw> OK, folks, that's all I had for the agenda - any other thoughts/notes?
15:26:14 <Sumantrom_> Tomorrow is kernel 4.17 test day!
15:26:33 <Sumantrom_> Reminder emails to hit inbox shortly!
15:26:40 <adamw> i'll note quickly that i have managed to mess up openqa staging, due to an attempt to upgrade to a new version which turns out to need a newer postgresql than is running on the database server. i'm trying to work that out with tflink and nirik.
15:26:50 <adamw> #info kernel 4.17 test day is tomorrow, 2018-06-12 - be there or be square!
15:27:09 <adamw> https://fedoraproject.org/wiki/Test_Day:2018-06-12_Kernel_4.17_Test_Day
15:27:27 <lruzicka> adamw: My heart stopped for a while when I started to read about messing up the OpenQA.
15:27:39 <adamw> heh, it's just my sysadmin style
15:27:42 <lruzicka> adamw: Lucky me, it was not for the test :)
15:27:44 <frantisekz> adamw: I am here, if you need some help with upgrading and breaking servers :)
15:27:45 <adamw> sloppy upgrades on a friday night are the only way to go! :P
15:27:54 <adamw> frantisekz: hehe, thanks
15:28:00 <adamw> lruzicka: yup, you're in the clear
15:28:22 <adamw> production is still fine, of course.
15:29:03 <adamw> f29 is looking generally OK ATM, except oddly in the last few days, live install tests - particularly KDE live install tests - are often failing on the root password screen. i've got to grab an ISO locally to try and figure out what's going on there.
15:31:04 <lruzicka> adamw: I realized, on my machine, that sometimes booting the vm takes so long that the test fails to complete.
15:32:01 <adamw> lruzicka: yikes, sounds like your test box might be a bit underpowered or badly configured...
15:32:17 <adamw> we can talk about it in #fedora-qa
15:32:28 <lruzicka> adamw: Ok.
15:35:22 <adamw> any other thoughts for the meeting, or shall we close out early so everyone can go hit the bar? :)
15:36:25 <Sumantrom_> Or grab dinner ;)
15:36:49 <adamw> who said you can't get dinner in the bar ;)
15:37:22 <Sumantrom_> ;)
15:38:49 <adamw> alrighty, thanks a lot for coming folks!
15:38:59 <adamw> note there's no blocker meeting today, we still only have two proposed blockers, doesn't seem worth it.
15:39:20 <adamw> #endmeeting