dotnet
LOGS
14:33:43 <Rhea> #startmeeting Fedora DotNet (2018-05-31)
14:33:43 <zodbot> Meeting started Thu May 31 14:33:43 2018 UTC.
14:33:43 <zodbot> This meeting is logged and archived in a public location.
14:33:43 <zodbot> The chair is Rhea. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:33:43 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:33:43 <zodbot> The meeting name has been set to 'fedora_dotnet_(2018-05-31)'
14:33:49 <Rhea> #meetingname dotnet
14:33:49 <zodbot> The meeting name has been set to 'dotnet'
14:33:51 <Rhea> #nick dotnet
14:34:24 <Rhea> #chair aslice pcreech omajid
14:34:24 <zodbot> Current chairs: Rhea aslice omajid pcreech
14:34:35 <omajid> hello!
14:34:48 <Rhea> #topic 2.1 release
14:34:52 <aslice> .hello aslice
14:34:53 <zodbot> aslice: aslice 'Andrew Slice' <andrew.slice@redhat.com>
14:35:52 <Rhea> Sooo omajid :] What do you think about fedora dotnet 2.1
14:36:17 <omajid> Rhea: it's pretty much the top fedora-related item on my list
14:36:48 <omajid> i tried some rc1-ish like builds a week or so ago: https://copr.fedorainfracloud.org/coprs/omajid/dotnet-2.1/build/755258/
14:36:57 <Rhea> yeah
14:37:10 <omajid> once i can test the final 2.1 bits, i will open a pr and do builds for it in the official copr
14:37:17 <Rhea> Is RHEL build much different?
14:37:32 <omajid> not sure :)
14:37:46 <Rhea> heh okay
14:38:15 <omajid> i needed minimal patches for 2.1 rc1, so i can't imagine buiding 2.1 final will be complicated
14:38:17 <Rhea> When that's done, should we update the dev portal to say "install dotnet-sdk-2.1" instead, or simply go with the meta "install dotnet" ?
14:38:50 <Rhea> ref https://developer.fedoraproject.org/tech/languages/csharp/dotnet-installation.html
14:38:59 <Rhea> It currently says `2.0`
14:39:18 <omajid> hm.. this will be interesting. the 2.1 sdk was, actually, shipped months ago.
14:39:35 <Rhea> I think that we could replace the SDK line with the meta, and the runtime one with `X.Y` and a note that it's whtaever version you want...
14:39:39 <omajid> i will have to fine tune the steps. we can do that late.
14:39:42 <omajid> yeah, that makes sense
14:39:47 <omajid> later*
14:41:26 <Rhea> Maybe worth mentioning, 2.1.400 *should* contain a fancy "fix" for us, that will make omnisharp-IDE's work again... until then they don't really work with our 2.1.300
14:41:47 <Rhea> (for those who may be present who missed out on that)
14:42:31 <Rhea> #action Rhea update the netcore instructions on the developer portal
14:42:34 <Rhea> there...
14:42:36 <Rhea> :D
14:42:47 <Rhea> Anything else we have to mention/talk about/rant about?
14:43:12 <Rhea> Come on, give me your rant aslice!
14:43:14 <Rhea> o_o
14:43:25 <aslice> Which one?
14:43:34 <Rhea> haha nice
14:44:05 <Rhea> Oh by the way, anyone looked at powershell?
14:44:16 * omajid runs away, screaming
14:44:17 * aslice cringes.
14:44:21 <Rhea> I was thinking that it should actually be relatively easy to package for Fedora
14:44:49 * Rhea shares those feelings
14:45:33 <Rhea> I thought that we could take it under dotnet-sig as it is dotnet dependent...
14:46:00 <aslice> I don't disagree with that sentiment.
14:46:29 <omajid> I would prefer to get .NET Core into fedora proper before we start picking up more packages, but if someone else wants to volunteer to do the work, i wont stop them
14:48:36 <Rhea> Hmm... well yep that's a bit of a long term thing
14:48:53 <Rhea> dotnet broken on Fedora 28 due to ncurses 6.1  - https://pagure.io/fedora-dotnet/issue/41
14:49:03 <Rhea> That's in 2.1 right
14:49:09 <omajid> yup. 2.1 should work fine
14:49:31 <Rhea> Unable to build on Fedora 28 due to missing LLDB.h - https://pagure.io/fedora-dotnet/issue/40
14:49:33 <Rhea> Close as well?
14:49:37 <omajid> i probably should have been more specific. dotnet fails on some terminals on fedora 28
14:49:49 <omajid> gnome-terminal fails. tmux fails. xterm works.
14:50:44 <omajid> yes, that's fixed with an update
14:51:15 <omajid> oh, you were faster :)
14:51:15 <Rhea> So the #41 kinda fails on... 2.0 only, some terminals in f28?
14:51:34 <omajid> right. and only on some releases of 2.0. the next 2.0 update will include the fix too.
14:51:44 <Rhea> heh
14:52:11 <Rhea> Okay, do we want to keep it open then or close it at this point?
14:52:41 <omajid> let me fix the wording. and we can close it when we either update to 2.1 or fix the underlying issue on 2.0
14:52:48 <omajid> does that sound okay?
14:52:56 <Rhea> yup
14:53:20 <Rhea> #46 Unable to upgrade dotnet/install 2.0&2.1 sdk side-by-side. - https://pagure.io/fedora-dotnet/issue/46
14:53:33 <Rhea> This will wait for actual 2.1?
14:54:18 <omajid> this one will be hard to fix unless we just go to 2.1 (sdk and runtime) and eol 2.0
14:54:50 <Rhea> I have nothing against dropping 2.0 due to not only this but also many other bugs (incl. security issues)
14:55:12 <omajid> in essense, it's a CANTFIX. the way i upgraded to sdk 2.1 from sdk 2.0, it kind of broke side-by-side, but also made it hard to go back and fix 2.0
14:55:29 <omajid> another data point: upstream will EOL 2.0 in 3 months now that 2.1 is out
14:55:40 <Rhea> Right...
14:55:56 <Rhea> We can do that as well then ^
14:56:57 <Rhea> Any other thoughts, aslice, ...? o_O
14:57:34 <aslice> I think after the 2.1 release gets through that I'm going to add fedora dockerfiles to s2i-dotnetcore.
14:57:56 <aslice> I don't know where we could host the final container images yet.
14:58:11 <Rhea> cool o.o
14:58:32 <aslice> Who on the fedora side should I talk to about maybe getting this stuff in a fedora branded docker registry?
14:58:56 <Rhea> I know nothing about that i'm afraid x.x
14:59:12 <Rhea> We can throw an email around
14:59:21 <aslice> Do we have a fedora 'program director'?
14:59:28 <aslice> for the dotnet stuff, I mean.
14:59:47 <Rhea> I really don't know about docker-in-fedora at all, nothing...
15:00:13 <aslice> Ok, I'll take a look at it too.
15:00:19 <Rhea> could just make it a question for fedora-devel and someone will know the answer
15:00:42 <Rhea> The next meeting approaches. Shall we end this suffering?
15:00:49 <aslice> I'm good.
15:01:08 <omajid> thanks everyone!
15:01:34 <Rhea> kaaaaay :]
15:01:43 <Rhea> aslice++
15:01:43 <zodbot> Rhea: Karma for aslice changed to 1 (for the f28 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:01:48 <Rhea> Omair ran away...
15:01:53 <Rhea> #endmeeting