fedora-qa
LOGS
15:00:26 <adamw> #startmeeting Fedora QA Meeting
15:00:26 <zodbot> Meeting started Mon Apr 30 15:00:26 2018 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:26 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:00:30 <adamw> #meetingname fedora-qa
15:00:30 <zodbot> The meeting name has been set to 'fedora-qa'
15:00:35 <adamw> #topic Roll call
15:01:13 * coremodule is here!
15:01:26 <tflink> .hello2
15:01:27 <zodbot> tflink: tflink 'Tim Flink' <tflink@redhat.com>
15:01:29 <adamw> morning folks, who's around for qa fun?
15:03:09 * kparal is here
15:03:38 <adamw> aw c'mon, there's going to be so much fun(*)
15:03:40 <adamw> * - not really
15:04:40 <adamw> welp, let's have a smol meeting then :P
15:05:33 <coremodule> :D
15:07:11 <adamw> #chair coremodule tflink
15:07:11 <zodbot> Current chairs: adamw coremodule tflink
15:07:33 * jsmith is here, lurking
15:07:57 <jsmith> (doing more ${DAYJOB} work than Fedora work at the moment)
15:08:24 <adamw> .fire jsmith inconceivable!
15:08:24 <zodbot> adamw fires jsmith inconceivable!
15:08:47 <adamw> #topic Previous meeting follow-up
15:09:05 <adamw> "kparal to check in with blocking image SIGs on changing their target image size to DVD media size"
15:09:08 <adamw> how's that going?
15:09:18 <kparal> they completely ignore me
15:09:41 <kparal> I think I'll put in the last value we used and ask them to change it if they want
15:09:47 <kparal> then they can me ignore me again
15:10:22 * kparal finds a link to the email
15:11:10 <kparal> https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/message/6AHPJ2L4E7CZB6TLMXNMUN4HHKLVOULS/
15:11:13 <kparal> #link https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/message/6AHPJ2L4E7CZB6TLMXNMUN4HHKLVOULS/
15:11:37 * adamw doesn't want to say he told you so, but...:P
15:12:15 * kparal shrugs. feels invisible
15:12:37 <jsmith> kparal: :-(
15:13:20 <jsmith> I'm about to the point that if they can't bother to respond to an email about a blocking item, that we drop the artifacts
15:13:36 <jsmith> I know that's cold and heartless and mean, but it's been happening for far too long...
15:13:41 <jsmith> </rant>
15:14:29 <kparal> workstation sig responded, so we keep their iso :-)
15:14:47 <adamw> i would be equally willing to accept possession of a large stick with rusty nails in it, marked "SIG INCENTIVISER"
15:15:14 <adamw> #info "kparal to check in with blocking image SIGs on changing their target image size to DVD media size" - kparal tried, most SIGs have simply ignored the request. He's going to try again
15:15:14 <pwhalen> apologies kparal, we will update the arm images today
15:15:18 <kparal> I'll just put the old value in and convert those tickets to "please review and change if needed"
15:15:24 <kparal> pwhalen: thanks
15:15:27 <kparal> *values
15:15:59 <kparal> I wasn't even sure whether it makes sense to have some size limit for disk images, or just .iso's
15:16:16 <kparal> thoughts?
15:16:25 <adamw> i mean, it kinda does
15:16:42 <adamw> the usual process is to write the image to an sd card and put that in the system, right?
15:16:50 <kparal> yep
15:16:54 <adamw> so, if one of the images was like 200GB that'd be a problem. 256GB SD cards are expensive. :P
15:17:00 <kparal> or, for cloud, boot directly
15:17:41 <kparal> anyway, they have the option. if they don't respond now, the values will be empty (no limit), and they can set it later
15:18:00 <kparal> (for those disk images)
15:19:59 <adamw> sounds good. we'll see.
15:20:00 <pwhalen> for graphical images we wanted it to fit on an 8Gb card, minimal 2G originally
15:20:09 <adamw> any other followup from last week?
15:22:43 <adamw> i guess not!
15:22:52 <adamw> #topic Fedora 28 status, final planning
15:23:56 <adamw> so, F28 is signed off and going out tomorrow
15:24:05 <adamw> #info F28 is signed off for release tomorrow
15:24:12 <adamw> #info many thanks to all who helped with validation testing, update testing etc.
15:24:17 <adamw> morning sumantro
15:24:45 <sumantro> morning adamw
15:24:47 <sumantro> how are you doing?
15:25:32 <adamw> good thanks
15:26:02 <adamw> so, we have the usual common bugs stuff to do: keep documenting issues tagged for the list, and change the header to the 'release' state tomorrow
15:26:45 <coremodule> I'll have some Heroes of Fedora articles drafted by the end of the week on F28.
15:27:05 <adamw> excellent
15:27:07 <kparal> coremodule++
15:27:07 <zodbot> kparal: Karma for coremodule changed to 5 (for the f27 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:27:17 <coremodule> :)
15:27:18 <adamw> #info coremodule will draft Heroes of Fedora articles for the F28 cycle
15:27:40 <kparal> I'd bundle it all (Beta + Final) instead of splitting it
15:27:57 <kparal> but that's just my personal preference
15:28:10 <adamw> doing it by milestone makes it more comparable to earlier cycles
15:28:17 <adamw> and also gives us more posts. :P
15:28:20 <kparal> ah, the historian has spoken
15:28:28 <adamw> and the publicist!
15:28:33 <kparal> :)
15:28:48 <adamw> never write in one page what you can write in five, with a cliffhanger at the end of each...
15:29:08 <coremodule> such sage advice
15:29:10 <coremodule> ;P
15:29:15 <kparal> it was split in the past because it was published directly after the milestone has completed, in the past. but I don't mind too much either way
15:29:38 <kparal> note that the scripts pulling old data get imprecise quite soon
15:30:00 <adamw> sure, but the original *posts* are still around.
15:30:37 <adamw> #action adamw and kparal to fill out common bugs and update header to release status
15:30:52 <kparal> common bugs should be up-to-date
15:30:54 <adamw> so, aside from that: there's an update out for the GNOME Shell password issue - https://bugzilla.redhat.com/show_bug.cgi?id=1569211
15:31:01 <kparal> the header is probably not
15:31:03 <adamw> it'd be great if folks can help test and karma that so we can have it pushed out for tomorrow
15:31:16 <sumantro> adamw will test it right away
15:31:46 <kparal> I found out that I have the first letter as capital in my password. didn't know :)
15:31:48 <adamw> kparal: yeah, the template only works after the version template is changed. that's kinda dumb, i should change the template so you can just specify the version number, or it reads it from the page name.
15:32:02 <adamw> i realized i was hitting it when trying to paste ssh passphrases
15:32:11 <adamw> but, because i'm terminally dumb, only about the seventh time it happend
15:32:29 <adamw> (hit ctrl-v, you don't get a pasted passphrase, you get a 'v'...)
15:33:24 <adamw> there's also a kernel in u-t with a fix for https://bugzilla.redhat.com/show_bug.cgi?id=1565131 , but that has sufficient karma to go stable already
15:33:59 <adamw> #info update https://bodhi.fedoraproject.org/updates/FEDORA-2018-f1989df398 is pending for the GNOME Shell password issue https://bugzilla.redhat.com/show_bug.cgi?id=1569211 , it would be good to get that tested and karma'ed so it can go out before release
15:34:19 <adamw> anyone aware of any other updates we should really get out by 0-day?
15:34:44 <kparal> hm
15:35:26 <kparal> h264 playback in firefox was broken. but rpmfusion might have fixed it already. not really a fedora problem
15:35:34 <kparal> also, firefox crashes on some certain pages
15:35:46 <kparal> ff60 will fix that, but it's not in updates-testing yet
15:35:54 <kparal> https://bugzilla.redhat.com/show_bug.cgi?id=1541603
15:35:55 <adamw> kparal: is that tagged for commonbugs?
15:36:15 <kparal> nope
15:36:21 <kparal> not sure how big a problem this is
15:36:25 <mclasen> kparal: I think it is a fedora problem
15:36:28 <kparal> so far, only 2 pages were identified
15:36:46 * mclasen will take it elsewhere
15:37:08 <kparal> mclasen: the h264 issue? since we don't have ffmpeg in fedora repos, it's hardly something we can do much about
15:37:22 <mclasen> that in itself, is a fedora problem too
15:37:22 <adamw> mclasen: talking about h264? yeah, we shouldn't really talk about it officially, but someone should SURE TALK TO FUSION ABOUT THAT HUH
15:37:30 <kparal> mclasen: I'm not arguing that
15:37:37 <mclasen> anyway, offtopic
15:38:16 <kparal> I talked about both issues with firefox maintainer
15:38:32 <adamw> wait, wasn't there that whole thing about having openh264 in firefox somehow "officially"? what happened to all of that? where am I? who's the president?
15:38:35 <kparal> both have fixes, definitely once FF60 hits repos
15:38:51 <adamw> oh, https://fedoraproject.org/wiki/OpenH264 . right.
15:39:02 <kparal> adamw: that's only for webrtc. it's there, but doesn't play usual videos
15:39:13 <kparal> it only supports the lowest profile that webrtc uses
15:39:26 <adamw> ah.
15:39:39 * adamw dodders off to play some lawn bowls
15:40:22 <kparal> so, I haven't proposed the firefox crash because I'm not sure it's too widespread
15:40:36 <kparal> but if  you see your browser crashing, we can definitely add it to common bugs
15:40:37 <adamw> #info there is a known crasher bug in Firefox which will be fixed by FF60 when it arrives: https://bugzilla.redhat.com/show_bug.cgi?id=1541603
15:40:44 <kparal> or hopefully FF60 gets pushed in the meantime
15:40:47 <adamw> i mean, i can see french people going to the Swatch website...
15:41:18 <adamw> and steamspy seems like a thing people might use. but then i've never hit it before. so, hey.
15:41:22 <kparal> alright, I can add it in
15:42:02 <adamw> alright, so, any other misc. f28 business?
15:42:27 <sumantro> Test day retrospection will go out tomorrow :)
15:42:39 <adamw> aha, thanks sumantro
15:42:52 <adamw> #action sumantro to send out Test Day retrospective for F28 cycle
15:42:58 <adamw> there, a free action item for you to look good next week :P
15:43:08 <sumantro> "D
15:43:14 <sumantro> :D
15:44:01 <adamw> #topic Fedora 29 initial thoughts
15:44:09 <adamw> i just threw this on here in case anyone had anything, i don't really yet.
15:44:51 <adamw> we do have some accepted Changes already: https://fedoraproject.org/wiki/Releases/29/ChangeSet
15:44:58 <sumantro> I have been looking at that and we have couple of python 3 stuffs to test for
15:45:03 <adamw> "Make dbus-broker the default DBus implementation" is obviously huge
15:45:22 <adamw> python minor version bumps are usually not a *huge* deal but of course good to be aware of
15:45:43 * kparal added the firefox crash to common bugs
15:45:54 <adamw> it might be a nice idea to do a custom rawhide with python 3.7 as the system python and see if anaconda breaks...
15:45:57 <adamw> thanks kparal
15:46:56 <sumantro> adamw great idea
15:51:26 <adamw> #info initial set of accepted F29 Changes is at https://fedoraproject.org/wiki/Releases/29/ChangeSet , we can immediately identify the dbus-broker and python 3.7 Changes as important
15:55:02 <adamw> anything else on f29?
15:55:15 <adamw> #topic Test Day and onboarding status
15:55:20 <adamw> just a quick one here, i guess
15:55:43 <adamw> sumantro: so, i think you're working on a freeipa test day, right? and what's the plan for the onboarding meeting?
15:56:41 <sumantro> yes
15:57:01 <sumantro> so FreeIPA test day in schedule for next couple of weeks
15:57:29 <sumantro> onboarding call will happen once we fix the time again sometime next week
15:58:07 <adamw> ok!
15:58:32 <adamw> #info F28 Test Days are now done but a FreeIPA Test Day is coming up in the next couple of weeks, onboarding call is likely to happen sometime next week, an announcement will be sent when date is fixed
15:58:36 <adamw> #topic Open floor
15:58:39 <adamw> anything else, folks?
15:58:49 <sumantro> nothing from my side
15:59:07 <kparal> nothing here
15:59:33 <coremodule> nothing here!
16:00:18 <adamw> alrighty then
16:00:19 <tflink> nothing from me, either
16:00:21 <adamw> thanks for coming along, folks
16:00:26 <tflink> thanks for leading
16:00:30 <adamw> #endmeeting