fedora_prioritized_bugs_and_issues
LOGS
14:00:08 <jkurik> #startmeeting Prioritized_bugs_and_issues
14:00:08 <zodbot> Meeting started Wed Apr 25 14:00:08 2018 UTC.  The chair is jkurik. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:00:08 <zodbot> The meeting name has been set to 'prioritized_bugs_and_issues'
14:00:15 <jkurik> #meetingname Fedora Prioritized bugs and issues
14:00:15 <zodbot> The meeting name has been set to 'fedora_prioritized_bugs_and_issues'
14:00:21 <jkurik> #topic Purpose of this meeting
14:00:26 <jkurik> #info The purpose of this process is to help with processing backlog of bugs and
14:00:32 <jkurik> #info   issues found during the development, verification and use of Fedora distribution.
14:00:37 <jkurik> #info The main goal is to raise visibility of bugs and issues to help
14:00:42 <jkurik> #info   contributors focus on the most important issues.
14:00:48 <jkurik> #link https://fedoraproject.org/wiki/Fedora_Program_Management/Prioritized_bugs_and_issues_-_the_process
14:00:55 <jkurik> #info Currently we have 3 proposed bugs for evaluation and 3 bugs already approved for review.
14:01:00 <jkurik> #topic Roll Call
14:01:31 <jkurik> #chair jkurik mattdm sgallagh kparal adamw
14:01:31 <zodbot> Current chairs: adamw jkurik kparal mattdm sgallagh
14:01:43 <jkurik> do we have someone around today for the meeting ?
14:02:21 <sgallagh> jkurik: I'm semi-here. Mostly running around trying to get the 🦆s in order for Go/No-Go tomorrow.
14:02:35 <mattdm> jkurik: hey, I'm here
14:02:48 <jkurik> ok, lets try to run the meeting
14:02:56 <jkurik> #topic Evaluation of bug #1558486: Firefox does not block suspend in Gnome when downloads are on progress
14:03:02 <jkurik> #link https://bugzilla.redhat.com/show_bug.cgi?id=1558486
14:04:03 <sgallagh> A couple points here: the GNOME feature that is necessitating this was postponed until at least F29
14:04:19 <mattdm> Yeah, I was just going to say that
14:04:30 <mattdm> Plus, there's also an upstream bug now
14:04:57 <sgallagh> Also, it sounds like upstream is unwilling to focus on it, so treating it as Prioritized when it's not getting worked on sounds like a bad idea.
14:05:06 <mattdm> I'd actually be unhappy if firefox inhibited suspend
14:05:17 <jkurik> yes, me to
14:05:32 <mattdm> if I have a download running and close my laptop, and then it burns up in my backpack.... that's a worse outcome than having to restart the download
14:05:36 <jkurik> imo the described behavior is what I will expect
14:06:11 <sgallagh> mattdm: I think there's a differentiation between active and passive suspend
14:06:24 <sgallagh> If you hit the sleep button or close the lid, that's a different event than idle-suspend
14:06:44 <mattdm> is there a different inhibitor, though?
14:07:14 <sgallagh> mattdm: I thought so, but now I'm doubting myself.
14:07:43 <sgallagh> Anyway, sounds like we all agree this shouldn't be prioritized.
14:07:49 <sgallagh> at least right now
14:07:49 <jkurik> proposed #agreed The bug has not been approved as a Prioritized one. Please consider to re-propose the bug as Prioritized once this is fixed upstream.
14:07:55 <mattdm> yeah
14:08:00 <sgallagh> patch
14:08:07 <jkurik> sgallagh: go on
14:08:09 <sgallagh> If it's fixed upstream, it doesn't need to be Prioritized
14:08:23 <sgallagh> proposed #agreed The bug has not been approved as a Prioritized one. Please consider to re-propose the bug as Prioritized if the GNOME idle suspend feature is reintroduced.
14:08:37 <mattdm> +1
14:08:42 <jkurik> +1
14:08:43 <mattdm> I have some other comments I'll also drop in the bug
14:08:49 <sgallagh> +1
14:08:53 <jkurik> #agreed The bug has not been approved as a Prioritized one. Please consider to re-propose the bug as Prioritized if the GNOME idle suspend feature is reintroduced.
14:08:57 <jkurik> mattdm: ok
14:09:10 <jkurik> #topic Evaluation of bug #1556790: System suspends immediately after application releases idle lock (e.g. movie playback ends)
14:09:16 <jkurik> #link https://bugzilla.redhat.com/show_bug.cgi?id=1556790
14:09:56 <jkurik> This is a similar issue
14:10:03 <sgallagh> I'd actually say this one should be prioritized (and arguably a blocker to allowing the idle-suspend feature into Fedora)
14:10:04 <mattdm> same point on "change was deferred" applies
14:10:11 <sgallagh> No, I don't think so.
14:10:23 <mattdm> okay, that's fair.
14:10:26 <sgallagh> Because this is a core behavior of the suspend feature rather than an application's interaction with it
14:10:41 <mattdm> yeah, let's recommend to the change owners / fesco that this be a blocker to that feature
14:10:52 * mattdm afk for about three minutes, sorry.
14:13:11 <jkurik> sgallagh: looks like you are +1 to have this as a prioritized one, am I correct ? I am in doubht (+0,5)
14:14:08 <sgallagh> Well, I’m not sure about Prioritized, but I think it’s a necessary part of the Change
14:15:44 <mattdm> okay back sorry about htat
14:16:15 <mattdm> jkurik: do you have a link to the change handy, or the fesco ticket?
14:17:33 <jkurik> the only Change I am thinking of is this one: https://fedoraproject.org/wiki/Changes/ImprovedLaptopBatteryLife
14:17:44 <mattdm> hmmm, okay.
14:18:43 <jkurik> Or it just came in via Gnome upgrade, which has no Change
14:18:51 <mattdm> So, here's my suggestion: accept this is a prioritized bug, and I'll take the action to take that to the Workstation WG and make sure that a change gets filed with this as part of it
14:19:08 <mattdm> and then when that's done, we'll call it complete from the point of view of this meeting / process
14:19:16 <jkurik> ok
14:19:29 <sgallagh> mattdm: worksforme
14:20:45 <jkurik> proposed #agreed This bug is accepted as Prioritized one. It will be brought to Workstation WG asking for taking an action.
14:21:44 <jkurik> sgallagh, mattdm ^^^
14:21:56 <sgallagh> sure, +1
14:22:42 <jkurik> #agreed This bug is accepted as Prioritized one. It will be brought to Workstation WG asking for taking an action.
14:23:00 <jkurik> #action mattdm to bring this bug to Workstation WG
14:23:09 <jkurik> #topic Evaluation of bug #1558485: auto-suspend can't be disabled when GDM is active
14:23:14 <jkurik> #link https://bugzilla.redhat.com/show_bug.cgi?id=1558485
14:23:28 <jkurik> looks like the auto-suspend has a lot of edge-cases
14:24:03 <sgallagh> This one breaks Server if someone installs the GDM package.
14:24:19 <mattdm> yeah, that's... also not good.
14:24:42 <mattdm> can we put that in the same bucket as the previous one?
14:25:14 <sgallagh> I think yes
14:25:42 <jkurik> proposed #agreed This bug is accepted as Prioritized one. It will be brought to Workstation WG asking for taking an action.
14:26:36 <mattdm> +1
14:27:17 <jkurik> #agreed This bug is accepted as Prioritized one. It will be brought to Workstation WG asking for taking an action.
14:27:38 <jkurik> that were all the new bugs
14:27:55 <jkurik> do you have some time for a review of the older ones ?
14:28:26 <halfline> wait, that bug already got taken care of right ?
14:28:29 <mattdm> it's been a while so we probably should
14:28:34 <halfline> * Tue Apr 10 2018 Michael Catanzaro <mcatanzaro@gnome.org> - 3.28.0-2•
14:28:34 <halfline> - Disable automatic suspend, except when on battery power•
14:29:13 <mattdm> halfline: is that intended to be permanent?
14:29:58 <halfline> not sure what the f29 story will be, but my understanding is that was the f28 story
14:30:18 <mattdm> halfline: yeah, we're looking at the overall picture not just f28 release
14:30:38 <halfline> ah okay
14:30:55 <halfline> sorry, carry on :-)
14:31:07 <jkurik> #topic Review of bug #1367666: [Wayland] Stability is worse compared to X11 session due to intolerance for display server or gnome-shell crashes
14:31:14 <jkurik> #link https://bugzilla.redhat.com/show_bug.cgi?id=1367666
14:32:19 <jkurik> No update for more then 5 months
14:33:07 <mattdm> halfline since you're here, do you have any thoughts on this?
14:33:08 <jkurik> Can we ask the reporter whether this is still a case ?
14:33:33 <mattdm> Oh, it's definitely stilll the case
14:33:39 <mattdm> Because it's an architectural issue
14:33:55 <mattdm> I mean, Wayland itself is getting more stable, but stuff can still crash the shell
14:34:03 <halfline> right
14:34:25 <halfline> part of the problem is that gnome-shell requires Xwayland internally to operate
14:34:36 <halfline> and there is a branch to cleave it of that requirement
14:34:51 <halfline> but it's not in a mergeable state at the moment
14:34:58 <mattdm> So, should we close this as "upstream is aware and working on it"?
14:35:25 <halfline> jadahl also has a plan to rearchitect things more extensively, but it's a mid-term future thing
14:35:30 <halfline> nothing on the immediate horizon
14:35:42 <halfline> yea i think that would make sense
14:36:07 <halfline> other than, sometimes closing bugs can set off bear detectors
14:36:32 <sgallagh> bear detectors?
14:37:01 <halfline> i just mean if it gets closed, someone might complain that it gets closed
14:37:12 <halfline> not that big of a deal
14:37:19 <jkurik> proposed #agreed As this is an architectural issue and upstream is aware and working on it we are closing this bug as WONTFIX.
14:37:32 <halfline> not WONTFIX, UPSTREAM
14:37:32 <mattdm> Hmmm. Thinking about what halfline said...
14:37:40 <mattdm> yeah, DEFINITELY not WONTFIX :)
14:37:58 <mattdm> We can also leave it open as a tracker and drop it from prioritized bugs
14:38:06 <mattdm> which may be better for appearances
14:38:45 <jkurik> proposed #agreed As this is an architectural issue and upstream is aware and working on it we are removing this bug from the list
14:39:05 <jkurik> proposed #agreed As this is an architectural issue and upstream is aware and working on it we are removing this bug from the Prioritized list
14:39:15 <sgallagh> jkurik: ack
14:39:53 <jkurik> mattdm: ^^^ ?
14:40:35 <mattdm> ack
14:41:16 <jkurik> #agreed As this is an architectural issue and upstream is aware and working on it we are removing this bug from the Prioritized list
14:41:23 <jkurik> #topic Review of bug #1336435: Require all other updates to be installed before allowing to start system upgrade
14:41:31 <jkurik> #link https://bugzilla.redhat.com/show_bug.cgi?id=1336435
14:42:23 <mattdm> I've not heard back on this. I'll check with hughsie again
14:42:54 <jkurik> #action mattdm to check with hughsie the progress
14:43:00 <jkurik> #topic Review of bug #1385432: Dracut exhibits numerous AVC denied errors during cleanup, takes long time to power off
14:43:06 <jkurik> #link https://bugzilla.redhat.com/show_bug.cgi?id=1385432
14:43:57 <mattdm> is this still an issue with f28?
14:44:33 <sgallagh> I occasionally see long shutdown times, but I think that's a different issue.
14:44:37 <sgallagh> I don't see AVCs at least
14:44:47 <jkurik> mattdm: yes: https://bugzilla.redhat.com/show_bug.cgi?id=1385432#c157
14:48:10 <mattdm> hmmm. sgallagh, any idea who could figure this out?
14:48:38 <mattdm> Ondrej Kozina  says "the first one is beyond my domain"
14:49:08 <jkurik> There is a workaround: https://bugzilla.redhat.com/show_bug.cgi?id=1385432#c150
14:49:33 <jkurik> Does it make sense to move this to Common bugs instead (as we have the workaround) ?
14:49:38 <sgallagh> Sorry, was away for a moment.
14:50:00 <sgallagh> jkurik: That workaround is BAD
14:50:06 <jkurik> ok
14:51:04 <sgallagh> mattdm: I honestly don't know
14:51:31 <mattdm> okay... I'll maybe ask hhoyer?
14:52:04 <mattdm> (i just did, so take the ? away from that)
14:53:40 <jkurik> proposed #action mattdm to ask hhoyer what we can do about this bug
14:53:46 <sgallagh> Also the "maybe" :)
14:53:54 <jkurik> mattdm: ok ^^^ ?
14:53:59 <mattdm> :)
14:54:01 <mattdm> yeah
14:54:07 <jkurik> #action mattdm to ask hhoyer what we can do about this bug
14:54:14 <jkurik> that is all for today
14:54:28 <jkurik> sgallagh, mattdm, halfline: Thanks for the meeting
14:54:40 <sgallagh> jkurik: Thanks
14:54:41 <jkurik> #endmeeting