fedora-qa
LOGS
15:01:28 <adamw> #startmeeting Fedora QA Meeting
15:01:28 <zodbot> Meeting started Mon Apr  9 15:01:28 2018 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:28 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:01:34 <adamw> #meetingname fedora-qa
15:01:34 <zodbot> The meeting name has been set to 'fedora-qa'
15:01:38 <adamw> #topic Roll call
15:01:48 <adamw> morning folks, who's around for qa meeting fun?
15:01:53 <nb> .hello2
15:01:53 <tflink> .helllo tflink
15:01:53 <zodbot> nb: nb 'Nick Bebout' <nb@nb.zone>
15:02:06 <coremodule> .hello2
15:02:07 <zodbot> coremodule: coremodule 'Geoffrey Marr' <gmarr@redhat.com>
15:02:08 * kparal is here
15:02:08 * satellit listening
15:02:17 * pschindl is here
15:05:15 * sumantro is here!
15:05:20 * lruzicka is here
15:05:32 <sumantro> how is everyone doing? :)
15:05:51 <lruzicka> slow by steady :)
15:06:03 <lruzicka> s/by/but/
15:06:30 <coremodule> doing well!
15:06:42 * adamw will be doing better when he finishes his coffee
15:06:49 <adamw> #chair sumantro pschindl
15:06:49 <zodbot> Current chairs: adamw pschindl sumantro
15:08:07 <sumantro> Awesome! we have a lot of testing to do this week :D
15:08:12 * sumantro is excited
15:09:47 <adamw> ahhh, they're so cute when they're young
15:09:48 <adamw> :P
15:09:53 <adamw> #topic Previous meeting follow-up
15:10:55 <adamw> where did i put my notes...
15:11:51 <adamw> "sgallagh and sumantrom to schedule and organize Modularity test day" - how's that going, sumantro?
15:12:13 <sumantro> 2018-04-10 , its live :D
15:12:16 <sgallagh> sumantro is doing a great job. I have, however, not been as responsive as I'd like
15:12:21 <sgallagh> Sorry about that
15:12:47 <sumantro> sgallagh, my pleasure :)
15:13:13 <sgallagh> Modularity team will be around on IRC tomorrow to assist as much as possible
15:13:34 <lruzicka> ok, I will try my best to participate
15:13:43 <sgallagh> However, I didn't realize when we originally scheduled it that langdon and I would be in most-of-the-day meetings tomorrow, so I hope that doesn't hurt things too much
15:14:10 <adamw> eh, they're just meetings
15:14:22 <adamw> you can deploy the Moderately Convincing Sgallagh Blow-Up Doll
15:14:49 <sgallagh> ...
15:14:58 <adamw> have it go "hmmmmmm....but-" every so often, someone will jump in and talk over it, you're done
15:14:59 <sgallagh> I thought you promised never to mention that again.
15:15:01 <adamw> =)
15:16:02 <adamw> #info "sgallagh and sumantrom to schedule and organize Modularity test day" - event is planned for tomorrow (2018-04-10), please join in! sumantro and the modularity team will be there to help with testing.
15:16:27 <adamw> #info "adamw to update Common Bugs for Beta" - the version of adamw otherwise known as 'kparal' did a great job on this, go team =)
15:16:36 <sgallagh> kparal++
15:16:38 <zodbot> sgallagh: Karma for kparal changed to 9 (for the f27 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
15:17:14 * kparal bows
15:17:23 * tflink did not know that adamw and kparal were the same person
15:17:32 <tflink> not sure how that works, either ...
15:17:37 <adamw> we're running version 1.0 of the puiterwijk clustering system
15:17:47 * kparal puts on a jenkins logo face
15:17:51 <adamw> haha
15:18:07 <adamw> i think we know what face jskladan would put on now
15:18:21 <tflink> laughing man from GITS?
15:18:53 <adamw> devops face!
15:18:53 <tflink> I kid, there's no replacement for devops face :)
15:19:12 <adamw> tflink: do you have the devops face link, for the uninitiated?
15:19:43 * tflink will look for it, jskladan is the one who found the image
15:19:51 <sgallagh> tflink: I think you should pretend to be one of those deaf-mutes.
15:20:16 <adamw> hehe
15:20:23 <adamw> stay tuned for devops face, folks
15:20:36 <sgallagh> (Oh, and in case anyone misunderstands that comment; it's part of the text in the "laughing man" icon)
15:20:41 <lruzicka> yeah, I am curious what it looks like
15:20:44 <adamw> "sumantrom to schedule an onboarding call soon"  - where are we on that, sumantro?
15:21:39 <sumantro> https://pagure.io/fedora-qa/issue/549 is filed and I will update it post 17th which is freeze :)
15:22:02 <sumantro> we have a lot of new contributors and we will start doing it ASAP
15:22:35 <adamw> #info "sumantrom to schedule an onboarding call soon" - ticket is filed https://pagure.io/fedora-qa/issue/549 , sumantro will start organizing the event after the 17th
15:23:54 <adamw> any other follow-up items?
15:24:14 <tflink> darn, I can'
15:24:27 <tflink> t find the link quickly, don't remember where it is
15:24:27 <sumantro> nothing from my side
15:25:06 <adamw> #topic Criteria proposals
15:25:10 <lruzicka> What is the onboarding for?
15:25:19 <lruzicka> sorry to write late :)
15:25:37 <adamw> lruzicka: it's a video call for new team members to get together and sumantro walks them through some testing tasks
15:26:00 <adamw> one of the ideas sumantro came up with to help new folks joining the team get started and get to know each other
15:26:02 <lruzicka> ok, I see
15:26:24 <adamw> we run one every so often, whenever there've been several new folks join since the last one
15:27:27 <adamw> so, there's a couple of pending release criteria proposals
15:27:31 <lruzicka> thank you for explanations :)
15:27:35 <adamw> it'd be good to get them agreed and pushed out before we forget :)
15:28:11 <adamw> #info criteria proposal 1: Server role upgrade coverage - https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/message/ZFDPWXVMRMV5H3ONPGHFFB5PK4A2H3TF/%3E
15:28:43 <adamw> #info criteria proposal 2: ISO image size - https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/message/NEXM7VO27CYSMMKFOKWNGMTTWVF4MM43/%3E
15:28:56 <adamw> sigh
15:28:57 <adamw> #undo
15:28:57 <zodbot> Removing item from minutes: INFO by adamw at 15:28:43 : criteria proposal 2: ISO image size - https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/message/NEXM7VO27CYSMMKFOKWNGMTTWVF4MM43/%3E
15:28:58 <adamw> #undo
15:28:58 <zodbot> Removing item from minutes: INFO by adamw at 15:28:11 : criteria proposal 1: Server role upgrade coverage - https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/message/ZFDPWXVMRMV5H3ONPGHFFB5PK4A2H3TF/%3E
15:29:07 <adamw> #info criteria proposal 1: Server role upgrade coverage - https://lists.fedoraproject.org/archives/list/server@lists.fedoraproject.org/message/ZFDPWXVMRMV5H3ONPGHFFB5PK4A2H3TF/
15:29:12 <adamw> #info criteria proposal 2: ISO image size - https://lists.fedoraproject.org/archives/list/test@lists.fedoraproject.org/message/NEXM7VO27CYSMMKFOKWNGMTTWVF4MM43/
15:29:19 <adamw> silly evolution, including > in URLs...
15:29:49 <adamw> so I figured we could set aside a bit of meeting time to discuss them, and if we have any concerns they can be changed, otherwise kparal and i can push them out soon
15:29:53 <adamw> so, anyone have thoughts on them?
15:31:11 * sumantro votes in for push! :)
15:32:08 <lruzicka> I support both, but I think we should specify more exactly how do we block according to media size
15:32:30 <adamw> yeah, i'd kinda like to relate to optical media size somehow
15:32:30 <kparal> lruzicka: what do you mean?
15:32:35 <lruzicka> I agree that it could be on Final
15:32:46 <kparal> should we care? I believe QA shouldn't. the owners should
15:33:05 <adamw> like, if target size for an image is 2GB and we're at 2.2GB on release date, it's still a bit hard to argue for a block...who is that overage hurting? people still using the 2GB usb stick they got with a pack of corn flakes five years ago?
15:33:14 <lruzicka> We should come up with criteria ... I mean based on devices, or something
15:33:39 <kparal> adamw: well then, the owner of the medium bumps the number or says no we really need to block
15:33:55 * satellit DVD size important ?
15:33:56 <lruzicka> Therefore, we need the criteria, adamw
15:34:01 <adamw> kparal: i'm kinda sick of the 'it's over the number? ah let's make the number bigger' game, but...
15:34:12 <lruzicka> All people should know in advance what to expect.
15:34:23 <adamw> lruzicka: we have a criterion now, and no-one pays attentions
15:34:26 <adamw> attention*
15:34:26 <kparal> I just don't believe it's our problem to solve. we just check it.
15:34:38 <lruzicka> If we say, that 2G is not a boundary, and that they need bigger drive, we can, but they should ḱnow
15:34:39 <adamw> kparal: in theory, i agree. in practice...you know how it goes.
15:34:51 <adamw> no-one looks at or cares about image size until we remember to file a bug for it. even if there are reports in the matrix.
15:35:17 <lruzicka> so, then we can decide that we will not block at all, if they do not care
15:35:29 <adamw> i mean, they don't bother to care until we spoon feed it to them. :P
15:35:38 <kparal> adamw: but we can't decide to bump the number anyway, we still need to talk to the relevant team
15:35:47 <adamw> if we'd ever *actually* shipped with the Workstation live 5GB big or something, everyone would be asking who tested it.
15:36:05 <adamw> kparal: that's why i'm saying we should relate it to a significant physical size somehow
15:36:21 <kparal> file a fesco ticket and let them bother with that :)
15:36:47 <adamw> frankly i'd just say all release-blocking ISO images must be under single-layer single-side DVD size, or 700MB CD size for network install images
15:36:47 <lruzicka> Speaking of this, I also had an idea about various spins
15:37:04 <lruzicka> adamw: I would agree on that boundary
15:37:14 <kparal> adamw: that sounds like something fesco should say, really
15:37:15 <tflink> makes sense to me as well
15:37:21 <adamw> we can still *list* target sizes somewhere for someone to care about, but i just don't see the point of blocking on them in the expectation that if they're exceeded the number will just get changed...
15:38:43 <kparal> adamw: btw I don't like your proposal. if the image is not blocking as optical, I don't see why it should be under DVD size
15:38:44 * satellit https://download.fedoraproject.org/pub/alt/releases/test/28_Beta/Labs/x86_64/iso/Fedora-Jam_KDE-Live-x86_64-28_Beta-1.3.iso   2.6 GB st least listed
15:38:46 <adamw> kparal: well, i don't think fesco was actually involved in the older versions of this, so dunno why they need to be involved now?
15:38:51 * satellit https://labs.fedoraproject.org/prerelease
15:39:01 <adamw> kparal: looking at the history, we used to just write the target sizes into the test case: e.g. https://fedoraproject.org/w/index.php?title=QA:Testcase_Mediakit_ISO_Size&oldid=165002
15:39:16 <kparal> I don't know who defined the original sized, I thought the SIGs did
15:39:20 <kparal> *sizes
15:39:34 <kparal> but I don't know why I should define it
15:39:47 <adamw> for lives when we went to the spins model, more or less, though IIRC none of them was very interested till we prodded them for a decision...
15:39:55 <adamw> that's just my recollection, though.
15:40:32 <adamw> in fact, the kinda 'initial' version of this test case was more or less exactly what i'm suggesting now :P
15:40:33 <adamw> https://fedoraproject.org/w/index.php?title=QA:Testcase_Mediakit_ISO_Size&oldid=160156
15:40:34 <lruzicka> I think we either should give up on checking on sizes or make ourselves clear about them
15:40:39 <kparal> well in the early days, when we blocked everything on optical disks, the answer was pretty clear
15:40:48 <kparal> but that's no longer true
15:41:10 <adamw> kparal: i do get what you're saying
15:41:55 <adamw> it's just that i suspect these 'target sizes' are something no-one cares a lot about and they'll inevitably just get bumped
15:42:09 <adamw> right up until they hit 4.7GB at which point someone will say BUT BUT DVDs! and we'll be right back here
15:42:26 <adamw> but, i can go with your proposal for now, for sure.
15:42:51 <adamw> the only other concern i have with it is that there's no actual clear process for how these target sizes get decided, but that's a pre-existing problem.
15:42:54 <kparal> so let's ask all teams if they're fine setting it to 4.7GB and if they don't object, put the number there. that should give us plenty of time before we need to deal with this again
15:43:02 <adamw> that would work, sure
15:43:57 <adamw> lruzicka: wdyt?
15:43:59 <lruzicka> kparal: adamw: Yes, that sounds like a decision that is quite ok to enforce and still gives plenty of space to the spins
15:44:39 <kparal> if they want a different size, though, I don't think QA should stop them
15:44:51 <kparal> it's their image after all
15:44:54 <adamw> btw, i've got a todo list item to make relval size-check file bugs when images are oversize, which hopefully would help. also, relval size-check is automated now.
15:45:17 <lruzicka> I would also like to propose something, shall I use the hyperkitty to do it?
15:45:36 <kparal> lruzicka: it's just a frontend to the mailing list
15:45:36 <adamw> lruzicka: a modification to one of these, or a separate idea?
15:45:41 <lruzicka> kparal: In that case, we can say that we at least recommend to keep it under 4.7
15:45:49 <kparal> sure
15:45:52 <lruzicka> adamw: A separate idea
15:45:58 <adamw> then start a new list thread for it, yep
15:46:18 <lruzicka> ok, I will do it tomorrow.
15:46:18 <adamw> and yeah, hyperkitty is just the mailing list archives :) you can post from it, of course, if you like.
15:46:29 <adamw> anyone had any comments on the server proposal?
15:47:01 <lruzicka> I agree with the proposal.
15:47:16 <adamw> sounds like i should just go ahead and push that one, then
15:48:20 <adamw> #info seems to be general agreement to the proposed criteria, some concerns that the size criterion should be more related to DVD media size, kparal will ask blocking image SIGs to consider setting their target size to that size
15:48:24 <adamw> #topic Fedora 28 status
15:48:32 <adamw> so, Beta went out, thanks everyone! great work on the testing
15:48:35 <kparal> ohm
15:48:42 <adamw> kparal: did i miss something?
15:48:43 <kparal> I have been action item'd
15:48:47 <adamw> ah :)
15:48:49 <kparal> silly me
15:49:04 <kparal> alright, I'll delegate it
15:49:05 <adamw> #action kparal to check in with blocking image SIGs on changing their target image size to DVD media size
15:49:06 <kparal> no problem
15:49:07 <adamw> =)
15:50:04 <adamw> we're now working towards Final. note there is a significant bug affecting Wayland in current F28 - https://bugzilla.redhat.com/show_bug.cgi?id=1564210
15:50:13 <adamw> an update to fix that should be coming soon, hopefully
15:50:44 <adamw> ah, the update has arrived in fact: https://bodhi.fedoraproject.org/updates/FEDORA-2018-10fbc1fcf6
15:50:55 <adamw> it'd be great if folks could test that and get it karma'ed ASAP (assuming it works)
15:51:12 * sumantro testing it right away
15:51:37 <coremodule> can do
15:52:07 <lruzicka> I can do it tomorrow the first thing, I will have to set up a wayland system
15:52:26 <adamw> a new anaconda just arrived in stable, so there will be a new validation compose event fairly soon
15:53:08 <adamw> that's about all the notes i have for f28, any others?
15:53:35 <sumantro> we have 3 test days coming up!
15:53:59 <sumantro> 2018-04-11 is Cloud/Atomic Test Day
15:54:16 <sumantro> 2018-04-13 is Kernel 4.16 Test Day
15:54:38 <sumantro> 2018-04-16 is Anaconda Modular  Test Day
15:54:55 <sumantro> 2018-04-19 is Upgrade Test Day
15:55:41 <sumantro> sometimes after that we might have a FreeIPA test day too
15:56:43 <adamw> awesome!
15:56:56 <adamw> isn't it 4? with modularity
15:57:10 <adamw> #info many test days are coming up, see https://apps.fedoraproject.org/calendar/list/QA/?subject=Test+Day
15:57:14 <adamw> #topic Open floor
15:57:18 <adamw> anyone have anything for open floor, quickly?
15:58:13 <sumantro> A new TCMS is coming soon.. I am prepping up a wiki which I will share for feedback to evaluate nitrate & kiwi
15:58:33 <sgallagh> adamw: I have this hammer, these nails and some boards to patch the floor.
15:59:01 * adamw pushes sgallagh through the floor
15:59:08 <adamw> thanks, sumantro
15:59:37 <adamw> that's regarding https://pagure.io/fedora-qa/issue/152 , btw
16:00:42 <adamw> sumantro: did i ever flag up rhe's evaluation from that ticket for you, btw? https://pagure.io/fedora-qa/issue/152#comment-66097
16:00:47 <adamw> they're old but still probably useful
16:00:56 <adamw> she did this same project, seven years ago :P
16:01:06 <adamw> blocker review meeting starting NOW over in #fedora-blocker-review, btw
16:01:25 <sumantro> I went through rhe's evalution
16:01:41 <sumantro> and had a word with cqi on this
16:02:06 <adamw> ok, cool
16:02:22 <adamw> there's also https://fedoraproject.org/wiki/Wikitcms#Alternatives_and_comparison which has some notes i wrote up a couple years ago.
16:02:28 <adamw> OK, anything else for open floor?
16:03:09 <sumantro> nothing from my side :)
16:03:30 <kparal> nothing here
16:03:52 <adamw> alrighty! thanks everyone
16:03:59 <adamw> sorry that the 'quick meeting' idea turned out to be a lie :P
16:04:02 <adamw> see you next time
16:04:40 <adamw> #endmeeting