fedora-qa
LOGS
15:05:26 <adamw> #startmeeting Fedora QA meeting
15:05:26 <zodbot> Meeting started Mon Mar 12 15:05:26 2018 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:05:26 <zodbot> The meeting name has been set to 'fedora_qa_meeting'
15:05:28 <sumantro> morning kparal adamw :)
15:05:29 <adamw> #meetingname fedora-qa
15:05:29 <zodbot> The meeting name has been set to 'fedora-qa'
15:05:29 <adamw> #topic Roll Call
15:05:32 * sumantro is here
15:05:43 <Suprith_> kparal, adamw sumantro Good Morning!
15:05:52 <lruzicka> Hello, everybody.
15:05:53 * satellit listening
15:06:05 <tflink> .hello2
15:06:06 <zodbot> tflink: tflink 'Tim Flink' <tflink@redhat.com>
15:06:13 * kparal is here
15:06:16 * Suprith_ Present
15:06:23 <adamw> morning folks, sorry i'm a bit late
15:06:27 <adamw> how's everyone doing?
15:06:27 <lruzicka> * lruzicka is here
15:06:29 * coremodule is here.
15:06:55 <coremodule> Doing well, and you adamw?
15:07:02 <roca> Hello
15:07:03 <sumantro> hi lruzicka coremodule tflink
15:07:13 <lruzicka> sumantro: Hi
15:07:28 <sumantro> all awesome here adamw .. what about you ?
15:08:11 <adamw> not too bad, thanks
15:09:15 <adamw> alrighty
15:09:19 <adamw> #topic Previous meeting follow-up
15:09:29 <adamw> what did i forget to do last week, i wonder
15:09:57 <adamw> #info "adamw to check in again on aarch64 openQA workers" - the work to enable aarch64 in openqa is mostly done, but we're blocked by a firewall issue only RH IT can resolve. so...we're waiting on them/
15:10:06 <adamw> woohoo, not my fault!
15:10:09 <adamw> good start to monday there.
15:11:25 <adamw> any other follow-up issues or anything?
15:12:39 <sumantro> nothing from my side
15:13:13 <Suprith_> missed a couple of meetings :(
15:13:36 * lruzicka is looking around, so nothing to say here.
15:13:58 <adamw> alrighty
15:14:06 <adamw> sorry, i'm catching up pings from other channels, sigh
15:14:26 <roca> no worries :)
15:14:45 <adamw> #topic Fedora 28 status, Beta schedule
15:15:18 <adamw> so, mainly i figured we should have a meeting this week even though we had one last week cos we still have a lot of moving parts for f28 and I wanted to make sure that was all on record...
15:16:02 <adamw> we just started getting composes again over the weekend, we still are at basically square 1 with figuring out if Modularity works, and there's quite the list of blockers
15:17:37 <adamw> sgallagh: ping - are you around to discuss the state of modularity? anyone else we can yank in?
15:17:44 <kparal> modularity is blocking beta?
15:18:16 * sumantro has the same question
15:18:23 <kparal> and what exactly, do we have a standard server install and then extra modular repos, and both have to work?
15:18:41 * satellit modularity repo called in live KDE spin in dnfdragora
15:19:27 <sgallagh> adamw: Sort of? Right now I have an awful lot of fingers stuck in this dam, though
15:20:08 <adamw> sgallagh: can you sort of turn around over your shoulder and describe the state of the dam to us? :P
15:21:00 <adamw> kparal: modularity is very much expected to land in beta, as I understand things, yes. it does not exactly hit any of the release criteria as currently implemented, but i believe fesco would give it special blocker status or whatever if necessary.
15:21:36 <sgallagh> adamw: I'm trying to see the state through all this water :-P
15:21:52 <sgallagh> I've got it on my TODO list to figure out how much of it is working today.
15:22:01 <adamw> okay.
15:22:01 <sgallagh> It's much closer to where we want things to be than it was on Friday.
15:22:04 <adamw> that was kinda where i was at too.
15:22:15 <adamw> i know on friday we were missing a chunk of the repo/mirror bits.
15:22:19 <sgallagh> We have a compose with all the expected content in it finally for F28
15:22:21 <adamw> we actually *still* need a fedora-repos update.
15:22:31 <sgallagh> We have a modular repo in fedora-repos, but it needs to be changed.
15:22:41 <sgallagh> I have a PR I'm almost ready to send out about that.
15:22:41 <lruzicka> The repo is not working.
15:22:52 <adamw> well, i think it's in updates-testing.
15:22:57 <adamw> alright
15:23:01 <lruzicka> Moreover it blocks any updates until you disable it.
15:23:02 <sgallagh> That repo is broken for anything other than the `dnf` CLI tool, so it won't work for PK/dnfdragora, etc.
15:23:05 <sgallagh> That's a new one this morning
15:23:07 <nirik> The base modularity repo isn't working in mm... we are fixing that now.
15:23:29 <adamw> #info status of Modularity is still not clear, but should be much closer to working than it was on Friday. sgallagh is planning to figure out exactly what still needs doing today
15:23:36 <sgallagh> Yes
15:23:52 <sgallagh> lruzicka: Are you talking about `dnf` or some other tool?
15:23:55 <sgallagh> Because I need to know
15:24:20 <lruzicka> sgallagh: I am talking about the impossibility of dnf to sync with that repo.
15:24:34 <lruzicka> sgallagh: As a cosequence, you cannot use dnf properly.
15:24:40 * satellit +1
15:24:44 <sgallagh> lruzicka: I need actual information. What did you attempt to do and what failed, what error did you get, etc.?
15:24:44 <adamw> #info (for Modularity) most of the stuff that needs to be in the compose is believed to be in the compose, remaining issues relate to repo/mirror configuration and tooling
15:24:46 <nirik> that is due to mirrormanager not knowing about the base modularity repo.
15:24:53 <sgallagh> "It's broken, fix it" is not helpful
15:25:05 <lruzicka> sgallagh: There is a bug for it, I will find it for you.
15:25:07 <nirik> (and why I asked about the dnfdragora thing, wondering if it was just that)
15:26:32 <adamw> sgallagh: it sounds like nirik knows what lruzicka is talking about
15:27:00 <adamw> if the mm config for a skip_if_unavailable=False repo is wrong, that'd explain it; dnf will die on not being able to update the repo.
15:27:01 <sgallagh> OK, so there's probably two issues there.
15:27:02 <nirik> The "base" modularity repo, ie, http://dl.fedoraproject.org/pub/fedora/linux/development/28/Modular/x86_64/os/ isn't known by mirrormanager... so it errors
15:27:12 <nirik> The updates and updates-testing ones are fine
15:27:35 <sgallagh> ah
15:27:39 <lruzicka> sgallagh: https://bodhi.fedoraproject.org/updates/FEDORA-2018-795b38a6a2
15:27:44 <sgallagh> This is fine.
15:27:50 <lruzicka> sgallagh: I have written about this here.
15:28:06 <lruzicka> sgallagh: But yes, seems we are talking about the same thing.
15:28:07 <nirik> to be fair, it's not that updates fault.
15:28:18 <sgallagh> lruzicka: Thanks. Sorry for being a bit harsh above. I've got 99 problems and DNF is 136 of them.
15:28:21 <adamw> =)
15:28:28 <lruzicka> sgallagh: Fine with me :)
15:28:29 <adamw> #info <sgallagh> lruzicka: Thanks. Sorry for being a bit harsh above. I've got 99 problems and DNF is 136 of them.
15:28:31 <nirik> ha
15:28:33 <sgallagh> ha
15:28:49 <roca> :)
15:28:55 <Suprith_> :P
15:32:27 <sgallagh> I'm not sure I have any more to add right now on this.
15:32:30 <adamw> alright
15:32:31 <sgallagh> I'm spread rather thin
15:32:50 <adamw> well, the remaining question i have, basically, is "did we decide what it is we actually expect modularity to achieve in f28"?
15:33:20 <adamw> if not, we'll just have to wing it in deciding what to actually test
15:34:15 <sgallagh> We expect basic operation of modules to work (which I'll define further in a moment) and to have at least a few functioning modules to work as an example, with the expectation that over the life of F28 and F29 the number will grow substantially.
15:34:36 <adamw> last week iirc the answer was to test the node.js streams, but i wasn't sure if that's actually what we *want* out of modularity for f28, or it's just the module stream that happens to be most viable.
15:34:57 <sgallagh> The representative example we have been using is the set of Node.js modules that I wrote and provides three streams: the 6.x LTS, 8.x LTS and 9.x dev branches from upstream
15:35:00 <adamw> so we should be focusing on the basic mechanism, as opposed to any specific modules?
15:35:06 <adamw> can we install, remove, update, switch streams, query, etc?
15:35:39 <sgallagh> adamw: "switch streams" is something I wouldn't try to test. We don't plan to support that officially (short of "uninstall everything from that stream before trying to change it")
15:35:47 <sgallagh> It may work, but not something we want to block on right now
15:35:57 <sgallagh> But yes, the rest of what you said is accurate.
15:36:11 <sgallagh> The best example to use would be Node.js since it is available, actually works and provides multiple streams
15:36:27 <sgallagh> More examples should be available by Final
15:36:54 <adamw> okay.
15:37:12 <sgallagh> adamw: We also need to validate that if the modular repo is not installed/enabled, the system must not be fundamentally broken
15:37:30 <adamw> #info goals of modularity for F28 are to have the basic mechanism provided and working, rather than focusing on any specific modules. expected functionality includes installing, removing, updating and querying modules.
15:37:42 <adamw> sgallagh: even if some modules are installed?
15:37:49 <sgallagh> adamw: No
15:37:54 <sgallagh> Good point
15:37:58 <adamw> okay.
15:38:27 <sgallagh> Once you start using modules, you're committed :)
15:38:37 <sgallagh> (Or *should be* committed, one or the other)
15:39:06 <lruzicka> sgallagh: But the system should still work fine even if the modular repos were down or something.
15:39:08 <adamw> we'll test that feature too =)
15:39:27 <lruzicka> sgallagh: Just not able to update/delete ,,,
15:39:33 <sgallagh> lruzicka: Yes
15:40:05 <sgallagh> I'm not sure we'd block on that case though
15:40:15 <lruzicka> Ok, get it.
15:40:18 <sgallagh> Because it would be unpredictable even in the standard RPM fcase
15:40:48 <adamw> yeah, if the repos are down dnf isn't going to work, in fact, unless you disable all the skip_if_unavailable=False repos
15:40:50 <sgallagh> e.g. if you have a third-party repo with a higher priority that is suddenly unavailable, you might end up inadvertently updating a package that you wouldn't have otherwise
15:41:34 <sgallagh> Right, so we should make sure that modular repos are set `skip_if_unavailable=False`
15:41:45 <sgallagh> That *should* be a blocker
15:42:03 <sgallagh> I'll check on that while working up this patch
15:43:55 <sgallagh> (Looks like that's correct)
15:44:21 <adamw> if they were cloned from the existing repos, i'd expect it to be correct.
15:44:30 <adamw> so, anyway, sounds like we're about up to date on modularity - thanks sgallagh.
15:44:54 <sgallagh> You're welcome.
15:45:03 <adamw> so...aside from the status of Modularity, we have quite the blocker list: https://qa.fedoraproject.org/blockerbugs/milestone/28/beta/buglist
15:45:09 <adamw> we have a blocker review meeting in 15 mins
15:45:17 <adamw> so we'll have a full list of accepted blockers after that
15:45:31 <adamw> although i haven't even gone through all openQA fails yet, so there may be more lurking.
15:45:56 <adamw> in fact, i know there's one i haven't looked into, and sgallagh isn't going to be happy about it, as it may involve rolekit :/
15:47:10 <adamw> sgallagh: the 'database server' role deployment seems to fail atm, i had a quick look at the logs but so far i only got as far as rolekit being unhappy that something which was supposed to receive a message didn't.
15:47:22 <adamw> didn't see any obvious failure messages from postgres.
15:47:27 <adamw> anyway, i'll look into it some more and file a bug.
15:47:30 <sgallagh> Thanks
15:47:38 * sgallagh goes off and cries
15:47:56 <adamw> =)
15:49:45 <adamw> so, anyway, my point being: we should probably raise the current state of affairs to fesco for their next meeting
15:49:57 <adamw> and let them know there's a chance the beta schedule's gonna be missed
15:50:07 <adamw> that's how things look to me, anyway. what do you folks think?
15:50:53 <sumantro> me thinks the same
15:51:51 * kparal nods
15:52:29 <lruzicka> adamw: If you think so, I do not object.
15:53:00 <Suprith_> Same here
15:53:19 <adamw> #action adamw to file FESCo ticket detailing current state and potential risk to Beta schedule
15:53:35 <adamw> ok, anyone have more f28 sadness to air or are we about done? :)
15:54:03 <Suprith_> Nope for me
15:54:48 <coremodule> Nothing here.
15:54:58 <adamw> #topic Open floor
15:55:06 <adamw> then, any other topics before the blocker meeting?
15:55:13 <adamw> which starts in 5 minutes in #fedora-blocker-review!
15:55:15 * satellit build dnfdragora for modularity ?
15:55:19 <mboddu> adamw: https://fedoraproject.org/wiki/Releases/28/Schedule the rain date is Apr 3rd
15:55:23 <mboddu> for F28 Beta
15:55:26 <roca> simply taking notes to review later. I have lots of homework it seems :)
15:55:50 <mboddu> Dont you think we cant get them working by then, if modularity is not raised as blocker?
15:56:02 <adamw> mboddu: that's the *release* date.
15:56:10 <adamw> and it's already a rain date, meaning 'late'
15:56:46 <lruzicka> mboddu: But if the whole modularity is a blocker, then there is a possibility of the whole release slip away.
15:56:51 <sumantro> Tomorrow is a i18n Test Day..come along and participate! https://fedoraproject.org/wiki/Test_Day:2018-03-13_I18N_Test_Day
15:57:11 <mboddu> adamw: Yes, but do you think we need more than that?
15:57:21 <adamw> there's also the fact that freeipa still hasn't worked for several months
15:57:33 <adamw> and the proposed fix for it is 'land new versions of everything, that'll make it better'
15:57:35 <roca> sumatro I created my boot usb of f28 :)
15:57:37 <adamw> which does not exactly fill me with confidence
15:58:09 <mboddu> lruzicka: Sure, which is why I said "if modularity is not raised as blocker", but if it becomes a blocker, then we need more time
15:58:22 <adamw> as i said, i am basically expecting that fesco is treating modularity as a blocker
15:58:27 <adamw> but that will be something i'll ask them
15:58:42 <adamw> #action adamw to ask fesco if they consider modularity as blocking Beta
15:58:51 <mboddu> adamw: Then sure, we might need more time
16:00:43 <suprith4989> adamw, sumantro any other upcoming test days apart from i18n, for f28? that we know of as of now?
16:00:53 <adamw> blocker meeting starting over in #fedora-blocker-review now
16:00:56 <adamw> so we'd better wind up in here
16:01:05 <adamw> Suprith: i believe there are some, sumantro will know the details
16:01:19 <suprith4989> adamw, ack
16:02:01 <adamw> so, thanks for coming, folks!
16:02:25 <suprith4989> adamw, Thanks!
16:02:51 <adamw> #endmeeting