i18n
LOGS
06:30:34 <paragan> #startmeeting i18n
06:30:35 <zodbot> Meeting started Wed Feb 28 06:30:34 2018 UTC.  The chair is paragan. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:30:35 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
06:30:35 <zodbot> The meeting name has been set to 'i18n'
06:30:35 <paragan> #meetingname i18n
06:30:35 <zodbot> The meeting name has been set to 'i18n'
06:30:35 <paragan> #topic agenda and roll call
06:30:35 <paragan> #link https://fedoraproject.org/wiki/I18N/Meetings/2018-02-28
06:30:54 <tagoh> hi
06:31:03 <paragan> #chair juhp tagoh fujiwara epico mfabian suanand bhavin192 pravins bbarve
06:31:03 <zodbot> Current chairs: bbarve bhavin192 epico fujiwara juhp mfabian paragan pravins suanand tagoh
06:31:13 <epico> hi
06:32:22 <paragan> lets wait while other members join this meeting
06:35:00 <paragan> let me start with initial agenda
06:35:27 <paragan> #topic Upcoming schedule
06:36:05 <paragan> Let's check the current F28 release milestones
06:36:05 <paragan> #topic Upcoming schedule
06:36:05 <paragan> #info 2018-03-06        Software Translation Deadline
06:36:05 <paragan> #info 2018-03-06        Bodhi activation point
06:36:05 <paragan> #info 2018-03-06        Beta Freeze (*)
06:36:06 <paragan> #info 2018-03-06        Change Checkpoint: 100% Code Complete Deadline
06:36:10 <paragan> #info 2018-03-27        Beta Release (Preferred Target)
06:36:23 <suanand__> hi
06:36:47 <paragan> We can see there is still one week left for bodhi to be enabled for Fedora 28 release.
06:37:43 <paragan> if you got any package updates then you can push them directly now to Fedora 28 :)
06:37:48 <mfabian_> hi
06:38:07 <fujiwarat> hi
06:38:09 <paragan> Make sure all the strings in your packages are translated by 6th March.
06:38:49 <paragan> Fedora 28 release plan have "Change Checkpoint: 100% code complete deadline" on 6th March.
06:39:18 <paragan> This is the last date on which it can be ensured that a build will appear in a Beta release.
06:40:01 <paragan> This checkpoint mean accepted changes must be code complete and all the code required to enable this new change is finished.
06:40:35 <paragan> The level of code completeness is reflected as tracker bug state ON_QA.
06:40:59 <paragan> The change does not have to be fully tested by this deadline.
06:41:50 <paragan> #info the current release blockers list is at https://qa.fedoraproject.org/blockerbugs/milestone/28/beta/buglist
06:41:57 <juhp> hi
06:42:07 <juhp> oops
06:42:29 <paragan> looks like not much bugs are there yet ;-)
06:43:19 <paragan> anyway keep watching it for knowing any blocker/FE bugs for F28
06:44:29 <paragan> Let's check now our F28 Changes for their development status
06:44:49 <paragan> #topic Outstanding issues
06:45:40 <paragan> #info #87: F28 Change: Fontconfig 2.13 (tagoh)
06:45:41 <paragan> #link https://pagure.io/i18n/issue/87
06:46:10 <paragan> tagoh, is this Change implementation already completed and testable in current F28 composes?
06:46:14 <tagoh> 2.12.93 has been built and the state of feature is now testable.
06:46:22 <tagoh> yes
06:47:14 <paragan> #info this Change is 100% code completed
06:47:38 <paragan> maybe move the tracker bug to ON_QA?
06:48:33 <tagoh> well, not yet completely finished as it named 2.13 :) I'll wait for a few weeks and then release 2.13. will change the status to ON_QA after that
06:49:29 <paragan> hm okay
06:49:33 <juhp> tagoh: 6 March is supposed to be complete
06:49:41 <juhp> :)
06:49:43 <paragan> #action tagoh to mark bug https://bugzilla.redhat.com/show_bug.cgi?id=1534557 status as ON_QA before 6th March
06:49:46 <juhp> but okay just a version
06:49:46 <tagoh> juhp: ah, okay
06:49:53 <tagoh> yep
06:50:56 <paragan> next ticket
06:51:07 <paragan> #info #88: F28 Change: Japanese Default Fonts to Google Noto (tagoh)
06:51:07 <paragan> #link https://pagure.io/i18n/issue/88
06:51:59 <tagoh> we can change the status for default font changes to ON_QA I think. will do that later.
06:52:32 <paragan> #action tagoh to mark bug https://bugzilla.redhat.com/show_bug.cgi?id=1534559 status as ON_QA before 6th March
06:52:40 <paragan> #info this Change is 100% code completed
06:53:08 <paragan> next ticket
06:53:16 <paragan> #info #89: F28 Change: Korean Default Fonts to Google Noto (tagoh)
06:53:17 <paragan> #link https://pagure.io/i18n/issue/89
06:53:29 <paragan> I guess same status like above here?
06:53:33 <tagoh> ditto
06:53:35 <tagoh> yes
06:53:49 <paragan> #info this Change is 100% code completed
06:54:07 <paragan> #action tagoh to mark bug https://bugzilla.redhat.com/show_bug.cgi?id=1534560 status as ON_QA before 6th March
06:54:25 <paragan> next ticket
06:54:38 <paragan> #info #90: F28 Change: Glibc collation update and sync with cldr (mfabian)
06:54:38 <paragan> #link https://pagure.io/i18n/issue/90
06:55:11 <paragan> mfabian, is this Change implementation already completed and testable in current F28 composes?
06:55:17 <mfabian_> I pushed my glibc collation patches upstream yesterday.
06:55:28 <paragan> cool
06:55:32 <mfabian_> But it is not in F28 yet.
06:55:47 <mfabian_> I hope it doesn’t explode upstream and cause problems for anybody.
06:55:59 <paragan> hopefully we will have it them built before 6th March
06:56:09 <paragan> s/them/then/
06:56:45 <mfabian_> I’ll ask Carlos now how to proceed, a while ago he said  he wants this backported to the glibc 2.27 release. This would be easy to do.
06:56:54 <juhp> mfabian_: congrats on the upstream merge
06:57:52 <paragan> #info let's wait one more week to check if we can get updated packages in Fedora for this Change
06:58:14 <paragan> #info glibc collation patches got pushed to upstream yesterday
06:59:30 <paragan> next ticket
06:59:40 <paragan> #info #91: F28 Change: IBus_Unicode_Typing (fujiwara)
06:59:40 <paragan> #link https://pagure.io/i18n/issue/91
07:00:16 <paragan> fujiwarat, is this Change implementation already completed and testable in current F28 composes?
07:00:29 <fujiwarat> yes
07:00:37 <paragan> cool
07:00:45 <paragan> #info this Change is 100% code completed
07:00:58 <paragan> maybe if you want move tracker bug to ON_QA now
07:01:30 <fujiwarat> I have some updates to release 1.5.18 yet.
07:01:53 <paragan> okay no problem
07:01:55 <juhp> fujiwarat: when do you expect to release them?
07:02:17 <fujiwarat> tomorrow or the next day.
07:02:52 <paragan> #action fujiwarat to mark bug https://bugzilla.redhat.com/show_bug.cgi?id=1537257 status as ON_QA before 6th March
07:03:04 <fujiwarat> PageDown implementation, Get anaconda user name, updating translations.
07:03:17 <fujiwarat> Done to set ON_QA
07:03:35 <paragan> fujiwarat thanks
07:04:22 <paragan> next ticket
07:04:52 <paragan> #info #92: F28 Change: Chinese Default Fonts to Google Noto (pwu)
07:04:52 <paragan> #link https://pagure.io/i18n/issue/92
07:05:09 <paragan> epico, is this Change implementation already completed and testable in current F28 composes?
07:05:15 <epico> yes
07:05:36 <paragan> :)
07:05:39 <paragan> #info this Change is 100% code completed
07:05:42 <juhp> fujiwarat: great
07:06:10 <paragan> epico, do you want to move tracker bug to ON_QA now or later?
07:06:21 <epico> okay, move it now.
07:06:48 <paragan> epico, thanks
07:07:28 <epico> done
07:07:43 <paragan> next ticket
07:08:49 <paragan> #topic No assignee issues
07:08:50 <paragan> #info #78: package Liberation Classic Font in Fedora (pnemade)
07:08:50 <paragan> #link https://pagure.io/i18n/issue/78
07:09:31 <paragan> I think this is pending for pravins changes to be made in upstream
07:09:58 <paragan> not sure if he is around here.
07:10:50 <paragan> maybe I will ping him on ticket
07:12:19 <paragan> okay I have done that just now.
07:12:46 <paragan> next ticket
07:13:00 <paragan> #info #82: Fedora 28 i18n test day  (pnemade)
07:13:00 <paragan> #link https://pagure.io/i18n/issue/82
07:13:48 <juhp> I think we could go ahead and build liberation 2.0 for F28
07:14:04 <paragan> All please keep this 13th March day reserved for Fedora 28 i18n test day :)
07:14:13 <juhp> pravins told me he would release LiberationOne next month
07:14:35 <paragan> okay
07:15:36 <paragan> I think i18n QE people are going to help here by updating/reviewing our test cases before test day
07:16:20 <juhp> good
07:17:57 <paragan> #info Mark 13th March as Fedora 28 i18n test day
07:18:03 <paragan> next ticket
07:18:26 <paragan> #info #84: Fedora 26 Bug triaging (pnemade)
07:18:26 <paragan> #link https://pagure.io/i18n/issue/84
07:19:32 <paragan> I think i18n QE people have already done or doing this bug triaging
07:19:39 <paragan> let me check their wiki page
07:20:03 <paragan> #info https://fedoraproject.org/wiki/QA/F26_I18N_Bug_Triage
07:21:32 <paragan> yes their work is going on
07:21:54 <paragan> Thanks to them for doing this work
07:22:01 <paragan> next ticket
07:22:13 <paragan> #info #85: Docs Beats for Fedora 28 (pnemade)
07:22:13 <paragan> #link https://pagure.io/i18n/issue/85
07:22:43 <paragan> I guess we still need to find how to add doc beats for Fedora 28
07:22:54 <paragan> we will find that soon.
07:25:07 <paragan> I think that was all the tickets that we needed to discuss.
07:25:23 <juhp> paragan: yes please
07:25:35 <paragan> #topic Open Floor
07:25:43 <paragan> anything left to discuss?
07:26:56 <paragan> Thanks all who came for this meeting
07:27:17 <paragan> if nothing to discuss will close the meeting in 2 minutes
07:29:10 <paragan> #endmeeting