fesco
LOGS
16:02:35 <nirik> #startmeeting FESCO (2018-02-02)
16:02:35 <nirik> #meetingname fesco
16:02:35 <nirik> #chair maxamillion dgilmore nirik jforbes jsmith kalev sgallagh bowlofeggs tyll
16:02:35 <zodbot> Meeting started Fri Feb  2 16:02:35 2018 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:35 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:02:35 <zodbot> The meeting name has been set to 'fesco_(2018-02-02)'
16:02:35 <zodbot> The meeting name has been set to 'fesco'
16:02:35 <zodbot> Current chairs: bowlofeggs dgilmore jforbes jsmith kalev maxamillion nirik sgallagh tyll
16:02:35 <nirik> #topic init process
16:03:07 <zbyszek> Can you add me to the chair list?
16:03:14 <jforbes> Changing of the guard right? I should be dropped
16:03:15 <nirik> oh yeah, we need to adjust the wiki for new members.
16:03:27 <nirik> #chair zbyszek
16:03:27 <zodbot> Current chairs: bowlofeggs dgilmore jforbes jsmith kalev maxamillion nirik sgallagh tyll zbyszek
16:04:23 <wadadli> ~o/
16:04:31 <zbyszek> What about "nirik maxamillion jsmith jwb zbyszek"?
16:04:46 <zbyszek> Oh, wait, never mind.
16:05:38 <jsmith> .hello jsmith
16:05:40 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
16:05:40 <jsmith> Sorry I'm late
16:05:57 <wadadli> .hello wadadli
16:05:58 <zodbot> wadadli: wadadli 'Michael Singh' <michael@wadadli.me>
16:06:00 * nirik is looking at updating it, but as I said, I am sick... so it's going slow.
16:08:21 <nirik> ok, done. How many of us are here...
16:08:30 <zbyszek> .hello zbyszek
16:08:31 <zodbot> zbyszek: zbyszek 'Zbigniew Jędrzejewski-Szmek' <zbyszek@in.waw.pl>
16:08:51 <nirik> #info thanks to jforbes and kalev for their service.
16:09:00 <nirik> #info welcome zbyszek and jwb.
16:09:39 <nirik> so, we need sgallagh to have a chance at quorum
16:11:16 <maxamillion> .hello2
16:11:17 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
16:11:31 <nirik> ok, if jwb is sort of here I guess that gives us quorum.
16:12:12 <nirik> #topic #1820 Adjust/Drop/Document batched updates policy
16:12:13 <nirik> .fesco 1820https://pagure.io/fesco/issue/1820
16:12:15 <zodbot> nirik: Error: '1820https://pagure.io/fesco/issue/1820' is not a valid integer.
16:12:29 <nirik> .fesco 1820
16:12:30 <zodbot> nirik: Issue #1820: Adjust/Drop/Document batched updates policy - fesco - Pagure - https://pagure.io/fesco/issue/1820
16:13:03 <nirik> there's comments from last night I have not yet read.
16:13:30 <zbyszek> I think we should try to get more packagers to use batched, and see if this becomes more effective.
16:14:34 <maxamillion> agreed
16:14:45 <nirik> we have a lot of things here we could adjust... I think it does need more thought
16:14:47 <maxamillion> I like the idea of batched, I think it results in a better user experience
16:14:52 <zbyszek> Batched is a band-aid that seems necessary until repo metadata distribution becomes more efficient. Once it is more efficient, we can switch to client-side batching like packagekit currently implements.
16:15:42 <maxamillion> metadata distribution being more efficient isn't a trivially resolved problem though
16:15:57 <zbyszek> I'm not saying it is.
16:16:01 <jsmith> maxamillion: Agreed
16:16:34 <zbyszek> proposal: FESCo encourages maintainers to use batched for all non-urgent cases
16:16:53 <jsmith> I'd like to find a nice balance between "trust the packagers to know best" and "encourage batching to reduce churn"
16:17:31 <nirik> zbyszek: not sure thats going to do much... there seems to be a group of folks who always push to stable...
16:18:09 <zbyszek> Yes, and that's the problem. This means that batched does not work, so we cannot even fully evaluate if it helps.
16:18:09 <jwb> focusing this discussion on a technical detail like efficient metadata distribution misses the point
16:18:12 <jsmith> nirik: Short of tracking metrics better and reaching out to said "group of folks", I don't know how to fix that, other than a more concerted public education campaign
16:18:50 <nirik> jsmith: well, we could do that... get their feedback / reasoning.
16:19:10 <jsmith> Does someone want to volunteer to write a Fedora Magazine article entitled "Batching is good, and here's why..."?
16:19:20 <zbyszek> jwb: I think that this "technical detail" is crucial. If the distribution was efficient, we'd push out updates twice a day, and do packagekit-style batching on the other side.
16:19:49 <jwb> zbyszek, it's important, but your solution is just another technical thing that not everybody uses
16:20:16 <jwb> zbyszek, the original goal was to reduce updates flooding to the users.  packagekit doesn't capture all the users
16:20:39 <nirik> jwb: they could just not apply updates until the time/day they decide to?
16:20:50 <zbyszek> jwb: Well yes. But (as kkofler says) batched removes flexibility. If the batching is on client side, it can be timed arbirarily.
16:21:08 <jwb> nirik, how is that a solution?
16:21:17 <jwb> nirik, they have always been able to do that
16:21:25 <maxamillion> zbyszek: I think another part of the problem with pushing multiple times is the varied timelines volunteer mirrors sync their content
16:21:34 <jwb> maxamillion, yes
16:21:35 <nirik> perhaps I don't understand the problem. ;) I was thinking it was metadata downloads... which are large.
16:21:41 <zbyszek> jwb: the problem is not the application of updates. The problem is that each metadata updates results in ~120 MB download.
16:21:49 <jwb> no, come on guys
16:21:58 <jwb> you guys are thinking about technical implementation details
16:22:03 <jwb> this is a user experience problem
16:22:09 <maxamillion> jwb: +1
16:22:13 <nirik> can you explain the non technical goal better to me?
16:22:20 <jwb> sure, let me type
16:22:29 * nirik might also just be sick and braindrained. :)
16:23:30 <jwb> i am a user.  i install fedora.  i am immediately and forever innudated with updates for packages that i don't understand and i have no idea what they do.  this leads me to believe that fedora is very very buggy and everything is never finished.  particularly if i come from a non-Linux world where updates are distinct, scheduled events that i can plan around
16:24:05 <jwb> the goal of batched was to help stem that flood, and make the updates more discrete chunks
16:24:34 <nirik> ok. gnome-software using folks already see just batches right?
16:24:45 <zbyszek> I think that was part of it. Since the original proposal, the awareness of the problem of metadata downloads has become bigger.
16:25:00 <nirik> so perhaps a better solution to this is to have dnf batch on the client.
16:25:09 <jwb> zbyszek, sure, but fixing efficient metadata distribution is orthogonal
16:25:33 <zbyszek> Not really. Batched is a band-aid until we get a proper solution to that part of the problem.
16:26:13 <jwb> zbyszek, no.  batched wasn't created to solve efficient metadata distribution.  if you solve that, batched still has other goals it is trying to accomplish that don't magically disappear with a metadata fix
16:26:43 <zbyszek> jwb: I don't disagree with anything you're saying.
16:26:56 <nirik> we could also just adjust the releng updates pushes. Only push stable updates when there is an urgent update or once a week.
16:27:18 <jwb> zbyszek, great.  then please stop framing batched as something that will go away with efficient metadata distribution.  that's how your reasoning is being perceived
16:27:37 <wadadli> not getting how batching updates, causes users to think that the software that they have no clue about, some how makes fedora seem less buggy.
16:27:46 <jwb> nirik, right, those kinds of things help the original goal
16:28:11 <nirik> in any case we have been on this for 30min now... perhaps we should reopen discussion on the list or wait for proposals of things to change?
16:28:26 <zbyszek> +1
16:28:28 <jwb> wadadli, it's all about perception and planning.  there are lots of packages.  batched doesn't solve that.  but it does help to update them in discrete chunks
16:28:34 <jwb> nirik, sure, we can move on
16:29:18 <jwb> even for linux-savy users coming from enterprise worlds, discrete updates are key to their workflows and important updates outside of those windows are exceptions that cause them headaches
16:30:30 <nirik> I think batched has reduced things a lot... but not to 0 most days.
16:30:34 <maxamillion> yeah, I'm with jwb on this
16:31:09 <maxamillion> but we can move on
16:31:11 <jwb> nirik, progress is all we can aim for :)
16:32:14 <nirik> sure, but I think we could rework this... just not sure how right now.
16:32:46 <nirik> #topic #1801 Unresponsive Maintainer: EDB Package
16:32:46 <nirik> .fesco 1801 https://pagure.io/fesco/issue/1801
16:32:46 <zodbot> nirik: Error: '1801 https://pagure.io/fesco/issue/1801' is not a valid integer.
16:33:13 <sgallagh> Hi folks. Sorry i am late.
16:33:21 <nirik> hey sgallagh, want to take over?
16:33:45 <sgallagh> Sure.
16:33:50 <sgallagh> .fesco 1801
16:33:52 <zodbot> sgallagh: Issue #1801: Unresponsive Maintainer: EDB Package - fesco - Pagure - https://pagure.io/fesco/issue/1801
16:34:01 <sgallagh> This got dropped on the floor.
16:34:17 <sgallagh> Seems like no movement, so I propose we go ahead and orphan
16:34:34 <zbyszek> Yes, there are 4 packages.
16:34:37 <nirik> sure. +1 to orphan/reassign packages
16:34:48 <zbyszek> +1
16:36:01 <maxamillion> +1
16:36:03 <sgallagh> +1 for the record
16:36:21 <wadadli> +1
16:36:57 <sgallagh> wadadli: votes are tallied only for FESCo members.
16:37:39 <sgallagh> jwb_: ?
16:37:53 <jwb> +1
16:38:01 <sgallagh> jsmith: ?
16:38:10 <sgallagh> (Sorry, had to catch up on who was around)
16:38:42 <sgallagh> #agreed Orphan the owner's packages. (+5, 0, -0)
16:38:48 <jsmith> +1
16:38:56 <sgallagh> #undo
16:38:56 <zodbot> Removing item from minutes: AGREED by sgallagh at 16:38:42 : Orphan the owner's packages. (+5, 0, -0)
16:38:58 <sgallagh> #agreed Orphan the owner's packages. (+6, 0, -0)
16:39:01 <jsmith> (Sorry, got pulled into a meeting at work -- trying to multi-task)
16:39:01 <sgallagh> #topic #1836 Non-responsive maintainer: Lameire Alexis
16:39:02 <sgallagh> .fesco 1836
16:39:13 <zodbot> sgallagh: Issue #1836: Non-responsive maintainer: Lameire Alexis - fesco - Pagure - https://pagure.io/fesco/issue/1836
16:39:18 <zbyszek> +1 to orphan/reassing packages
16:39:27 <sgallagh> Same, +1 to orphan
16:39:43 <jsmith> I'm fine to orphan, consider me +1
16:40:03 <nirik> +1
16:40:06 <maxamillion> +1
16:40:21 <zbyszek> jwb?
16:40:29 <jwb> yes, +1
16:40:39 <jwb> apologies, still doing double meeting duty
16:40:47 <sgallagh> #agreed Orphan the owner's packages. (+6, 0, -0)
16:41:13 <sgallagh> nirik: May I ask you as usual to do the actual orphaning of these two?
16:41:41 <nirik> sure, and can try and do that other pending one thats still waiting.
16:41:47 <nirik> if I am alive later today
16:42:34 <sgallagh> nirik: thanks
16:42:42 <sgallagh> #action nirik to process the orphans
16:42:52 <sgallagh> ... that sounds a bit disturbing, phrased like that
16:42:55 <sgallagh> #topic #1767 F28 Self Contained Changes
16:42:55 <sgallagh> .fesco 1767
16:43:00 <zodbot> sgallagh: Issue #1767: F28 Self Contained Changes - fesco - Pagure - https://pagure.io/fesco/issue/1767
16:43:10 <zbyszek> +1 to all of them
16:43:19 <sgallagh> +1 to all of them
16:43:33 <zbyszek> But not that Sando Mani asked for giflib to be (re-)orphaned.
16:43:48 <zbyszek> Can we just reassign the ownership to him?
16:43:48 <nirik> +1 all
16:43:54 <zbyszek> *note
16:44:14 <jwb> +1 to all (i read this ticket before the meetign)
16:44:15 <sgallagh> I'd be fine just adding him as a maintainer
16:44:26 <nirik> the owner is unresponsive?
16:44:43 <zbyszek> jcapik is long gone... There was a fesco ticket, and his packages were orphaned, but not giflib somehow.
16:44:57 <jsmith> +1 to all (Chinese fonts, python generators, and giflib5)
16:45:03 <zbyszek> Adding as a maintainer works too.
16:45:17 <nirik> yeah, thats the other ticket thats not done that I was going to do.
16:45:22 <nirik> I can reassign it to him.
16:45:26 <maxamillion> +1 to all as well
16:45:27 <sgallagh> nirik++
16:45:27 <zodbot> sgallagh: Karma for kevin changed to 20 (for the f27 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
16:45:35 <jsmith> And for the record, I'm fine with reassigning it to him or adding him as a maintainer
16:46:03 <sgallagh> #agreed Noto, Python Generators and GifLib 5 are approved (+6, 0, -0)
16:46:23 <sgallagh> #topic Next Week's Meeting Time
16:46:53 <sgallagh> #link http://whenisgood.net/fesco/2018/results/fh3yjbg
16:46:58 <sgallagh> So, we are at an impasse...
16:47:08 <nirik> 6 have replied.
16:47:16 <nirik> but yeah, 0 meeting times
16:47:43 <jsmith> I'm very flexible now on times :-)
16:47:55 <sgallagh> Proposal: FESCo should reduce its membership to 5 people to increase the likelihood of finding an acceptable meeting time :-D
16:48:11 <nirik> ha
16:48:13 <jsmith> sgallagh: If that proposal passes, I'll give up my seat :-)
16:48:20 <maxamillion> I could be a little flexible at times, I blocked off some times because I often have meetings in those time slots
16:48:25 <sgallagh> (That's a joke, for the record)
16:48:44 <sgallagh> maxamillion: Mind updating your reply to mark those times "open"?
16:48:56 <maxamillion> sgallagh: yeah, I can
16:48:58 <zbyszek> Do you have a link to the results?
16:48:59 <sgallagh> thanks
16:49:08 <nirik> who needs to reply still? jsmith and jwb ? and tyll ?
16:49:16 <sgallagh> zbyszek: I pasted it above
16:49:16 <jsmith> Are those times in UTC?
16:49:21 <zbyszek> Oh.
16:49:22 <nirik> jsmith: yes
16:49:27 <jwb> i do need to reply.  i will do it today
16:50:15 <zbyszek> FTR, I updated my answer to include all the times which are inconvenient but doable...
16:50:18 <nirik> so perhaps one more week of this meeting slot and discuss some other slot next weeks meeting?
16:50:34 <sgallagh> Proposal: we give people until 2359 UTC on Monday to respond and then if the best time is Wednesday or later, hold it that day, otherwise push it out to the following week.
16:50:41 <nirik> zbyszek: that gives one window now. ;)
16:50:44 <maxamillion> sgallagh: how do I edit my response/
16:50:45 <maxamillion> ?*
16:51:25 <nirik> I can try and adjust mine too.
16:51:44 <sgallagh> maxamillion: If you were logged in, you should have an edit link
16:51:54 <sgallagh> If not, create a new one and we'll suppress your original reply
16:52:11 <jsmith> OK, I've added my availability, but it shouldn't be very restrictive now
16:52:12 <nirik> yeah, I didnt save my edit link either I don;'t think.
16:52:17 <zbyszek> maxamillion: if you have a page like whenisgood.net/fesco/2018/thanks/<gibberish> in your history, that includes a link to edit
16:53:24 <jsmith> Looks like we now have a time on Wednesday that works
16:53:27 <nirik> zbyszek++ worked for me. ;)
16:53:57 <maxamillion> zbyszek: I don't :(
16:54:44 <tyll> I became a father three weeks ago and still need to adjust but I will try to resüond somehow useful
16:54:53 <maxamillion> tyll: +1 congrats!
16:54:55 <nirik> tyll: congrats!
16:55:10 <zbyszek> tyll: congrats
16:55:12 <maxamillion> I've got my second child due in 9 days so I'll be a little sleep deprived soon as well
16:55:12 <sgallagh> tyll: Congratulations!
16:55:14 <nirik> sgallagh: +1 your proposal. we need a chair for next week...
16:55:24 <tyll> thank you
16:55:45 <sgallagh> To reiterate, my proposal was:
16:55:45 <sgallagh> Proposal: we give people until 2359 UTC on Monday to respond and then if the best time is Wednesday or later, hold it that day, otherwise push it out to the following week.
16:55:52 <jsmith> sgallagh: +1 to your latest proposal
16:56:06 * jsmith is happy to run the next meeting
16:56:15 <tyll> maxamillion: good luck
16:56:18 <zbyszek> +1 to sgallagh's proposal
16:56:24 <maxamillion> tyll: thanks :)
16:56:35 <maxamillion> sgallagh: +1
16:56:36 <tyll> +1
16:57:15 <sgallagh> #agreed We give people until 2359 UTC on Monday to respond and then if the best time is Wednesday or later, hold it that day, otherwise push it out to the following week. (+5, 0, -0)
16:57:29 <sgallagh> #action jsmith to chair the next meeting
16:57:33 <sgallagh> #topic Open Floor
16:57:56 <sgallagh> Anything?
16:59:01 <sgallagh> nirik: Thanks for kicking off the meeting. I appreciate it.
16:59:24 <sgallagh> (Also, feel better!)
16:59:56 <nirik> I sure hope so
17:00:42 <sgallagh> #endmeeting