fesco
LOGS
16:00:33 <maxamillion> #startmeeting FESCO (2018-01-19)
16:00:33 <maxamillion> #meetingname fesco
16:00:33 <zodbot> Meeting started Fri Jan 19 16:00:33 2018 UTC.  The chair is maxamillion. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:33 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:33 <zodbot> The meeting name has been set to 'fesco_(2018-01-19)'
16:00:33 <zodbot> The meeting name has been set to 'fesco'
16:00:33 <maxamillion> #chair maxamillion dgilmore nirik jforbes jsmith kalev sgallagh bowlofeggs tyll
16:00:33 <zodbot> Current chairs: bowlofeggs dgilmore jforbes jsmith kalev maxamillion nirik sgallagh tyll
16:00:33 <maxamillion> #topic init process
16:00:39 <jsmith> .hello jsmith
16:00:40 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
16:00:43 <nirik> morning everyone.
16:00:45 <maxamillion> .hello2
16:00:46 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
16:00:56 <jsmith> (I'm on a phone call, but I'll try my best to multi-task)
16:01:15 <maxamillion> jsmith: uggggghhhh ... fine :)
16:01:41 <jsmith> maxamillion: With any luck, it'll be a boring/uneventful call, so that I can mostly focus on FESCo
16:01:43 <jforbes> .hello2
16:01:44 <zodbot> jforbes: jforbes 'Justin M. Forbes' <jforbes@redhat.com>
16:01:51 <bowlofeggs> .hello2
16:01:52 <zodbot> bowlofeggs: bowlofeggs 'Randy Barlow' <randy@electronsweatshop.com>
16:02:34 <maxamillion> we'll wait a couple minutes and then get rolling ... we have one hell of an agenda today
16:02:36 <sgallagh> I am not here for the purposes of quorum (at the car dealership and on my phone), but if there are direct questions for me I can answer.
16:02:56 <maxamillion> sgallagh: hope all is well
16:04:16 * dgilmore is doing double meeting duty
16:04:20 <kalev-afk> .hello2
16:04:21 <zodbot> kalev-afk: Sorry, but you don't exist
16:04:24 <kalev-afk> arr
16:04:29 <kalev> .hello2
16:04:32 <zodbot> kalev: kalev 'Kalev Lember' <klember@redhat.com>
16:05:06 <maxamillion> alright, let's get rolling
16:05:12 <maxamillion> #topic #1767 F28 Self Contained Changes
16:05:13 <maxamillion> .fesco 1767
16:05:13 <maxamillion> https://pagure.io/fesco/issue/1767
16:05:18 <zodbot> maxamillion: Issue #1767: F28 Self Contained Changes - fesco - Pagure - https://pagure.io/fesco/issue/1767
16:05:31 <langdon> .hello2
16:05:32 <zodbot> langdon: langdon 'Langdon White' <langdon@redhat.com>
16:05:36 * langdon lurks if you need me
16:05:57 <nirik> +1 on the self contained change
16:06:15 <maxamillion> +1
16:06:26 <jsmith> +1
16:06:55 <kalev> +1
16:07:04 <bowlofeggs> +1 on the python change
16:07:07 <dgilmore> +1
16:07:40 <jforbes> +1 I guess
16:07:48 <maxamillion> #agreed APPROVED - F28 Self Contained Changes - Avoid /usr/bin/python in RPM build (+1:7, -1:0, +0:0)
16:08:01 <maxamillion> #topic #1803 F28 System Wide Change: Reduce Initial Setup Redundancy
16:08:01 <maxamillion> .fesco 1803
16:08:01 <maxamillion> https://pagure.io/fesco/issue/1803
16:08:02 <zodbot> maxamillion: Issue #1803: F28 System Wide Change: Reduce Initial Setup Redundancy - fesco - Pagure - https://pagure.io/fesco/issue/1803
16:09:02 <bowlofeggs> so has the proposal changed, or the OPs want to talk about it, or both?
16:09:05 <dgilmore> sgallagh: what is the new info?
16:09:27 <kalev> we had a long discussion about this at the Workstation WG meeting
16:10:11 <maxamillion> are the Workstation WG representatives in attendance?
16:10:54 <kalev> otaylor and me I guess
16:11:15 * otaylor is in attendance
16:12:13 <kalev> as I understand it, the main issue that FESCo raised at the last meeting (I sadly missed that one) was that this change would require other desktops to implement new code to match gnome-initial-setup, and that's an unfair burden to them
16:12:13 <otaylor> the proposal has changed, but we think that there was perhaps some misunderstanding of the proposal, and want to discuss it with representatives in attendance
16:12:18 <otaylor> has *not* changed
16:12:27 <dgilmore> kalev: otaylor: the floor is yours, FESCo had decided that we wanted gnome-initial-setup to remove duplication so that all fedora installs are consistently configured
16:12:58 <bowlofeggs> i think it wasn't necessarily just other desktops that were a concern, but also server and minimal install too
16:13:05 <dgilmore> correct
16:13:09 <maxamillion> bowlofeggs: +1
16:13:47 <kalev> right. but as it turns out, the change only affects workstation and nothing should change for other spins
16:13:48 <otaylor> Was it clear that there was no additional work being proposed for other editions? That we were proposing a change *only* for the workstation?
16:14:14 <bowlofeggs> yeah i think that was clear
16:14:20 <dgilmore> kalev: well one of the issues identified is that gnome-initial-setup configures users differently to the rest of the system tools
16:14:31 <bowlofeggs> the concern i think was more about making the anaconda experience be different on the different editions
16:15:22 <dgilmore> if you configure workstation to use ipa for instance using gnome-initial-setup your user name is user@domain  but every other way to configure thinsg results in your user being just user
16:15:48 <otaylor> Hmm, well, it would be slightly different - but isn't user experience something that is supposed to largely left to the discretion of the working group?
16:16:02 <kalev> why is the user experience difference a concern? we created the workstation edition specifically so that we could iterate faster with improvements and wouldn't have to wait for other spins to catch up
16:16:31 <kalev> the main reason for having separate workstation and server and spins was to be able to differ in certain aspects
16:16:45 <dgilmore> otaylor: what we want is that gnome-initial-setup remove duplication for things that can be done in initial-setup so that when you configure things your configuration is the same regardless of which spin/variant/edition you use
16:16:46 <kalev> and we created a workstation wg to drive those changes and this change is backed by the workstation wg
16:16:59 <otaylor> dgilmore: these sound like fixable problems.
16:17:19 <otaylor> can we be clear whether the problem is a) user experience or b) technical differences in how things end up configured?
16:18:10 <dgilmore> both
16:18:34 <kalev> why is fesco overriding the workstation wg here? shouldn't this be a workstation wg domain item?
16:18:43 <maxamillion> I lean more with A than B, but I suppose B is a side effect of the situation
16:19:58 <maxamillion> kalev: it's classified as a system wide change, that shouldn't be FESCo if it's affects are considered system wide
16:20:03 <maxamillion> errr
16:20:07 <maxamillion> that *should* be FESCo
16:20:12 <dgilmore> right
16:20:48 <otaylor> I think the basic problem here is that gnome-initial-setup is a *uniform* user design for configuring both things that are technically system-wide and technically user-specific so that the user has to only deal with configuring things in one place. Hacking out parts of it and putting them into anaconda (or firstboot, I suppose) degrades the user experiencs. There is extreme reluctance on the worjkstaiton working group to
16:20:50 <otaylor> do that - we do don't consider that a good idea.
16:21:06 <kalev> would it help if we reclassify it as a self contained change, with the notion that it only affects Workstation and not the rest of Fedora?
16:22:10 <kalev> in any case, my understanding was that FESCo created individual WG-s so that they'd have freedom to decide and drive what happens in their domain
16:22:38 <maxamillion> kalev: but it does affect the rest of Fedora, this is making a situation where the installable entity known as "Fedora" will be fundamentally different based on GNOME or not-GNOME
16:22:50 <otaylor> maxamillion: isn't that always the case?
16:23:24 <kalev> maxamillion: but that's already the case. we already use gnome-initial-setup in workstation
16:23:24 <otaylor> I mean, in the end you get a Desktop - or a server, or a cloud vm, or ..... and the way that you will interact with that will vary a great deal
16:23:58 <jforbes> otaylor: Are anaconda developers aware of what you want to do here? Do they have a way to "config it out" without having to maintain separate builds?
16:24:23 <nirik> jforbes: there's a file you can write to tell anaconda not to show some spokes/items.
16:25:02 <maxamillion> otaylor: no, the setup is in Anaconda ... we're talking about taking it out of Anaconda, yes?
16:25:14 <otaylor> Generally, what we'd like to see is that installing the Workstation product you get a slick, easy to use install that is (as much as possible) consistent with the final product - I don't think making the initial experience worse (in our estimation - because of the split of configuration duties to multiple points in the process) is worth it just because the user might install a server at some other time, and might find it
16:25:16 <maxamillion> I understand that GNOME-specific things are in GNOME, that's always been true
16:25:16 <otaylor> a little confusing if the installation was different.
16:25:51 <otaylor> I think the goal is to get the user *to Fedora* as slickly as possible, to make them feel good, and if they happen to be a reviewer, reflect that in their review.
16:26:03 <jforbes> With this in mind, I suppose I have a technical issue with the user creation results being different, but I don't see a problem in the method/UI being different as long as the end results are the same
16:26:05 <maxamillion> otaylor: alright, so what happens if I install from the "Everything DVD"?
16:26:10 <otaylor> jforbes: my understanding is that the necessary changes to make this configurable within anaconda have already been done by the anaconda team
16:26:12 <maxamillion> (which is how I often install)
16:26:23 <dgilmore> jforbes: agreed
16:26:25 <maxamillion> otaylor: is my experience there degraded?
16:26:41 <maxamillion> jforbes: yeah, that's a fair point +1
16:26:46 <jforbes> So, one more question, if this is configured out of anaconda, and the UI is not displayed, it will still honor kickstart directives for user?
16:26:50 <otaylor> maxamillion: We're *only* talking about the WG live installer and WG netinstall
16:27:02 <otaylor> maxamillion: err, workstation, not WG
16:27:03 <nirik> maxamillion: you mean the netinstall? thats different... but thats always been different from live media for several reasons.
16:27:15 <maxamillion> nirik: I am not
16:27:35 <nirik> then I am not sure what media you mean.
16:27:46 <dgilmore> nirik: from Everything variant
16:28:05 <otaylor> If  you are installing through a way where you have a choice of edition, we don't see doing something complicated to change the flow in anaconda depending on the edition being worth effort - it's a corner case
16:28:34 <otaylor> what we care about is what happens if you go to getfedora.org and click on Workstation
16:29:20 <maxamillion> nevermind, my point has been missed and we've been on this for 20 minutes ... can someone make a proprosal so we can vote? we have 17 more items on the meeting agenda
16:29:54 <jforbes> otaylor: So, I go and click on workstation, I see this new experience, anaconda doesn't as me for user information, gnome does, that's fine. Now I want to roll it out to 30 PCs in a lab.  will kickstart still honor the user directives?
16:30:14 <otaylor> jforbes: yes, kickstart will honor it
16:30:28 <bowlofeggs> will kickstart set up the users differently though?
16:30:30 <dgilmore> otaylor: so if under the hood the same methods were used I do not think that FESCo minds how things are done
16:30:35 <bowlofeggs> like that user@domain thing that dgilmore brought up?
16:30:47 <kalev> before we vote, I'd like to put this in a bit different perspective
16:30:58 <dgilmore> Our main reason was that we wanted the underlying foundation to be set up consistently across Fedora install methods
16:30:59 <kalev> right now we have basically two completely different code paths:
16:31:10 <maxamillion> dgilmore: +1
16:31:34 <otaylor> dgilmore: I think I'd have to do more research to see what the practicalities are there - though I think we'd agree that non-essential differences in setup are bugs (as in the past when g-i-s would add the first user to wheel and anaconda wouldn't)
16:31:38 <dgilmore> if you use  your own gui or anaconda's we do not mind so much.
16:31:57 <dgilmore> otaylor: right
16:32:02 <kalev> one code path is if we create a user in anaconda, and the other one is if we don't
16:32:44 <kalev> depending on that, it completely changes what gnome-initial-setup does; it has separate new user and existing user modes
16:33:13 <kalev> now, the proposal here is to kill one of the code paths, so that we wouldn't get completely different setup paths
16:33:52 <kalev> note that we _already_ have totally different initial setup paths, depending on where the user is created
16:34:09 <kalev> this proposal here tries to take one of the paths out of the equation
16:34:13 <maxamillion> kalev: the proposal here isn't to kill one of the code paths, it's to conditionally not take one of the code paths *if* the install media is Fedora Workstation, which can lead to inconsistently configured systems
16:34:21 <jforbes> kalev: I am perfectly fine with that, and I don't even care which path you choose to kill for UI, I do care that the results of those codepaths are the same
16:34:32 <maxamillion> jforbes: +1
16:35:03 <otaylor> kalev: I think we can't get there unless we declare kickstart, generic anaconda install, etc, invalid. What we can do is make sure that most installs go through a single path andmake that slick.
16:35:48 * kalev nods.
16:36:10 <jforbes> I care that documentation for doing things on Fedora doesn't have to suddenly specify "unless you installed with workstation, if so it will be this"
16:36:22 <maxamillion> jforbes: +1
16:36:35 * nirik nods
16:36:57 <bowlofeggs> yeah i also feel that way
16:37:13 <bowlofeggs> otaylor, kalev: can you elaborate on the problems of going the reverse direction?
16:37:26 <otaylor> OK, perhaps you guys can vote on a proposal that a) configuring workstatoin-specific installs to have a streamlined anaconda is ok if the result is "enough alike" b) the workstation working group will report back on whether it is possible to use the exact same code for user creation, or what can be done to automate testing to prevent extraneous differences ?
16:37:50 <otaylor> bowlofeggs: the reverse direction being what? to remove parts of g-i-s ?
16:38:06 <bowlofeggs> otaylor: yeah
16:38:24 <bowlofeggs> i.e., accomplish the same overall goal, but continue letting anaconda do its bits
16:38:58 <nirik> well, note that we also have initial-setup. ;)
16:39:23 <kalev> this just leads to less polished user experience, as we believe that certain items belong to post-install configuration after user creation
16:39:25 <jforbes> Proposal: The reduction of redundancy for workstation can happen in either anaconda or g-i-s at the working groups discretion provided the end results are consistent with the rest of Fedora.
16:39:43 <maxamillion> +1 to jforbes proposal
16:40:27 <bowlofeggs> sure i can +1 that
16:40:42 <otaylor> bowlofeggs: generally it's just that we want to have a unified configuration experience - that we don't believe that users care whether configuration items they are presented are shared with other editions or not, or are system-wide or not, or require a network or not, etc
16:41:16 <nirik> +1
16:41:39 <kalev> I'm not sure what consistent means in the proposal, but I hope that's also at the working groups discretion :)
16:42:42 <nirik> kalev: I guess that would fall back to otaylor's proposal... "enough alike" + testing?
16:43:01 <kalev> fair enough, +1 to the proposal then
16:43:39 <maxamillion> otaylor: you may "believe" that, but without any real substantial evidence I don't accept that as a metric by which to alter the distro and I don't think anyone else should either. Multiple members of FESCo brought up scenarios by which that would be problematic and none of the them are far fetched.
16:44:19 <maxamillion> kalev: I don't think it should be, if we need to define it then I think we should
16:44:48 <otaylor> maxamillion: do you believe that the working groups should have the authority to make user interface decisions largely based on their own judgement (experts, expertise, etc.)?
16:45:03 <maxamillion> kalev: ultimately I think the use case that jforbes brought up about "if I install with Workstation Live and then want to deploy that out to my computer lab via kickstart, this should be the same" is what we should aim for
16:46:00 * otaylor wonders who configures users in kickstart for their lab... as opposed to using kerberos or similar
16:46:14 <kalev> maxamillion: I am sure we can try to make kickstart and live installations as similar as possible, that's a good comment
16:46:19 <maxamillion> otaylor: user interface decisions that affect only the domain that the working group is the subject matter expert of? absolutely, this isn't that as it has side effects for the entire distro's consistency
16:47:33 <maxamillion> otaylor: we have customers using both kickstarts with sections in them auto generated by scripts and Ansible for user creation and configuration management ... you'd be surprised (or maybe you wouldn't)
16:47:45 <otaylor> maxamillion: I just don't undestand why we expect 100% consistency of the installation process when we are installing entirely different user experiences
16:48:13 <rdieter> maxamillion: in this case, live/kickstart can easily be made consistent (I believe)
16:48:14 <maxamillion> otaylor: but we're not, why can't I install Workstation from a kickstart?
16:48:25 <jforbes> otaylor: I don't think we do expect consistency in the process, just in the results
16:48:44 <maxamillion> jsmith: dgilmore: waiting on your votes
16:48:51 <otaylor> maxamillion: I think it's very much possible, though not typical. But yes, consistency of configuration is definitely a good technical goal - we don't want someone who adds a user by some other means to have a degraded, inconsistent experience
16:49:10 <maxamillion> otaylor: right, what jforbes said ... I don't care about the UX, I care about the resulting state of the machine being consistent
16:50:12 <otaylor> maxamillion: OK, I wasn't sure what you were arguing against - I was originally replying to bowlofeggs asking about why we wanted to change the UX (or why we didn't want a different change to the UX)
16:50:40 <jsmith> +1
16:50:46 <jsmith> (sorry for the latency)
16:51:10 <maxamillion> otaylor: ohhhhh, yeah, I don't have any preference there ... y'all change it however you want and best see fit
16:51:40 <maxamillion> alright, I'm going to assume we lost dgilmore
16:51:42 <maxamillion> #agreed The reduction of redundancy for workstation can happen in either anaconda or g-i-s at the working groups discretion provided the end results are consistent with the rest of Fedora. (+1:6, -1:0, +0:0)
16:52:00 <maxamillion> #topic #1814 F28 System Wide Change: Anaconda Modularization
16:52:00 <maxamillion> .fesco 1814
16:52:01 <maxamillion> https://pagure.io/fesco/issue/1814
16:52:04 <zodbot> maxamillion: Issue #1814: F28 System Wide Change: Anaconda modularization - fesco - Pagure - https://pagure.io/fesco/issue/1814
16:52:19 <nirik> +1
16:52:23 <kalev> +1
16:52:34 <maxamillion> +1
16:54:20 <maxamillion> jsmith: bowlofeggs jforbes: ?
16:54:29 <maxamillion> and we lost jsmith
16:54:31 <jforbes> +1 here
16:54:34 <bowlofeggs> +1
16:54:37 <jsmith> jsmith: Sorry, I'm back
16:54:42 <maxamillion> jsmith: welcome back :)
16:54:43 <jsmith> +1 from me
16:54:45 <jforbes> They were pretty good at handling feedback on the -devel thread
16:54:50 <maxamillion> #agreed F28 System Wide Change: Anaconda modularization (+1:6, -1:0, +0:0)
16:55:02 <maxamillion> #topic #1815 F28 System Wide Change: Make authselect default tool instead of authconfig
16:55:02 <maxamillion> .fesco 1815
16:55:03 <maxamillion> https://pagure.io/fesco/issue/1815
16:55:05 <zodbot> maxamillion: Issue #1815: F28 System Wide Change: Make authselect default tool instead of authconfig - fesco - Pagure - https://pagure.io/fesco/issue/1815
16:55:44 <nirik> +1
16:55:56 <kalev> +1
16:56:00 <maxamillion> +1
16:56:02 <jforbes> +1
16:56:14 <bowlofeggs> +1
16:56:42 <maxamillion> jsmith: ?
16:56:49 <jsmith> +1
16:56:59 <maxamillion> #topic #1816 F28 System Wide Change: Glibc collation update and sync with cldr
16:57:00 <maxamillion> .fesco 1816
16:57:00 <maxamillion> https://pagure.io/fesco/issue/1816
16:57:02 <zodbot> maxamillion: Issue #1816: F28 System Wide Change: Glibc collation update and sync with cldr - fesco - Pagure - https://pagure.io/fesco/issue/1816
16:57:32 <jsmith> I don't pretend to understand all the details, but it sounds good to me
16:57:33 <jsmith> +1
16:57:57 <nirik> +1
16:58:03 <maxamillion> +1
16:58:49 <bowlofeggs> +1
16:59:44 <jforbes> sorry, desktop crashed and I am missing some backscroll, are we voting on 1816 approval, or was there some discussion I missed?
17:00:05 <kalev> +1
17:00:19 <nirik> jforbes: yes, voting on 1816.
17:00:28 <nirik> no discussion in particular on it yet.
17:00:36 <kalev> sorry, my time is up, I'll have to step away from the computer now
17:00:49 <dgilmore> +1
17:01:06 <jforbes> Ahh, +1 then
17:01:47 <maxamillion> #agreed APPROVE - F28 System Wide Change: Glibc collation update and sync with cldr (+1:7, -1:0, +0:0)
17:01:54 <jforbes> -+
17:01:54 <jforbes> .+
17:02:05 <maxamillion> #topic #1817 F28 System Wide Change: golang 1.10
17:02:05 <maxamillion> .fesco 1817
17:02:06 <maxamillion> https://pagure.io/fesco/issue/1817
17:02:09 <zodbot> maxamillion: Issue #1817: F28 System Wide Change: Golang 1.10 - fesco - Pagure - https://pagure.io/fesco/issue/1817
17:02:10 <maxamillion> +1
17:02:19 <nirik> +1
17:02:23 <jforbes> +1
17:02:49 <bowlofeggs> +1
17:04:16 <maxamillion> jsmith: dgilmore: ?
17:05:22 <maxamillion> we might have lost quorum ... :/
17:05:39 <dgilmore> +1
17:05:49 <dgilmore> sorry meeting just wrapped up
17:05:55 <dgilmore> this is my only thing now
17:06:53 <maxamillion> alright, assuming we've lost jsmith
17:06:57 <maxamillion> #agreed APPROVE - F28 System Wide Change: Golang 1.10 (+1:5, -1:0, +0:0)
17:07:02 <jsmith> I'm still here, sorry
17:07:06 <jsmith> Just wrapping up a phone call
17:07:09 <maxamillion> #topic #1818 F28 System Wide Change: Kerberos in Python modernization
17:07:09 <maxamillion> .fesco 1818
17:07:09 <maxamillion> https://pagure.io/fesco/issue/1818
17:07:11 <zodbot> maxamillion: Issue #1818: F28 System Wide Change: Kerberos in Python modernization - fesco - Pagure - https://pagure.io/fesco/issue/1818
17:07:42 <bowlofeggs> this sounds like it could be a lot of work, but +1 :)
17:07:48 <maxamillion> same
17:07:49 <maxamillion> +1
17:08:00 <dgilmore> +1
17:08:04 <jsmith> Yeah... but we did get some discussion on the list, so that's good.. +1 from me
17:08:10 <maxamillion> all the karma for rharwood for taking tha ton
17:08:24 <jsmith> Indeed
17:08:27 <jforbes> +1
17:08:40 <nirik> +1
17:08:43 <maxamillion> #agreed APPROVE - F28 System Wide Change: Kerberos in Python modernization (+1:6, -1:0, +0:0)
17:08:59 <maxamillion> #topic #1819 F28 System Wide Change: Removal of Sun RPC Interfaces from glibc
17:08:59 <maxamillion> .fesco 1819
17:08:59 <maxamillion> https://pagure.io/fesco/issue/1819
17:09:04 <nirik> +1
17:09:08 <jsmith> +1
17:09:14 <zodbot> maxamillion: Issue #1819: F28 System Wide Change: Removal of Sun RPC Interfaces From glibc - fesco - Pagure - https://pagure.io/fesco/issue/1819
17:09:14 <dgilmore> +1
17:09:16 <maxamillion> +1
17:09:35 <jforbes> This one is a lot more work, but I agree with Florian, the issue has to be forced
17:09:36 <jforbes> +1
17:09:45 <bowlofeggs> +1
17:09:52 <maxamillion> #agreed APPROVE - F28 System Wide Change: Removal of Sun RPC Interfaces from glibc (+1:6, -1:0, +0:0)
17:10:14 <maxamillion> omg pagure is being so slow
17:10:33 <maxamillion> #topic #1822 F28 System Wide Change: AArch64 Server Promotion
17:10:33 <maxamillion> .fesco 1822
17:10:33 <maxamillion> https://pagure.io/fesco/issue/1822
17:10:33 <jsmith> maxamillion: I was noticing the same thing.
17:10:55 <jsmith> Easy +1 from me...
17:10:56 <bowlofeggs> have we ever had an arch that was primary for only one edition before?
17:10:59 <zodbot> maxamillion: Issue #1822: F28 System Wide Change: AArch64 Server Promotion - fesco - Pagure - https://pagure.io/fesco/issue/1822
17:11:01 <jforbes> +1
17:11:04 <maxamillion> yeah, +1 from me as well
17:11:09 <bowlofeggs> +1 for me too, just curious about the edition thing
17:11:26 <maxamillion> if jforbes is good with it from the kernel side, I think everything else makes sense
17:11:40 <jsmith> bowlofeggs: It's an easier way to get a new arch into Fedora, than to have to work for all editions
17:12:07 <bowlofeggs> oooh, the pine64 being blocking makes me want to buy a pine64
17:12:10 <bowlofeggs> jcline: ^
17:12:15 <dgilmore> +1
17:12:35 <jforbes> maxamillion: there has been a ton of work to not only make systems work, but to make sure it happens upstream... Half of our patch churn is something fixed in Fedora, and with the next merge window the patch is dropped because it is upstream
17:12:56 <jsmith> :-)
17:13:09 <maxamillion> jforbes: awesome
17:13:10 <dgilmore> jforbes: which is awesome and how it should be
17:13:17 <maxamillion> nirik: thoughts?
17:13:32 <maxamillion> bowlofeggs: they're nice little boards
17:14:06 <nirik> +1
17:14:13 <nirik> I think it's time...
17:14:23 <dgilmore> bowlofeggs: I have 4 of them
17:15:10 <maxamillion> #agreed APPROVE - F28 System Wide Change:  AArch64 Server Promotion (+1:6, -1:0, +0:0)
17:15:27 <jforbes> I still want a decent aarch64 platform with pluggable memory, etc. Something I can do builds and testing on locally, or use as a workstation
17:15:43 <maxamillion> #topic #1823 F28 System Wide Change: mpfr-4.0.0
17:15:44 <maxamillion> .fesco 1823
17:15:44 <maxamillion> https://pagure.io/fesco/issue/1823
17:15:49 <maxamillion> jforbes: +1
17:15:55 <zodbot> maxamillion: Issue #1823: F28 System Wide Change: mpfr-4.0.0 - fesco - Pagure - https://pagure.io/fesco/issue/1823
17:16:00 <dgilmore> jforbes: they will come
17:16:01 <maxamillion> jforbes: I'm still waiting for someone to make one of  those
17:16:11 <jforbes> +1 on mpfr
17:16:27 <maxamillion> +1 on mpfr also
17:16:30 <nirik> +1
17:17:06 <bowlofeggs> +1
17:17:07 <dgilmore> +1
17:17:21 <jsmith> +1
17:18:02 <maxamillion> #agreed APPROVE - F28 System Wide Change:  mpfr-4.0.0 (+1:6, -1:0, +0:0)
17:18:20 <maxamillion> #topic #1824 F28 System Wide Change: Binutils version 2.29.1
17:18:21 <maxamillion> .fesco 1824
17:18:21 <maxamillion> https://pagure.io/fesco/issue/1824
17:18:23 <zodbot> maxamillion: Issue #1824: F28 System Wide Change: Binutils version 2.29.1 - fesco - Pagure - https://pagure.io/fesco/issue/1824
17:18:36 <jforbes> +1
17:18:39 <maxamillion> +1
17:19:09 <bowlofeggs> +1
17:20:13 <jsmith> +1 (straightforward)
17:20:28 <dgilmore> +1
17:20:48 <nirik> +1
17:21:30 <maxamillion> #agreed APPROVE - F28 System Wide Change: Binutils version 2.29.1 (+1:6, -1:0, +0:0)
17:21:42 <maxamillion> #topic #1825 F28 System Wide Change: Add-On Modularity
17:21:42 <maxamillion> .fesco 1825
17:21:42 <maxamillion> https://pagure.io/fesco/issue/1825
17:21:45 <zodbot> maxamillion: Issue #1825: F28 System Wide Change: Add-On Modularity - fesco - Pagure - https://pagure.io/fesco/issue/1825
17:22:04 <jforbes> +1 (blog post is worth reading if you haven't as well)
17:22:15 <maxamillion> I'm really on the fence about this one, I don't really like the idea and I think it's going to be a hit to the mirrors
17:22:30 <sgallagh> Well, this is a convenient moment for me to return.
17:22:37 <maxamillion> but I understand it's a Council objective so I'm not inclined to throw a fit if everyone else is on board
17:22:40 <dgilmore> I am concerned about getting all the tooling changes in place in time
17:22:56 <dgilmore> but overall I am good with the idea
17:23:03 * jsmith is leaning towards approval, but would love more discussion
17:23:13 * nirik is good with the idea... I think it's much more tenable than the previous plan.
17:23:24 <bowlofeggs> i agree
17:23:27 <langdon> maxamillion: what is the concern about the mirrors? any more than any other "kind" of modularity?
17:23:44 <langdon> like just having more stuff available meanss more content to mirror?
17:23:45 <maxamillion> langdon: it's the same concern I had with modularity from the start
17:24:07 <maxamillion> langdon: yes, we're already taxing our mirrors hard and have lost mirrors over time, I don't think adding more stuff is going to really get us new mirrors
17:24:43 <langdon> right.. i get that
17:24:57 <maxamillion> langdon: it's fine, I'm sure daddy shadowman will loosen those purse strings for  the estimated $3.5 Million per year CDN bill ... >.>
17:25:23 <langdon> ha.. i actuallly thought we had a couple of donations for cdn now :)
17:25:43 <nirik> There is a cdn we are using for some web assets.
17:25:51 <nirik> but not rpms/images
17:25:54 <dgilmore> langdon: mirror support is code that has to be written
17:26:03 <maxamillion> langdon: we have limits on amount of traffic we're allowed without  paying
17:26:15 <maxamillion> anyhoo
17:26:26 <dgilmore> the request from mattdm is that the content be on the mirrors
17:26:46 <maxamillion> I'm understand this is something the Council wants and my concerns aren't inherently technical in nature as this pertains to Fedora as a system or a distro, so I'm not inclined to attempt to block
17:27:54 * langdon has been wondering if there is a way we can enable random users to be mirrors easily.. i know i have some spare bandwidth
17:27:59 <mattdm> maxamillion: I don't expect this to be a huge increase in content initially.
17:28:16 <mattdm> Although I do hope it will be *eventually*
17:28:28 <dgilmore> langdon: if you have a static ip you can
17:28:34 <dgilmore> langdon: but not easily
17:28:35 <mattdm> It will still be the kind of rpm stuff that mirrors are already on board for
17:28:40 <maxamillion> a wild FPL appears!
17:28:43 <mattdm> :)
17:28:44 <langdon> dgilmore: yeah.. but it is still kinda hard
17:28:48 <mattdm> I heard my name :)
17:28:57 <maxamillion> yeah, alright ... I'm +1
17:29:01 <dgilmore> mattdm: :D
17:29:02 <langdon> dgilmore: ha... missed your second line :)
17:29:07 <maxamillion> what says FESCo?
17:29:23 <jsmith> I'm a cautious +1, if we're voting
17:29:27 <dgilmore> mattdm: there was brief mention of where to put the content
17:29:37 <bowlofeggs> +1
17:29:48 <nirik> +1
17:29:52 <dgilmore> to the idea I am +1
17:30:04 <sgallagh> +1
17:30:11 <maxamillion> #agreed APPROVE - F28 System Wide Change: Add-On Modularity (+1:7, -1:0, +0:0)
17:30:18 <mattdm> yay! thanks everyone
17:30:22 <dgilmore> I will watch it closely to make sure we give it the best possible chance of being a success
17:30:31 <maxamillion> #topic #1826 F28 System Wide Change: Boost 1.66 upgrade
17:30:31 <maxamillion> .fesco 1826
17:30:31 <maxamillion> https://pagure.io/fesco/issue/1826
17:30:32 <mattdm> dgilmore++
17:30:32 <zodbot> maxamillion: Issue #1826: F28 System Wide Change: Fedora 28 Boost 1.66 upgrade - fesco - Pagure - https://pagure.io/fesco/issue/1826
17:30:35 <zodbot> mattdm: Karma for ausil changed to 8 (for the f27 release cycle):  https://badges.fedoraproject.org/tags/cookie/any
17:30:39 <nirik> +1 as always
17:30:44 <sgallagh> +1
17:30:49 <maxamillion> +1
17:30:50 <jforbes> +1
17:30:54 <dgilmore> +1 boost
17:31:00 <jsmith> +1 to boost
17:31:02 <mattdm> I just feel like this should be called "the boost boost"
17:31:18 * mattdm crawls back into the woods
17:31:26 <maxamillion> bowlofeggs: ?
17:31:33 <bowlofeggs> +1
17:31:59 <maxamillion> #agreed APPROVE - F28 System Wide Change: : Boost 1.66 upgrade (+1:7, -1:0, +0:0)
17:32:15 <maxamillion> #topic #1827 F28 System Wide Change: GCC8
17:32:15 <maxamillion> .fesco 1827
17:32:15 <maxamillion> https://pagure.io/fesco/issue/1827
17:32:18 <zodbot> maxamillion: Issue #1827: F28 System Wide Change: GCC8 - fesco - Pagure - https://pagure.io/fesco/issue/1827
17:32:19 <nirik> +1
17:32:28 <sgallagh> +1
17:32:28 <maxamillion> +1
17:32:29 <bowlofeggs> +1 to the g of all cc's
17:32:31 <jforbes> +1
17:33:17 <jsmith> +1 from me
17:33:23 <maxamillion> dgilmore: ?
17:33:37 <dgilmore> +1
17:33:41 <maxamillion> #agreed APPROVE - F28 System Wide Change:  GCC8 (+1:7, -1:0, +0:0)
17:33:47 <maxamillion> #topic #1828 F28 System Wide Change: The GNU C Library version 2.27
17:33:47 <maxamillion> .fesco 1828
17:33:47 <maxamillion> https://pagure.io/fesco/issue/1828
17:33:48 <zodbot> maxamillion: Issue #1828: F28 System Wide Change: The GNU C Library version 2.27 - fesco - Pagure - https://pagure.io/fesco/issue/1828
17:33:55 <jforbes> +1
17:33:57 <jsmith> +1 from me on glibc
17:34:15 <maxamillion> +1
17:34:20 <nirik> +1
17:34:29 <dgilmore> +1 glibc
17:34:39 <sgallagh> +1
17:35:40 <maxamillion> bowlofeggs: where you at bowl of slowness? ;)
17:35:53 <bowlofeggs> +1
17:35:56 <bowlofeggs> srry
17:35:57 <bowlofeggs> haha
17:35:58 <maxamillion> #agreed APPROVE - F28 System Wide Change: GNU C Lib 2.27 (+1:7, -1:0, +0:0)
17:35:59 <maxamillion> #topic #1829 F28 System Wide Change: IBus Unicode Typing
17:35:59 <maxamillion> .fesco 1829
17:35:59 <maxamillion> https://pagure.io/fesco/issue/1829
17:36:01 <zodbot> maxamillion: Issue #1829: F28 System Wide Change: IBus Unicode Typing - fesco - Pagure - https://pagure.io/fesco/issue/1829
17:36:19 <dgilmore> +1
17:36:21 <bowlofeggs> +1 and i look forward to nirik using it
17:36:22 <maxamillion> +1
17:36:35 <jforbes> +1
17:36:44 <sgallagh> +1
17:36:48 <jforbes> the voting system will be replaced with thumbs
17:36:54 <bowlofeggs> haha
17:36:55 <nirik> +1
17:36:56 <sgallagh> 👍
17:37:01 <maxamillion> #agreed APPROVE - F28 System Wide Change: IBus Unicode Typing  (+1:7, -1:0, +0:0)
17:37:13 <maxamillion> #topic #1830 F28 System Wide Change: NIS switching to new libnsl to support IPv6
17:37:13 <maxamillion> .fesco 1830
17:37:13 <maxamillion> https://pagure.io/fesco/issue/1830
17:37:15 <zodbot> maxamillion: Issue #1830: F28 System Wide Change: NIS switching to new libnsl to support IPv6 - fesco - Pagure - https://pagure.io/fesco/issue/1830
17:37:17 * nirik suspects no one noticed that was a unicode + and a unicode 1
17:37:25 <bowlofeggs> eventually we will lose text as humans and only communicate with emoji, so this chnage is important
17:37:40 <dgilmore> ipv6 support is good
17:37:46 <nirik> 🤘
17:37:48 <bowlofeggs> +1 to v6
17:37:50 <nirik> +1
17:37:52 <maxamillion> +1
17:38:01 <jforbes> +1
17:38:02 <dgilmore> +1
17:38:09 <maxamillion> 🖖
17:38:16 <sgallagh> +1
17:38:36 <maxamillion> wait, who we missing?
17:38:52 <Southern_Gentlem> jsmith
17:38:56 <jsmith> +1
17:39:03 <maxamillion> Southern_Gentlem: thanks
17:39:05 <maxamillion> #agreed APPROVE - F28 System Wide Change: NIS switching to new libnsl to support IPv6  (+1:7, -1:0, +0:0)
17:39:24 <maxamillion> #topic #1831 F28 System Wide Change: OpenLDAP defaults to use only Shared System Certificates
17:39:24 <maxamillion> .fesco 1831
17:39:24 <maxamillion> https://pagure.io/fesco/issue/1831
17:39:26 <zodbot> maxamillion: Issue #1831: F28 System Wide Change: OpenLDAP defaults to use only Shared System Certificates - fesco - Pagure - https://pagure.io/fesco/issue/1831
17:39:34 <dgilmore> +1
17:39:39 <maxamillion> +1
17:39:39 <jforbes> +1
17:39:40 <sgallagh> +1 I can’t believe it’s taken this long
17:39:45 <maxamillion> I didn't realize that wasn't the default already
17:39:52 <dgilmore> maxamillion: indeed
17:40:12 <sgallagh> OpenLDAP has always been *special* when it comes to certs.
17:40:20 <nirik> +1
17:40:50 <bowlofeggs> +1
17:41:22 <maxamillion> jsmith: you still with us?
17:41:30 <jsmith> +1
17:41:33 <jsmith> maxamillion: Barely :-/
17:41:35 <maxamillion> #agreed APPROVE - F28 System Wide Change: OpenLDAP defaults to use only Shared System Certificates (+1:7, -1:0, +0:0)
17:41:52 <maxamillion> #topic #1832 F28 System Wide Change: OpenLDAP without Non-threaded Libraries
17:41:52 <maxamillion> .fesco 1832
17:41:52 <maxamillion> https://pagure.io/fesco/issue/1832
17:41:53 <zodbot> maxamillion: Issue #1832: F28 System Wide Change: OpenLDAP without Non-threaded Libraries - fesco - Pagure - https://pagure.io/fesco/issue/1832
17:42:23 <sgallagh> This one seems slightly riskier, but I’m still +1
17:42:34 <dgilmore> +1
17:42:43 <nirik> +1
17:42:44 <jforbes> +1
17:43:02 <maxamillion> yeah, there's definitely some risk but as long as there's enough testing it should be fine
17:43:03 <maxamillion> +1
17:43:06 <bowlofeggs> +1
17:43:43 <bowlofeggs> apparenrly debian did this too
17:45:07 <nirik> +1
17:45:46 <maxamillion> going to assume we've lost jsmith
17:45:51 <maxamillion> #agreed APPROVE - F28 System Wide Change: OpenLDAP without Non-threaded Libraries (+1:6, -1:0, +0:0)
17:45:52 <jsmith> +1
17:45:57 <jsmith> (sorry)
17:46:03 <maxamillion> #undo
17:46:03 <zodbot> Removing item from minutes: AGREED by maxamillion at 17:45:51 : APPROVE - F28 System Wide Change: OpenLDAP without Non-threaded Libraries (+1:6, -1:0, +0:0)
17:46:08 <maxamillion> #agreed APPROVE - F28 System Wide Change: OpenLDAP without Non-threaded Libraries (+1:7, -1:0, +0:0)
17:46:20 <maxamillion> #topic #1833 F28 System Wide Change: Replace glibc's libcrypt with libxcrypt
17:46:21 <maxamillion> .fesco 1833
17:46:21 <maxamillion> https://pagure.io/fesco/issue/1833
17:46:22 <zodbot> maxamillion: Issue #1833: F28 System Wide Change: Replace glibc's libcrypt with libxcrypt - fesco - Pagure - https://pagure.io/fesco/issue/1833
17:46:34 <maxamillion> puiterwijk: ping - if you're around, I'd be interested in your thoughts on this ^
17:47:01 <puiterwijk> maxamillion: reading
17:47:11 <sgallagh> I can’t wait to see how this interacts on upgrades from the libcrypt[-nss] packages.
17:48:33 <puiterwijk> maxamillion: so, yeah, it looks reasonably sane for me, just the packaging is going to be hairy/tricky maybe.
17:48:59 <bowlofeggs> i wonder if anything in fedora uses those legacy APIs
17:49:06 <puiterwijk> "libxcrypt is fully binary compatible with software linked against glibc's libcrypt and does not require any rebuilds" - looks like they're binary compatible, so should not even need a mass rebuild from what I see?
17:49:06 <sgallagh> I’m +1. I think it needs doing.
17:49:07 <nirik> +1 from me
17:49:15 <puiterwijk> Yeah, on a personal note I'd be +1
17:49:23 <bowlofeggs> puiterwijk: except for the legacy APIs
17:49:25 <puiterwijk> bowlofeggs: if anything is using those, this'd be a good time to port them
17:49:26 <bowlofeggs> +1
17:49:29 <bowlofeggs> true
17:49:44 <dgilmore> +1 here.
17:49:56 <puiterwijk> bowlofeggs: also, as far as my parsing goes: it does actually have the symbols, so it'll run, it's just not in the headers,  so new things won't compile
17:50:01 <jsmith> I guess I'm +1 to this, though I do worry about the details
17:50:01 <puiterwijk> (RE: legacy APIs)
17:50:18 <jforbes> +1
17:51:38 <maxamillion> +1
17:52:04 <maxamillion> #agreed APPROVE - F28 System Wide Change:  Replace glibc's libcrypt with libxcrypt  (+1:7, -1:0, +0:0)
17:52:20 <maxamillion> #topic #1834 F28 System Wide Change: Rename "nobody" user
17:52:20 <maxamillion> .fesco 1834
17:52:20 <maxamillion> https://pagure.io/fesco/issue/1834
17:52:22 <zodbot> maxamillion: Issue #1834: F28 System Wide Change: Rename "nobody" user - fesco - Pagure - https://pagure.io/fesco/issue/1834
17:52:47 <sgallagh> This one will be quick, I'm sure...
17:52:51 <bowlofeggs> haha
17:52:54 <maxamillion> lol
17:53:00 <bowlofeggs> there were like millions of posts about this one
17:53:14 <sgallagh> I'm not going to lie, I stopped being able to keep up with the barrage
17:53:17 <nirik> who knew nobody could be somebody
17:53:31 <sgallagh> nirik: Nobody did
17:53:37 <jsmith> So many arguments about little old me :-p
17:53:53 <jsmith> (or maybe that's just my imposter syndrome)
17:53:58 <bowlofeggs> well nobody said this would be easy
17:54:16 <sgallagh> OK, I think we all got that out of our systems...
17:54:21 <bowlofeggs> haha
17:54:40 * langdon assumes you don't need him any more and is going to lunch... (will log in from mobile if mentioned)
17:54:48 <sgallagh> I assume that asking for a larger UID space is not an achievable answer for this?
17:54:55 * nirik doesn't like that new systems will be different from all the existing ones.
17:55:39 <jforbes> sgallagh: no
17:55:39 <mattdm> sgallagh: 128-bit uids!
17:55:42 <dgilmore> this is tricky
17:56:04 <sgallagh> nirik: That *is* the price of progress.
17:56:13 <maxamillion> nirik: yeah, I agree ... I'm not super excited about the change, but I agree with it in terms of "this is a problem that needs addressing" .... especially in the magical containerized future
17:56:47 <nirik> yeah.
17:57:44 <maxamillion> the main concern I have is compatibility for upgrades and continuity of function of things that depend on the current behavior
17:58:00 <dgilmore> maxamillion: indeed
17:58:01 <bowlofeggs> they do propose that this would only happen on new installs
17:58:19 <bowlofeggs> 'Changing existing systems is hard, so this change would apply only to new systems. "New" means systems which have neither the old "nobody" user with uid 99 nor the nfsnobody user defined.'
17:59:00 <nirik> I guess I am +1...
17:59:24 <dgilmore> i am +0.5
17:59:30 <maxamillion> bowlofeggs: right, but it mentions about a conditional for upgrades to "keep the old behavior" ... I want to make sure that works *and* make sure there aren't any programs out there that are for some reason depending on nfsnobody or uid/gid 99
18:00:10 <sgallagh> maxamillion: Well, the latter part of that sentence is impossible to accomplish
18:00:16 <jsmith> +1
18:00:18 <sgallagh> We can't audit every program that exists.
18:00:19 <dgilmore> maxamillion: biggest issue is probably the latter
18:00:25 <maxamillion> sgallagh: yeah, I know ... :/
18:00:37 <maxamillion> sgallagh: which gives me reason for pause
18:00:59 <sgallagh> I think the only solution is to just go ahead and do it, but announce it VERY loudly
18:01:06 * dgilmore notes we are at 2 hours
18:01:08 <jforbes> code scanning.
18:01:11 <maxamillion> sgallagh: +1
18:01:20 <maxamillion> ultimately, I'm unenthusiastically +1 to this change
18:01:23 <sgallagh> (My hesitation mainly comes from the possibility of a real human getting assigned the nfsnobody UID)
18:01:27 <bowlofeggs> yeah i don't like the current way things are and this seems like a difficult change, but an overall good one
18:01:32 <bowlofeggs> +1 from em
18:01:44 <maxamillion> so we have a +4.5 so far (do we count +0.5 ?)
18:01:56 <sgallagh> maxamillion: We round up :)
18:01:57 <jforbes> sgallagh: Yeah, it is going to hurt, but I think it is unavoidable
18:02:03 <jforbes> +1
18:02:10 <sgallagh> +1
18:02:26 <maxamillion> #agreed APPROVE - F28 System Wide Change:  Rename "nobody" user (+1:6,  +0.5:1, -1:0, +0:0)
18:03:04 <maxamillion> WE MADE IT
18:03:05 <maxamillion> #topic Next week's chair
18:03:23 <sgallagh> Are we meeting next week?
18:03:34 <sgallagh> I suspect a large subset of FESCo members will be at DevConf.cz then
18:03:46 <maxamillion> oh right
18:03:57 <maxamillion> so ... Chair for the following week?
18:04:09 <jforbes> I can take it
18:04:13 <sgallagh> Or I can
18:04:40 <maxamillion> #info jforbes to Chair meeting on February 2 as many FESCo members will be away next Friday
18:04:55 <maxamillion> #action jforbes to Chair meeting on February 2 as many FESCo members will be away next Friday
18:04:59 <maxamillion> #topic Open Floor
18:05:00 <bowlofeggs> i will not be here the next 2 weeks
18:05:08 <maxamillion> bowlofeggs: FINE THEN
18:05:09 <maxamillion> >.>
18:05:10 <bowlofeggs> haha
18:05:11 <maxamillion> bowlofeggs: <3
18:05:17 <bowlofeggs> awww
18:05:23 <jsmith> We're still in the middle of elections, for those who haven't voted yet.
18:05:38 <maxamillion> #info We're still in the middle of elections if anyone hasn't voted yet
18:05:49 <jforbes> Just something quick, if people could read through the tickets/devel threads the morning of the meetings (before the meeting) it might make these go faster
18:06:04 <jsmith> jforbes: I did :-)
18:06:20 <maxamillion> jforbes: +1
18:06:32 * nirik nods. Good to keep up on that
18:07:24 <maxamillion> Alright, thanks everyone for powering through
18:07:27 <maxamillion> have a good weekend
18:07:36 <maxamillion> #endmeeting