kde-sig
LOGS
15:12:53 <rdieter> #startmeeting kde-sig
15:12:53 <zodbot> Meeting started Tue Jan  9 15:12:53 2018 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:12:53 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:12:53 <zodbot> The meeting name has been set to 'kde-sig'
15:12:56 <rdieter> hi all
15:12:58 <lupinix> hi
15:12:59 <rdieter> #topic roll call
15:13:02 <rdieter> who's present today?
15:13:09 <jgrulich> hello
15:13:24 <mbriza> hello
15:13:36 <rdieter> #info rdieter lupinix jgrulich mbriza present
15:13:42 <rdieter> #chair lupinix jgrulich mbriza
15:13:42 <zodbot> Current chairs: jgrulich lupinix mbriza rdieter
15:16:35 <Southern_Gentlem> .hello jbwillia
15:16:36 <zodbot> Southern_Gentlem: jbwillia 'Ben Williams' <vaioof@gmail.com>
15:16:49 <rdieter> info Southern_Gentlem present
15:16:54 <rdieter> #info Southern_Gentlem present
15:17:00 <rdieter> #topic agenda
15:17:08 <rdieter> ok, any agenda topics to discuss?
15:17:14 <rdieter> I have: "plasma-5.11 for f26"
15:17:18 <jgrulich> wayland by default for F28
15:20:05 <rdieter> ok, let's go with that
15:20:09 <rdieter> #topic plasma-5.11 for f26
15:20:29 <rdieter> subject says it all, what say ye?  Any comments, concerns, objections?
15:20:46 <lupinix> i'm +1 with that
15:21:09 <jgrulich> +1 definitely, I don't have any problem with that
15:21:19 <mbriza> +1
15:21:34 <rdieter> historically, we've done at least one plasma-5.x+1 update per release, this would be f26's turn
15:22:37 <rdieter> One minor thing I may investigate is that dnf doesn't handle package renames 100% well yet, wrt plasma-workspace-drkonqi -> plasma-drkonqi rename
15:23:00 <lupinix> what is the exact issue here?
15:23:09 <rdieter> I *may* end up changing the name back to plasma-workspace-drkonqi
15:23:24 <rdieter> lupinix: for f26/f27, try doing:  dnf install @kde-desktop
15:23:34 <rdieter> (assuming it's not already installed of course).
15:23:41 * lupinix will check later
15:24:10 <rdieter> It'll try to install plasma-workspace-drkonqi (and fail/complain about missing/broken deps), instead of using plasma-drkonqi (that Obsoletes/Provides it)
15:24:34 <lupinix> :(
15:24:53 <rdieter> I hit that with a box here that I initially installed workstation, then wanted to add kde-desktop
15:25:06 <lupinix> then changing the name back would be the best workaround, yes
15:25:10 * Southern_Gentlem testing
15:25:13 <jgrulich> is this a known issue? Is it reported?
15:25:28 <rdieter> I haven't reported it yet, at least.  I don't know about "known" status
15:25:47 <rdieter> I did support a fedora-comps pull request to modify f28 (and f27) though
15:25:53 <rdieter> s/support/submit/
15:27:15 <rdieter> otherwise, sounds like we're agreed on moving forward with the f26 plan
15:27:39 <Southern_Gentlem> rdieter, appears to be working under xfce so maybe you were hitting a bad mirror
15:27:40 <rdieter> #agreed plasma-5.11.x for f26 is a go
15:28:15 <rdieter> Southern_Gentlem: so installing kde-desktop group, ended up pulling in plasma-drkonqi ?
15:28:20 <rdieter> (on f27?)
15:28:33 <pino|work> (am i late?)
15:28:33 <Southern_Gentlem> will check as soon as the install finishes
15:28:40 * rdieter double checks if comps pull request has been pulled in yet (I didn't think so)
15:28:49 <rdieter> pino|work: right on time :)
15:28:52 <rdieter> #info pino|work present
15:29:01 <tosky> I'm around too
15:29:07 <rdieter> pino|work: currently discussing plan to bring plasma-5.11.x to f26
15:29:11 <rdieter> #info tosky present
15:30:02 <rdieter> pino|work, tosky: any related comments, concerns or objections?
15:30:19 <pino|work> options a) bring to f26 what's in f27+, and then update everything b) update f27+ first to 5.11.x, then update f26
15:30:22 <pino|work> ?
15:31:25 <jgrulich> pino|work: F27 is already on 5.11.x
15:31:26 <rdieter> f27 already has it
15:31:45 <pino|work> yes, i know, i mean to whatever is the latest 5.11.x
15:31:56 <rdieter> pino|work: your plan a matches
15:32:24 <rdieter> already have plasma-5.11.5 f27 builds ready to submit to bodhi.
15:32:34 <rdieter> wanted ok to move forward with doing same for f26
15:33:03 <rdieter> (before you got here): historically, we've done at least one plasma-5.x+1 update per release, this would be f26's turn
15:33:13 <rdieter> f26 is currently at plasma-5.10.5
15:35:05 <Southern_Gentlem> rdieter, anyway that will happen with the 4.14.12 kernel? (or whatever kernel that fixes the intel mess)
15:35:43 <rdieter> Southern_Gentlem: not sure what your question is, can you rephrase ?
15:37:00 <rdieter> (or clarify for me how that is relevant to us?)
15:37:32 <Southern_Gentlem> rdieter,  since i am the person the produce the respins i watch the kernels more than what the DE are doing so if your new 5.11.5 is pushed the sametime as the kernel i will make a new respin at that time
15:38:11 <rdieter> ah!  thanks
15:38:54 <rdieter> moving on...
15:38:55 <Southern_Gentlem> rpm -qa |grep |plasma |grep drkonqi returns plasma-workspace-drkonqi
15:39:06 <rdieter> Southern_Gentlem: on f27?
15:39:09 <Southern_Gentlem> yep
15:39:31 <rdieter> I didn't think that was installable on top of plasma-5.11
15:39:35 <Southern_Gentlem> xfce 27 doing dnf install @kde-desktop
15:39:58 <rdieter> Southern_Gentlem: thanks!
15:40:20 <rdieter> #topic wayland by default for F28
15:40:29 <rdieter> jgrulich: go ahead
15:40:59 <jgrulich> yesterday I started a discussion on our mailing list about having wayland as default for F28
15:41:28 <jgrulich> I think majority of people responded there agreed with this if there is a safe option go back to X11
15:42:09 <jgrulich> I know it's an ambitious plan and there is lots of work ahead, but I believe that this step will help a lot to make wayland more usable
15:42:31 <mbriza> i'm planning to switch to wayland for qt apps under gnome, too - there will be even more testers from the other side, too
15:42:42 <tosky> totally fine with that; what would it be the lastest time to revert the default, if things are not working as expected for 28?
15:42:48 <rdieter> in the least (I think), even if the default session is not changed, including wayland session support by default is a good baby step forwards
15:42:58 <tosky> which is more or less the same as asking: how much time there is for testing?
15:43:23 <jgrulich> I'm now running Plasma 5.11.90 (almost beta) with Qt 5.10 and it works, not perfectly and there are minor annoying issues, but I think all of them can be fixed until F28 gets released
15:43:30 * rdieter checks https://fedoraproject.org/wiki/Releases/28/Schedule
15:44:19 <rdieter> I'd say approximately f28 beta, 2018-03-06 is where we'll need to decide go/no-go on this feature
15:44:42 <rdieter> sorry, that's f28-beta freeze
15:44:47 <jgrulich> Plasma 5.12 is going to be an LTS release, now even with LTS support for wayland
15:45:34 * lupinix uses 5.11 with wayland (on intel graphics)
15:45:45 <mbriza> lupinix: do you use multiple screens?
15:45:52 <lupinix> works fine so far (using for some weeks now)
15:45:57 <lupinix> no, on notebook
15:46:32 <jgrulich> there are some issues with multiscreen, I believe that once those are properly identified then they can be fixed in time
15:47:09 <jgrulich> and to have them properly identified we need people to test it → wayland by default
15:47:15 * rdieter looks forward to testing
15:47:47 <rdieter> jgrulich: curious, are you aware of any other distros condidering similar?
15:47:52 <rdieter> considering even
15:48:21 <jgrulich> rdieter: nope, I just know that Neon uses it by default, but I think on the unstable version
15:48:50 <rdieter> ok. (was hoping for some help/collaboration)
15:48:53 * lupinix thinks we should enable as default, if things are really problematic we switch back to X for f28 final
15:49:21 <mbriza> i'd say we should be conservative and if there is a bunch of issues left before final, revert
15:49:23 <lupinix> and still have wayland preinstalled for people who want to test
15:49:35 <tosky> that's why I asked when is the last day for a revert :)
15:49:37 <jgrulich> I believe that upstream really wants wayland to move forward and they will happily help to identify and fix issues
15:49:44 <rdieter> sounds like we're in general agreement on moving forward with general plan
15:50:00 <lupinix> +1 from me, yes
15:50:03 <tosky> and for sure provide the Plasma/Wayland session for session managers in any case, as rdieter proposed
15:50:14 <rdieter> jgrulich: once you have a change proposal in place, we can formally vote and send it on
15:50:43 <jgrulich> rdieter: ok, I'll start working on it and we can vote on the next meeting
15:51:08 <rdieter> I'll prep another fedora-comps pull request to get -wayland included on spin
15:51:18 <rdieter> (which we'll want regardless)
15:51:29 <mbriza> yes
15:51:38 <mbriza> ideally, this change will be just changing the default in sddm
15:51:50 <lupinix> yes
15:51:55 <jgrulich> rdieter: I'll also update Plasma to 5.12 as soon as possible so people get the most "stable" experience
15:52:11 <jgrulich> beta should be released next week
15:52:54 <rdieter> I'll help coordinate plasma-5.12 copr availability too (as time allows)
15:53:22 <rdieter> for f27, though that won't be a 100% good test due to Qt 5.10 vs Qt 5.9, but it should be close
15:54:32 <rdieter> anything else on f28/wayland ?
15:55:13 <rdieter> another todo: create bugzilla tracking bug for plasma-wayland related issues
15:55:24 <jgrulich> good idea
15:55:25 <lupinix> are there known issues with graphics drivers and wayland? nouveau for example?
15:55:48 <rdieter> I already have one in mind (pinentry fails when $DISPLAY not defined)
15:56:14 <rdieter> (but that's not specific to plasma, probably not worth considering a blocker either)
15:56:21 <jgrulich> NVidia → https://blog.martin-graesslin.com/blog/2017/10/plasmawayland-and-nvidia-2017-edition/
15:57:29 <lupinix> should not be a blocker as it is not shipped by us @default and X is always available as fallback
15:58:34 <martinbriza[m]> I think we should have checks in place like gdm does and don't allow wayland at all with problematic drivers
15:59:04 <rdieter> that would be nice, but no idea what that involves or how much work it would be
15:59:19 <jgrulich> martinbriza[m]: volunteering for it? :)
15:59:57 <martinbriza[m]> I'll see what does it take for the next meeting
16:00:02 <jgrulich> well, the logic can be stolen from GDM I guess, just needs to be put into a proper place in SDDM
16:01:01 <martinbriza[m]> Yes, I think so... I guess it's just a bunch of opengl calls
16:02:39 <jgrulich> ok, so let's move on
16:03:01 <jgrulich> I'll write a proposal and we will vote on it next meeting
16:03:25 <rdieter> #topic open discussion
16:03:28 <rdieter> ok, anything else for today?
16:04:45 <rdieter> let's go with no, we're kinda over our hour anyway.  Thanks all!
16:04:50 <rdieter> #endmeeting