fesco
LOGS
16:00:09 <jsmith> #startmeeting FESCO (2018-01-05)
16:00:09 <zodbot> Meeting started Fri Jan  5 16:00:09 2018 UTC.  The chair is jsmith. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:09 <zodbot> The meeting name has been set to 'fesco_(2018-01-05)'
16:00:09 <jsmith> #meetingname fesco
16:00:09 <jsmith> #chair maxamillion dgilmore nirik jforbes jsmith kalev sgallagh bowlofeggs tyll
16:00:09 <jsmith> #topic init process
16:00:09 <zodbot> The meeting name has been set to 'fesco'
16:00:09 <zodbot> Current chairs: bowlofeggs dgilmore jforbes jsmith kalev maxamillion nirik sgallagh tyll
16:00:17 <jforbes> .hello jforbes
16:00:18 <zodbot> jforbes: jforbes 'Justin M. Forbes' <jforbes@redhat.com>
16:00:23 <jsmith> .hello jsmith
16:00:24 <zodbot> jsmith: jsmith 'Jared Smith' <jsmith.fedora@gmail.com>
16:00:34 <nirik> morning
16:00:45 <jsmith> Morning, and Happy New Year to all...
16:00:49 <orc_fedo> .hello orc_fedo
16:00:50 <zodbot> orc_fedo: Sorry, but you don't exist
16:01:03 <orc_fedo> heh
16:01:33 <jsmith> Apologies for the late agenda -- I totally spaced the fact that I was running the meeting this week.
16:01:52 <jsmith> Luckily, it's pretty small, if we can get a quorum together today
16:03:19 <maxamillion> .hello2
16:03:20 <zodbot> maxamillion: maxamillion 'Adam Miller' <maxamillion@gmail.com>
16:03:55 <jsmith> OK, by my count, that makes four FESCo members present...
16:04:22 <jsmith> Let's wait another few minutes and see if we can get a fifth member, otherwise we'll kick the proverbial can down the road a week
16:06:14 <maxamillion> +1
16:09:27 <tyll_> .hello till
16:09:28 <zodbot> tyll_: till 'Till Maas' <opensource@till.name>
16:09:38 <tyll_> Sorry, got stuck in  traffic
16:10:04 <tyll_> Happy New Year
16:10:44 <jsmith> OK, let's begin
16:10:59 <jsmith> #topic #1799 The ProvenPackager rubric needs more formality
16:10:59 <jsmith> .fesco 1799
16:10:59 <jsmith> https://pagure.io/fesco/issue/1799
16:11:00 <zodbot> jsmith: Issue #1799: The ProvenPackager rubric needs more formality - fesco - Pagure - https://pagure.io/fesco/issue/1799
16:11:25 <jsmith> It seems to me that the mailing list discussions have run their course...
16:12:41 <jsmith> My general thoughts on the matter are 1) "packager" or "primary contact" doesn't necessarily mean "owner" -- it's more closely related to being the "steward" of a particular package
16:13:13 <jsmith> and 2) Yes, provenpackagers (myself included) should be more communicative when they use their provenpackager powers
16:13:31 <jsmith> Other thoughts?
16:13:38 <jsmith> Proposals?
16:13:56 <orc_fedo> jsmith: I may be mistaken, but I thot that there was a per package bugzilla inendity which explodes new bugs on a oackage to _all_ stakeholders_
16:13:58 <nirik> I think it's hard to legislate "sufficent communication" in all cases...
16:14:52 <orc_fedo> ... thus my structuring the proposal to flow notifications through Bugzilla ...
16:14:57 <nirik> package-owner goes to everyone 'watching' a package (point of contact, commiters, others if they watch it)
16:14:58 <tyll_> I prefer for my packages if PP just help instead of having to ask for permission every time to be honest
16:15:20 <orc_fedo> nirik: ty
16:15:49 <nirik> so yes, bugs would work... but... that prevents mass changes or minor changes.
16:16:14 <jsmith> tyll_: I'm much that same way -- I *trust* the provenpackagers to do the right thing, and I've yet to have a bad experience with someone else fixing something in one of my packages.
16:16:18 <nirik> I mean filing a bug for 'I rebuilt your package because libfoo was updated" seems like overkill and overhead
16:16:30 <orc_fedo> I understand the labor of manually filing individual bugs without automation, and playing 'mother may I'
16:16:31 <jforbes> Yes it does
16:16:40 <jsmith> nirik: Agreed :-)
16:17:26 <orc_fedo> nirik: but a SOname bump is itself invasive -- a non SO name bump library rebuild seems a non event (except when upstream or the library rebuilder does not catch the issue (as the ML thread had a case of)
16:17:41 <jsmith> Part of it depends on the scope of change -- if a provenpacker were to make major changes to one of the packages that I'm the steward over -- I'd prefer to at least have a heads up.
16:17:50 <tyll_> Also for me it is acceptable to possibly revert/fix something a PP did wrong, since mistakes happen and it is a price I am willing to pay to have less work with accepting minor changes
16:18:17 <orc_fedo> tyll_: I certainly agree in RawHide .. it is outside of that that is drawing complaints
16:18:52 <jsmith> I'm hesitant to get too formal -- I'm afraid it might scare off provenpackagers from doing any work, and it's obvious we need their help
16:19:36 * nirik nods.
16:20:56 <jforbes> Provenpackager status is given for a reason (never default). I would think the default is trust there, and if a packager owner complains, the provenpackager should respect their wishes
16:21:27 <tyll_> Actually I am not really sure what the proposal is, that we discuss except that the question is whether to change something to the PP policy
16:21:34 <orc_fedo> jforbes: but that does not scale to alert the next PP that there is such a desire a
16:21:40 <jforbes> If a provenpackager oversteps their bounds consistently, then perhaps their status should be brought into question
16:21:58 <tyll_> https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/NDU33GE2DX52DMWRNNG6YFTAHHZ25ZJS/ states a problem with "random changes to random packages" which is IMHO not specific enough
16:21:58 <jsmith> So, thoughts on a proposal?  Maybe FESCo works on a set of general guidelines, such as the ones that have been talked about here?
16:21:59 <orc_fedo> tyll_: I restated a flow in the middle of the ticket
16:22:09 <nirik> we could propose people put their wishes in a spec comment, but I fear that will leed to comments that are just against the policy
16:22:24 <jforbes> orc_fedo: it does not, but we don't exactly have a sea of new provenpackagers flooding in
16:22:49 <tyll_> orc_fedo: could you link to the comment?
16:23:05 <orc_fedo> jforbes: I tried to pull it out of pagure, but the query and addition process dies not get anywhere near the asserted number of PPs
16:23:55 <orc_fedo> tyll_  no datemark in the Pagure bug, and I cannot see how to get a 'Comment N' type link
16:24:12 <nirik> FYI, for history/background: when provenpackagers were created, they were copied off from the existing group of packagers at the time... ie, grandfathered in as packagers used to work like provenpackagers do today.
16:24:47 <tyll_> orc_fedo: for me each comment  has a age value such as "xx days ago" which contains a link to the comment
16:24:58 <orc_fedo> tyll_: seemingly: https://pagure.io/fesco/issue/1799#comment-483751
16:25:18 <orc_fedo> tyll_: * nod * my exploration just found that
16:26:26 * nirik finds that way too wordy and complex. No offense.
16:26:47 <orc_fedo> nirik: I wholly agree and the markup loss inside a block-quote makes it all run together
16:27:02 <nirik> yeah, that likely doesn't help at all.
16:27:05 <orc_fedo> nirik: no offense take of course
16:28:16 <jsmith> Again, I'm going to push back (in a friendly manner) and say that I think the level of formality expressed there isn't in line with the scope of concerns that have been addressed.  In short, it seems overly formal to me.
16:29:05 <jsmith> maxamillion: You've been quiet -- thoughts?
16:29:14 <orc_fedo> jsmith: no worries to say no to it, as I'll continue to address the raised objectsions: too much busywork to file lots of little notifications bugs, and see if automation / scripting can help here
16:29:27 <nirik> I am not sure what to suggest here... I guess just saying that we assert provenpackagers should use their own judgenment and if that causes concerns from packagers they could bring up those additional concerns. I am not sure any of the cases I have seen are things I would object to pp's doing
16:30:46 <jsmith> Proposal: FESCo makes no changes to the provenpackager process, but reiterates that provenpackager should exercise judgment and communication skills when making changes to packages, especially in release branches.
16:31:00 <jsmith> (and feel free to re-write that proposal if you think it's weak)
16:31:55 <nirik> +1
16:32:13 <jsmith> For the record, I'm +1 to my own proposal.
16:32:16 <jforbes> +1 here
16:32:24 * jsmith wonders if we've lost quorum
16:32:57 <tyll_> +1
16:33:02 <rdieter> my $0.02, I (still) think it's better for provenpackagers to ask for forgiveness than permission (essentially matching the spirit of the proposal as-is)
16:33:25 <jsmith> maxamillion?
16:33:28 <maxamillion> +1
16:33:30 <maxamillion> sorry
16:33:41 <jsmith> OK, looks like we're agreed.
16:33:52 <tyll_> I was also thinking about adding something about how to handle possible mistakes, e.g. to state that mistakes will happen and that we will accept them or something like this
16:33:53 <maxamillion> multitasking badly, but I was reading along, my thoughts pretty much were echo'd through out the conversation by others
16:34:02 <jsmith> #agreed FESCo makes no changes to the provenpackager process, but reiterates that provenpackager should exercise judgment and communication skills when making changes to packages, especially in release branches.
16:34:07 <jsmith> Oops
16:34:09 <jsmith> #undo
16:34:09 <zodbot> Removing item from minutes: AGREED by jsmith at 16:34:02 : FESCo makes no changes to the provenpackager process, but reiterates that provenpackager should exercise judgment and communication skills when making changes to packages, especially in release branches.
16:34:19 <jsmith> #agreed FESCo makes no changes to the provenpackager process, but reiterates that provenpackager should exercise judgment and communication skills when making changes to packages, especially in release branches. (+1:5, +0:0, -1:0)
16:34:39 <jsmith> #topic #1800 Election Planning discussion
16:34:40 <jsmith> .fesco 1800
16:34:40 <jsmith> https://pagure.io/fesco/issue/1800
16:34:41 <zodbot> jsmith: Issue #1800: Election Planning discussion - fesco - Pagure - https://pagure.io/fesco/issue/1800
16:35:13 <jsmith> Ok, we're supposed to be thinking about how to make the elections run more smoothly...
16:36:15 <jsmith> Not sure if we have anything actionable yet, or any proposals, other than a vague "don't run elections during infra outages" comment
16:36:16 <tyll_> maxamillion: do you want to run again, you are currently missing on the nominations list afaics: https://fedoraproject.org/wiki/Development/SteeringCommittee/Nominations
16:36:24 <nirik> it might be nice to have a schedule page for them thats at least a year in advance.
16:36:54 <maxamillion> tyll_: I shouldn't be, I added myself like a month ago
16:37:01 <maxamillion> shouldn't be missing*
16:37:20 <orc_fedo> maxamillion: the cancellation of the prior balloting removed all nominees as to council -- not sure here
16:37:29 <jsmith> maxamillion: The election got reset, and so did the list of nominees
16:37:51 <tyll_> jforbes: you are also missing atm: https://fedoraproject.org/wiki/Development/SteeringCommittee/Nominations
16:38:06 <maxamillion> jsmith: when?
16:38:13 <tyll_> and kalev is, too
16:38:14 <jforbes> tyll_: Yeah, just added, I have been a bit busy since the holidays with the sky falling and all
16:38:33 <maxamillion> jforbes: heh
16:39:13 <tyll_> maxamillion: jforbes: you also need to answer our three questions in a private pagure instance now
16:40:07 <jsmith> maxamillion: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/CIJ7NSKZQOKEPS5MUQHG4V43EV7VKPKS/#DCUIZSTCEUZOYLXGBIHSMKX56EQXNWGL
16:40:10 <jforbes> yup, will do that
16:40:32 <maxamillion> tyll_: +1
16:40:54 * nirik has that on his list, but hasn't gotten to it yet.
16:40:59 <tyll_> Notififying missing nominees was my idea to improve this voting cycle :o)
16:42:32 <dgilmore> sorry I am late
16:42:49 * dgilmore has a conflicting meeting every week at the start time since DST ended
16:42:52 <jsmith> tyll_: +1
16:43:53 <jsmith> Any other suggestions?
16:44:34 <dgilmore> I wonder if we should make changes to have them less frequent
16:44:42 <dgilmore> extend FESCo terms or something
16:44:50 <dgilmore> and do elections yearly
16:45:16 <jsmith> dgilmore: I personally like the idea of being able to decide if I want to run again, and not be locked into a two-year term.
16:45:28 <jsmith> dgilmore: Or are you saying that all seats would come up for re-election at the same time?
16:45:44 <dgilmore> jsmith: not saying anything specific
16:45:59 <dgilmore> we went to the split terms to ensure consistency between FESCo's
16:46:03 <jforbes> I certainly like the current staggered terms
16:46:23 <dgilmore> so that we never were in a situation where everyone in FESCo changed and things ended up chaotic as a result
16:46:39 <dgilmore> I like the split terms
16:46:46 <jsmith> dgilmore: Right, but if we keep staggered terms and only have elections once a year, that means 2-year terms.
16:46:53 <dgilmore> so maybe 2 year terms
16:46:56 <jsmith> dgilmore: A lot can happen in two years...
16:46:58 <dgilmore> though that is a long time
16:47:03 * jsmith prefers the current setup
16:47:09 * tyll_ too
16:47:17 <dgilmore> we ask people to vote a lot
16:47:42 <dgilmore> I think visability of elections is prtty good
16:47:45 <dgilmore> pretty good
16:48:32 <jsmith> Any other suggestions or proposals?
16:49:07 <dgilmore> badges for voting?
16:49:14 <dgilmore> or do we already do that?
16:49:32 <maxamillion> +1 to badges
16:49:40 <maxamillion> I can't remember if we do that or not
16:49:55 <jforbes> we don't except for wallpapers, and that can be a good incentive for people
16:50:21 <nirik> it's been suggested, but there was a privacy issue... you could tell someone voted...
16:50:33 <dgilmore> sure
16:50:46 <dgilmore> could be an opt in
16:50:52 <jforbes> nirik: optional then, click link to claim after vote submit
16:50:53 <tyll_> maybe we could make serving less time consuming by limiting meeting times and requiring more formal proposals to decide upon
16:50:54 <nirik> well, I should say a concern was raised... but yeah.
16:50:55 <dgilmore> I want to let people know I voted
16:51:21 <tyll_> then maybe more people would consider running for FESCo
16:51:38 <tyll_> IMHO it is rather a problem of getting enough nominees that getting enough voters
16:51:56 <nirik> voter turnout isn't really that great either...
16:52:31 <tyll_> it might be related, since there is also not much choice
16:53:27 <tyll_> therefore people might think that voting does not matter anyhow
16:53:38 <nirik> sure, could be a number of reasons.
16:55:41 <maxamillion> jforbes: +1
16:57:32 <nirik> I think redoing election stuff is more a discussion for council list or the like... not sure we are going to come up with much here on the fly
16:57:54 <dgilmore> nirik: sure
16:58:37 <jsmith> nirik: I tend to agree.
16:58:59 <dgilmore> should we move on?
16:59:49 <jsmith> Proposal: FESCO agrees that best practices for elections might include 1) not scheduling them during known infra changes 2) reminding current members to add themselves to the nominee list if they're interested, and 3) bringing back opt-in badges for people who vote.
17:00:00 <jsmith> Thoughts on that proposal?
17:00:54 <dgilmore> ack
17:00:55 <nirik> can I add my suggestion:
17:01:01 <dgilmore> nirik: sure :)
17:01:09 <jsmith> nirik: Please!
17:01:30 <nirik> 4) Have a known schedule page (like the fedora schedules) that lists that cycles schedule for elections at least one in advance
17:01:53 <jforbes> one year?
17:02:12 <nirik> ie, https://fedoraproject.org/wiki/Elections/28/Schedule
17:02:17 <dgilmore> nirik: sure
17:02:28 <nirik> and https://fedoraproject.org/wiki/Elections/29/Schedule
17:02:35 <nirik> etc
17:03:00 <jsmith> Update proposal: FESCO agrees that best practices for elections might include 1) not scheduling them during known infra changes 2) reminding current members to add themselves to the nominee list if they're interested, and 3) bringing back opt-in badges for people who vote, and 4) have a known schedule page with at least one year of upcoming elections
17:03:07 <nirik> +1
17:03:10 <jsmith> +1
17:03:15 <tyll_> +1
17:03:25 <maxamillion> +1
17:03:42 <jsmith> jforbes, dgilmore?
17:03:56 <jforbes> +1
17:04:31 <jsmith> #agreed:  FESCO agrees that best practices for elections might include 1) not scheduling them during known infra changes 2) reminding current members to add themselves to the nominee list if they're interested, and 3) bringing back opt-in badges for people who vote, and 4) have a known schedule page with at least one year of upcoming elections (+1:5, +0:0, -1:0)
17:04:37 <jsmith> #topic Open Floor
17:05:01 <jsmith> If you have anything else you'd like to discuss with FESCo, now's your chance!
17:06:25 <nirik> who's chairing next week?
17:06:39 <jforbes> I can chair next week
17:07:08 <jsmith> #agreed jforbes to chair next week.
17:07:18 <jsmith> Anything else?
17:07:39 <jsmith> As a reminder, the nomination period is open for FESCo and Council and Mindshare, if I remember correctly.
17:08:04 <jsmith> Also, there are deadlines coming up for System-Wide and Self-Contained changes for F28.
17:08:31 <dgilmore> sorry someone was at the door
17:08:41 <dgilmore> but I was +1
17:08:49 * jsmith sets a timer for two minutes
17:10:45 <jsmith> Ok, thanks everyone!
17:10:48 <jsmith> #endmeeting